source: projects/specs/trunk/m/maxima/maxima-vl.spec @ 11688

Revision 11688, 5.9 KB checked in by ara_t, 6 years ago (diff)

maxima: rebuild with sbcl-1.4.8

Line 
1# -*- mode: rpm-spec -*-
2
3# By default, this spec file will generate RPMs for Clisp and SBCL.
4# This can be changed by modifying the variables below.
5%define enable_clisp 0
6%define enable_sbcl 1
7
8# Inhibit automatic compressing of info files. Compressed info
9# files break maxima's internal help.
10%define __spec_install_post /bin/true
11
12Summary: Maxima Symbolic Computation Program
13Summary(ja): 数式処理プログラム Maxima
14Name: maxima
15Version: 5.41.0
16Release: 2%{?_dist_release}
17
18License: GPL
19Group:   Applications/Engineering
20URL:     http://maxima.sourceforge.net
21Source0: %{name}-%{version}.tar.gz
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24
25# Requires: maxima_exec = %{version}-%{release}
26%if %{enable_clisp}
27BuildRequires: clisp
28Requires: clisp
29%endif
30%if %{enable_sbcl}
31BuildRequires: sbcl
32Requires: sbcl
33%endif
34BuildRequires: texinfo
35Requires(post): /sbin/install-info
36Requires(preun): /sbin/install-info
37
38Obsoletes: %{name}-exec-clisp
39Obsoletes: %{name}-exec-sbcl
40
41Vendor:       Project Vine
42Distribution: Vine Linux
43
44
45%description
46Maxima is a full symbolic computation program.  It is full featured
47doing symbolic manipulation of polynomials, matrices, rational
48functions, integration, Todd-coxeter, graphing, bigfloats.  It has a
49symbolic debugger source level debugger for maxima code.  Maxima is
50based on the original Macsyma developed at MIT in the 1970's.  It is
51quite reliable, and has good garbage collection, and no memory leaks.
52It comes with hundreds of self tests.
53#'
54
55%description -l ja
56Maxima は高機能な数式処理プログラムです。Maximaを使えば、多項式、行列、
57有理関数、積分、Todd-coxeter、グラフ描画、高精度浮動小数点といった演算
58も簡単にこなせます。Maxima のコードに対応したソースレベルの数式デバッ
59ガも備えています。Maxima は MIT で1970年台に開発されたオリジナルの
60Macsyma がベースとなっています。Maxima はとても信頼性が高く、すぐれた
61ガーベッジコレクションを搭載しており、メモリリークを起こしません。この
62信頼性は、数百件に及ぶセルフテストによってもたらされたものです。
63%if %{enable_sbcl}
64SBCLではコマンドライン履歴を使用することができません。
65コマンドライン履歴を使用する場合には rlwrap パッケージを
66インストールして、
67rlwrap maxima
68のように起動して下さい。
69%endif
70
71
72%package xmaxima
73Summary: Tcl/Tk interface to Maxima
74Summary(ja): Maxima 用 Tcl/Tk インターフェース
75Group: Applications/Engineering
76Requires: %{name} = %{version}-%{release}
77Requires: tk > 8.1
78Provides: xmaxima
79
80%description xmaxima
81Tcl/Tk interface to Maxima.
82
83
84%prep
85%setup -q
86%{configure} \
87%if %{enable_clisp}
88    --enable-clisp \
89%endif
90%if %{enable_sbcl}
91    --enable-sbcl \
92%endif
93    ;
94
95%build
96%{__make} %{?_smp_mflags}
97
98%install
99%{__rm} -rf %{buildroot}
100%{makeinstall}
101
102%{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
103
104%post
105/sbin/install-info %{_infodir}/maxima.info %{_infodir}/dir
106
107%preun
108if [ "$1" = 0 ]; then
109    /sbin/install-info --delete %{_infodir}/maxima.info %{_infodir}/dir
110fi
111
112%clean
113%{__rm} -rf %{buildroot}
114
115
116%files
117%defattr(-,root,root,-)
118%doc AUTHORS COPYING ChangeLog INSTALL* NEWS README*
119%{_bindir}/maxima
120%{_bindir}/rmaxima
121%dir %{_libdir}/maxima/%{version}
122%if %{enable_clisp}
123%{_libdir}/maxima/%{version}/binary-clisp
124%endif
125%if %{enable_sbcl}
126%{_libdir}/maxima/%{version}/binary-sbcl
127%endif
128%{_libexecdir}/maxima/%{version}
129%{_datadir}/applications/xmaxima.desktop
130%{_datadir}/bash-completion/completions/*
131%{_datadir}/pixmaps/*
132%{_datadir}/maxima/%{version}
133%{_datadir}/mime/packages/*
134%{_mandir}/man1/*
135%{_infodir}/*
136
137%files xmaxima
138%{_bindir}/xmaxima
139
140
141%changelog
142* Fri Jun 01 2018 Toshiaki Ara <ara_t@384.jp> 5.41.0-2
143- rebuild with sbcl-.4.8
144
145* Wed Nov 01 2017 Toshiaki Ara <ara_t@384.jp> 5.41.0-1
146- new upstream release
147
148* Sat Nov 05 2016 Toshiaki Ara <ara_t@384.jp> 5.38.1-2
149- delete maxima-exec-{clisp,sbcl} subpackages
150- add Vendor and Distribution
151
152* Sat Nov 05 2016 Toshiaki Ara <ara_t@384.jp> 5.38.1-1
153- New upstream release
154- add build option (SBCL)
155- delete build options (GCL and CMUCL)
156
157* Fri Jul 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.36.1-1
158- update to 5.36.1
159- add BuildRequires: texinfo
160
161* Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.16.3-3
162- rebuild with Vine6 environment
163
164* Sat Mar 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-2
165- rebuilt with new toolchain, libsigsev-2.8 and clisp-2.48
166
167* Sun Oct 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-1vl5
168- new upstream release
169
170* Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 5.11.0-1vl5
171- applied new versioning policy, spec in utf-8
172
173* Mon Mar 19 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.11.0-0vl1
174- New upstream release
175- Change Group
176
177* Fri May 20 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl2
178- Japanese Summary and description by rpmSpecTranslate project
179
180* Sat Apr 23 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl1
181- New upstream release (for diff() bug fix)
182- Tidy up spec file
183
184* Sun Feb  1 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl4
185- Change Requires and BuildPreReq clisp (= 2.29 -> >= 2.29)
186
187* Sat Aug  2 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl3
188- Add exec-clisp BuildPreReq clisp
189- Add xmaxima Requires tk > 8.1
190- Remove xmaxima-olderTcl patch
191
192* Fri Jun  6 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl2
193- Rebuild for clisp-2.29-0vl1
194
195* Fri May 30 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl1
196- Enable clisp only, disable cmucl and gcl
197- Add xmaxima-olderTcl patch (for tclversion older than 8.1)
198- Remove %{_infodir}/dir file
199
200* Sat Jan  4 2003 James Amundson <amundson@fnal.gov>
201- Added doc files
202- Added explicit clisp version
203- Added conditional to postun
204- Renamed exec_* packages to exec-*
205- Use rpm macros instead of hard-coded paths
206- Thanks to Rex Dieter for helpful suggestions
207
208* Sun Sep  8 2002 James Amundson <amundson@fnal.gov>
209- Initial build.
Note: See TracBrowser for help on using the repository browser.