source: projects/specs/trunk/m/maxima/maxima-vl.spec @ 11964

Revision 11964, 6.0 KB checked in by ara_t, 5 years ago (diff)

maxima: update to 5.42.1

RevLine 
[521]1# -*- mode: rpm-spec -*-
2
[10794]3# By default, this spec file will generate RPMs for Clisp and SBCL.
4# This can be changed by modifying the variables below.
5%define enable_clisp 0
6%define enable_sbcl 1
[521]7
8# Inhibit automatic compressing of info files. Compressed info
9# files break maxima's internal help.
10%define __spec_install_post /bin/true
11
12Summary: Maxima Symbolic Computation Program
13Summary(ja): 数式処理プログラム Maxima
14Name: maxima
[11964]15Version: 5.42.1
16Release: 1%{?_dist_release}
[10803]17
[521]18License: GPL
[10803]19Group:   Applications/Engineering
20URL:     http://maxima.sourceforge.net
[521]21Source0: %{name}-%{version}.tar.gz
[10803]22
[521]23BuildRoot: %{_tmppath}/%{name}-%{version}-root
[10803]24
25# Requires: maxima_exec = %{version}-%{release}
26%if %{enable_clisp}
27BuildRequires: clisp
28Requires: clisp
29%endif
30%if %{enable_sbcl}
31BuildRequires: sbcl
32Requires: sbcl
33%endif
[9684]34BuildRequires: texinfo
[521]35Requires(post): /sbin/install-info
36Requires(preun): /sbin/install-info
37
[10803]38Obsoletes: %{name}-exec-clisp
39Obsoletes: %{name}-exec-sbcl
40
41Vendor:       Project Vine
42Distribution: Vine Linux
43
44
[521]45%description
46Maxima is a full symbolic computation program.  It is full featured
47doing symbolic manipulation of polynomials, matrices, rational
48functions, integration, Todd-coxeter, graphing, bigfloats.  It has a
49symbolic debugger source level debugger for maxima code.  Maxima is
50based on the original Macsyma developed at MIT in the 1970's.  It is
51quite reliable, and has good garbage collection, and no memory leaks.
52It comes with hundreds of self tests.
[10794]53#'
[521]54
55%description -l ja
56Maxima は高機能な数式処理プログラムです。Maximaを使えば、多項式、行列、
57有理関数、積分、Todd-coxeter、グラフ描画、高精度浮動小数点といった演算
58も簡単にこなせます。Maxima のコードに対応したソースレベルの数式デバッ
[10794]59ガも備えています。Maxima は MIT で1970年台に開発されたオリジナルの
[521]60Macsyma がベースとなっています。Maxima はとても信頼性が高く、すぐれた
61ガーベッジコレクションを搭載しており、メモリリークを起こしません。この
62信頼性は、数百件に及ぶセルフテストによってもたらされたものです。
[10794]63%if %{enable_sbcl}
64SBCLではコマンドライン履歴を使用することができません。
65コマンドライン履歴を使用する場合には rlwrap パッケージを
66インストールして、
67rlwrap maxima
68のように起動して下さい。
69%endif
[521]70
[10794]71
[521]72%package xmaxima
73Summary: Tcl/Tk interface to Maxima
74Summary(ja): Maxima 用 Tcl/Tk インターフェース
75Group: Applications/Engineering
76Requires: %{name} = %{version}-%{release}
77Requires: tk > 8.1
78Provides: xmaxima
79
80%description xmaxima
81Tcl/Tk interface to Maxima.
82
83
84%prep
85%setup -q
[10803]86%{configure} \
[10794]87%if %{enable_clisp}
88    --enable-clisp \
89%endif
90%if %{enable_sbcl}
91    --enable-sbcl \
92%endif
93    ;
[521]94
95%build
[10803]96%{__make} %{?_smp_mflags}
[521]97
98%install
[10803]99%{__rm} -rf %{buildroot}
100%{makeinstall}
[521]101
[10803]102%{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
[521]103
104%post
105/sbin/install-info %{_infodir}/maxima.info %{_infodir}/dir
106
107%preun
108if [ "$1" = 0 ]; then
[10803]109    /sbin/install-info --delete %{_infodir}/maxima.info %{_infodir}/dir
[521]110fi
111
112%clean
[10803]113%{__rm} -rf %{buildroot}
[521]114
[10803]115
[521]116%files
117%defattr(-,root,root,-)
[10803]118%doc AUTHORS COPYING ChangeLog INSTALL* NEWS README*
119%{_bindir}/maxima
120%{_bindir}/rmaxima
[521]121%dir %{_libdir}/maxima/%{version}
122%if %{enable_clisp}
123%{_libdir}/maxima/%{version}/binary-clisp
124%endif
[10794]125%if %{enable_sbcl}
126%{_libdir}/maxima/%{version}/binary-sbcl
[521]127%endif
[10803]128%{_libexecdir}/maxima/%{version}
[11221]129%{_datadir}/applications/xmaxima.desktop
130%{_datadir}/bash-completion/completions/*
131%{_datadir}/pixmaps/*
[10803]132%{_datadir}/maxima/%{version}
133%{_datadir}/mime/packages/*
134%{_mandir}/man1/*
135%{_infodir}/*
[521]136
[10803]137%files xmaxima
138%{_bindir}/xmaxima
[521]139
[10803]140
[521]141%changelog
[11964]142* Thu Dec 06 2018 Toshiaki Ara <ara_t@384.jp> 5.42.1-1
143- new upstream release
144
[11688]145* Fri Jun 01 2018 Toshiaki Ara <ara_t@384.jp> 5.41.0-2
[11964]146- rebuild with sbcl-1.4.8
[11688]147
[11221]148* Wed Nov 01 2017 Toshiaki Ara <ara_t@384.jp> 5.41.0-1
149- new upstream release
150
[10803]151* Sat Nov 05 2016 Toshiaki Ara <ara_t@384.jp> 5.38.1-2
152- delete maxima-exec-{clisp,sbcl} subpackages
153- add Vendor and Distribution
154
[10794]155* Sat Nov 05 2016 Toshiaki Ara <ara_t@384.jp> 5.38.1-1
156- New upstream release
157- add build option (SBCL)
158- delete build options (GCL and CMUCL)
159
[9684]160* Fri Jul 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.36.1-1
161- update to 5.36.1
162- add BuildRequires: texinfo
163
[10794]164* Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.16.3-3
165- rebuild with Vine6 environment
166
[521]167* Sat Mar 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-2
168- rebuilt with new toolchain, libsigsev-2.8 and clisp-2.48
169
170* Sun Oct 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-1vl5
171- new upstream release
172
173* Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 5.11.0-1vl5
174- applied new versioning policy, spec in utf-8
175
176* Mon Mar 19 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.11.0-0vl1
177- New upstream release
178- Change Group
179
180* Fri May 20 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl2
181- Japanese Summary and description by rpmSpecTranslate project
182
183* Sat Apr 23 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl1
184- New upstream release (for diff() bug fix)
185- Tidy up spec file
186
187* Sun Feb  1 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl4
188- Change Requires and BuildPreReq clisp (= 2.29 -> >= 2.29)
189
190* Sat Aug  2 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl3
191- Add exec-clisp BuildPreReq clisp
192- Add xmaxima Requires tk > 8.1
193- Remove xmaxima-olderTcl patch
194
195* Fri Jun  6 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl2
196- Rebuild for clisp-2.29-0vl1
197
198* Fri May 30 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl1
199- Enable clisp only, disable cmucl and gcl
200- Add xmaxima-olderTcl patch (for tclversion older than 8.1)
201- Remove %{_infodir}/dir file
202
203* Sat Jan  4 2003 James Amundson <amundson@fnal.gov>
204- Added doc files
205- Added explicit clisp version
206- Added conditional to postun
207- Renamed exec_* packages to exec-*
208- Use rpm macros instead of hard-coded paths
209- Thanks to Rex Dieter for helpful suggestions
210
211* Sun Sep  8 2002 James Amundson <amundson@fnal.gov>
212- Initial build.
Note: See TracBrowser for help on using the repository browser.