source: projects/specs/trunk/m/mathabx-type1/mathabx-type1-vl.spec @ 1532

Revision 1532, 4.8 KB checked in by munepi, 14 years ago (diff)

NEW mathabx-type1: renamed from mathabx to mathabx-type1; ready for TeX Live

Line 
1%define pkgname         mathabx
2
3%define tex_destdir     %{_datadir}
4%define texmf           %{tex_destdir}/texmf
5%define texlive_src     %{tex_destdir}/texlive-sources
6%define build_tex_destdir       %{buildroot}%{tex_destdir}
7%define build_texmf     %{buildroot}%{texmf}
8
9%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
10%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
11%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
12%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
13%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
14%define vartexfonts %{_var}/lib/texmf
15
16%define mapdir          %{texmf}-dist/fonts/map/dvips/misc
17%define mathabxdate     20050518
18
19Summary: The mathabx font series: extended and extendable series of mathematical symbols for TeX
20Summary(ja): mathabx: TeX 用の新しい数式フォント
21Name: mathabx-type1
22Version: 2005
23Release: 2%{?_dist_release}
24Source0: mathabx-%{mathabxdate}.tar.bz2
25Source1: abxtype1-%{mathabxdate}.tar.bz2
26Source2: mathabx_docs-%{mathabxdate}.tar.bz2
27URL: http://auemath.aichi-edu.ac.jp/~khotta/ghost/mathabx.html
28License: GPL
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30Group: Applications/Publishing
31BuildArch: noarch
32PreReq: sed, sh-utils
33
34Requires: texlive-collection-fontsextra
35Obsoletes: mathabx <= 2005-1
36
37Vendor: Project Vine
38Distribution: Vine Linux
39
40%description
41The mathabx font series is a high quality extended and extendable series of
42mathematical symbols.
43To use this package, you describe \usepackage{mathabx} at preamble in your
44TeX document.
45
46This package provides Type1 fonts of mathabx.
47
48
49%description -l ja
50mathabx は CM + AMS の拡張であると考えられます。 全体的に色々な工夫が見られ,
51例えば、積分記号 \int が CM より垂直に見え、不等号 ≦ は AMS のものより < と
52 = がくっついているので、日本人が見慣れているものにより近いようです。
53
54TeX 文書の最初の部分へ \usepackage{mathabx} と記述すれば、普通の数式モードに
55て mathabx の利用が可能になります。
56
57このパッケージは mathabx の Type1 を提供します。
58
59
60%prep
61%__rm -rf $RPM_BUILD_ROOT
62
63%setup -q -a 1 -a 2 -n %{pkgname}
64
65%build
66
67%install
68%__rm -rf $RPM_BUILD_ROOT
69# mkdir -p            %{build_texmf}/fonts/source/public/mathabx
70# cp -p source/*      %{build_texmf}/fonts/source/public/mathabx
71# mkdir -p            %{build_texmf}/tex/latex/mathabx
72# cp -p texinputs/*   %{build_texmf}/tex/latex/mathabx
73%__mkdir_p            %{build_texmf}/fonts/type1/mathabx
74%__cp -p abxtype1/pfb/*.pfb %{build_texmf}/fonts/type1/mathabx
75%__mkdir_p          %{buildroot}%{mapdir}
76%__cp -p abxtype1/map/mathabx.map %{buildroot}%{mapdir}/mathabx.map
77
78%post
79%{exec_texhash}
80
81[ -f %{texmf}/web2c/updmap.cfg ] || exit 0
82
83echo -n "    " && \
84    echo -n "Running updmap: enable mathabx.map ... " && \
85    %{exec_updmap} --enable Map mathabx.map >/dev/null 2>&1 && \
86    echo "done."
87
88exit 0
89
90%postun
91if [ "$1" = "0" ]; then
92    %{exec_texhash}
93
94    [ -f %{texmf}/web2c/updmap.cfg ] || exit 0
95
96    echo -n "    " && \
97        echo -n "Running updmap: disable mathabx.map ... " && \
98        %{exec_updmap} --disable mathabx.map >/dev/null 2>&1 && \
99        echo "done."
100fi
101
102exit 0
103
104
105%clean
106%__rm -rf $RPM_BUILD_ROOT
107
108%files
109%defattr(-,root,root)
110# %{texmf}/fonts/source/public/mathabx/*
111%{texmf}/fonts/type1/mathabx/*
112# %{texmf}/tex/latex/mathabx/*
113%{mapdir}/mathabx.map
114# %doc mathtest.tex mathtest.dvi mathtest.pdf
115
116
117%changelog
118* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2005-2
119- renamed to mathabx-type1
120- TeX Live 2009
121- added Requires: texlive-collection-fontsextra
122  - texlive-collection-fontsextra has mathabx package
123
124* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 2005-1vl5
125- applied new versioning policy, spec in utf-8
126
127* Tue May 16 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl4
128- fix exec_updmap: added --nostop option
129
130* Fri Dec 02 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl3
131- fix install dir of mathabx.mat
132
133* Thu Nov 17 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl2
134- fix exec_updmap
135
136* Wed Nov 16 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl1
137- source update
138- modified for tetex-3.0
139
140* Tue Feb 03 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl3
141- fix exec_updmap
142
143* Thu Dec 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl2
144- source update
145
146* Fri Aug 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl1
147- source update
148
149* Wed Jun 12 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2002-1vl2
150- update Type1 fonts
151
152* Sun Jun 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2002-1vl1
153- 1st release
Note: See TracBrowser for help on using the repository browser.