source: projects/specs/trunk/m/mate-utils/mate-utils-vl.spec @ 5322

Revision 5322, 4.5 KB checked in by Takemikaduchi, 12 years ago (diff)

mate: add mate-conf-editor, mate-utils

Line 
1Summary:        MATE utility programs
2Name:           mate-utils
3Version:        1.1.0
4Release:        1%{?_dist_release}
5Source0:        %{name}-%{version}.tar.xz
6License:        GPLv2
7Group:          Applications/System
8URL:            https://matsusoft.com.ar/projects/mate/
9
10BuildRequires:  mate-common
11BuildRequires:  mate-doc-utils
12BuildRequires:  mate-conf-devel
13BuildRequires:  mate-panel-devel
14BuildRequires:  gtk2-devel
15BuildRequires:  libgtop2-devel
16BuildRequires:  libSM-devel
17BuildRequires:  popt-devel
18BuildRequires:  gtk-doc
19BuildRequires:  autoconf
20BuildRequires:  automake
21
22Requires(post,pre,preun):       mate-conf
23Requires(post,postun):  desktop-file-utils
24
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26
27Vendor:         Project Vine
28Distribution:   Vine Linux
29Packager:       Takemikaduchi
30
31
32%description
33MATE Utilities for the MATE Desktop contains the following -
34
35        mate-system-log [logview]
36        mate-search-tool        [gseachtool]
37        mate-dictionary [mate-dictionary]
38        mate-screenshot [mate-screenshot]
39        baobab                  [baobab]
40
41
42%package        devel
43Summary:        Development tools for mate-utils
44Summary(ja):    mate-utils の開発環境
45Group:          Development/Libraries
46Requires:       %{name} = %{version}-%{release}
47Requires:       pkgconfig
48
49%description    devel
50Header files and libraries for building a extension library for the
51mate-utils.
52
53
54%package        doc
55Summary:        Documentation for mate-utils
56Summary(ja):    mate-utils 用のドキュメント
57Group:          Documentation
58Requires:       %{name} = %{version}-%{release}
59BuildArch:      noarch
60
61%description    doc
62This package contains documentation for mate-utils.
63
64
65%prep
66%setup -q
67
68
69%build
70(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
71%configure \
72        --libexecdir=%{_libexecdir}/mate \
73        --disable-static \
74        --disable-scrollkeeper
75
76%{__make} %{?_smp_mflags}
77
78
79%install
80%{__rm} -rf ${RPM_BUILD_ROOT}
81%{__make} install DESTDIR=${RPM_BUILD_ROOT}
82
83find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
84find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
85
86%find_lang %{name}-2.0
87
88
89%clean
90%{__rm} -rf ${RPM_BUILD_ROOT}
91
92%post
93/sbin/ldconfig
94
95export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
96
97SCHEMAS=" \
98  baobab.schemas \
99  mate-dictionary.schemas \
100  mate-screenshot.schemas \
101  mate-search-tool.schemas \
102  mate-system-log.schemas"
103for S in $SCHEMAS; do
104  echo %{_sysconfdir}/mateconf/schemas/$S; done \
105  | xargs mateconftool-2 --makefile-install-rule >& /dev/null ||:
106
107update-desktop-database %{_datadir}/applications >& /dev/null ||:
108
109%pre
110if [ "$1" -gt 1 ]; then
111  export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
112
113  SCHEMAS=" \
114    baobab.schemas \
115    mate-dictionary.schemas \
116    mate-screenshot.schemas \
117    mate-search-tool.schemas \
118    mate-system-log.schemas"
119  for S in $SCHEMAS; do
120    echo %{_sysconfdir}/mateconf/schemas/$S; done \
121    | xargs mateconftool-2 --makefile-uninstall-rule >& /dev/null ||:
122fi
123
124%preun
125if [ "$1" -eq 0 ]; then
126  export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
127
128  SCHEMAS=" \
129    baobab.schemas \
130    mate-dictionary.schemas \
131    mate-screenshot.schemas \
132    mate-search-tool.schemas \
133    mate-system-log.schemas"
134  for S in $SCHEMAS; do
135    echo %{_sysconfdir}/mateconf/schemas/$S; done \
136    | xargs mateconftool-2 --makefile-uninstall-rule >& /dev/null ||:
137fi
138
139%postun
140/sbin/ldconfig
141update-desktop-database %{_datadir}/applications >& /dev/null ||:
142
143
144%files -f %{name}-2.0.lang
145%defattr(-,root,root,-)
146%doc COPYING ChangeLog NEWS README
147%{_sysconfdir}/mateconf/schemas/baobab.schemas
148%{_sysconfdir}/mateconf/schemas/mate-dictionary.schemas
149%{_sysconfdir}/mateconf/schemas/mate-screenshot.schemas
150%{_sysconfdir}/mateconf/schemas/mate-search-tool.schemas
151%{_sysconfdir}/mateconf/schemas/mate-system-log.schemas
152%{_bindir}/mate-dictionary
153%{_bindir}/mate-disk-usage-analyzer
154%{_bindir}/mate-panel-screenshot
155%{_bindir}/mate-screenshot
156%{_bindir}/mate-search-tool
157%{_bindir}/mate-system-log
158%{_libdir}/libmatedict.so.*
159%{_libdir}/matecomponent/servers/MATE_DictionaryApplet.server
160%{_libexecdir}/mate/mate-dictionary-applet
161%{_datadir}/applications/*.desktop
162%{_datadir}/icons/mate/*/*/*
163%{_datadir}/mate/help/*
164%{_datadir}/mate-2.0/ui/MATE_DictionaryApplet.xml
165%{_datadir}/mate-dict
166%{_datadir}/mate-dictionary
167%{_datadir}/mate-disk-usage-analyzer
168%{_datadir}/mate-screenshot
169%{_datadir}/mate-utils
170%{_datadir}/omf/*
171%{_datadir}/pixmaps/mate-search-tool/thumbnail_frame.png
172%{_mandir}/man1/*.1.gz
173
174%files devel
175%defattr(-,root,root,-)
176%{_includedir}/mate-dict
177%{_libdir}/libmatedict.so
178%{_libdir}/pkgconfig/mate-dict.pc
179
180
181%changelog
182* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
183- initial build for Vine Linux
184
Note: See TracBrowser for help on using the repository browser.