source: projects/specs/trunk/m/mate-terminal/mate-terminal-vl.spec @ 11076

Revision 11076, 4.3 KB checked in by iwaim, 7 years ago (diff)

mate-terminal 1.18.1-1

Line 
1%define major_ver 1.18
2%define ver %{major_ver}.1
3%define rel 1
4
5Summary:        The MATE Terminal Emulator
6Name:           mate-terminal
7Version:        %{ver}
8Release:        %{rel}%{?_dist_release}
9
10Source0:        http://pub.mate-desktop.org/releases/%{major_ver}/%{name}-%{version}.tar.xz
11
12License:        GPLv3
13Group:          User Interface/Desktops
14URL:            http://mate-desktop.org/
15
16BuildRequires:  mate-common
17BuildRequires:  gtk3-devel
18BuildRequires:  dconf-devel
19BuildRequires:  vte3-devel
20BuildRequires:  libSM-devel
21BuildRequires:  mate-desktop-devel
22BuildRequires:  itstool
23BuildRequires:  gtk-doc
24BuildRequires:  autoconf
25BuildRequires:  automake
26BuildRequires:  desktop-file-utils
27
28Requires(posttrans,postun):     glib2
29Requires(post,postun):  desktop-file-utils
30
31BuildRoot:      %{_tmppath}/%{name}-%{version}-root
32
33Vendor:         Project Vine
34Distribution:   Vine Linux
35Packager:       Takemikaduchi, iwaim
36
37
38%description
39This is the MATE terminal emulator application.  mate-terminal is
40only the shell (menubar, prefs dialog); the terminal emulation ("stuff
41in the middle") comes from the VTE widget. Remember this when
42choosing a bugzilla component. ;-)
43
44
45%prep
46%setup -q
47
48
49%build
50(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
51%configure \
52        --disable-static
53
54%{__make} %{?_smp_mflags}
55
56
57%install
58%{__rm} -rf ${RPM_BUILD_ROOT}
59
60%{__make} install DESTDIR=${RPM_BUILD_ROOT}
61
62find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
63find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
64
65desktop-file-install --vendor ''                        \
66        --dir $RPM_BUILD_ROOT%{_datadir}/applications       \
67        --remove-category=System                            \
68        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
69
70
71%find_lang %{name}
72
73
74%clean
75%{__rm} -rf ${RPM_BUILD_ROOT}
76
77%post
78/sbin/ldconfig
79update-desktop-database %{_datadir}/applications >& /dev/null ||:
80
81%postun
82/sbin/ldconfig
83if [ $1 -eq 0 ]; then
84  update-desktop-database %{_datadir}/applications >& /dev/null ||:
85  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
86fi
87
88%posttrans
89glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
90
91
92%files -f %{name}.lang
93%defattr(-,root,root,-)
94%doc COPYING ChangeLog NEWS README
95%{_bindir}/%{name}
96%{_bindir}/%{name}.wrapper
97%{_datadir}/appdata/%{name}.appdata.xml
98%{_datadir}/applications/%{name}.desktop
99%{_datadir}/glib-2.0/schemas/org.mate.terminal.gschema.xml
100%{_datadir}/help/*
101%{_datadir}/%{name}
102%{_mandir}/man1/%{name}.1.gz
103
104
105%changelog
106* Wed May 10 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.1-1
107- update to 1.18.1
108
109* Sat Apr  8 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.0-1
110- update to 1.18.0
111
112* Sun Mar 26 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.16.2-1
113- update to 1.16.2
114
115* Sun Nov 27 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.16.1-1
116- new upstream release
117- update GTK+ version
118 - BR: gtk3-devel
119- update VTE version (require API 2.91)
120- update Packager
121
122* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
123- new upstream release
124
125* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
126- new upstream release
127
128* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
129- new upstream release
130
131* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
132- new upstream release
133
134* Sat May 23 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
135- new upstream release
136- add BuildRequires: mate-desktop-devel
137
138* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
139- new upstream release
140
141* Tue Jun 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-2
142- add BuildRequires: desktop-file-utils
143- remove Categories=System to mate-terminal.desktop
144
145* Wed Apr 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
146- new upstream release
147- remove Patch0 (mate-terminal-1.4.0-ja.po.patch)
148- add BuildRequires: itstool
149
150* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-2
151- rebuild with VineSeed environment
152
153* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
154- new upstream release
155- remove BuildRequires: mate-conf-devel
156- add BuildRequires: dconf-devel
157
158* Thu Aug 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
159- new upstream release
160- add Patch0 (mate-terminal-1.4.0-ja.po.patch)
161
162* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
163- new upstream release
164
165* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
166- change category
167
168* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
169- initial build for Vine Linux
170
Note: See TracBrowser for help on using the repository browser.