source: projects/specs/trunk/m/mate-session-manager/mate-session-manager-vl.spec @ 11658

Revision 11658, 5.3 KB checked in by iwaim, 6 years ago (diff)

mate-session-manager 1.20.0-1

Line 
1%define major_ver 1.20
2%define ver %{major_ver}.0
3%define rel 1
4
5Summary:        The MATE Session Handler
6Name:           mate-session-manager
7Version:        %{ver}
8Release:        %{rel}%{?_dist_release}
9Source0:        http://pub.mate-desktop.org/releases/%{major_ver}/%{name}-%{version}.tar.xz
10License:        GPLv2
11Group:          User Interface/Desktops
12URL:            http://mate-desktop.org/
13
14# patch for Vine
15Patch1001:      mate-session-manager-1.18.0-use-vine-sleep-helper.patch
16Patch1002:      mate-session-manager-1.12.0-mate-wm.patch
17
18BuildRequires:  mate-common
19BuildRequires:  mate-desktop-devel >= 1.17.0
20BuildRequires:  gtk3-devel
21BuildRequires:  dbus-glib-devel
22BuildRequires:  libSM-devel
23BuildRequires:  libXtst-devel
24BuildRequires:  gtk-doc
25BuildRequires:  autoconf
26BuildRequires:  automake
27BuildRequires:  xorg-x11-xtrans-devel
28
29Requires:       vine-sleep-helper
30Requires(posttrans,postun):     glib2
31Requires(post,postun):  gtk2
32Requires(post,postun):  desktop-file-utils
33
34BuildRoot:      %{_tmppath}/%{name}-%{version}-root
35
36Vendor:         Project Vine
37Distribution:   Vine Linux
38Packager:       Takemikaduchi, iwaim
39
40
41%description
42mate-session contains the MATE session manager, as well as a
43configuration program to choose applications starting on login.
44
45
46%prep
47%setup -q
48%patch1001 -p1 -b .vine
49%patch1002 -p1 -b .vine
50
51
52%build
53NOCONFIGURE=1 ./autogen.sh
54%configure \
55        --disable-static \
56        --disable-upower \
57        --with-default-wm=mate-wm
58
59%{__make} %{?_smp_mflags}
60
61
62%install
63%{__rm} -rf ${RPM_BUILD_ROOT}
64
65%{__make} install DESTDIR=${RPM_BUILD_ROOT}
66
67find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
68find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
69
70%find_lang %{name}
71
72
73%clean
74%{__rm} -rf ${RPM_BUILD_ROOT}
75
76
77%post
78/sbin/ldconfig
79update-desktop-database %{_datadir}/applications >& /dev/null ||:
80touch --no-create %{_datadir}/icons/hicolor
81/usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
82
83%postun
84/sbin/ldconfig
85if [ $1 -eq 0 ]; then
86  update-desktop-database %{_datadir}/applications >& /dev/null ||:
87  touch --no-create %{_datadir}/icons/hicolor
88  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
89  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
90fi
91
92%posttrans
93glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
94
95
96%files -f %{name}.lang
97%defattr(-,root,root,-)
98%doc COPYING ChangeLog NEWS README
99%{_bindir}/mate-session
100%{_bindir}/mate-session-inhibit
101%{_bindir}/mate-session-properties
102%{_bindir}/mate-session-save
103%{_bindir}/mate-wm
104%{_datadir}/applications/mate-session-properties.desktop
105%{_datadir}/applications/mate-wm.desktop
106%{_datadir}/glib-2.0/schemas/org.mate.session.gschema.xml
107%{_datadir}/icons/hicolor/*/*/*
108%{_datadir}/mate-session-manager/gsm-inhibit-dialog.ui
109%{_datadir}/mate-session-manager/session-properties.ui
110%{_datadir}/xsessions/mate.desktop
111%{_mandir}/man1/*.1.gz
112
113
114%changelog
115* Sun May 20 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.20.0-1
116- update to 1.20.0
117
118* Thu Jan 18 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.2-1
119- update to 1.18.2
120
121* Mon Apr  3 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.0-1
122- update to 1.18.0
123- update use vine-sleep-helper patch (Patch1001)
124- update Packager tag
125
126* Sun Mar 26 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.16.1-1
127- update to 1.16.1
128- add BuildRequires: xorg-x11-xtrans-devel
129
130* Sun Nov 27 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.16.0-1
131- new upstream release
132- update GTK+ version
133 - BR: gtk3-devel
134
135* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
136- new upstream release
137
138* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
139- new upstream release
140- update Patch1001 (mate-session-manager-1.12.2-use-vine-sleep-helper.patch)
141
142* Tue Dec 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
143- new upstream release
144
145* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
146- new upstream release
147- add Patch1002 (mate-session-manager-1.12.0-mate-wm.patch)
148
149* Wed Sep 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-3
150- add configure option (--with-default-wm=mate-wm)
151
152* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-2
153- add Patch1001 (mate-session-manager-1.10.2-use-vine-sleep-helper.patch)
154- add Requires: vine-sleep-helper
155
156* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
157- new upstream release
158
159* Sat Jun 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
160- new upstream release
161
162* Sat May 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
163- new upstream release
164- add BuildRequires: mate-desktop-devel
165
166* Sun Sep 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-2
167- remove BuildRequires: libupower09-devel
168
169* Mon Apr 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
170- new upstream release
171- add BuildRequires: libupower09-devel
172- remove BuildRequires: upower-devel
173
174* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-2
175- rebuild with VineSeed environment
176
177* Sun Sep 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
178- new upstream release
179
180* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
181- new upstream release
182- remove BuildRequires: mate-conf-devel
183
184* Wed Aug 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
185- new upstream release
186
187* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
188- new upstream release
189
190* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
191- change category
192
193* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
194- initial build for Vine Linux
195
Note: See TracBrowser for help on using the repository browser.