source: projects/specs/trunk/m/mate-panel/mate-panel-vl.spec @ 9661

Revision 9661, 6.8 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1Summary:        The MATE Panel
2Name:           mate-panel
3Version:        1.10.1
4Release:        1%{?_dist_release}
5
6Source0:        http://pub.mate-desktop.org/releases/1.10/%{name}-%{version}.tar.xz
7Source1:        vine.layout
8
9# for Vine
10Patch2000:      mate-panel-1.6.1-about-vine.patch
11Patch2001:      mate-panel-1.8.0-vine-layout.patch
12
13License:        GPLv2
14Group:          User Interface/Desktops
15URL:            http://mate-desktop.org/
16
17BuildRequires:  mate-common
18BuildRequires:  mate-doc-utils
19BuildRequires:  mate-desktop-devel
20BuildRequires:  mate-menus-devel
21BuildRequires:  libmateweather-devel
22BuildRequires:  gtk2-devel
23BuildRequires:  libSM-devel
24BuildRequires:  libcanberra-devel
25BuildRequires:  dbus-glib-devel
26BuildRequires:  libwnck-devel
27BuildRequires:  librsvg2-devel
28BuildRequires:  evolution-data-server-devel
29BuildRequires:  NetworkManager-devel
30BuildRequires:  dconf-devel
31BuildRequires:  gtk-doc
32BuildRequires:  itstool
33BuildRequires:  autoconf
34BuildRequires:  automake
35
36Requires:               vine-menus
37Requires(posttrans,postun):     glib2
38Requires(post,postun):  gtk2
39Requires(post,postun):  desktop-file-utils
40
41BuildRoot:      %{_tmppath}/%{name}-%{version}-root
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45Packager:       Takemikaduchi
46
47
48%description
49mate-panel contains the MATE panel, the libmate-panel-applet library and
50several applets:
51
52  + the MATE panel is the area on your desktop from which you can run
53    applications and applets, and perform other tasks.
54
55  + the libmate-panel-applet library allows to develop small applications
56    which may be embedded in the panel. These are called applets.
57    Documentation for the API is available with gtk-doc.
58
59  + the applets supplied here include the Workspace Switcher, the Window
60    List, the Window Selector, the Notification Area, the Clock and the
61    infamous 'Wanda the Fish'.
62
63
64%package                devel
65Summary:        Development tools for mate-panel
66Summary(ja):    mate-panel の開発環境
67Group:          Development/Libraries
68Requires:       %{name} = %{version}-%{release}
69Requires:       pkgconfig
70
71%description    devel
72Header files and libraries for building a extension library for the
73mate-panel.
74
75
76%package        docs
77Summary:        Documentation for mate-panel
78Summary(ja):    mate-panel 用のドキュメント
79Group:          Documentation
80Requires:       %{name} = %{version}-%{release}
81Obsoletes:      %{name}-doc < 1.10.1
82BuildArch:      noarch
83
84%description    docs
85This package contains documentation for mate-panel.
86
87
88%prep
89%setup -q
90%patch2000 -p1 -b .vine
91%patch2001 -p1 -b .vine
92
93%build
94(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
95%configure \
96        --libexecdir=%{_libexecdir}/mate \
97        --disable-static \
98        --disable-scrollkeeper \
99        --enable-introspection \
100        --enable-matecomponent
101
102%{__make} %{?_smp_mflags}
103
104
105%install
106%{__rm} -rf ${RPM_BUILD_ROOT}
107
108%{__make} install DESTDIR=${RPM_BUILD_ROOT}
109
110find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
111find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
112
113install -c -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{name}/layouts/
114
115%find_lang %{name}
116
117
118%clean
119%{__rm} -rf ${RPM_BUILD_ROOT}
120
121
122%post
123/sbin/ldconfig
124update-desktop-database %{_datadir}/applications >& /dev/null ||:
125touch --no-create %{_datadir}/icons/hicolor
126gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
127
128%postun
129/sbin/ldconfig
130if [ $1 -eq 0 ]; then
131  update-desktop-database %{_datadir}/applications >& /dev/null ||:
132  touch --no-create %{_datadir}/icons/hicolor
133  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
134  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
135fi
136
137%posttrans
138glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
139
140
141%files -f %{name}.lang
142%defattr(-,root,root,-)
143%doc COPYING ChangeLog NEWS README
144%{_bindir}/mate-desktop-item-edit
145%{_bindir}/mate-panel
146%{_bindir}/mate-panel-test-applets
147%{_libdir}/girepository-1.0/MatePanelApplet-4.0.typelib
148%{_libdir}/libmate-panel-applet-*.so.*
149%{_libexecdir}/mate/clock-applet
150%{_libexecdir}/mate/fish-applet
151%{_libexecdir}/mate/notification-area-applet
152%{_libexecdir}/mate/wnck-applet
153%{_datadir}//MateConf/gsettings/mate-panel.convert
154%{_datadir}/applications/mate-panel.desktop
155%{_datadir}/dbus-1/services/*.service
156%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.clock.gschema.xml
157%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.fish.gschema.xml
158%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.window-list.gschema.xml
159%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.workspace-switcher.gschema.xml
160%{_datadir}/glib-2.0/schemas/org.mate.panel.enums.xml
161%{_datadir}/glib-2.0/schemas/org.mate.panel.gschema.xml
162%{_datadir}/glib-2.0/schemas/org.mate.panel.menubar.gschema.xml
163%{_datadir}/glib-2.0/schemas/org.mate.panel.object.gschema.xml
164%{_datadir}/glib-2.0/schemas/org.mate.panel.toplevel.gschema.xml
165%{_datadir}/icons/hicolor/*/*/*
166%{_datadir}/help
167%{_datadir}/mate-panel
168%{_mandir}/man1/mate-panel.1.gz
169%{_mandir}/man1/mate-desktop-item-edit.1.gz
170%{_mandir}/man1/mate-panel-test-applets.1.gz
171
172%files devel
173%defattr(-,root,root,-)
174%{_includedir}/mate-panel-4.0/
175%{_libdir}/libmate-panel-applet-*.so
176%{_libdir}/pkgconfig/libmatepanelapplet-4.0.pc
177%{_datadir}/gir-1.0/MatePanelApplet-4.0.gir
178
179%files docs
180%defattr(-,root,root,-)
181%{_datadir}/gtk-doc/html/mate-panel-applet
182
183
184%changelog
185* Sat Jul 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
186- new upstream release
187
188* Sat May 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
189- new upstream release
190- remove Patch2002 (mate-panel-1.8.0-ja.po.patch)
191
192* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
193- rename Source (vine.layout)
194
195* Sun Jun 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-2
196- rename Source (vine.layout)
197- add Patch2001 (mate-panel-1.8.0-vine-layout.patch)
198- add Patch2002 (mate-panel-1.8.0-ja.po.patch)
199
200* Tue Apr 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
201- new upstream release
202- change BuildRequires: libwnck-devel instead of libmatewnck-devel
203- add BuildRequires: itstool
204
205* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-3
206- rebuild with VineSeed environment
207
208* Wed Sep 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-2
209- change Source1 (panel-default-layout.mate.vine)
210- add Patch2000 (mate-panel-1.6.1-about-vine.patch)
211- add Requires: vine-menus
212
213* Sun Sep 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
214- new upstream release
215
216* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
217- new upstream release
218- remove BuildRequires: mate-conf-devel, libmatecomponentui-devel
219- add BuildRequires: dconf-devel
220
221* Wed Aug 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
222- new upstream release
223- remove Patch0 (mate-panel-1.2.1-configure.patch)
224- change BuildRequires: libmatewnck-devel instead of libwnck-devel
225
226* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
227- new upstream release
228- add Patch0 (mate-panel-1.2.1-configure.patch)
229
230* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
231- change category
232
233* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
234- initial build for Vine Linux
235
Note: See TracBrowser for help on using the repository browser.