source: projects/specs/trunk/m/mate-panel/mate-panel-vl.spec @ 9552

Revision 9552, 6.7 KB checked in by Takemikaduchi, 9 years ago (diff)

task-xorg-x11: fix BTS:2913
others: new upstream release

Line 
1Summary:        The MATE Panel
2Name:           mate-panel
3Version:        1.10.0
4Release:        1%{?_dist_release}
5
6Source0:        http://pub.mate-desktop.org/releases/1.10/%{name}-%{version}.tar.xz
7Source1:        vine.layout
8
9# for Vine
10Patch2000:      mate-panel-1.6.1-about-vine.patch
11Patch2001:      mate-panel-1.8.0-vine-layout.patch
12
13License:        GPLv2
14Group:          User Interface/Desktops
15URL:            http://mate-desktop.org/
16
17BuildRequires:  mate-common
18BuildRequires:  mate-doc-utils
19BuildRequires:  mate-desktop-devel
20BuildRequires:  mate-menus-devel
21BuildRequires:  libmateweather-devel
22BuildRequires:  gtk2-devel
23BuildRequires:  libSM-devel
24BuildRequires:  libcanberra-devel
25BuildRequires:  dbus-glib-devel
26BuildRequires:  libwnck-devel
27BuildRequires:  librsvg2-devel
28BuildRequires:  evolution-data-server-devel
29BuildRequires:  NetworkManager-devel
30BuildRequires:  dconf-devel
31BuildRequires:  gtk-doc
32BuildRequires:  itstool
33BuildRequires:  autoconf
34BuildRequires:  automake
35
36Requires:               vine-menus
37Requires(posttrans,postun):     glib2
38Requires(post,postun):  gtk2
39Requires(post,postun):  desktop-file-utils
40
41BuildRoot:      %{_tmppath}/%{name}-%{version}-root
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45Packager:       Takemikaduchi
46
47
48%description
49mate-panel contains the MATE panel, the libmate-panel-applet library and
50several applets:
51
52  + the MATE panel is the area on your desktop from which you can run
53    applications and applets, and perform other tasks.
54
55  + the libmate-panel-applet library allows to develop small applications
56    which may be embedded in the panel. These are called applets.
57    Documentation for the API is available with gtk-doc.
58
59  + the applets supplied here include the Workspace Switcher, the Window
60    List, the Window Selector, the Notification Area, the Clock and the
61    infamous 'Wanda the Fish'.
62
63
64%package                devel
65Summary:        Development tools for mate-panel
66Summary(ja):    mate-panel の開発環境
67Group:          Development/Libraries
68Requires:       %{name} = %{version}-%{release}
69Requires:       pkgconfig
70
71%description    devel
72Header files and libraries for building a extension library for the
73mate-panel.
74
75
76%package        doc
77Summary:        Documentation for mate-panel
78Summary(ja):    mate-panel 用のドキュメント
79Group:          Documentation
80Requires:       %{name} = %{version}-%{release}
81BuildArch:      noarch
82
83%description    doc
84This package contains documentation for mate-panel.
85
86
87%prep
88%setup -q
89%patch2000 -p1 -b .vine
90%patch2001 -p1 -b .vine
91
92%build
93(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
94%configure \
95        --libexecdir=%{_libexecdir}/mate \
96        --disable-static \
97        --disable-scrollkeeper \
98        --enable-introspection \
99        --enable-matecomponent
100
101%{__make} %{?_smp_mflags}
102
103
104%install
105%{__rm} -rf ${RPM_BUILD_ROOT}
106
107%{__make} install DESTDIR=${RPM_BUILD_ROOT}
108
109find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
110find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
111
112install -c -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{name}/layouts/
113
114%find_lang %{name}
115
116
117%clean
118%{__rm} -rf ${RPM_BUILD_ROOT}
119
120
121%post
122/sbin/ldconfig
123update-desktop-database %{_datadir}/applications >& /dev/null ||:
124touch --no-create %{_datadir}/icons/hicolor
125gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
126
127%postun
128/sbin/ldconfig
129if [ $1 -eq 0 ]; then
130  update-desktop-database %{_datadir}/applications >& /dev/null ||:
131  touch --no-create %{_datadir}/icons/hicolor
132  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
133  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
134fi
135
136%posttrans
137glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
138
139
140%files -f %{name}.lang
141%defattr(-,root,root,-)
142%doc COPYING ChangeLog NEWS README
143%{_bindir}/mate-desktop-item-edit
144%{_bindir}/mate-panel
145%{_bindir}/mate-panel-test-applets
146%{_libdir}/girepository-1.0/MatePanelApplet-4.0.typelib
147%{_libdir}/libmate-panel-applet-*.so.*
148%{_libexecdir}/mate/clock-applet
149%{_libexecdir}/mate/fish-applet
150%{_libexecdir}/mate/notification-area-applet
151%{_libexecdir}/mate/wnck-applet
152%{_datadir}//MateConf/gsettings/mate-panel.convert
153%{_datadir}/applications/mate-panel.desktop
154%{_datadir}/dbus-1/services/*.service
155%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.clock.gschema.xml
156%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.fish.gschema.xml
157%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.window-list.gschema.xml
158%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.workspace-switcher.gschema.xml
159%{_datadir}/glib-2.0/schemas/org.mate.panel.enums.xml
160%{_datadir}/glib-2.0/schemas/org.mate.panel.gschema.xml
161%{_datadir}/glib-2.0/schemas/org.mate.panel.menubar.gschema.xml
162%{_datadir}/glib-2.0/schemas/org.mate.panel.object.gschema.xml
163%{_datadir}/glib-2.0/schemas/org.mate.panel.toplevel.gschema.xml
164%{_datadir}/icons/hicolor/*/*/*
165%{_datadir}/help
166%{_datadir}/mate-panel
167%{_mandir}/man1/mate-panel.1.gz
168%{_mandir}/man1/mate-desktop-item-edit.1.gz
169%{_mandir}/man1/mate-panel-test-applets.1.gz
170
171%files devel
172%defattr(-,root,root,-)
173%{_includedir}/mate-panel-4.0/
174%{_libdir}/libmate-panel-applet-*.so
175%{_libdir}/pkgconfig/libmatepanelapplet-4.0.pc
176%{_datadir}/gir-1.0/MatePanelApplet-4.0.gir
177
178%files doc
179%defattr(-,root,root,-)
180%{_datadir}/gtk-doc/html/mate-panel-applet
181
182
183%changelog
184* Sat May 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
185- new upstream release
186- remove Patch2002 (mate-panel-1.8.0-ja.po.patch)
187
188* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
189- rename Source (vine.layout)
190
191* Sun Jun 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-2
192- rename Source (vine.layout)
193- add Patch2001 (mate-panel-1.8.0-vine-layout.patch)
194- add Patch2002 (mate-panel-1.8.0-ja.po.patch)
195
196* Tue Apr 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
197- new upstream release
198- change BuildRequires: libwnck-devel instead of libmatewnck-devel
199- add BuildRequires: itstool
200
201* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-3
202- rebuild with VineSeed environment
203
204* Wed Sep 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-2
205- change Source1 (panel-default-layout.mate.vine)
206- add Patch2000 (mate-panel-1.6.1-about-vine.patch)
207- add Requires: vine-menus
208
209* Sun Sep 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
210- new upstream release
211
212* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
213- new upstream release
214- remove BuildRequires: mate-conf-devel, libmatecomponentui-devel
215- add BuildRequires: dconf-devel
216
217* Wed Aug 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
218- new upstream release
219- remove Patch0 (mate-panel-1.2.1-configure.patch)
220- change BuildRequires: libmatewnck-devel instead of libwnck-devel
221
222* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
223- new upstream release
224- add Patch0 (mate-panel-1.2.1-configure.patch)
225
226* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
227- change category
228
229* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
230- initial build for Vine Linux
231
Note: See TracBrowser for help on using the repository browser.