source: projects/specs/trunk/m/mate-panel/mate-panel-vl.spec @ 9120

Revision 9120, 6.6 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1Summary:        The MATE Panel
2Name:           mate-panel
3Version:        1.8.1
4Release:        1%{?_dist_release}
5
6Source0:        http://pub.mate-desktop.org/releases/1.8/%{name}-%{version}.tar.xz
7Source1:        vine.layout
8
9# for Vine
10Patch2000:      mate-panel-1.6.1-about-vine.patch
11Patch2001:      mate-panel-1.8.0-vine-layout.patch
12Patch2002:      mate-panel-1.8.0-ja.po.patch
13
14License:        GPLv2
15Group:          User Interface/Desktops
16URL:            http://mate-desktop.org/
17
18BuildRequires:  mate-common
19BuildRequires:  mate-doc-utils
20BuildRequires:  mate-desktop-devel
21BuildRequires:  mate-menus-devel
22BuildRequires:  libmateweather-devel
23BuildRequires:  gtk2-devel
24BuildRequires:  libSM-devel
25BuildRequires:  libcanberra-devel
26BuildRequires:  dbus-glib-devel
27BuildRequires:  libwnck-devel
28BuildRequires:  librsvg2-devel
29BuildRequires:  evolution-data-server-devel
30BuildRequires:  NetworkManager-devel
31BuildRequires:  dconf-devel
32BuildRequires:  gtk-doc
33BuildRequires:  itstool
34BuildRequires:  autoconf
35BuildRequires:  automake
36
37Requires:               vine-menus
38Requires(posttrans,postun):     glib2
39Requires(post,postun):  gtk2
40Requires(post,postun):  desktop-file-utils
41
42BuildRoot:      %{_tmppath}/%{name}-%{version}-root
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46Packager:       Takemikaduchi
47
48
49%description
50mate-panel contains the MATE panel, the libmate-panel-applet library and
51several applets:
52
53  + the MATE panel is the area on your desktop from which you can run
54    applications and applets, and perform other tasks.
55
56  + the libmate-panel-applet library allows to develop small applications
57    which may be embedded in the panel. These are called applets.
58    Documentation for the API is available with gtk-doc.
59
60  + the applets supplied here include the Workspace Switcher, the Window
61    List, the Window Selector, the Notification Area, the Clock and the
62    infamous 'Wanda the Fish'.
63
64
65%package                devel
66Summary:        Development tools for mate-panel
67Summary(ja):    mate-panel の開発環境
68Group:          Development/Libraries
69Requires:       %{name} = %{version}-%{release}
70Requires:       pkgconfig
71
72%description    devel
73Header files and libraries for building a extension library for the
74mate-panel.
75
76
77%package        doc
78Summary:        Documentation for mate-panel
79Summary(ja):    mate-panel 用のドキュメント
80Group:          Documentation
81Requires:       %{name} = %{version}-%{release}
82BuildArch:      noarch
83
84%description    doc
85This package contains documentation for mate-panel.
86
87
88%prep
89%setup -q
90%patch2000 -p1 -b .vine
91%patch2001 -p1 -b .vine
92%patch2002 -p1 -b .vine
93
94%build
95(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
96%configure \
97        --libexecdir=%{_libexecdir}/mate \
98        --disable-static \
99        --disable-scrollkeeper \
100        --enable-introspection \
101        --enable-matecomponent
102
103%{__make} %{?_smp_mflags}
104
105
106%install
107%{__rm} -rf ${RPM_BUILD_ROOT}
108
109%{__make} install DESTDIR=${RPM_BUILD_ROOT}
110
111find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
112find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
113
114install -c -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{name}/layouts/
115
116%find_lang %{name}
117
118
119%clean
120%{__rm} -rf ${RPM_BUILD_ROOT}
121
122
123%post
124/sbin/ldconfig
125update-desktop-database %{_datadir}/applications >& /dev/null ||:
126touch --no-create %{_datadir}/icons/hicolor
127gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
128
129%postun
130/sbin/ldconfig
131if [ $1 -eq 0 ]; then
132  update-desktop-database %{_datadir}/applications >& /dev/null ||:
133  touch --no-create %{_datadir}/icons/hicolor
134  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
135  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
136fi
137
138%posttrans
139glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
140
141
142%files -f %{name}.lang
143%defattr(-,root,root,-)
144%doc COPYING ChangeLog NEWS README
145%{_bindir}/mate-desktop-item-edit
146%{_bindir}/mate-panel
147%{_bindir}/mate-panel-test-applets
148%{_libdir}/girepository-1.0/MatePanelApplet-4.0.typelib
149%{_libdir}/libmate-panel-applet-*.so.*
150%{_libexecdir}/mate/clock-applet
151%{_libexecdir}/mate/fish-applet
152%{_libexecdir}/mate/notification-area-applet
153%{_libexecdir}/mate/wnck-applet
154%{_datadir}//MateConf/gsettings/mate-panel.convert
155%{_datadir}/applications/mate-panel.desktop
156%{_datadir}/dbus-1/services/*.service
157%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.clock.gschema.xml
158%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.fish.gschema.xml
159%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.window-list.gschema.xml
160%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.workspace-switcher.gschema.xml
161%{_datadir}/glib-2.0/schemas/org.mate.panel.enums.xml
162%{_datadir}/glib-2.0/schemas/org.mate.panel.gschema.xml
163%{_datadir}/glib-2.0/schemas/org.mate.panel.menubar.gschema.xml
164%{_datadir}/glib-2.0/schemas/org.mate.panel.object.gschema.xml
165%{_datadir}/glib-2.0/schemas/org.mate.panel.toplevel.gschema.xml
166%{_datadir}/icons/hicolor/*/*/*
167%{_datadir}/help
168%{_datadir}/mate-panel
169%{_mandir}/man1/mate-panel.1.gz
170%{_mandir}/man1/mate-desktop-item-edit.1.gz
171%{_mandir}/man1/mate-panel-test-applets.1.gz
172
173%files devel
174%defattr(-,root,root,-)
175%{_includedir}/mate-panel-4.0/
176%{_libdir}/libmate-panel-applet-*.so
177%{_libdir}/pkgconfig/libmatepanelapplet-4.0.pc
178%{_datadir}/gir-1.0/MatePanelApplet-4.0.gir
179
180%files doc
181%defattr(-,root,root,-)
182%{_datadir}/gtk-doc/html/mate-panel-applet
183
184
185%changelog
186* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
187- rename Source (vine.layout)
188
189* Sun Jun 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-2
190- rename Source (vine.layout)
191- add Patch2001 (mate-panel-1.8.0-vine-layout.patch)
192- add Patch2002 (mate-panel-1.8.0-ja.po.patch)
193
194* Tue Apr 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
195- new upstream release
196- change BuildRequires: libwnck-devel instead of libmatewnck-devel
197- add BuildRequires: itstool
198
199* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-3
200- rebuild with VineSeed environment
201
202* Wed Sep 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-2
203- change Source1 (panel-default-layout.mate.vine)
204- add Patch2000 (mate-panel-1.6.1-about-vine.patch)
205- add Requires: vine-menus
206
207* Sun Sep 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
208- new upstream release
209
210* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
211- new upstream release
212- remove BuildRequires: mate-conf-devel, libmatecomponentui-devel
213- add BuildRequires: dconf-devel
214
215* Wed Aug 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
216- new upstream release
217- remove Patch0 (mate-panel-1.2.1-configure.patch)
218- change BuildRequires: libmatewnck-devel instead of libwnck-devel
219
220* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
221- new upstream release
222- add Patch0 (mate-panel-1.2.1-configure.patch)
223
224* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
225- change category
226
227* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
228- initial build for Vine Linux
229
Note: See TracBrowser for help on using the repository browser.