source: projects/specs/trunk/m/mate-panel/mate-panel-vl.spec @ 6679

Revision 6679, 7.5 KB checked in by Takemikaduchi, 12 years ago (diff)

MATE-1.4.0

Line 
1Summary:        The MATE Panel
2Name:           mate-panel
3Version:        1.4.0
4Release:        1%{?_dist_release}
5
6Source0:        http://pub.mate-desktop.org/releases/1.4/%{name}-%{version}.tar.xz
7Source1:        vine-mate-panel-default-setup.entries
8
9License:        GPLv2
10Group:          User Interface/Desktops
11URL:            http://mate-desktop.org/
12
13BuildRequires:  mate-common
14BuildRequires:  mate-doc-utils
15BuildRequires:  mate-conf-devel
16BuildRequires:  mate-desktop-devel
17BuildRequires:  mate-menus-devel
18BuildRequires:  libmateweather-devel
19BuildRequires:  libmatecomponentui-devel
20BuildRequires:  gtk2-devel
21BuildRequires:  libSM-devel
22BuildRequires:  libcanberra-devel
23BuildRequires:  dbus-glib-devel
24BuildRequires:  libmatewnck-devel
25BuildRequires:  librsvg2-devel
26BuildRequires:  evolution-data-server-devel
27BuildRequires:  NetworkManager-devel
28BuildRequires:  gtk-doc
29BuildRequires:  autoconf
30BuildRequires:  automake
31
32Requires(post,pre,preun):       mate-conf
33Requires(post,postun):  desktop-file-utils
34
35BuildRoot:      %{_tmppath}/%{name}-%{version}-root
36
37Vendor:         Project Vine
38Distribution:   Vine Linux
39Packager:       Takemikaduchi
40
41
42%description
43mate-panel contains the MATE panel, the libmate-panel-applet library and
44several applets:
45
46  + the MATE panel is the area on your desktop from which you can run
47    applications and applets, and perform other tasks.
48
49  + the libmate-panel-applet library allows to develop small applications
50    which may be embedded in the panel. These are called applets.
51    Documentation for the API is available with gtk-doc.
52
53  + the applets supplied here include the Workspace Switcher, the Window
54    List, the Window Selector, the Notification Area, the Clock and the
55    infamous 'Wanda the Fish'.
56
57
58%package        devel
59Summary:        Development tools for mate-panel
60Summary(ja):    mate-panel の開発環境
61Group:          Development/Libraries
62Requires:       %{name} = %{version}-%{release}
63Requires:       pkgconfig
64
65%description    devel
66Header files and libraries for building a extension library for the
67mate-panel.
68
69
70%package        doc
71Summary:        Documentation for mate-panel
72Summary(ja):    mate-panel 用のドキュメント
73Group:          Documentation
74Requires:       %{name} = %{version}-%{release}
75BuildArch:      noarch
76
77%description    doc
78This package contains documentation for mate-panel.
79
80
81%prep
82%setup -q
83
84cp -f %{SOURCE1} mate-panel/panel-default-setup.entries
85
86%build
87(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
88%configure \
89        --libexecdir=%{_libexecdir}/mate \
90        --disable-static \
91        --disable-scrollkeeper \
92        --enable-introspection \
93        --enable-matecomponent
94
95%{__make} %{?_smp_mflags}
96
97
98%install
99%{__rm} -rf ${RPM_BUILD_ROOT}
100
101export MATECONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
102%{__make} install DESTDIR=${RPM_BUILD_ROOT}
103unset MATECONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
104
105find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
106find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
107
108%find_lang %{name}
109
110
111%clean
112%{__rm} -rf ${RPM_BUILD_ROOT}
113
114
115%post
116/sbin/ldconfig
117
118export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
119
120SCHEMAS=" \
121  clock.schemas \
122  fish.schemas \
123  panel-compatibility.schemas \
124  panel-default-setup.entries \
125  panel-general.schemas \
126  panel-global.schemas \
127  panel-object.schemas \
128  panel-toplevel.schemas \
129  window-list.schemas \
130  workspace-switcher.schemas"
131for S in $SCHEMAS; do
132  echo %{_sysconfdir}/mateconf/schemas/$S; done \
133  | xargs mateconftool-2 --makefile-install-rule >& /dev/null ||:
134
135mateconftool-2 --direct --config-source=$MATECONF_CONFIG_SOURCE --load %{_sysconfdir}/mateconf/schemas/panel-default-setup.entries > /dev/null || :
136mateconftool-2 --direct --config-source=$MATECONF_CONFIG_SOURCE --load %{_sysconfdir}/mateconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || :
137
138update-desktop-database %{_datadir}/applications >& /dev/null ||:
139touch --no-create %{_datadir}/icons/hicolor
140if [ -x /usr/bin/gtk-update-icon-cache ]; then
141  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
142fi
143
144%pre
145if [ "$1" -gt 1 ]; then
146  export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
147
148  SCHEMAS=" \
149    clock.schemas \
150    fish.schemas \
151    panel-compatibility.schemas \
152    panel-default-setup.entries \
153    panel-general.schemas \
154    panel-global.schemas \
155    panel-object.schemas \
156    panel-toplevel.schemas \
157    window-list.schemas \
158    workspace-switcher.schemas"
159  for S in $SCHEMAS; do
160    echo %{_sysconfdir}/mateconf/schemas/$S; done \
161    | xargs mateconftool-2 --makefile-uninstall-rule >& /dev/null ||:
162fi
163
164%preun
165if [ "$1" -eq 0 ]; then
166  export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
167
168  SCHEMAS=" \
169    clock.schemas \
170    fish.schemas \
171    panel-compatibility.schemas \
172    panel-default-setup.entries \
173    panel-general.schemas \
174    panel-global.schemas \
175    panel-object.schemas \
176    panel-toplevel.schemas \
177    window-list.schemas \
178    workspace-switcher.schemas"
179  for S in $SCHEMAS; do
180    echo %{_sysconfdir}/mateconf/schemas/$S; done \
181    | xargs mateconftool-2 --makefile-uninstall-rule >& /dev/null ||:
182fi
183
184%postun
185/sbin/ldconfig
186update-desktop-database %{_datadir}/applications >& /dev/null ||:
187touch --no-create %{_datadir}/icons/hicolor
188if [ -x /usr/bin/gtk-update-icon-cache ]; then
189  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
190fi
191
192
193%files -f %{name}.lang
194%defattr(-,root,root,-)
195%doc COPYING ChangeLog NEWS README
196%{_sysconfdir}/mateconf/schemas/clock.schemas
197%{_sysconfdir}/mateconf/schemas/fish.schemas
198%{_sysconfdir}/mateconf/schemas/panel-compatibility.schemas
199%{_sysconfdir}/mateconf/schemas/panel-default-setup.entries
200%{_sysconfdir}/mateconf/schemas/panel-general.schemas
201%{_sysconfdir}/mateconf/schemas/panel-global.schemas
202%{_sysconfdir}/mateconf/schemas/panel-object.schemas
203%{_sysconfdir}/mateconf/schemas/panel-toplevel.schemas
204%{_sysconfdir}/mateconf/schemas/window-list.schemas
205%{_sysconfdir}/mateconf/schemas/workspace-switcher.schemas
206%{_bindir}/mate-desktop-item-edit
207%{_bindir}/mate-panel
208%{_bindir}/mate-panel-test-applets
209%{_bindir}/panel-test-applets-matecomponent
210%{_libdir}/libmate-panel-applet-*.so.*
211%{_libdir}/girepository-1.0/MatePanelApplet-3.0.typelib
212%{_libdir}/mate-panel/modules/libmate-panel-applets-matecomponent.so
213%{_libexecdir}/mate/clock-applet
214%{_libexecdir}/mate/fish-applet
215%{_libexecdir}/mate/mate-panel-add
216%{_libexecdir}/mate/notification-area-applet
217%{_libexecdir}/mate/wnck-applet
218%{_datadir}/applications/mate-panel.desktop
219%{_datadir}/dbus-1/services/*.service
220%{_datadir}/icons/hicolor/*/*/*
221%{_datadir}/idl/mate-panel-2.0/MATE_Panel.idl
222%{_datadir}/mate/help
223%{_datadir}/mate-2.0/ui/MATE_Panel_Popup.xml
224%{_datadir}/mate-panel
225%{_datadir}/mate-panelrc
226%{_datadir}/omf/mate-applet-clock
227%{_datadir}/omf/mate-applet-fish
228%{_mandir}/man1/mate-panel.1.gz
229
230%files devel
231%defattr(-,root,root,-)
232%{_includedir}/mate-panel-3.0/
233%{_includedir}/panel-2.0/
234%{_libdir}/libmate-panel-applet-*.so
235%{_libdir}/pkgconfig/libmatepanelapplet-2.0.pc
236%{_libdir}/pkgconfig/libmatepanelapplet-3.0.pc
237%{_datadir}/gir-1.0/MatePanelApplet-3.0.gir
238
239%files doc
240%defattr(-,root,root,-)
241%{_datadir}/gtk-doc/html/mate-panel-applet
242
243
244%changelog
245* Wed Aug 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
246- new upstream release
247- remove Patch0 (mate-panel-1.2.1-configure.patch)
248- change BuildRequires: libmatewnck-devel instead of libwnck-devel
249
250* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
251- new upstream release
252- add Patch0 (mate-panel-1.2.1-configure.patch)
253
254* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
255- change category
256
257* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
258- initial build for Vine Linux
259
Note: See TracBrowser for help on using the repository browser.