source: projects/specs/trunk/m/mate-panel/mate-panel-vl.spec @ 6172

Revision 6172, 7.3 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1Summary:        The MATE Panel
2Name:           mate-panel
3Version:        1.2.1
4Release:        1%{?_dist_release}
5
6Source0:        %{name}-%{version}.tar.xz
7Source1:        vine-mate-panel-default-setup.entries
8
9Patch0:         mate-panel-1.2.1-configure.patch
10
11License:        GPLv2
12Group:          User Interface/Desktops
13URL:            https://matsusoft.com.ar/projects/mate/
14
15BuildRequires:  mate-common
16BuildRequires:  mate-doc-utils
17BuildRequires:  mate-conf-devel
18BuildRequires:  mate-desktop-devel
19BuildRequires:  mate-menus-devel
20BuildRequires:  libmateweather-devel
21BuildRequires:  libmatecomponentui-devel
22BuildRequires:  gtk2-devel
23BuildRequires:  libSM-devel
24BuildRequires:  libcanberra-devel
25BuildRequires:  dbus-glib-devel
26BuildRequires:  libwnck-devel
27BuildRequires:  librsvg2-devel
28BuildRequires:  evolution-data-server-devel
29BuildRequires:  NetworkManager-devel
30BuildRequires:  gtk-doc
31BuildRequires:  autoconf
32BuildRequires:  automake
33
34Requires(post,pre,preun):       mate-conf
35Requires(post,postun):  desktop-file-utils
36
37BuildRoot:      %{_tmppath}/%{name}-%{version}-root
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41Packager:       Takemikaduchi
42
43
44%description
45mate-panel contains the MATE panel, the libmate-panel-applet library and
46several applets:
47
48  + the MATE panel is the area on your desktop from which you can run
49    applications and applets, and perform other tasks.
50
51  + the libmate-panel-applet library allows to develop small applications
52    which may be embedded in the panel. These are called applets.
53    Documentation for the API is available with gtk-doc.
54
55  + the applets supplied here include the Workspace Switcher, the Window
56    List, the Window Selector, the Notification Area, the Clock and the
57    infamous 'Wanda the Fish'.
58
59
60%package        devel
61Summary:        Development tools for mate-panel
62Summary(ja):    mate-panel の開発環境
63Group:          Development/Libraries
64Requires:       %{name} = %{version}-%{release}
65Requires:       pkgconfig
66
67%description    devel
68Header files and libraries for building a extension library for the
69mate-panel.
70
71
72%package        doc
73Summary:        Documentation for mate-panel
74Summary(ja):    mate-panel 用のドキュメント
75Group:          Documentation
76Requires:       %{name} = %{version}-%{release}
77BuildArch:      noarch
78
79%description    doc
80This package contains documentation for mate-panel.
81
82
83%prep
84%setup -q
85%patch0 -p1
86
87cp -f %{SOURCE1} mate-panel/panel-default-setup.entries
88
89%build
90(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
91%configure \
92        --libexecdir=%{_libexecdir}/mate \
93        --disable-static \
94        --disable-scrollkeeper \
95        --enable-introspection \
96        --enable-matecomponent
97
98%{__make} %{?_smp_mflags}
99
100
101%install
102%{__rm} -rf ${RPM_BUILD_ROOT}
103
104export MATECONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
105%{__make} install DESTDIR=${RPM_BUILD_ROOT}
106unset MATECONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
107
108find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
109find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
110
111%find_lang %{name}
112
113
114%clean
115%{__rm} -rf ${RPM_BUILD_ROOT}
116
117
118%post
119/sbin/ldconfig
120
121export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
122
123SCHEMAS=" \
124  clock.schemas \
125  fish.schemas \
126  panel-compatibility.schemas \
127  panel-default-setup.entries \
128  panel-general.schemas \
129  panel-global.schemas \
130  panel-object.schemas \
131  panel-toplevel.schemas \
132  window-list.schemas \
133  workspace-switcher.schemas"
134for S in $SCHEMAS; do
135  echo %{_sysconfdir}/mateconf/schemas/$S; done \
136  | xargs mateconftool-2 --makefile-install-rule >& /dev/null ||:
137
138mateconftool-2 --direct --config-source=$MATECONF_CONFIG_SOURCE --load %{_sysconfdir}/mateconf/schemas/panel-default-setup.entries > /dev/null || :
139mateconftool-2 --direct --config-source=$MATECONF_CONFIG_SOURCE --load %{_sysconfdir}/mateconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || :
140
141update-desktop-database %{_datadir}/applications >& /dev/null ||:
142touch --no-create %{_datadir}/icons/hicolor
143if [ -x /usr/bin/gtk-update-icon-cache ]; then
144  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
145fi
146
147%pre
148if [ "$1" -gt 1 ]; then
149  export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
150
151  SCHEMAS=" \
152    clock.schemas \
153    fish.schemas \
154    panel-compatibility.schemas \
155    panel-default-setup.entries \
156    panel-general.schemas \
157    panel-global.schemas \
158    panel-object.schemas \
159    panel-toplevel.schemas \
160    window-list.schemas \
161    workspace-switcher.schemas"
162  for S in $SCHEMAS; do
163    echo %{_sysconfdir}/mateconf/schemas/$S; done \
164    | xargs mateconftool-2 --makefile-uninstall-rule >& /dev/null ||:
165fi
166
167%preun
168if [ "$1" -eq 0 ]; then
169  export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
170
171  SCHEMAS=" \
172    clock.schemas \
173    fish.schemas \
174    panel-compatibility.schemas \
175    panel-default-setup.entries \
176    panel-general.schemas \
177    panel-global.schemas \
178    panel-object.schemas \
179    panel-toplevel.schemas \
180    window-list.schemas \
181    workspace-switcher.schemas"
182  for S in $SCHEMAS; do
183    echo %{_sysconfdir}/mateconf/schemas/$S; done \
184    | xargs mateconftool-2 --makefile-uninstall-rule >& /dev/null ||:
185fi
186
187%postun
188/sbin/ldconfig
189update-desktop-database %{_datadir}/applications >& /dev/null ||:
190touch --no-create %{_datadir}/icons/hicolor
191if [ -x /usr/bin/gtk-update-icon-cache ]; then
192  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
193fi
194
195
196%files -f %{name}.lang
197%defattr(-,root,root,-)
198%doc COPYING ChangeLog NEWS README
199%{_sysconfdir}/mateconf/schemas/clock.schemas
200%{_sysconfdir}/mateconf/schemas/fish.schemas
201%{_sysconfdir}/mateconf/schemas/panel-compatibility.schemas
202%{_sysconfdir}/mateconf/schemas/panel-default-setup.entries
203%{_sysconfdir}/mateconf/schemas/panel-general.schemas
204%{_sysconfdir}/mateconf/schemas/panel-global.schemas
205%{_sysconfdir}/mateconf/schemas/panel-object.schemas
206%{_sysconfdir}/mateconf/schemas/panel-toplevel.schemas
207%{_sysconfdir}/mateconf/schemas/window-list.schemas
208%{_sysconfdir}/mateconf/schemas/workspace-switcher.schemas
209%{_bindir}/mate-desktop-item-edit
210%{_bindir}/mate-panel
211%{_bindir}/mate-panel-test-applets
212%{_bindir}/panel-test-applets-matecomponent
213%{_libdir}/libmate-panel-applet-*.so.*
214%{_libdir}/girepository-1.0/MatePanelApplet-3.0.typelib
215%{_libdir}/mate-panel/modules/libmate-panel-applets-matecomponent.so
216%{_libexecdir}/mate/clock-applet
217%{_libexecdir}/mate/fish-applet
218%{_libexecdir}/mate/mate-panel-add
219%{_libexecdir}/mate/notification-area-applet
220%{_libexecdir}/mate/wnck-applet
221%{_datadir}/applications/mate-panel.desktop
222%{_datadir}/dbus-1/services/*.service
223%{_datadir}/icons/hicolor/*/*/*
224%{_datadir}/idl/mate-panel-2.0/MATE_Panel.idl
225%{_datadir}/mate/help
226%{_datadir}/mate-2.0/ui/MATE_Panel_Popup.xml
227%{_datadir}/mate-panel
228%{_datadir}/mate-panelrc
229%{_datadir}/omf/mate-applet-clock
230%{_datadir}/omf/mate-applet-fish
231%{_mandir}/man1/mate-panel.1.gz
232
233%files devel
234%defattr(-,root,root,-)
235%{_includedir}/mate-panel-3.0/
236%{_includedir}/panel-2.0/
237%{_libdir}/libmate-panel-applet-*.so
238%{_libdir}/pkgconfig/libmatepanelapplet-2.0.pc
239%{_libdir}/pkgconfig/libmatepanelapplet-3.0.pc
240%{_datadir}/gir-1.0/MatePanelApplet-3.0.gir
241
242%files doc
243%defattr(-,root,root,-)
244%{_datadir}/gtk-doc/html/mate-panel-applet
245
246
247%changelog
248* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
249- new upstream release
250- add Patch0 (mate-panel-1.2.1-configure.patch)
251
252* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
253- change category
254
255* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
256- initial build for Vine Linux
257
Note: See TracBrowser for help on using the repository browser.