source: projects/specs/trunk/m/mate-panel/mate-panel-vl.spec @ 5316

Revision 5316, 7.1 KB checked in by Takemikaduchi, 12 years ago (diff)

mate: change category
fontconfig: rebuild
others: new upstream release

Line 
1Summary:        The MATE Panel
2Name:           mate-panel
3Version:        1.1.0
4Release:        2%{?_dist_release}
5Source0:        %{name}-%{version}.tar.xz
6Source1:        vine-mate-panel-default-setup.entries
7License:        GPLv2
8Group:          User Interface/Desktops
9URL:            https://matsusoft.com.ar/projects/mate/
10
11BuildRequires:  mate-common
12BuildRequires:  mate-doc-utils
13BuildRequires:  mate-conf-devel
14BuildRequires:  mate-desktop-devel
15BuildRequires:  mate-menus-devel
16BuildRequires:  libmateweather-devel
17BuildRequires:  libmatecomponentui-devel
18BuildRequires:  gtk2-devel
19BuildRequires:  libSM-devel
20BuildRequires:  libcanberra-devel
21BuildRequires:  dbus-glib-devel
22BuildRequires:  libwnck-devel
23BuildRequires:  librsvg2-devel
24BuildRequires:  evolution-data-server-devel
25BuildRequires:  NetworkManager-devel
26BuildRequires:  gtk-doc
27BuildRequires:  autoconf
28BuildRequires:  automake
29
30Requires(post,pre,preun):       mate-conf
31Requires(post,postun):  desktop-file-utils
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34
35Vendor:         Project Vine
36Distribution:   Vine Linux
37Packager:       Takemikaduchi
38
39
40%description
41mate-panel contains the MATE panel, the libmate-panel-applet library and
42several applets:
43
44  + the MATE panel is the area on your desktop from which you can run
45    applications and applets, and perform other tasks.
46
47  + the libmate-panel-applet library allows to develop small applications
48    which may be embedded in the panel. These are called applets.
49    Documentation for the API is available with gtk-doc.
50
51  + the applets supplied here include the Workspace Switcher, the Window
52    List, the Window Selector, the Notification Area, the Clock and the
53    infamous 'Wanda the Fish'.
54
55
56%package        devel
57Summary:        Development tools for mate-panel
58Summary(ja):    mate-panel の開発環境
59Group:          Development/Libraries
60Requires:       %{name} = %{version}-%{release}
61Requires:       pkgconfig
62
63%description    devel
64Header files and libraries for building a extension library for the
65mate-panel.
66
67
68%package        doc
69Summary:        Documentation for mate-panel
70Summary(ja):    mate-panel 用のドキュメント
71Group:          Documentation
72Requires:       %{name} = %{version}-%{release}
73BuildArch:      noarch
74
75%description    doc
76This package contains documentation for mate-panel.
77
78
79%prep
80%setup -q
81
82cp -f %{SOURCE1} mate-panel/panel-default-setup.entries
83
84%build
85(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
86%configure \
87        --libexecdir=%{_libexecdir}/mate \
88        --disable-static \
89        --disable-scrollkeeper \
90        --enable-introspection \
91        --enable-matecomponent
92
93%{__make} %{?_smp_mflags}
94
95
96%install
97%{__rm} -rf ${RPM_BUILD_ROOT}
98
99export MATECONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
100%{__make} install DESTDIR=${RPM_BUILD_ROOT}
101unset MATECONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
102
103find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
104find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
105
106%find_lang %{name}-2.0
107
108
109%clean
110%{__rm} -rf ${RPM_BUILD_ROOT}
111
112
113%post
114/sbin/ldconfig
115
116export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
117
118SCHEMAS=" \
119  clock.schemas \
120  fish.schemas \
121  panel-compatibility.schemas \
122  panel-default-setup.entries \
123  panel-general.schemas \
124  panel-global.schemas \
125  panel-object.schemas \
126  panel-toplevel.schemas \
127  window-list.schemas \
128  workspace-switcher.schemas"
129for S in $SCHEMAS; do
130  echo %{_sysconfdir}/mateconf/schemas/$S; done \
131  | xargs mateconftool-2 --makefile-install-rule >& /dev/null ||:
132
133mateconftool-2 --direct --config-source=$MATECONF_CONFIG_SOURCE --load %{_sysconfdir}/mateconf/schemas/panel-default-setup.entries > /dev/null || :
134mateconftool-2 --direct --config-source=$MATECONF_CONFIG_SOURCE --load %{_sysconfdir}/mateconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || :
135
136update-desktop-database %{_datadir}/applications >& /dev/null ||:
137touch --no-create %{_datadir}/icons/hicolor
138if [ -x /usr/bin/gtk-update-icon-cache ]; then
139  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
140fi
141
142%pre
143if [ "$1" -gt 1 ]; then
144  export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
145
146  SCHEMAS=" \
147    clock.schemas \
148    fish.schemas \
149    panel-compatibility.schemas \
150    panel-default-setup.entries \
151    panel-general.schemas \
152    panel-global.schemas \
153    panel-object.schemas \
154    panel-toplevel.schemas \
155    window-list.schemas \
156    workspace-switcher.schemas"
157  for S in $SCHEMAS; do
158    echo %{_sysconfdir}/mateconf/schemas/$S; done \
159    | xargs mateconftool-2 --makefile-uninstall-rule >& /dev/null ||:
160fi
161
162%preun
163if [ "$1" -eq 0 ]; then
164  export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
165
166  SCHEMAS=" \
167    clock.schemas \
168    fish.schemas \
169    panel-compatibility.schemas \
170    panel-default-setup.entries \
171    panel-general.schemas \
172    panel-global.schemas \
173    panel-object.schemas \
174    panel-toplevel.schemas \
175    window-list.schemas \
176    workspace-switcher.schemas"
177  for S in $SCHEMAS; do
178    echo %{_sysconfdir}/mateconf/schemas/$S; done \
179    | xargs mateconftool-2 --makefile-uninstall-rule >& /dev/null ||:
180fi
181
182%postun
183/sbin/ldconfig
184update-desktop-database %{_datadir}/applications >& /dev/null ||:
185touch --no-create %{_datadir}/icons/hicolor
186if [ -x /usr/bin/gtk-update-icon-cache ]; then
187  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
188fi
189
190
191%files -f %{name}-2.0.lang
192%defattr(-,root,root,-)
193%doc COPYING ChangeLog NEWS README
194%{_sysconfdir}/mateconf/schemas/clock.schemas
195%{_sysconfdir}/mateconf/schemas/fish.schemas
196%{_sysconfdir}/mateconf/schemas/panel-compatibility.schemas
197%{_sysconfdir}/mateconf/schemas/panel-default-setup.entries
198%{_sysconfdir}/mateconf/schemas/panel-general.schemas
199%{_sysconfdir}/mateconf/schemas/panel-global.schemas
200%{_sysconfdir}/mateconf/schemas/panel-object.schemas
201%{_sysconfdir}/mateconf/schemas/panel-toplevel.schemas
202%{_sysconfdir}/mateconf/schemas/window-list.schemas
203%{_sysconfdir}/mateconf/schemas/workspace-switcher.schemas
204%{_bindir}/mate-desktop-item-edit
205%{_bindir}/mate-panel
206%{_bindir}/mate-panel-test-applets
207%{_bindir}/panel-test-applets-matecomponent
208%{_libdir}/libmate-panel-applet-*.so.*
209%{_libdir}/girepository-1.0/MatePanelApplet-3.0.typelib
210%{_libdir}/mate-panel/modules/libmate-panel-applets-matecomponent.so
211%{_libexecdir}/mate/clock-applet
212%{_libexecdir}/mate/fish-applet
213%{_libexecdir}/mate/mate-panel-add
214%{_libexecdir}/mate/notification-area-applet
215%{_libexecdir}/mate/wnck-applet
216%{_datadir}/applications/mate-panel.desktop
217%{_datadir}/dbus-1/services/*.service
218%{_datadir}/icons/hicolor/*/*/*
219%{_datadir}/idl/mate-panel-2.0/MATE_Panel.idl
220%{_datadir}/mate/help
221%{_datadir}/mate-2.0/ui/MATE_Panel_Popup.xml
222%{_datadir}/mate-panel
223%{_datadir}/mate-panelrc
224%{_datadir}/omf/mate-applet-clock
225%{_datadir}/omf/mate-applet-fish
226%{_mandir}/man1/mate-panel.1.gz
227
228%files devel
229%defattr(-,root,root,-)
230%{_includedir}/mate-panel-3.0/
231%{_includedir}/panel-2.0/
232%{_libdir}/libmate-panel-applet-*.so
233%{_libdir}/pkgconfig/libmatepanelapplet-2.0.pc
234%{_libdir}/pkgconfig/libmatepanelapplet-3.0.pc
235%{_datadir}/gir-1.0/MatePanelApplet-3.0.gir
236
237%files doc
238%defattr(-,root,root,-)
239%{_datadir}/gtk-doc/html/mate-panel-applet
240
241
242%changelog
243* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
244- change category
245
246* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
247- initial build for Vine Linux
248
Note: See TracBrowser for help on using the repository browser.