source: projects/specs/trunk/m/mate-panel/mate-panel-vl.spec @ 11040

Revision 11040, 8.1 KB checked in by iwaim, 7 years ago (diff)

mate-panel 1.18.1-1

Line 
1%define major_ver 1.18
2%define ver %{major_ver}.1
3%define rel 1
4
5Summary:        The MATE Panel
6Name:           mate-panel
7Version:        %{ver}
8Release:        %{rel}%{?_dist_release}
9
10Source0:        http://pub.mate-desktop.org/releases/%{major_ver}/%{name}-%{version}.tar.xz
11Source1:        vine.layout
12
13# for Vine
14Patch2000:      mate-panel-1.6.1-about-vine.patch
15Patch2001:      mate-panel-1.12.0-vine-layout.patch
16
17License:        GPLv2, LGPLv2 and GFDLv1.1
18Group:          User Interface/Desktops
19URL:            http://mate-desktop.org/
20
21BuildRequires:  mate-common
22BuildRequires:  mate-desktop-devel >= 1.17.0
23BuildRequires:  mate-menus-devel >= 1.10.0
24BuildRequires:  libmateweather-devel >= 1.17.0
25BuildRequires:  gtk3-devel >= 3.14
26BuildRequires:  libSM-devel
27BuildRequires:  dbus-glib-devel
28BuildRequires:  libwnck3-devel
29BuildRequires:  librsvg2-devel
30BuildRequires:  gtk-doc
31BuildRequires:  itstool
32BuildRequires:  autoconf
33BuildRequires:  automake
34
35Requires:               vine-menus
36Requires(posttrans,postun):     glib2
37Requires(post,postun):  gtk2
38Requires(post,postun):  desktop-file-utils
39
40BuildRoot:      %{_tmppath}/%{name}-%{version}-root
41
42Vendor:         Project Vine
43Distribution:   Vine Linux
44Packager:       Takemikaduchi, iwaim
45
46
47%description
48mate-panel contains the MATE panel, the libmate-panel-applet library and
49several applets:
50
51  + the MATE panel is the area on your desktop from which you can run
52    applications and applets, and perform other tasks.
53
54  + the libmate-panel-applet library allows to develop small applications
55    which may be embedded in the panel. These are called applets.
56    Documentation for the API is available with gtk-doc.
57
58  + the applets supplied here include the Workspace Switcher, the Window
59    List, the Window Selector, the Notification Area, the Clock and the
60    infamous 'Wanda the Fish'.
61
62
63%package                devel
64Summary:        Development tools for mate-panel
65Summary(ja):    mate-panel の開発環境
66Group:          Development/Libraries
67Requires:       %{name} = %{version}-%{release}
68Requires:       pkgconfig
69
70%description    devel
71Header files and libraries for building a extension library for the
72mate-panel.
73
74
75%package        docs
76Summary:        Documentation for mate-panel
77Summary(ja):    mate-panel 用のドキュメント
78Group:          Documentation
79Requires:       %{name} = %{version}-%{release}
80Obsoletes:      %{name}-doc < 1.10.1
81BuildArch:      noarch
82
83%description    docs
84This package contains documentation for mate-panel.
85
86
87%prep
88%setup -q
89%patch2000 -p1 -b .vine
90%patch2001 -p1 -b .vine
91
92%build
93(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
94%configure \
95        --libexecdir=%{_libexecdir}/mate \
96        --disable-static \
97        --enable-introspection
98
99%{__make} %{?_smp_mflags}
100
101
102%install
103%{__rm} -rf ${RPM_BUILD_ROOT}
104
105%{__make} install DESTDIR=${RPM_BUILD_ROOT}
106
107find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
108find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
109
110install -c -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{name}/layouts/
111
112%find_lang %{name}
113
114
115%clean
116%{__rm} -rf ${RPM_BUILD_ROOT}
117
118
119%post
120/sbin/ldconfig
121update-desktop-database %{_datadir}/applications >& /dev/null ||:
122touch --no-create %{_datadir}/icons/hicolor
123gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
124
125%postun
126/sbin/ldconfig
127if [ $1 -eq 0 ]; then
128  update-desktop-database %{_datadir}/applications >& /dev/null ||:
129  touch --no-create %{_datadir}/icons/hicolor
130  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
131  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
132fi
133
134%posttrans
135glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
136
137
138%files -f %{name}.lang
139%defattr(-,root,root,-)
140%doc COPYING* ChangeLog NEWS README
141%{_bindir}/mate-desktop-item-edit
142%{_bindir}/mate-panel
143%{_bindir}/mate-panel-test-applets
144%{_libdir}/girepository-1.0/MatePanelApplet-4.0.typelib
145%{_libdir}/libmate-panel-applet-*.so.*
146%{_libexecdir}/mate/clock-applet
147%{_libexecdir}/mate/fish-applet
148%{_libexecdir}/mate/notification-area-applet
149%{_libexecdir}/mate/wnck-applet
150%{_datadir}/applications/mate-panel.desktop
151%{_datadir}/dbus-1/services/*.service
152%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.clock.gschema.xml
153%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.fish.gschema.xml
154%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.window-list.gschema.xml
155%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.workspace-switcher.gschema.xml
156%{_datadir}/glib-2.0/schemas/org.mate.panel.enums.xml
157%{_datadir}/glib-2.0/schemas/org.mate.panel.gschema.xml
158%{_datadir}/glib-2.0/schemas/org.mate.panel.menubar.gschema.xml
159%{_datadir}/glib-2.0/schemas/org.mate.panel.object.gschema.xml
160%{_datadir}/glib-2.0/schemas/org.mate.panel.toplevel.gschema.xml
161%{_datadir}/icons/hicolor/*/*/*
162%{_datadir}/help
163%{_datadir}/mate-panel
164%{_mandir}/man1/mate-panel.1.gz
165%{_mandir}/man1/mate-desktop-item-edit.1.gz
166%{_mandir}/man1/mate-panel-test-applets.1.gz
167
168%files devel
169%defattr(-,root,root,-)
170%{_includedir}/mate-panel-4.0/
171%{_libdir}/libmate-panel-applet-*.so
172%{_libdir}/pkgconfig/libmatepanelapplet-4.0.pc
173%{_datadir}/gir-1.0/MatePanelApplet-4.0.gir
174
175%files docs
176%defattr(-,root,root,-)
177%{_datadir}/gtk-doc/html/mate-panel-applet
178
179
180%changelog
181* Tue Apr 11 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.1-1
182- update to 1.18.1
183
184* Sun Apr  2 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.0-1
185- update to 1.18.0
186- move to GTK3+
187- drop ja.po patch (Patch2002); upstream merged
188- drop unrecognized options:
189 - '--disable-scrollkeeper' and '--enable-matecomponent'
190- update BuildRequires
191 - drop
192  - gtk2-devel
193  - libwnck-devel
194  - libcanberra-devel
195  - evolution-data-server-devel
196  - NetworkManager-devel
197  - dconf-devel
198 - add
199  - gtk3-devel
200  - libwnck3-devel
201
202* Sun Mar 26 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.16.1-1
203- update to 1.16.1
204
205* Sun Nov 27 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.16.0-1
206- new upstream release
207- update ja.po patch (Patch2002)
208- update License
209- update Packager
210
211* Wed Jun 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.1-1
212- new upstream release
213
214* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
215- new upstream release
216
217* Sun Feb 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
218- new upstream release
219
220* Tue Dec 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
221- new upstream release
222
223* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
224- new upstream release
225- update Patch2001 (mate-panel-1.12.0-vine-layout.patch)
226- update Patch2002 (mate-panel-1.12.0-ja.po.patch)
227
228* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-2
229- add Patch2002 (mate-panel-1.10.1-ja.po.patch)
230
231* Sat Jul 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
232- new upstream release
233
234* Sat May 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
235- new upstream release
236- remove Patch2002 (mate-panel-1.8.0-ja.po.patch)
237
238* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
239- rename Source (vine.layout)
240
241* Sun Jun 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-2
242- rename Source (vine.layout)
243- add Patch2001 (mate-panel-1.8.0-vine-layout.patch)
244- add Patch2002 (mate-panel-1.8.0-ja.po.patch)
245
246* Tue Apr 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
247- new upstream release
248- change BuildRequires: libwnck-devel instead of libmatewnck-devel
249- add BuildRequires: itstool
250
251* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-3
252- rebuild with VineSeed environment
253
254* Wed Sep 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-2
255- change Source1 (panel-default-layout.mate.vine)
256- add Patch2000 (mate-panel-1.6.1-about-vine.patch)
257- add Requires: vine-menus
258
259* Sun Sep 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
260- new upstream release
261
262* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
263- new upstream release
264- remove BuildRequires: mate-conf-devel, libmatecomponentui-devel
265- add BuildRequires: dconf-devel
266
267* Wed Aug 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
268- new upstream release
269- remove Patch0 (mate-panel-1.2.1-configure.patch)
270- change BuildRequires: libmatewnck-devel instead of libwnck-devel
271
272* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
273- new upstream release
274- add Patch0 (mate-panel-1.2.1-configure.patch)
275
276* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
277- change category
278
279* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
280- initial build for Vine Linux
281
Note: See TracBrowser for help on using the repository browser.