source: projects/specs/trunk/m/mate-panel/mate-panel-vl.spec @ 10255

Revision 10255, 7.4 KB checked in by Takemikaduchi, 8 years ago (diff)

MATE-1.14.0

Line 
1Summary:        The MATE Panel
2Name:           mate-panel
3Version:        1.14.0
4Release:        1%{?_dist_release}
5
6Source0:        http://pub.mate-desktop.org/releases/1.14/%{name}-%{version}.tar.xz
7Source1:        vine.layout
8
9# for Vine
10Patch2000:      mate-panel-1.6.1-about-vine.patch
11Patch2001:      mate-panel-1.12.0-vine-layout.patch
12Patch2002:      mate-panel-1.12.0-ja.po.patch
13
14License:        GPLv2
15Group:          User Interface/Desktops
16URL:            http://mate-desktop.org/
17
18BuildRequires:  mate-common
19BuildRequires:  mate-doc-utils
20BuildRequires:  mate-desktop-devel
21BuildRequires:  mate-menus-devel
22BuildRequires:  libmateweather-devel
23BuildRequires:  gtk2-devel
24BuildRequires:  libSM-devel
25BuildRequires:  libcanberra-devel
26BuildRequires:  dbus-glib-devel
27BuildRequires:  libwnck-devel
28BuildRequires:  librsvg2-devel
29BuildRequires:  evolution-data-server-devel
30BuildRequires:  NetworkManager-devel
31BuildRequires:  dconf-devel
32BuildRequires:  gtk-doc
33BuildRequires:  itstool
34BuildRequires:  autoconf
35BuildRequires:  automake
36
37Requires:               vine-menus
38Requires(posttrans,postun):     glib2
39Requires(post,postun):  gtk2
40Requires(post,postun):  desktop-file-utils
41
42BuildRoot:      %{_tmppath}/%{name}-%{version}-root
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46Packager:       Takemikaduchi
47
48
49%description
50mate-panel contains the MATE panel, the libmate-panel-applet library and
51several applets:
52
53  + the MATE panel is the area on your desktop from which you can run
54    applications and applets, and perform other tasks.
55
56  + the libmate-panel-applet library allows to develop small applications
57    which may be embedded in the panel. These are called applets.
58    Documentation for the API is available with gtk-doc.
59
60  + the applets supplied here include the Workspace Switcher, the Window
61    List, the Window Selector, the Notification Area, the Clock and the
62    infamous 'Wanda the Fish'.
63
64
65%package                devel
66Summary:        Development tools for mate-panel
67Summary(ja):    mate-panel の開発環境
68Group:          Development/Libraries
69Requires:       %{name} = %{version}-%{release}
70Requires:       pkgconfig
71
72%description    devel
73Header files and libraries for building a extension library for the
74mate-panel.
75
76
77%package        docs
78Summary:        Documentation for mate-panel
79Summary(ja):    mate-panel 用のドキュメント
80Group:          Documentation
81Requires:       %{name} = %{version}-%{release}
82Obsoletes:      %{name}-doc < 1.10.1
83BuildArch:      noarch
84
85%description    docs
86This package contains documentation for mate-panel.
87
88
89%prep
90%setup -q
91%patch2000 -p1 -b .vine
92%patch2001 -p1 -b .vine
93%patch2002 -p1 -b .vine
94
95%build
96(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
97%configure \
98        --libexecdir=%{_libexecdir}/mate \
99        --disable-static \
100        --disable-scrollkeeper \
101        --enable-introspection \
102        --enable-matecomponent
103
104%{__make} %{?_smp_mflags}
105
106
107%install
108%{__rm} -rf ${RPM_BUILD_ROOT}
109
110%{__make} install DESTDIR=${RPM_BUILD_ROOT}
111
112find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
113find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
114
115install -c -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{name}/layouts/
116
117%find_lang %{name}
118
119
120%clean
121%{__rm} -rf ${RPM_BUILD_ROOT}
122
123
124%post
125/sbin/ldconfig
126update-desktop-database %{_datadir}/applications >& /dev/null ||:
127touch --no-create %{_datadir}/icons/hicolor
128gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
129
130%postun
131/sbin/ldconfig
132if [ $1 -eq 0 ]; then
133  update-desktop-database %{_datadir}/applications >& /dev/null ||:
134  touch --no-create %{_datadir}/icons/hicolor
135  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
136  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
137fi
138
139%posttrans
140glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
141
142
143%files -f %{name}.lang
144%defattr(-,root,root,-)
145%doc COPYING ChangeLog NEWS README
146%{_bindir}/mate-desktop-item-edit
147%{_bindir}/mate-panel
148%{_bindir}/mate-panel-test-applets
149%{_libdir}/girepository-1.0/MatePanelApplet-4.0.typelib
150%{_libdir}/libmate-panel-applet-*.so.*
151%{_libexecdir}/mate/clock-applet
152%{_libexecdir}/mate/fish-applet
153%{_libexecdir}/mate/notification-area-applet
154%{_libexecdir}/mate/wnck-applet
155%{_datadir}/applications/mate-panel.desktop
156%{_datadir}/dbus-1/services/*.service
157%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.clock.gschema.xml
158%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.fish.gschema.xml
159%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.window-list.gschema.xml
160%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.workspace-switcher.gschema.xml
161%{_datadir}/glib-2.0/schemas/org.mate.panel.enums.xml
162%{_datadir}/glib-2.0/schemas/org.mate.panel.gschema.xml
163%{_datadir}/glib-2.0/schemas/org.mate.panel.menubar.gschema.xml
164%{_datadir}/glib-2.0/schemas/org.mate.panel.object.gschema.xml
165%{_datadir}/glib-2.0/schemas/org.mate.panel.toplevel.gschema.xml
166%{_datadir}/icons/hicolor/*/*/*
167%{_datadir}/help
168%{_datadir}/mate-panel
169%{_mandir}/man1/mate-panel.1.gz
170%{_mandir}/man1/mate-desktop-item-edit.1.gz
171%{_mandir}/man1/mate-panel-test-applets.1.gz
172
173%files devel
174%defattr(-,root,root,-)
175%{_includedir}/mate-panel-4.0/
176%{_libdir}/libmate-panel-applet-*.so
177%{_libdir}/pkgconfig/libmatepanelapplet-4.0.pc
178%{_datadir}/gir-1.0/MatePanelApplet-4.0.gir
179
180%files docs
181%defattr(-,root,root,-)
182%{_datadir}/gtk-doc/html/mate-panel-applet
183
184
185%changelog
186* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
187- new upstream release
188
189* Sun Feb 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
190- new upstream release
191
192* Tue Dec 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
193- new upstream release
194
195* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
196- new upstream release
197- update Patch2001 (mate-panel-1.12.0-vine-layout.patch)
198- update Patch2002 (mate-panel-1.12.0-ja.po.patch)
199
200* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-2
201- add Patch2002 (mate-panel-1.10.1-ja.po.patch)
202
203* Sat Jul 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
204- new upstream release
205
206* Sat May 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
207- new upstream release
208- remove Patch2002 (mate-panel-1.8.0-ja.po.patch)
209
210* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
211- rename Source (vine.layout)
212
213* Sun Jun 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-2
214- rename Source (vine.layout)
215- add Patch2001 (mate-panel-1.8.0-vine-layout.patch)
216- add Patch2002 (mate-panel-1.8.0-ja.po.patch)
217
218* Tue Apr 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
219- new upstream release
220- change BuildRequires: libwnck-devel instead of libmatewnck-devel
221- add BuildRequires: itstool
222
223* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-3
224- rebuild with VineSeed environment
225
226* Wed Sep 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-2
227- change Source1 (panel-default-layout.mate.vine)
228- add Patch2000 (mate-panel-1.6.1-about-vine.patch)
229- add Requires: vine-menus
230
231* Sun Sep 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
232- new upstream release
233
234* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
235- new upstream release
236- remove BuildRequires: mate-conf-devel, libmatecomponentui-devel
237- add BuildRequires: dconf-devel
238
239* Wed Aug 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
240- new upstream release
241- remove Patch0 (mate-panel-1.2.1-configure.patch)
242- change BuildRequires: libmatewnck-devel instead of libwnck-devel
243
244* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
245- new upstream release
246- add Patch0 (mate-panel-1.2.1-configure.patch)
247
248* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
249- change category
250
251* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
252- initial build for Vine Linux
253
Note: See TracBrowser for help on using the repository browser.