source: projects/specs/trunk/m/mars-nwe/mars-nwe-vl.spec @ 521

Revision 521, 6.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: NetWare file and print servers which run on Linux systems.
2Name: mars-nwe
3Version: 0.99pl20
4Release: 6vl1
5License: GPL
6Source:  ftp://ftp.gwdg.de/pub/linux/misc/ncpfs/mars_nwe-0.99.pl19.tgz
7Source1: mars_nwe-mk.li
8Source2: mars_nwe-config.h
9Source4: mars_nwe-readme.txt
10Source5: mars_nwe.init
11Source6: mars_nwe.log
12Patch1: mars_nwe-glibc21.patch
13Patch2: mars_nwe-0.99.pl19-buffer.patch
14Patch3: mars_nwe-rh.patch
15Patch4: mars_nwe-format.patch
16Group: System Environment/Daemons
17Prereq: /sbin/chkconfig, /sbin/service
18BuildPrereq: gdbm-devel
19Requires: ipxutils
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21ExcludeArch: s390 s390x
22
23%description
24The mars_nwe (MARtin Stover's NetWare Emulator) package enables Linux
25to provide both file and print services for NetWare clients (i.e.,
26providing the services of a Novell NetWare file server).  Mars_nwe
27allows the sharing of files between Linux machines and Novell NetWare
28clients, using NetWare's native IPX protocol suite.
29
30Install the mars_nwe package if you need a Novell NetWare file server
31on your Red Hat Linux system.
32
33%prep
34%setup -q -n mars_nwe
35%patch1 -p1 -b .glibc21
36%patch2 -p1 -b .buffer
37%patch3 -p1 -b .rh
38%patch4 -p1 -b .format
39cp -f $RPM_SOURCE_DIR/mars_nwe-config.h ./config.h
40cp -f $RPM_SOURCE_DIR/mars_nwe-mk.li ./mk.li
41
42%build
43chmod 755 mk.li
44make RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE_ -DUSE_GDBM"
45
46%install
47rm -rf $RPM_BUILD_ROOT
48for I in sys/login sys/public sys/system bindery; do \
49        mkdir -p --mode=0755 $RPM_BUILD_ROOT/var/mars_nwe/$I
50done
51
52mkdir -p $RPM_BUILD_ROOT/var/log $RPM_BUILD_ROOT/var/run
53install -m644 $RPM_SOURCE_DIR/mars_nwe-readme.txt $RPM_BUILD_ROOT/var/mars_nwe/sys/readme.txt
54:> $RPM_BUILD_ROOT/var/log/mars_nwe.log
55chmod 0644 $RPM_BUILD_ROOT/var/log/mars_nwe.log
56:> $RPM_BUILD_ROOT/var/run/mars_nwe.routes
57chmod 0644 $RPM_BUILD_ROOT/var/run/mars_nwe.routes
58
59mkdir -p $RPM_BUILD_ROOT/etc $RPM_BUILD_ROOT/usr/sbin
60install -m644 examples/nwserv.stations $RPM_BUILD_ROOT/etc/nwserv.stations
61for I in nwserv nwconn ncpserv nwclient nwbind; do
62        install -s -m 755 $I $RPM_BUILD_ROOT/usr/sbin/$I
63done
64install -m600 examples/nw.ini $RPM_BUILD_ROOT/etc/nwserv.conf
65
66mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d $RPM_BUILD_ROOT/etc/logrotate.d
67install -m755 $RPM_SOURCE_DIR/mars_nwe.init $RPM_BUILD_ROOT/etc/rc.d/init.d/mars-nwe
68install -m644 $RPM_SOURCE_DIR/mars_nwe.log $RPM_BUILD_ROOT/etc/logrotate.d/mars-nwe.log
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%post
74/sbin/chkconfig --add mars-nwe
75
76%preun
77if [ $1 = 0 ]; then
78    /sbin/service mars-nwe stop > /dev/null 2>&1 || :
79    /sbin/chkconfig --del mars-nwe
80fi
81
82%postun
83if [ "$1" -ge "1" ]; then
84    /sbin/service mars-nwe condrestart > /dev/null 2>&1 || :
85fi
86
87%files
88%defattr(-,root,root)
89%dir /var/mars_nwe
90/var/mars_nwe/sys
91%dir /var/mars_nwe/bindery
92%ghost /var/log/mars_nwe.log
93%ghost /var/run/mars_nwe.routes
94%config(noreplace) /etc/nwserv.conf
95%config(noreplace) /etc/nwserv.stations
96%config /etc/logrotate.d/mars-nwe.log
97%doc README COPYING doc examples
98/usr/sbin/nwserv
99/usr/sbin/nwconn
100/usr/sbin/ncpserv
101/usr/sbin/nwclient
102/usr/sbin/nwbind
103%config /etc/rc.d/init.d/mars-nwe
104
105%changelog
106* Sat Aug 18 2001 <sagami@vinelinux.org>
107- 0.99pl20-6vl1: was ported to Vine
108
109* Mon Jul 16 2001 Philipp Knirsch <pknirsch@redhat.de>
110- Fixed missing BuildPrerequ for gdbm-devel (#44864)
111
112* Tue Jun 19 2001 Florian La Roche <Florian.LaRoche@redhat.de>
113- add ExcludeArch: s390 s390x
114
115* Tue Mar 13 2001 Bill Nottingham <notting@redhat.com>
116- fix usage translation message in init script
117
118* Tue Feb 27 2001 Bill Nottingham <notting@redhat.com>
119- fix subsys in init script
120
121* Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
122- don't use gprintf
123
124* Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
125- fix format string error (#17911)
126- i18n-ize initscript
127- update to 0.99.pl20
128
129* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
130- condrestart fixes
131
132* Mon Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
133- fix %%post and %%postun scripts
134
135* Sun Jul 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
136- source files from /etc/rc.d/init.d
137- don't prereq /etc/init.d anymore
138- rename "rh-status"
139
140* Thu Jul 20 2000 Bill Nottingham <notting@redhat.com>
141- move initscript back
142
143* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
144- automatic rebuild
145
146* Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
147- don't prereq, only require initscripts
148
149* Mon Jun 26 2000 Bill Nottingham <notting@redhat.com>
150- initscript munging
151
152* Sat Jun 17 2000 Matt Wilson <msw@redhat.com>
153- added defattr
154
155* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
156- tweak logrotate configuration file to use the PID file in /var/run
157
158* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
159- update to pl19
160
161* Tue Apr 18 2000 Bill Nottingham <notting@redhat.com>
162- build on alpha again
163- require ipxutils
164- futz with default config some (use included sample)
165
166* Thu Feb 24 2000 Bill Nottingham <notting@redhat.com>
167- don't build on alpha for now
168
169* Tue Dec 22 1999 Bill Nottingham <notting@redhat.com>
170- fix buffer overflow patch oops
171
172* Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
173- fix typo in buffer overflow patch
174- fix path to killall in logrotate file
175
176* Fri Sep  3 1999 Bill Nottingham <notting@redhat.com>
177- add patch to fix some buffer overflows.
178
179* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
180- initscript munging
181
182* Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
183- update to 0.99.pl17
184
185* Thu Jun 10 1999 Dale Lovelace <dale@redhat.com>
186- fixed logrotate script
187
188* Mon May 24 1999 Bill Nottingham <notting@redhat.com>
189- update to 0.99.pl16
190
191* Thu May 13 1999 Bill Nottingham <notting@redhat.com>
192- actually update source to 0.99.pl15. Doh!
193
194* Tue Mar 23 1999 Bill Nottingham <notting@redhat.com>
195- logrotate fixes
196
197* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
198- auto rebuild in the new build environment (release 2)
199
200* Tue Mar  9 1999 Bill Nottingham <notting@redhat.com>
201- update to 0.99.pl15
202
203* Tue Feb 23 1999 Bill Nottingham <notting@redhat.com>
204- update to 0.99.pl14
205
206* Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
207- buildroot
208
209* Sun May 10 1998 Alan Cox <alan@redhat.com>
210- Made it compile with 2.1.* kernels and also gcc 2.0.7 where sysv_signal
211  is correctly hidden as __sysv_signal.
212
213* Fri May 08 1998 Prospector System <bugs@redhat.com>
214- translations modified for de, fr, tr
215
216* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
217- upgraded to 0.99pl6
218- enhanced initscripts
219
220* Tue Jan 13 1998 Erik Troan <ewt@redhat.com>
221- use sysv_signal everywhere instead of normal signal -- this makes signal
222  handlers not block signals, which mars_nwe expects
223- changed _ to - in name of logrotate config file
224
225* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
226- updated for chkconfig
227- doesn't start by default
228- added status, restart options to init script
229
230* Fri Aug 22 1997 Erik Troan <ewt@redhat.com>
231- built against glibc
Note: See TracBrowser for help on using the repository browser.