source: projects/specs/trunk/m/marisa-trie/marisa-trie-vl.spec @ 7379

Revision 7379, 2.4 KB checked in by iwaim, 11 years ago (diff)

new: marisa-trie 0.2.1-1

Line 
1%define ver 0.2.1
2%define rel 1
3
4%define srcname marisa
5
6Summary: Matching Algorithm with Recursively Implemented StorAge
7Name: marisa-trie
8Version: %{ver}
9Release: %{rel}%{_dist_release}
10License: BSD
11Group: System Environment/Libraries
12URL: http://code.google.com/p/marisa-trie/
13Source0: http://marisa-trie.googlecode.com/files/%{srcname}-%{version}.tar.gz
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
15
16Vendor: Project Vine
17Distribution: Vine Linux
18Packager: iwaim
19
20%description
21*Matching Algorithm with Recursively Implemented !StorAge (MARISA)* is a static
22 and space-efficient trie data structure. And *libmarisa* is a C++ library to p
23rovide an implementation of MARISA. Also, the package of *libmarisa* contains a
24 set of command line tools for building and operating a MARISA-based dictionary
25.
26
27A MARISA-based dictionary supports not only lookup but also reverse lookup, com
28mon prefix search and predictive search.
29
30 * Lookup is to check whether or not a given string exists in a dictionary.
31 * Reverse lookup is to restore a key from its ID.
32 * Common prefix search is to find keys from prefixes of a given string.
33 * Predictive search is to find keys starting with a given string.
34
35The biggest advantage of *libmarisa* is that its dictionary size is considerabl
36y more compact than others. See below for the dictionary size of other implemen
37tations.
38
39
40%package devel
41Summary: Header files and libraries for developing apps which will use marisa-trie
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44
45%description devel
46The marisa-trie-devel package contains the header files and libraries.
47
48%prep
49%setup -q -n %{srcname}-%{version}
50
51%build
52%configure --enable-shared
53%__make
54
55%install
56%__rm -rf $RPM_BUILD_ROOT
57%makeinstall
58
59# remove files
60%__rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
61
62%clean
63%__rm -rf $RPM_BUILD_ROOT
64
65%files
66%defattr(-,root,root,-)
67%doc README ChangeLog COPYING AUTHORS NEWS docs
68%{_bindir}/marisa-benchmark
69%{_bindir}/marisa-build
70%{_bindir}/marisa-common-prefix-search
71%{_bindir}/marisa-dump
72%{_bindir}/marisa-lookup
73%{_bindir}/marisa-predictive-search
74%{_bindir}/marisa-reverse-lookup
75%{_libdir}/libmarisa.so.*
76
77%files devel
78%defattr(-,root,root,-)
79%doc COPYING AUTHORS
80%{_libdir}/pkgconfig/marisa.pc
81%dir %{_includedir}/marisa
82%{_includedir}/marisa.h
83%{_includedir}/marisa/*.h
84%{_libdir}/libmarisa.so
85
86%changelog
87* Mon Jan 28 2013 IWAI, Masaharu <iwai@alib.jp> 0.2.1-1
88- initial build for Vine Linux
89
Note: See TracBrowser for help on using the repository browser.