source: projects/specs/trunk/m/marisa-trie/marisa-trie-vl.spec @ 9544

Revision 9544, 3.5 KB checked in by iwaim, 9 years ago (diff)

marisa-trie 0.2.4-2

Line 
1%define ver 0.2.4
2%define rel 2
3
4%define srcname marisa
5
6%define enable_python 1
7
8Summary: Matching Algorithm with Recursively Implemented StorAge
9Name: marisa-trie
10Version: %{ver}
11Release: %{rel}%{_dist_release}
12License: BSD
13Group: System Environment/Libraries
14URL: http://code.google.com/p/marisa-trie/
15Source0: http://marisa-trie.googlecode.com/files/%{srcname}-%{version}.tar.gz
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
17%if %{enable_python}
18BuildRequires: swig
19BuildRequires: python-devel
20BuildRequires: marisa-trie-devel
21%endif
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: iwaim
26
27%description
28*Matching Algorithm with Recursively Implemented !StorAge (MARISA)* is a static
29 and space-efficient trie data structure. And *libmarisa* is a C++ library to p
30rovide an implementation of MARISA. Also, the package of *libmarisa* contains a
31 set of command line tools for building and operating a MARISA-based dictionary
32.
33
34A MARISA-based dictionary supports not only lookup but also reverse lookup, com
35mon prefix search and predictive search.
36
37 * Lookup is to check whether or not a given string exists in a dictionary.
38 * Reverse lookup is to restore a key from its ID.
39 * Common prefix search is to find keys from prefixes of a given string.
40 * Predictive search is to find keys starting with a given string.
41
42The biggest advantage of *libmarisa* is that its dictionary size is considerabl
43y more compact than others. See below for the dictionary size of other implemen
44tations.
45
46
47%package devel
48Summary: Header files and libraries for developing apps which will use marisa-trie
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51
52%description devel
53The marisa-trie-devel package contains the header files and libraries.
54
55%if %{enable_python}
56%package python
57Summary: marisa-trie Python binding
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60
61%description python
62marisa-trie Python binding
63
64%endif
65
66%prep
67%setup -q -n %{srcname}-%{version}
68
69%build
70%configure --enable-shared
71%__make
72
73%if %{enable_python}
74pushd bindings
75make swig-python
76pushd python
77python setup.py build
78popd
79popd
80%endif
81
82%install
83%__rm -rf $RPM_BUILD_ROOT
84%makeinstall
85
86%if %{enable_python}
87pushd bindings/python
88python setup.py install --root $RPM_BUILD_ROOT
89popd
90%endif
91
92# remove files
93%__rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
94
95%clean
96%__rm -rf $RPM_BUILD_ROOT
97
98%files
99%defattr(-,root,root,-)
100%doc README ChangeLog COPYING AUTHORS NEWS docs
101%{_bindir}/marisa-benchmark
102%{_bindir}/marisa-build
103%{_bindir}/marisa-common-prefix-search
104%{_bindir}/marisa-dump
105%{_bindir}/marisa-lookup
106%{_bindir}/marisa-predictive-search
107%{_bindir}/marisa-reverse-lookup
108%{_libdir}/libmarisa.so.*
109
110%files devel
111%defattr(-,root,root,-)
112%doc COPYING AUTHORS
113%{_libdir}/pkgconfig/marisa.pc
114%dir %{_includedir}/marisa
115%{_includedir}/marisa.h
116%{_includedir}/marisa/*.h
117%{_libdir}/libmarisa.so
118
119%if %{enable_python}
120%files python
121%defattr(-,root,root,-)
122%doc COPYING AUTHORS
123%{python_sitearch}/_marisa.so
124%{python_sitearch}/marisa-*.egg-info
125%{python_sitearch}/marisa.py
126%{python_sitearch}/marisa.pyc
127%endif
128
129%changelog
130* Wed May  6 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.4-2
131- build with current VineSeed
132
133* Tue Jun 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.4-1
134- update to 0.2.4
135
136* Sat Mar 16 2013 IWAI, Masaharu <iwai@alib.jp> 0.2.2-1
137- update to 0.2.2
138
139* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 0.2.1-2
140- create python sub package
141
142* Mon Jan 28 2013 IWAI, Masaharu <iwai@alib.jp> 0.2.1-1
143- initial build for Vine Linux
144
Note: See TracBrowser for help on using the repository browser.