source: projects/specs/trunk/m/mariadb/mariadb-vl.spec @ 9835

Revision 9835, 32.0 KB checked in by tomop, 8 years ago (diff)

mariadb-10.1.9-4

Line 
1%bcond_with source
2
3%define mysqld_user             mysql
4%define mysqld_group            mysql
5%define mysqldatadir /var/lib/mysql
6
7# Working around perl dependency problem
8%global __perl_requires %{SOURCE998}
9%global __perllib_requires %{SOURCE998}
10
11%define _unpackaged_files_terminate_build 1
12
13%define mariadb_base_version    10.0
14%define mariadb_version         10.1.9
15%define mroonga_version         5.10
16%define client_version          18
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager:       tomop
21
22Name: mariadb
23Summary:        MariaDB: a very fast and robust SQL database server
24Version:        %{mariadb_version}
25Release:        4%{_dist_release}
26
27Group:          Applications/Databases
28License:        GPL2
29URL:            http://www.mariadb.org/
30
31Source:         mariadb-%{version}.tar.gz
32# Don't depend on lib::mtr*
33Source998:      perl-requires.sh
34Source1000:     macros.mariadb.in
35
36# mroonga 5.04 -> git master
37patch1000: mariadb-10.1.9-mroonga-master.patch
38
39#
40#Patch2000:     mysql-srv_buf_size.patch
41
42BuildRoot:              %{_tmppath}/%{name}-%{version}-root
43BuildRequires:  bison, cmake, gcc-c++, groff
44BuildRequires:  libaio-devel, libboost-devel, libevent-devel, libxml2-devel
45BuildRequires:  ncurses-devel, perl, openssl-devel, readline-devel
46BuildRequires:  jemalloc-devel
47BuildRequires:  zlib-devel
48BuildRequires:  mecab-devel
49Requires:               fileutils sh-utils
50Provides:               msqlormysql MySQL mysql
51Obsoletes:              mysql MySQL5
52
53# From the manual
54%description
55MariaDB: a very fast and robust SQL database server
56
57It is GPL v2 licensed, which means you can use the it free of charge under the
58conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
59
60MariaDB documentation can be found at http://kb.askmonty.org/
61MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
62
63
64%package server
65Version:        %{mariadb_version}
66Release: %{release}
67Summary:        MariaDB: a very fast and robust SQL database server
68Group:          Applications/Databases
69Requires:       fileutils sh-utils net-tools mariadb-common
70Requires(post): mariadb-common
71Provides:       mysql-server mysql MySQL MySQL-server mariadbserver-%{mariadb_base_version}
72Obsoletes:      MySQL mysql mysql-server
73Obsoletes:      MySQL-server < 5.6.0
74
75%description server
76MariaDB: a very fast and robust SQL database server
77
78It is GPL v2 licensed, which means you can use the it free of charge under the
79conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
80
81MariaDB documentation can be found at http://kb.askmonty.org/
82MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
83
84%package mroonga
85##Version: %{mroonga_version}
86Version:        %{mariadb_version}
87Summary:        A fast fulltext searchable storage engine for MariaDB.
88Group:          Applications/Databases
89Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
90Requires:       mariadb-server = %{mariadb_version}-%{release}
91Obsoletes:      MySQL-mroonga < 4.02
92Obsoletes:      mariadb-mroonga < 4.07
93Obsoletes:      mariadb-mroonga-doc < 4.07
94
95%description mroonga
96Mroonga is a fast fulltext searchable storage plugin for MariaDB.
97It is based on groonga that is a fast fulltext search engine and
98column store. Groonga is good at real-time update.
99
100%package client
101Version:        %{mariadb_version}
102Summary: MariaDB - Client
103Group: Applications/Databases
104Obsoletes: mysql-client MySQL-client < 5.6.0
105Provides: mysql-client MySQL-client  mariadbclient-%{mariadb_base_version}
106
107%description client
108This package contains the standard MariaDB clients and administration tools.
109
110
111%package devel
112Version:        %{mariadb_version}
113Summary: MariaDB - Development libraries and headers
114Group: Development/Libraries
115Requires: %{name}-static, openssl-devel, zlib-devel
116Conflicts: MySQL-devel < 5.6.0
117Conflicts: libmysqlclient-devel
118
119%description devel
120This package contains the development libraries and headers to develop
121MariaDB server components (e.g. plugins or embedded applications).
122
123
124%package static
125Version:        %{mariadb_version}
126Summary: MariaDB - static libraries
127Group: Development/Libraries
128Requires: %{name}-devel
129
130%description static
131This package provides static libraries of MariaDB.
132
133%if %{with source}
134%package source
135Version:        %{mariadb_version}
136Summary: MariaDB - Source
137Group: Development/Libraries
138Requires: mariadb-devel = %{version}-%{release}
139Obsoletes: MySQL-source < 5.6.0
140AutoReqProv: no
141
142%description source
143This package contains the sources files of MariaDB.
144
145%endif
146
147%package test
148Version:        %{mariadb_version}
149Requires: %{name}-client = %{version}-%{release} perl-DBI perl
150Summary: MariaDB - Test suite
151Group: Applications/Databases
152Obsoletes: mysql-bench MySQL5-bench MySQL-bench MySQL-test < 5.6.0
153Provides: perl(mtr_misc.pl)
154
155%description test
156This package contains the MariaDB regression test suite.
157
158
159%package embedded
160Version:        %{mariadb_version}
161Summary: MariaDB as an embeddable library
162Group: System Environment/Libraries
163Obsoletes: mysql-embedded MySQL-embedded
164Provides: mysql-embedded MySQL-embedded
165
166%description embedded
167This package contains a version of the MariaDB server that can be embedded
168into a client application instead of running as a separate process.
169
170
171%prep
172%setup -q
173%patch1000 -p1 -b .mroonga
174#%patch2000 -p1 -b .srv_buf_size
175
176%build
177
178# Be strict about variables, bail at earliest opportunity, etc.
179set -eu
180
181# Optional package files
182touch optional-files-devel
183
184export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
185export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
186
187# Build full release
188mkdir release
189(
190  cd release
191  cmake ../ \
192      -DINSTALL_LAYOUT=RPM \
193      -DBUILD_CONFIG=mysql_release \
194      -DCMAKE_BUILD_TYPE=Release \
195      -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
196      -DCOMPILATION_COMMENT="Vine Linux MariaDB RPM" \
197      -DWITH_PIC="ON" \
198      -DWITH_EMBEDDED_SERVER="ON" \
199      -DWITH_ZLIB="system" \
200      -DWITH_LOCALES="yes" \
201      -DWITH_UNIT_TESTS="no" \
202      -DWITH_CONNECT_STORAGE_ENGINE="ON" \
203      -DWITH_SEQUENCE_STORAGE_ENGINE="ON" \
204      -DWITH_XTRADB_STORAGE_ENGINE="ON" \
205      -DWITH_JEMALLOC="yes" \
206      -DGRN_WITH_MECAB="yes" \
207      -DGRN_WITH_ONIGMO="no"
208
209#      -DWITHOUT_TOKUDB="yes"
210#      -DWITH_PCRE="system"
211
212  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
213  make %{?_smp_mflags} VERBOSE=1
214)
215
216
217%install
218rm -rf %{buildroot}
219
220install -d %{buildroot}%{mysqldatadir}/mysql
221install -d %{buildroot}%{_infodir}
222
223# Install all binaries
224(
225  cd release
226  make DESTDIR=%{buildroot} install
227)
228
229install -m 0644  Docs/mysql.info %{buildroot}%{_infodir}
230rm -rf ./doc
231mv -f %{buildroot}%{_docdir} ./
232
233mv -f %{buildroot}%{_datadir}/groonga ./
234
235%if %{with source}
236mkdir -p %{buildroot}%{_datadir}/%{name}-source
237pushd %{buildroot}%{_datadir}/%{name}-source
238tar zxf %{SOURCE0}
239find %{buildroot}%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
240popd
241%endif
242
243install -d %{buildroot}%{_sysconfdir}/rpm
244sed -e 's/@BASEVERSION@/%{mariadb_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > %{buildroot}%{_sysconfdir}/rpm/macros.mariadb
245
246rm -f %{buildroot}%{_mandir}/man1/mysql_fix_privilege_tables.1*
247rm -f %{buildroot}%{_mandir}/man8/mysqlmanager.8*
248rm -f %{buildroot}%{_sysconfdir}/my.cnf
249rm -f %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
250rm -f %{buildroot}%{_libdir}/libmysqlclient*.so*
251rm -f %{buildroot}%{_libdir}/mysql/plugin/daemon_example.ini
252
253# force linking statically.
254perl -pi -e 's,-lmysqlclient_r,%{_libdir}/libmysqlclient_r.a,' %{buildroot}%{_bindir}/mysql_config
255perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_bindir}/mysql_config
256
257perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_datadir}/pkgconfig/mariadb.pc
258
259##############################################################################
260
261%pre server
262# Create a MySQL user and group. Do not report any problems if it already
263# exists.
264datadir=/var/lib/mysql
265
266groupadd -r mysql 2> /dev/null || true
267useradd -M -r -d $datadir -s /bin/bash -c "MySQL server" -g mysql mysql 2> /dev/null || true
268# The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
269usermod -g mysql mysql 2> /dev/null || true
270
271%post server
272
273# Make MySQL start/shutdown automatically when the machine does it.
274if [ $1 = 1 ] ; then
275  if [ -x /sbin/chkconfig ] ; then
276          /sbin/chkconfig --add mysql
277  fi
278
279  basedir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--basedir=//p'|tail -1`
280  if [ -z "$basedir" ] ; then
281    basedir=/usr
282  fi
283
284  datadir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
285  if [ -z "$datadir" ] ; then
286    datadir=/var/lib/mysql
287  else
288    # datadir may be relative to a basedir!
289    if ! expr $datadir : / > /dev/null; then
290      datadir=$basedir/$datadir
291    fi
292  fi
293
294  tmpdir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
295  if [ -z "$datadir" ] ; then
296    datadir=/var/lib/mysql
297  else
298    # datadir may be relative to a basedir!
299    if ! expr $datadir : / > /dev/null; then
300      datadir=$basedir/$datadir
301    fi
302  fi
303
304  # Change permissions so that the user that will run the MySQL daemon
305  # owns all database files.
306  chown -R mysql:mysql $datadir
307
308  if [ ! -e $datadir/mysql ]; then
309    # Create data directory
310    mkdir -p $datadir/{mysql,test}
311    chown -R mysql:mysql $datadir
312
313    # Initiate databases
314    /usr/bin/mysql_install_db --rpm --user=mysql
315  fi
316
317  # Change permissions again to fix any new files.
318  chown -R mysql:mysql $datadir
319
320  # Fix permissions for the permission database so that only the user
321  # can read them.
322  chmod -R og-rw $datadir/mysql
323fi
324
325%preun server
326if [ $1 = 0 ] ; then
327        # Stop MySQL before uninstalling it
328        if [ -x /etc/init.d/mysql ] ; then
329                /etc/init.d/mysql stop > /dev/null
330        fi
331        # Don't start it automatically anymore
332        if [ -x /sbin/chkconfig ] ; then
333                /sbin/chkconfig --del mysql
334        fi
335fi
336
337%postun server
338if [ $1 -ge 1 ]; then
339  if [ -x /etc/init.d/mysql ] ; then
340    # only restart the server if it was alredy running
341    /etc/init.d/mysql status > /dev/null 2>&1 && \
342    /etc/init.d/mysql restart
343  fi
344fi
345
346%pre mroonga
347if [ $1 -gt 1 ]; then
348/usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql || cat <<EOF
349An error occured when to unregister plugin.
350Please run a command below:
351
352  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql
353
354EOF
355
356fi
357
358%post mroonga
359if [ $1 -eq 1 ] ; then
360        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
361An error occured when to register plugin.
362Please run a command below:
363
364  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
365
366EOF
367fi
368
369%postun mroonga
370if [ $1 -gt 0 ] ; then
371        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
372An error occured when to register plugin.
373Please run a command below:
374
375  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
376
377EOF
378fi
379
380# Clean up the BuildRoot
381%clean
382[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
383
384%files server
385%defattr(-,root,root)
386
387%doc doc/*
388%doc release/support-files/my-*.cnf
389%doc %{_infodir}/mysql.info*
390
391%doc %{_mandir}/man1/aria_*.1*
392%doc %{_mandir}/man1/innochecksum.1*
393%doc %{_mandir}/man1/my_print_defaults.1*
394%doc %{_mandir}/man1/myisam_ftdump.1*
395%doc %{_mandir}/man1/myisamchk.1*
396%doc %{_mandir}/man1/myisamlog.1*
397%doc %{_mandir}/man1/myisampack.1*
398%doc %{_mandir}/man1/mysql_convert_table_format.1*
399%doc %{_mandir}/man1/mysql_fix_extensions.1*
400%doc %{_mandir}/man8/mysqld.8*
401%doc %{_mandir}/man1/mysqld_multi.1*
402%doc %{_mandir}/man1/mysqld_safe.1*
403%doc %{_mandir}/man1/mysqldumpslow.1*
404%doc %{_mandir}/man1/mysql_install_db.1*
405%doc %{_mandir}/man1/mysql_plugin.1*
406%doc %{_mandir}/man1/mysql_secure_installation.1*
407%doc %{_mandir}/man1/mysql_setpermission.1*
408%doc %{_mandir}/man1/mysql_upgrade.1*
409%doc %{_mandir}/man1/mysqlhotcopy.1*
410%doc %{_mandir}/man1/mysql.server.1*
411%doc %{_mandir}/man1/mysqltest.1*
412%doc %{_mandir}/man1/mysql_tzinfo_to_sql.1*
413%doc %{_mandir}/man1/mysql_zap.1*
414%doc %{_mandir}/man1/mysqlbug.1*
415%doc %{_mandir}/man1/perror.1*
416%doc %{_mandir}/man1/replace.1*
417%doc %{_mandir}/man1/resolve_stack_dump.1*
418%doc %{_mandir}/man1/resolveip.1*
419%{_bindir}/aria_*
420%{_bindir}/innochecksum
421%{_bindir}/my_print_defaults
422%{_bindir}/myisam_ftdump
423%{_bindir}/myisamchk
424%{_bindir}/myisamlog
425%{_bindir}/myisampack
426%{_bindir}/mysql_convert_table_format
427%{_bindir}/mysql_fix_extensions
428%{_bindir}/mysql_install_db
429%{_bindir}/mysql_plugin
430%{_bindir}/mysql_secure_installation
431%{_bindir}/mysql_setpermission
432%{_bindir}/mysql_tzinfo_to_sql
433%{_bindir}/mysql_upgrade
434%{_bindir}/mysql_zap
435%{_bindir}/mysqlbug
436%{_bindir}/mysqld_multi
437%{_bindir}/mysqld_safe
438%{_bindir}/mysqldumpslow
439%{_bindir}/mysqlhotcopy
440%{_bindir}/mysqltest
441%{_bindir}/perror
442%{_bindir}/replace
443%{_bindir}/resolve_stack_dump
444%{_bindir}/resolveip
445%ifarch x86_64
446%{_bindir}/tokuft*
447%endif
448%{_bindir}/wsrep*
449%{_sbindir}/mysqld
450%{_sbindir}/rcmysql
451%exclude %{_libdir}/mysql/plugin/ha_mroonga.so
452%exclude %{_datadir}/mysql/mroonga
453%{_libdir}/mysql
454%config(noreplace) %{_sysconfdir}/my.cnf.d/enable_encryption.preset
455%config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
456%ifarch x86_64
457%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
458%endif
459%config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
460%{_sysconfdir}/init.d/mysql
461%{_datadir}/mysql
462%attr(755, mysql, mysql) %dir %{mysqldatadir}
463
464%files mroonga
465%defattr(-, root, root)
466%doc groonga
467%{_libdir}/mysql/plugin/ha_mroonga.so
468%{_datadir}/mysql/mroonga
469
470%files client
471%defattr(-, root, root)
472%config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
473%{_bindir}/msql2mysql
474%{_bindir}/mysql
475%{_bindir}/mysql_find_rows
476%{_bindir}/mysql_waitpid
477%{_bindir}/mysqlaccess
478%{_bindir}/mysqladmin
479%{_bindir}/mysqlbinlog
480%{_bindir}/mysqlcheck
481%{_bindir}/mysqldump
482%{_bindir}/mysqlimport
483%{_bindir}/mysqlshow
484%{_bindir}/mysqlslap
485%{_bindir}/mytop
486
487%doc %{_mandir}/man1/msql2mysql.1*
488%doc %{_mandir}/man1/mysql.1*
489%doc %{_mandir}/man1/mysql_find_rows.1*
490%doc %{_mandir}/man1/mysql_waitpid.1*
491%doc %{_mandir}/man1/mysqlaccess.1*
492%doc %{_mandir}/man1/mysqladmin.1*
493%doc %{_mandir}/man1/mysqlbinlog.1*
494%doc %{_mandir}/man1/mysqlcheck.1*
495%doc %{_mandir}/man1/mysqldump.1*
496%doc %{_mandir}/man1/mysqlimport.1*
497%doc %{_mandir}/man1/mysqlshow.1*
498%doc %{_mandir}/man1/mysqlslap.1*
499
500%files devel -f optional-files-devel
501%defattr(-, root, root)
502%doc %{_mandir}/man1/mysql_config.1*
503%{_bindir}/mysql_config
504%{_includedir}/mysql
505%{_datadir}/aclocal/mysql.m4
506%{_datadir}/pkgconfig/mariadb.pc
507%{_libdir}/*.so
508%{_sysconfdir}/rpm/*
509%{_bindir}/mysql_embedded
510
511%files static
512%defattr(-,root,root)
513%{_libdir}/lib*.a
514
515%if %{with source}
516%files source
517%defattr(-, root, root)
518%{_datadir}/mariadb-source
519%endif
520
521%files test
522%defattr(-, root, root)
523%attr(-, root, root) %{_datadir}/mysql-test
524%{_bindir}/mysql_client_test
525%{_bindir}/mysql_client_test_embedded
526%{_bindir}/mysqltest_embedded
527%doc %{_mandir}/man1/mysql_client_test.1*
528%doc %{_mandir}/man1/mysql-stress-test.pl.1*
529%doc %{_mandir}/man1/mysql-test-run.pl.1*
530%doc %{_mandir}/man1/mysql_client_test_embedded.1*
531%doc %{_mandir}/man1/mysqltest_embedded.1*
532
533%files embedded
534%defattr(-,root,root)
535%{_libdir}/libmysqld.so.*
536
537
538%changelog
539* Sun Nov 29 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-4
540- replaced patch1000 to update Mroonga to git HEAD.
541
542* Sat Nov 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-3
543- replaced patch1000 to update Mroonga to git HEAD.
544
545* Thu Nov 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-2
546- replaced patch1000 to update Mroonga to git HEAD.
547
548* Tue Nov 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-1
549- new upstream release.
550- replaced patch1000 to update Mroonga to git HEAD.
551
552* Fri Oct 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-3
553- added BR:jemalloc-devel.
554
555* Thu Oct 29 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-2
556- replaced patch1000 to update Mroonga to 5.09.
557
558* Wed Oct 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-1
559- new upstream release.
560- replaced patch1000 for MariaDB 10.1.8.
561
562* Fri Oct  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-3
563- replaced patch1000 to update Mroonga to 5.08.
564
565* Mon Aug 31 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-2
566- replaced patch1000 to update Mroonga to 5.06.
567
568* Mon Aug 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-1
569- new upstream release.
570- added patch1000 to update Mroonga from 5.02 to 5.05.
571
572* Tue Jun 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-2
573- fixed dependencies.
574
575* Fri Jun 19 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-1
576- new upstream release.
577
578* Sun May 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.19-1
579- new upstream release.
580
581* Fri May  8 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.18-1
582- new upstream release.
583
584* Tue Mar  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.17-1
585- new upstream release.
586
587* Wed Jan 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.16-1
588- new upstream release.
589
590* Wed Nov 26 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.15-1
591- new upstream release.
592- enabled bundled Mroonga.
593
594* Mon Sep 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.14-1
595- new upstream release.
596
597* Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
598- new upstream release.
599
600* Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
601- fixed Conflicts: and Obsoletes:.
602
603* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
604- new upstream release.
605
606* Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
607- new upstream release.
608
609* Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
610- new upstream release.
611
612* Sat Dec 07 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-2
613- removed duplicated files.
614
615* Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
616- switched to MariaDB.
617
618* Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
619- new upstream release.
620
621* Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
622- new upstream release.
623
624* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
625- new upstream release.
626- added a sub-package 'MySQL-source".
627- added some macros for rpm.
628
629* Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
630- new upstream release.
631
632* Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
633- new upstream release.
634
635* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
636- new upstream release.
637- added "Vendor:" and "Distribution:" tag.
638
639* Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
640- new upstream release.
641- removed NDB cluster support.
642
643* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
644- Added "BR: zlib-devel" to MySQL-devel.
645
646* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
647- Added "BR: openssl-devel" to MySQL-devel.
648
649* Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
650- new upstream release.
651
652* Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
653- new upstream release.
654- updated jp-patch.
655- added ssl support.
656
657* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
658- new upstream release.
659- replaced '%%__find_requires' to '%%__perl_requires'.
660- updated jp-patch.
661
662* Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
663- added mysql-5.1.44-lib64.patch (on x86_64)
664- added -fPIC (on x86_64)
665
666* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
667- made embedded package again
668
669* Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
670- new upstream release.
671- updated jp-patch.
672
673* Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
674- VineSeed: rebuilt with new toolchain.
675
676* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
677- new upstream release.
678  - fixed CVE-2009-4484.
679
680* Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
681- new upstream release.
682
683* Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
684- added net-tools to 'Requires'.
685- added groff to 'BuildRequires'.
686- renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
687
688* Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
689- new upstream release.
690
691* Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
692- new upstream release.
693
694* Sun Jul  5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
695- new upstream release.
696- dropped %%Patch100 (fixed in upstream).
697
698* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
699- new upstream release.
700- add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
701
702* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
703- new upstream release.
704- rename 'MySQL-bench' to 'MySQL-test'.
705- update Patch0.
706- change default charset to 'utf8'.
707
708* Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
709- new upstream release.
710- update Patch0.
711- add "--with-client-charset=ujis".
712- sync %%files to official RPM.
713- remove MySQL-Max.
714
715* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
716- for VineSeed
717
718* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
719- move shared library from /usr/lib/ to /usr/lib/mysql/
720- add /etc/ld.so.conf.d/*.conf
721- fix broken libmysqlcient*.la files (or should we remove them permanently?)
722
723* Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
724- rebuild <BTS:VineLinux:534>
725
726* Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
727- added -fPIC
728
729* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
730- fixed dependency. <BTS:338>
731
732* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
733- add %%Patch1. <BTS:320>
734
735* Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
736- new upstream release.
737
738* Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
739- new upstream release.
740
741* Sat Jun  3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
742- new upstream release.
743
744* Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
745- release++.
746
747* Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
748- new upstream release.
749- for VineSeed.
750
751* Wed Feb  8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
752- new upstream release.
753- replace Patch0 for MySQL-4.1.16.
754
755* Thu Oct  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
756- new upstream release.
757- add Patch0.
758
759* Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
760- new upstream version
761        -- mysql-4.0.25
762
763* Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
764- new upstream version
765        -- mysql-4.0.23
766
767* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
768- new upstream version
769        -- mysql-4.0.22
770 
771* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
772- new upstream version
773        -- mysql-4.0.21
774 
775* Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
776- new upstream version
777        -- mysql-4.0.20
778 
779* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
780- modify CFLAGS, CXXFLAGS and configure options for alpha
781
782* Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
783- Upgraded to MySQL-4
784- added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
785- merged to MySQL Official packages
786        -- renamed package "MySQL" to "MySQL-server"
787        -- when using gcc, _always_ use CXX=gcc
788        -- replaced Copyright with License field (Copyright is obsolete)
789        -- added myisam_ftdump to the Server package
790        -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
791        -- fixed file permissions (BUG 1672)
792        -- removed dependency on MySQL-client from the MySQL-devel subpackage
793        -- as it is not really required. (BUG 1610)
794        -- Fixed BUG 1162 (removed macro names from the changelog)
795        -- Really fixed BUG 998 (disable the checking for installed but
796        --  unpackaged files)
797        -- Fixed BUG 959 (libmysqld not being compiled properly)
798        -- Fixed BUG 998 (RPM build errors): added missing files to the
799        -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
800        -- mysql_fix_privilege_tables.1), removed "-n" from install section.
801        -- removed the GIF Icon (file was not included in the sources anyway)
802        -- removed unused variable shared_lib_version
803        -- do not run automake before building the standard binary
804        --  (should not be necessary)
805        -- add server suffix '-standard' to standard binary (to be in line
806        -- with the binary tarball distributions)
807        -- allow overriding CC and CXX (required when building
808        -- with other compilers)
809
810* Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
811- added BuildRequires:  automake16
812                                                                               
813* Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
814- add '-fPIC -DPIC' to CFLAGS on alpha
815- little fix of spec file
816                                                                               
817* Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
818- enable MySQL-shared subpackage for alpha
819- delete 'BuildPrereq: kernel24-headers' for alpha
820- fix shared %files (exclude sparc)
821                                                                               
822* Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
823- new upstream version
824                                                                               
825* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
826- fixed devel %files (dropped *.la files)
827                                                                               
828* Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
829- new upstream version
830- fixed document permission
831                                                                               
832* Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
833- new upstream version
834                                                                               
835* Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
836- dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
837        -- don't work
838                                                                               
839* Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
840- new upstream version
841- diseble-assembler in configure on sparc,sparc64,alpha
842                                                                               
843* Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
844- new upstream version
845- moved some man files to main package
846- added enable-local-infile in configure
847- changed --with-extra-charsets=all in configure
848                                                                               
849* Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
850- fixed changelog
851                                                                               
852* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
853- updated to mysql-3.23.51
854                                                                               
855* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
856- rebuild on zlib-1.1.4(security fix.)
857                                                                               
858* Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
859- updated to mysql-2.23.49
860                                                                               
861* Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
862- add 'BuildPrereq: kernel24-headers' on alpha
863- remove shared library and max on alpha
864                                                                               
865* Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
866- updated to mysql-3.23.48
867                                                                               
868* Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
869- updated to mysql-3.23.47
870                                                                               
871* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
872- updated to mysql-3.23.46
873                                                                               
874* Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
875- updated to mysql-3.23.45
876                                                                               
877* Mon Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
878- updated to mysql-3.23.44
879                                                                               
880* Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
881- updated to mysql-3.23.43
882- removed shared library and max on sparc
883                                                                               
884* Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
885- updated to mysql-3.23.42
886- changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
887                                                                               
888* Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
889- updated to mysql-3.23.41
890                                                                               
891* Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
892- updated to mysql-3.23.40
893                                                                               
894* Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
895- updated to mysql-3.23.39
896
897* Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
898- added configure --with-charset=ujis
899                                                                               
900* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
901- used some rpmmacro
902                                                                               
903* Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
904- updated to MySQL-3.23.38
905                                                                               
906* Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
907- removed Bench pakages
908                                                                               
909* Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
910- removed pt_BR locale
911- build on Vine Linux
912- partially used rpmmacros
913- added %clean tag
914                                                                               
915* Fri Aug 18 2000 Tim Smith <tim@mysql.com>
916- Added separate libmysql_r directory; now both a threaded
917  and non-threaded library is shipped.
918                                                                               
919* Tue Sep 28 1999 David Axmark <davida@mysql.com>
920- Added the support-files/my-example.cnf to the docs directory.
921- Removed devel dependency on base since it is about client
922  development.
923                                                                               
924* Wed Sep 8 1999 David Axmark <davida@mysql.com>
925- Cleaned up some for 3.23.
926                                                                               
927* Thu Jul 1 1999 David Axmark <davida@mysql.com>
928- Added support for shared libraries in a separate sub
929  package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
930- The --enable-assembler switch is now automatically disables on
931  platforms there assembler code is unavailable. This should allow
932  building this RPM on non i386 systems.
933                                                                               
934* Mon Feb 22 1999 David Axmark <david@detron.se>
935- Removed unportable cc switches from the spec file. The defaults can
936  now be overridden with environment variables. This feature is used
937  to compile the official RPM with optimal (but compiler version
938  specific) switches.
939- Removed the repetitive description parts for the sub rpms. Maybe add
940  again if RPM gets a multiline macro capability.
941- Added support for a pt_BR translation. Translation contributed by
942  Jorge Godoy <jorge@bestway.com.br>.
943                                                                               
944* Wed Nov 4 1998 David Axmark <david@detron.se>
945- A lot of changes in all the rpm and install scripts. This may even
946  be a working RPM :-)
947                                                                               
948* Sun Aug 16 1998 David Axmark <david@detron.se>
949- A developers changelog for MySQL is available in the source RPM. And
950  there is a history of major user visible changed in the Reference
951  Manual.  Only RPM specific changes will be documented here.
952
Note: See TracBrowser for help on using the repository browser.