source: projects/specs/trunk/m/mariadb/mariadb-vl.spec @ 9728

Revision 9728, 30.3 KB checked in by tomop, 9 years ago (diff)

mariadb-10.0.21-2

Line 
1%bcond_with source
2
3%define mysqld_user             mysql
4%define mysqld_group            mysql
5%define mysqldatadir /var/lib/mysql
6
7# Working around perl dependency problem
8%global __perl_requires %{SOURCE998}
9%global __perllib_requires %{SOURCE998}
10
11%define _unpackaged_files_terminate_build 1
12
13%define mariadb_base_version    10.0
14%define mariadb_version         10.0.21
15%define mroonga_version         5.06
16%define client_version          18
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager:       tomop
21
22Name: mariadb
23Summary:        MariaDB: a very fast and robust SQL database server
24Version:        %{mariadb_version}
25Release:        2%{_dist_release}
26
27Group:          Applications/Databases
28License:        GPL2
29URL:            http://www.mariadb.org/
30
31Source:         mariadb-%{version}.tar.gz
32# Don't depend on lib::mtr*
33Source998:      perl-requires.sh
34Source1000:     macros.mariadb.in
35
36# mroonga 5.02 -> 5.06
37patch1000: mariadb-10.0.21-mroonga-5.06.patch
38
39#
40Patch2000:      mysql-srv_buf_size.patch
41
42BuildRoot:              %{_tmppath}/%{name}-%{version}-root
43BuildRequires:  bison, cmake, gcc-c++, groff
44BuildRequires:  libaio-devel, libboost-devel, libevent-devel, libxml2-devel
45BuildRequires:  ncurses-devel, perl, openssl-devel, readline-devel
46BuildRequires:  zlib-devel
47BuildRequires:  mecab-devel
48Requires:               fileutils sh-utils
49Provides:               msqlormysql MySQL mysql
50Obsoletes:              mysql MySQL5
51
52# From the manual
53%description
54MariaDB: a very fast and robust SQL database server
55
56It is GPL v2 licensed, which means you can use the it free of charge under the
57conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
58
59MariaDB documentation can be found at http://kb.askmonty.org/
60MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
61
62
63%package server
64Version:        %{mariadb_version}
65Release: %{release}
66Summary:        MariaDB: a very fast and robust SQL database server
67Group:          Applications/Databases
68Requires:       fileutils sh-utils net-tools mariadb-common
69Requires(post): mariadb-common
70Provides:       mysql-server mysql MySQL MySQL-server mariadbserver-%{mariadb_base_version}
71Obsoletes:      MySQL mysql mysql-server
72Obsoletes:      MySQL-server < 5.6.0
73
74%description server
75MariaDB: a very fast and robust SQL database server
76
77It is GPL v2 licensed, which means you can use the it free of charge under the
78conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
79
80MariaDB documentation can be found at http://kb.askmonty.org/
81MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
82
83%package mroonga
84##Version: %{mroonga_version}
85Version:        %{mariadb_version}
86Summary:        A fast fulltext searchable storage engine for MariaDB.
87Group:          Applications/Databases
88Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
89Requires:       mariadb-server = %{mariadb_version}-%{release}
90Obsoletes:      MySQL-mroonga < 4.02
91Obsoletes:      mariadb-mroonga < 4.07
92Obsoletes:      mariadb-mroonga-doc < 4.07
93
94%description mroonga
95Mroonga is a fast fulltext searchable storage plugin for MariaDB.
96It is based on groonga that is a fast fulltext search engine and
97column store. Groonga is good at real-time update.
98
99%package client
100Version:        %{mariadb_version}
101Summary: MariaDB - Client
102Group: Applications/Databases
103Obsoletes: mysql-client MySQL-client < 5.6.0
104Provides: mysql-client MySQL-client  mariadbclient-%{mariadb_base_version}
105
106%description client
107This package contains the standard MariaDB clients and administration tools.
108
109
110%package devel
111Version:        %{mariadb_version}
112Summary: MariaDB - Development libraries and headers
113Group: Development/Libraries
114Requires: %{name}-static, openssl-devel, zlib-devel
115Conflicts: MySQL-devel < 5.6.0
116Conflicts: libmysqlclient-devel
117
118%description devel
119This package contains the development libraries and headers to develop
120MariaDB server components (e.g. plugins or embedded applications).
121
122
123%package static
124Version:        %{mariadb_version}
125Summary: MariaDB - static libraries
126Group: Development/Libraries
127Requires: %{name}-devel
128
129%description static
130This package provides static libraries of MariaDB.
131
132%if %{with source}
133%package source
134Version:        %{mariadb_version}
135Summary: MariaDB - Source
136Group: Development/Libraries
137Requires: mariadb-devel = %{version}-%{release}
138Obsoletes: MySQL-source < 5.6.0
139AutoReqProv: no
140
141%description source
142This package contains the sources files of MariaDB.
143
144%endif
145
146%package test
147Version:        %{mariadb_version}
148Requires: %{name}-client = %{version}-%{release} perl-DBI perl
149Summary: MariaDB - Test suite
150Group: Applications/Databases
151Obsoletes: mysql-bench MySQL5-bench MySQL-bench MySQL-test < 5.6.0
152Provides: perl(mtr_misc.pl)
153
154%description test
155This package contains the MariaDB regression test suite.
156
157
158%package embedded
159Version:        %{mariadb_version}
160Summary: MariaDB as an embeddable library
161Group: System Environment/Libraries
162Obsoletes: mysql-embedded MySQL-embedded
163Provides: mysql-embedded MySQL-embedded
164
165%description embedded
166This package contains a version of the MariaDB server that can be embedded
167into a client application instead of running as a separate process.
168
169
170%prep
171%setup -q
172%patch1000 -p1 -b .mroonga
173%patch2000 -p1 -b .srv_buf_size
174
175%build
176
177# Be strict about variables, bail at earliest opportunity, etc.
178set -eu
179
180# Optional package files
181touch optional-files-devel
182
183export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
184export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
185
186# Build full release
187mkdir release
188(
189  cd release
190  cmake ../ \
191      -DINSTALL_LAYOUT=RPM \
192      -DBUILD_CONFIG=mysql_release \
193      -DCMAKE_BUILD_TYPE=Release \
194      -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
195      -DCOMPILATION_COMMENT="Vine Linux MariaDB RPM" \
196      -DWITH_PIC="ON" \
197      -DWITH_EMBEDDED_SERVER="ON" \
198      -DWITH_ZLIB="system" \
199      -DWITH_LOCALES="yes" \
200      -DWITH_UNIT_TESTS="no" \
201      -DWITH_CONNECT_STORAGE_ENGINE="ON" \
202      -DWITH_SEQUENCE_STORAGE_ENGINE="ON" \
203      -DWITH_XTRADB_STORAGE_ENGINE="ON" \
204      -DWITHOUT_TOKUDB=1 \
205      -DWITH_JEMALLOC="no" \
206      -DGRN_WITH_MECAB="yes"
207
208#      -DWITH_PCRE="system"
209
210  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
211  make %{?_smp_mflags} VERBOSE=1
212)
213
214
215%install
216rm -rf %{buildroot}
217
218install -d %{buildroot}%{mysqldatadir}/mysql
219install -d %{buildroot}%{_infodir}
220
221# Install all binaries
222(
223  cd release
224  make DESTDIR=%{buildroot} install
225)
226
227install -m 0644  Docs/mysql.info %{buildroot}%{_infodir}
228rm -rf ./doc
229mv -f %{buildroot}%{_docdir} ./
230
231%if %{with source}
232mkdir -p %{buildroot}%{_datadir}/%{name}-source
233pushd %{buildroot}%{_datadir}/%{name}-source
234tar zxf %{SOURCE0}
235find %{buildroot}%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
236popd
237%endif
238
239install -d %{buildroot}%{_sysconfdir}/rpm
240sed -e 's/@BASEVERSION@/%{mariadb_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > %{buildroot}%{_sysconfdir}/rpm/macros.mariadb
241
242rm -f %{buildroot}%{_mandir}/man1/mysql_fix_privilege_tables.1*
243rm -f %{buildroot}%{_mandir}/man8/mysqlmanager.8*
244rm -f %{buildroot}%{_sysconfdir}/my.cnf
245rm -f %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
246rm -f %{buildroot}%{_libdir}/libmysqlclient*.so*
247rm -f %{buildroot}%{_libdir}/mysql/plugin/daemon_example.ini
248
249# force linking statically.
250perl -pi -e 's,-lmysqlclient_r,%{_libdir}/libmysqlclient_r.a,' %{buildroot}%{_bindir}/mysql_config
251perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_bindir}/mysql_config
252
253##############################################################################
254
255%pre server
256# Create a MySQL user and group. Do not report any problems if it already
257# exists.
258datadir=/var/lib/mysql
259
260groupadd -r mysql 2> /dev/null || true
261useradd -M -r -d $datadir -s /bin/bash -c "MySQL server" -g mysql mysql 2> /dev/null || true
262# The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
263usermod -g mysql mysql 2> /dev/null || true
264
265%post server
266
267# Make MySQL start/shutdown automatically when the machine does it.
268if [ $1 = 1 ] ; then
269  if [ -x /sbin/chkconfig ] ; then
270          /sbin/chkconfig --add mysql
271  fi
272
273  basedir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--basedir=//p'|tail -1`
274  if [ -z "$basedir" ] ; then
275    basedir=/usr
276  fi
277
278  datadir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
279  if [ -z "$datadir" ] ; then
280    datadir=/var/lib/mysql
281  else
282    # datadir may be relative to a basedir!
283    if ! expr $datadir : / > /dev/null; then
284      datadir=$basedir/$datadir
285    fi
286  fi
287
288  # Change permissions so that the user that will run the MySQL daemon
289  # owns all database files.
290  chown -R mysql:mysql $datadir
291
292  if [ ! -e $datadir/mysql ]; then
293    # Create data directory
294    mkdir -p $datadir/{mysql,test}
295
296    # Initiate databases
297    /usr/bin/mysql_install_db --rpm --user=mysql
298  fi
299
300  # Change permissions again to fix any new files.
301  chown -R mysql:mysql $datadir
302
303  # Fix permissions for the permission database so that only the user
304  # can read them.
305  chmod -R og-rw $datadir/mysql
306fi
307
308%preun server
309if [ $1 = 0 ] ; then
310        # Stop MySQL before uninstalling it
311        if [ -x /etc/init.d/mysql ] ; then
312                /etc/init.d/mysql stop > /dev/null
313        fi
314        # Don't start it automatically anymore
315        if [ -x /sbin/chkconfig ] ; then
316                /sbin/chkconfig --del mysql
317        fi
318fi
319
320%postun server
321if [ $1 -ge 1 ]; then
322  if [ -x /etc/init.d/mysql ] ; then
323    # only restart the server if it was alredy running
324    /etc/init.d/mysql status > /dev/null 2>&1 && \
325    /etc/init.d/mysql restart
326  fi
327fi
328
329%pre mroonga
330if [ $1 -gt 1 ]; then
331/usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql || cat <<EOF
332An error occured when to unregister plugin.
333Please run a command below:
334
335  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql
336
337EOF
338
339fi
340
341%post mroonga
342if [ $1 -eq 1 ] ; then
343        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
344An error occured when to register plugin.
345Please run a command below:
346
347  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
348
349EOF
350fi
351
352%postun mroonga
353if [ $1 -gt 0 ] ; then
354        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
355An error occured when to register plugin.
356Please run a command below:
357
358  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
359
360EOF
361fi
362
363# Clean up the BuildRoot
364%clean
365[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
366
367%files server
368%defattr(-,root,root)
369
370%doc doc/*
371%doc release/support-files/my-*.cnf
372%doc %{_infodir}/mysql.info*
373
374%doc %{_mandir}/man1/aria_*.1*
375%doc %{_mandir}/man1/innochecksum.1*
376%doc %{_mandir}/man1/my_print_defaults.1*
377%doc %{_mandir}/man1/myisam_ftdump.1*
378%doc %{_mandir}/man1/myisamchk.1*
379%doc %{_mandir}/man1/myisamlog.1*
380%doc %{_mandir}/man1/myisampack.1*
381%doc %{_mandir}/man1/mysql_convert_table_format.1*
382%doc %{_mandir}/man1/mysql_fix_extensions.1*
383%doc %{_mandir}/man8/mysqld.8*
384%doc %{_mandir}/man1/mysqld_multi.1*
385%doc %{_mandir}/man1/mysqld_safe.1*
386%doc %{_mandir}/man1/mysqldumpslow.1*
387%doc %{_mandir}/man1/mysql_install_db.1*
388%doc %{_mandir}/man1/mysql_plugin.1*
389%doc %{_mandir}/man1/mysql_secure_installation.1*
390%doc %{_mandir}/man1/mysql_setpermission.1*
391%doc %{_mandir}/man1/mysql_upgrade.1*
392%doc %{_mandir}/man1/mysqlhotcopy.1*
393%doc %{_mandir}/man1/mysql.server.1*
394%doc %{_mandir}/man1/mysqltest.1*
395%doc %{_mandir}/man1/mysql_tzinfo_to_sql.1*
396%doc %{_mandir}/man1/mysql_zap.1*
397%doc %{_mandir}/man1/mysqlbug.1*
398%doc %{_mandir}/man1/perror.1*
399%doc %{_mandir}/man1/replace.1*
400%doc %{_mandir}/man1/resolve_stack_dump.1*
401%doc %{_mandir}/man1/resolveip.1*
402%{_bindir}/aria_*
403%{_bindir}/innochecksum
404%{_bindir}/my_print_defaults
405%{_bindir}/myisam_ftdump
406%{_bindir}/myisamchk
407%{_bindir}/myisamlog
408%{_bindir}/myisampack
409%{_bindir}/mysql_convert_table_format
410%{_bindir}/mysql_fix_extensions
411%{_bindir}/mysql_install_db
412%{_bindir}/mysql_plugin
413%{_bindir}/mysql_secure_installation
414%{_bindir}/mysql_setpermission
415%{_bindir}/mysql_tzinfo_to_sql
416%{_bindir}/mysql_upgrade
417%{_bindir}/mysql_zap
418%{_bindir}/mysqlbug
419%{_bindir}/mysqld_multi
420%{_bindir}/mysqld_safe
421%{_bindir}/mysqldumpslow
422%{_bindir}/mysqlhotcopy
423%{_bindir}/mysqltest
424%{_bindir}/perror
425%{_bindir}/replace
426%{_bindir}/resolve_stack_dump
427%{_bindir}/resolveip
428#%{_bindir}/tokuftdump
429%{_sbindir}/mysqld
430%exclude %{_libdir}/mysql/plugin/ha_mroonga.so
431%exclude %{_datadir}/mysql/mroonga
432%{_libdir}/mysql
433%config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
434#%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
435%config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
436%{_sysconfdir}/init.d/mysql
437%{_datadir}/mysql
438%attr(755, mysql, mysql) %dir %{mysqldatadir}
439
440%files mroonga
441%defattr(-, root, root)
442%{_libdir}/mysql/plugin/ha_mroonga.so
443%{_datadir}/mysql/mroonga
444
445%files client
446%defattr(-, root, root)
447%config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
448%{_bindir}/msql2mysql
449%{_bindir}/mysql
450%{_bindir}/mysql_find_rows
451%{_bindir}/mysql_waitpid
452%{_bindir}/mysqlaccess
453%{_bindir}/mysqladmin
454%{_bindir}/mysqlbinlog
455%{_bindir}/mysqlcheck
456%{_bindir}/mysqldump
457%{_bindir}/mysqlimport
458%{_bindir}/mysqlshow
459%{_bindir}/mysqlslap
460%{_bindir}/mytop
461
462%doc %{_mandir}/man1/msql2mysql.1*
463%doc %{_mandir}/man1/mysql.1*
464%doc %{_mandir}/man1/mysql_find_rows.1*
465%doc %{_mandir}/man1/mysql_waitpid.1*
466%doc %{_mandir}/man1/mysqlaccess.1*
467%doc %{_mandir}/man1/mysqladmin.1*
468%doc %{_mandir}/man1/mysqlbinlog.1*
469%doc %{_mandir}/man1/mysqlcheck.1*
470%doc %{_mandir}/man1/mysqldump.1*
471%doc %{_mandir}/man1/mysqlimport.1*
472%doc %{_mandir}/man1/mysqlshow.1*
473%doc %{_mandir}/man1/mysqlslap.1*
474
475%files devel -f optional-files-devel
476%defattr(-, root, root)
477%doc %{_mandir}/man1/mysql_config.1*
478%{_bindir}/mysql_config
479%{_includedir}/mysql
480%{_datadir}/aclocal/mysql.m4
481%{_libdir}/*.so
482%{_sysconfdir}/rpm/*
483%{_bindir}/mysql_embedded
484
485%files static
486%defattr(-,root,root)
487%{_libdir}/lib*.a
488
489%if %{with source}
490%files source
491%defattr(-, root, root)
492%{_datadir}/mariadb-source
493%endif
494
495%files test
496%defattr(-, root, root)
497%attr(-, root, root) %{_datadir}/mysql-test
498%{_bindir}/mysql_client_test
499%{_bindir}/mysql_client_test_embedded
500%{_bindir}/mysqltest_embedded
501%doc %{_mandir}/man1/mysql_client_test.1*
502%doc %{_mandir}/man1/mysql-stress-test.pl.1*
503%doc %{_mandir}/man1/mysql-test-run.pl.1*
504%doc %{_mandir}/man1/mysql_client_test_embedded.1*
505%doc %{_mandir}/man1/mysqltest_embedded.1*
506
507%files embedded
508%defattr(-,root,root)
509%{_libdir}/libmysqld.so.*
510
511
512%changelog
513* Mon Aug 31 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-2
514- replaced patch1000 to update Mroonga to 5.06.
515
516* Mon Aug 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-1
517- new upstream release.
518- added patch1000 to update Mroonga from 5.02 to 5.05.
519
520* Tue Jun 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-2
521- fixed dependencies.
522
523* Fri Jun 19 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-1
524- new upstream release.
525
526* Sun May 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.19-1
527- new upstream release.
528
529* Fri May  8 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.18-1
530- new upstream release.
531
532* Tue Mar  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.17-1
533- new upstream release.
534
535* Wed Jan 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.16-1
536- new upstream release.
537
538* Wed Nov 26 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.15-1
539- new upstream release.
540- enabled bundled Mroonga.
541
542* Mon Sep 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.14-1
543- new upstream release.
544
545* Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
546- new upstream release.
547
548* Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
549- fixed Conflicts: and Obsoletes:.
550
551* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
552- new upstream release.
553
554* Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
555- new upstream release.
556
557* Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
558- new upstream release.
559
560* Sat Dec 07 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-2
561- removed duplicated files.
562
563* Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
564- switched to MariaDB.
565
566* Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
567- new upstream release.
568
569* Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
570- new upstream release.
571
572* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
573- new upstream release.
574- added a sub-package 'MySQL-source".
575- added some macros for rpm.
576
577* Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
578- new upstream release.
579
580* Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
581- new upstream release.
582
583* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
584- new upstream release.
585- added "Vendor:" and "Distribution:" tag.
586
587* Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
588- new upstream release.
589- removed NDB cluster support.
590
591* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
592- Added "BR: zlib-devel" to MySQL-devel.
593
594* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
595- Added "BR: openssl-devel" to MySQL-devel.
596
597* Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
598- new upstream release.
599
600* Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
601- new upstream release.
602- updated jp-patch.
603- added ssl support.
604
605* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
606- new upstream release.
607- replaced '%%__find_requires' to '%%__perl_requires'.
608- updated jp-patch.
609
610* Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
611- added mysql-5.1.44-lib64.patch (on x86_64)
612- added -fPIC (on x86_64)
613
614* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
615- made embedded package again
616
617* Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
618- new upstream release.
619- updated jp-patch.
620
621* Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
622- VineSeed: rebuilt with new toolchain.
623
624* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
625- new upstream release.
626  - fixed CVE-2009-4484.
627
628* Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
629- new upstream release.
630
631* Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
632- added net-tools to 'Requires'.
633- added groff to 'BuildRequires'.
634- renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
635
636* Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
637- new upstream release.
638
639* Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
640- new upstream release.
641
642* Sun Jul  5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
643- new upstream release.
644- dropped %%Patch100 (fixed in upstream).
645
646* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
647- new upstream release.
648- add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
649
650* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
651- new upstream release.
652- rename 'MySQL-bench' to 'MySQL-test'.
653- update Patch0.
654- change default charset to 'utf8'.
655
656* Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
657- new upstream release.
658- update Patch0.
659- add "--with-client-charset=ujis".
660- sync %%files to official RPM.
661- remove MySQL-Max.
662
663* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
664- for VineSeed
665
666* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
667- move shared library from /usr/lib/ to /usr/lib/mysql/
668- add /etc/ld.so.conf.d/*.conf
669- fix broken libmysqlcient*.la files (or should we remove them permanently?)
670
671* Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
672- rebuild <BTS:VineLinux:534>
673
674* Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
675- added -fPIC
676
677* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
678- fixed dependency. <BTS:338>
679
680* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
681- add %%Patch1. <BTS:320>
682
683* Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
684- new upstream release.
685
686* Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
687- new upstream release.
688
689* Sat Jun  3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
690- new upstream release.
691
692* Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
693- release++.
694
695* Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
696- new upstream release.
697- for VineSeed.
698
699* Wed Feb  8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
700- new upstream release.
701- replace Patch0 for MySQL-4.1.16.
702
703* Thu Oct  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
704- new upstream release.
705- add Patch0.
706
707* Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
708- new upstream version
709        -- mysql-4.0.25
710
711* Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
712- new upstream version
713        -- mysql-4.0.23
714
715* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
716- new upstream version
717        -- mysql-4.0.22
718 
719* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
720- new upstream version
721        -- mysql-4.0.21
722 
723* Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
724- new upstream version
725        -- mysql-4.0.20
726 
727* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
728- modify CFLAGS, CXXFLAGS and configure options for alpha
729
730* Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
731- Upgraded to MySQL-4
732- added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
733- merged to MySQL Official packages
734        -- renamed package "MySQL" to "MySQL-server"
735        -- when using gcc, _always_ use CXX=gcc
736        -- replaced Copyright with License field (Copyright is obsolete)
737        -- added myisam_ftdump to the Server package
738        -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
739        -- fixed file permissions (BUG 1672)
740        -- removed dependency on MySQL-client from the MySQL-devel subpackage
741        -- as it is not really required. (BUG 1610)
742        -- Fixed BUG 1162 (removed macro names from the changelog)
743        -- Really fixed BUG 998 (disable the checking for installed but
744        --  unpackaged files)
745        -- Fixed BUG 959 (libmysqld not being compiled properly)
746        -- Fixed BUG 998 (RPM build errors): added missing files to the
747        -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
748        -- mysql_fix_privilege_tables.1), removed "-n" from install section.
749        -- removed the GIF Icon (file was not included in the sources anyway)
750        -- removed unused variable shared_lib_version
751        -- do not run automake before building the standard binary
752        --  (should not be necessary)
753        -- add server suffix '-standard' to standard binary (to be in line
754        -- with the binary tarball distributions)
755        -- allow overriding CC and CXX (required when building
756        -- with other compilers)
757
758* Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
759- added BuildRequires:  automake16
760                                                                               
761* Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
762- add '-fPIC -DPIC' to CFLAGS on alpha
763- little fix of spec file
764                                                                               
765* Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
766- enable MySQL-shared subpackage for alpha
767- delete 'BuildPrereq: kernel24-headers' for alpha
768- fix shared %files (exclude sparc)
769                                                                               
770* Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
771- new upstream version
772                                                                               
773* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
774- fixed devel %files (dropped *.la files)
775                                                                               
776* Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
777- new upstream version
778- fixed document permission
779                                                                               
780* Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
781- new upstream version
782                                                                               
783* Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
784- dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
785        -- don't work
786                                                                               
787* Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
788- new upstream version
789- diseble-assembler in configure on sparc,sparc64,alpha
790                                                                               
791* Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
792- new upstream version
793- moved some man files to main package
794- added enable-local-infile in configure
795- changed --with-extra-charsets=all in configure
796                                                                               
797* Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
798- fixed changelog
799                                                                               
800* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
801- updated to mysql-3.23.51
802                                                                               
803* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
804- rebuild on zlib-1.1.4(security fix.)
805                                                                               
806* Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
807- updated to mysql-2.23.49
808                                                                               
809* Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
810- add 'BuildPrereq: kernel24-headers' on alpha
811- remove shared library and max on alpha
812                                                                               
813* Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
814- updated to mysql-3.23.48
815                                                                               
816* Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
817- updated to mysql-3.23.47
818                                                                               
819* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
820- updated to mysql-3.23.46
821                                                                               
822* Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
823- updated to mysql-3.23.45
824                                                                               
825* Mon Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
826- updated to mysql-3.23.44
827                                                                               
828* Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
829- updated to mysql-3.23.43
830- removed shared library and max on sparc
831                                                                               
832* Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
833- updated to mysql-3.23.42
834- changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
835                                                                               
836* Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
837- updated to mysql-3.23.41
838                                                                               
839* Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
840- updated to mysql-3.23.40
841                                                                               
842* Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
843- updated to mysql-3.23.39
844
845* Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
846- added configure --with-charset=ujis
847                                                                               
848* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
849- used some rpmmacro
850                                                                               
851* Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
852- updated to MySQL-3.23.38
853                                                                               
854* Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
855- removed Bench pakages
856                                                                               
857* Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
858- removed pt_BR locale
859- build on Vine Linux
860- partially used rpmmacros
861- added %clean tag
862                                                                               
863* Fri Aug 18 2000 Tim Smith <tim@mysql.com>
864- Added separate libmysql_r directory; now both a threaded
865  and non-threaded library is shipped.
866                                                                               
867* Tue Sep 28 1999 David Axmark <davida@mysql.com>
868- Added the support-files/my-example.cnf to the docs directory.
869- Removed devel dependency on base since it is about client
870  development.
871                                                                               
872* Wed Sep 8 1999 David Axmark <davida@mysql.com>
873- Cleaned up some for 3.23.
874                                                                               
875* Thu Jul 1 1999 David Axmark <davida@mysql.com>
876- Added support for shared libraries in a separate sub
877  package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
878- The --enable-assembler switch is now automatically disables on
879  platforms there assembler code is unavailable. This should allow
880  building this RPM on non i386 systems.
881                                                                               
882* Mon Feb 22 1999 David Axmark <david@detron.se>
883- Removed unportable cc switches from the spec file. The defaults can
884  now be overridden with environment variables. This feature is used
885  to compile the official RPM with optimal (but compiler version
886  specific) switches.
887- Removed the repetitive description parts for the sub rpms. Maybe add
888  again if RPM gets a multiline macro capability.
889- Added support for a pt_BR translation. Translation contributed by
890  Jorge Godoy <jorge@bestway.com.br>.
891                                                                               
892* Wed Nov 4 1998 David Axmark <david@detron.se>
893- A lot of changes in all the rpm and install scripts. This may even
894  be a working RPM :-)
895                                                                               
896* Sun Aug 16 1998 David Axmark <david@detron.se>
897- A developers changelog for MySQL is available in the source RPM. And
898  there is a history of major user visible changed in the Reference
899  Manual.  Only RPM specific changes will be documented here.
900
Note: See TracBrowser for help on using the repository browser.