source: projects/specs/trunk/m/mariadb/mariadb-vl.spec @ 9706

Revision 9706, 30.2 KB checked in by tomop, 9 years ago (diff)

mariadb-10.0.21-1

Line 
1%bcond_with source
2
3%define mysqld_user             mysql
4%define mysqld_group            mysql
5%define mysqldatadir /var/lib/mysql
6
7# Working around perl dependency problem
8%global __perl_requires %{SOURCE998}
9%global __perllib_requires %{SOURCE998}
10
11%define _unpackaged_files_terminate_build 1
12
13%define mariadb_base_version    10.0
14%define mariadb_version         10.0.21
15%define mroonga_version         5.04
16%define client_version          18
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager:       tomop
21
22Name: mariadb
23Summary:        MariaDB: a very fast and robust SQL database server
24Version:        %{mariadb_version}
25Release:        1%{_dist_release}
26
27Group:          Applications/Databases
28License:        GPL2
29URL:            http://www.mariadb.org/
30
31Source:         mariadb-%{version}.tar.gz
32# Don't depend on lib::mtr*
33Source998:      perl-requires.sh
34Source1000:     macros.mariadb.in
35
36# mroonga 5.02 -> 5.05
37patch1000: mariadb-10.0.21-mroonga-5.05.patch
38
39#
40Patch2000:      mysql-srv_buf_size.patch
41
42BuildRoot:              %{_tmppath}/%{name}-%{version}-root
43BuildRequires:  bison, cmake, gcc-c++, groff
44BuildRequires:  libaio-devel, libboost-devel, libevent-devel, libxml2-devel
45BuildRequires:  ncurses-devel, perl, openssl-devel, readline-devel
46BuildRequires:  zlib-devel
47BuildRequires:  mecab-devel
48Requires:               fileutils sh-utils
49Provides:               msqlormysql MySQL mysql
50Obsoletes:              mysql MySQL5
51
52# From the manual
53%description
54MariaDB: a very fast and robust SQL database server
55
56It is GPL v2 licensed, which means you can use the it free of charge under the
57conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
58
59MariaDB documentation can be found at http://kb.askmonty.org/
60MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
61
62
63%package server
64Version:        %{mariadb_version}
65Release: %{release}
66Summary:        MariaDB: a very fast and robust SQL database server
67Group:          Applications/Databases
68Requires:       fileutils sh-utils net-tools mariadb-common
69Requires(post): mariadb-common
70Provides:       mysql-server mysql MySQL MySQL-server mariadbserver-%{mariadb_base_version}
71Obsoletes:      MySQL mysql mysql-server
72Obsoletes:      MySQL-server < 5.6.0
73
74%description server
75MariaDB: a very fast and robust SQL database server
76
77It is GPL v2 licensed, which means you can use the it free of charge under the
78conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
79
80MariaDB documentation can be found at http://kb.askmonty.org/
81MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
82
83%package mroonga
84##Version: %{mroonga_version}
85Version:        %{mariadb_version}
86Summary:        A fast fulltext searchable storage engine for MariaDB.
87Group:          Applications/Databases
88Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
89Requires:       mariadb-server = %{mariadb_version}-%{release}
90Obsoletes:      MySQL-mroonga < 4.02
91Obsoletes:      mariadb-mroonga < 4.07
92Obsoletes:      mariadb-mroonga-doc < 4.07
93
94%description mroonga
95Mroonga is a fast fulltext searchable storage plugin for MariaDB.
96It is based on groonga that is a fast fulltext search engine and
97column store. Groonga is good at real-time update.
98
99%package client
100Version:        %{mariadb_version}
101Summary: MariaDB - Client
102Group: Applications/Databases
103Obsoletes: mysql-client MySQL-client < 5.6.0
104Provides: mysql-client MySQL-client  mariadbclient-%{mariadb_base_version}
105
106%description client
107This package contains the standard MariaDB clients and administration tools.
108
109
110%package devel
111Version:        %{mariadb_version}
112Summary: MariaDB - Development libraries and headers
113Group: Development/Libraries
114Requires: %{name}-static, openssl-devel, zlib-devel
115Conflicts: MySQL-devel < 5.6.0
116Conflicts: libmysqlclient-devel
117
118%description devel
119This package contains the development libraries and headers to develop
120MariaDB server components (e.g. plugins or embedded applications).
121
122
123%package static
124Version:        %{mariadb_version}
125Summary: MariaDB - static libraries
126Group: Development/Libraries
127Requires: %{name}-devel
128
129%description static
130This package provides static libraries of MariaDB.
131
132%if %{with source}
133%package source
134Version:        %{mariadb_version}
135Summary: MariaDB - Source
136Group: Development/Libraries
137Requires: mariadb-devel = %{version}-%{release}
138Obsoletes: MySQL-source < 5.6.0
139AutoReqProv: no
140
141%description source
142This package contains the sources files of MariaDB.
143
144%endif
145
146%package test
147Version:        %{mariadb_version}
148Requires: %{name}-client = %{version}-%{release} perl-DBI perl
149Summary: MariaDB - Test suite
150Group: Applications/Databases
151Obsoletes: mysql-bench MySQL5-bench MySQL-bench MySQL-test < 5.6.0
152Provides: perl(mtr_misc.pl)
153
154%description test
155This package contains the MariaDB regression test suite.
156
157
158%package embedded
159Version:        %{mariadb_version}
160Summary: MariaDB as an embeddable library
161Group: System Environment/Libraries
162Obsoletes: mysql-embedded MySQL-embedded
163Provides: mysql-embedded MySQL-embedded
164
165%description embedded
166This package contains a version of the MariaDB server that can be embedded
167into a client application instead of running as a separate process.
168
169
170%prep
171%setup -q
172%patch1000 -p1 -b .mroonga
173%patch2000 -p1 -b .srv_buf_size
174
175%build
176
177# Be strict about variables, bail at earliest opportunity, etc.
178set -eu
179
180# Optional package files
181touch optional-files-devel
182
183export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
184export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
185
186# Build full release
187mkdir release
188(
189  cd release
190  cmake ../ \
191      -DINSTALL_LAYOUT=RPM \
192      -DBUILD_CONFIG=mysql_release \
193      -DCMAKE_BUILD_TYPE=Release \
194      -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
195      -DMANUFACTURER="Vine Linux" \
196      -DCOMPILATION_COMMENT="Vine Linux MariaDB RPM" \
197      -DWITH_PIC="ON" \
198      -DWITH_EMBEDDED_SERVER="ON" \
199      -DWITH_ZLIB="system" \
200      -DWITH_LIBEVENT="system" \
201      -DWITH_LOCALES="yes" \
202      -DWITH_UNIT_TESTS="no" \
203      -DWITH_CONNECT_STORAGE_ENGINE="ON" \
204      -DWITH_SEQUENCE_STORAGE_ENGINE="ON" \
205      -DWITH_XTRADB_STORAGE_ENGINE="ON" \
206      -DWITHOUT_TOKUDB=1 \
207      -DWITH_JEMALLOC="no" \
208      -DGRN_WITH_MECAB="yes"
209
210#      -DWITH_PCRE="system"
211
212  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
213  make %{?_smp_mflags} VERBOSE=1
214)
215
216
217%install
218rm -rf %{buildroot}
219
220install -d %{buildroot}%{mysqldatadir}/mysql
221install -d %{buildroot}%{_infodir}
222
223# Install all binaries
224(
225  cd release
226  make DESTDIR=%{buildroot} install
227)
228
229install -m 0644  Docs/mysql.info %{buildroot}%{_infodir}
230rm -rf ./doc
231mv -f %{buildroot}%{_docdir} ./
232
233%if %{with source}
234mkdir -p %{buildroot}%{_datadir}/%{name}-source
235pushd %{buildroot}%{_datadir}/%{name}-source
236tar zxf %{SOURCE0}
237find %{buildroot}%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
238popd
239%endif
240
241install -d %{buildroot}%{_sysconfdir}/rpm
242sed -e 's/@BASEVERSION@/%{mariadb_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > %{buildroot}%{_sysconfdir}/rpm/macros.mariadb
243
244rm -f %{buildroot}%{_mandir}/man1/mysql_fix_privilege_tables.1*
245rm -f %{buildroot}%{_mandir}/man8/mysqlmanager.8*
246rm -f %{buildroot}%{_sysconfdir}/my.cnf
247rm -f %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
248rm -f %{buildroot}%{_libdir}/libmysqlclient*.so*
249rm -f %{buildroot}%{_libdir}/mysql/plugin/daemon_example.ini
250
251# force linking statically.
252perl -pi -e 's,-lmysqlclient_r,%{_libdir}/libmysqlclient_r.a,' %{buildroot}%{_bindir}/mysql_config
253perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_bindir}/mysql_config
254
255##############################################################################
256
257%pre server
258# Create a MySQL user and group. Do not report any problems if it already
259# exists.
260datadir=/var/lib/mysql
261
262groupadd -r mysql 2> /dev/null || true
263useradd -M -r -d $datadir -s /bin/bash -c "MySQL server" -g mysql mysql 2> /dev/null || true
264# The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
265usermod -g mysql mysql 2> /dev/null || true
266
267%post server
268
269# Make MySQL start/shutdown automatically when the machine does it.
270if [ $1 = 1 ] ; then
271  if [ -x /sbin/chkconfig ] ; then
272          /sbin/chkconfig --add mysql
273  fi
274
275  basedir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--basedir=//p'|tail -1`
276  if [ -z "$basedir" ] ; then
277    basedir=/usr
278  fi
279
280  datadir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
281  if [ -z "$datadir" ] ; then
282    datadir=/var/lib/mysql
283  else
284    # datadir may be relative to a basedir!
285    if ! expr $datadir : / > /dev/null; then
286      datadir=$basedir/$datadir
287    fi
288  fi
289
290  # Change permissions so that the user that will run the MySQL daemon
291  # owns all database files.
292  chown -R mysql:mysql $datadir
293
294  if [ ! -e $datadir/mysql ]; then
295    # Create data directory
296    mkdir -p $datadir/{mysql,test}
297
298    # Initiate databases
299    /usr/bin/mysql_install_db --rpm --user=mysql
300  fi
301
302  # Change permissions again to fix any new files.
303  chown -R mysql:mysql $datadir
304
305  # Fix permissions for the permission database so that only the user
306  # can read them.
307  chmod -R og-rw $datadir/mysql
308fi
309
310%preun server
311if [ $1 = 0 ] ; then
312        # Stop MySQL before uninstalling it
313        if [ -x /etc/init.d/mysql ] ; then
314                /etc/init.d/mysql stop > /dev/null
315        fi
316        # Don't start it automatically anymore
317        if [ -x /sbin/chkconfig ] ; then
318                /sbin/chkconfig --del mysql
319        fi
320fi
321
322%postun server
323if [ $1 -ge 1 ]; then
324  if [ -x /etc/init.d/mysql ] ; then
325    # only restart the server if it was alredy running
326    /etc/init.d/mysql status > /dev/null 2>&1 && \
327    /etc/init.d/mysql restart
328  fi
329fi
330
331%pre mroonga
332if [ $1 -gt 1 ]; then
333/usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql || cat <<EOF
334An error occured when to unregister plugin.
335Please run a command below:
336
337  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql
338
339EOF
340
341fi
342
343%post mroonga
344if [ $1 -eq 1 ] ; then
345        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
346An error occured when to register plugin.
347Please run a command below:
348
349  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
350
351EOF
352fi
353
354%postun mroonga
355if [ $1 -gt 0 ] ; then
356        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
357An error occured when to register plugin.
358Please run a command below:
359
360  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
361
362EOF
363fi
364
365# Clean up the BuildRoot
366%clean
367[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
368
369%files server
370%defattr(-,root,root)
371
372%doc doc/*
373%doc release/support-files/my-*.cnf
374%doc %{_infodir}/mysql.info*
375
376%doc %{_mandir}/man1/aria_*.1*
377%doc %{_mandir}/man1/innochecksum.1*
378%doc %{_mandir}/man1/my_print_defaults.1*
379%doc %{_mandir}/man1/myisam_ftdump.1*
380%doc %{_mandir}/man1/myisamchk.1*
381%doc %{_mandir}/man1/myisamlog.1*
382%doc %{_mandir}/man1/myisampack.1*
383%doc %{_mandir}/man1/mysql_convert_table_format.1*
384%doc %{_mandir}/man1/mysql_fix_extensions.1*
385%doc %{_mandir}/man8/mysqld.8*
386%doc %{_mandir}/man1/mysqld_multi.1*
387%doc %{_mandir}/man1/mysqld_safe.1*
388%doc %{_mandir}/man1/mysqldumpslow.1*
389%doc %{_mandir}/man1/mysql_install_db.1*
390%doc %{_mandir}/man1/mysql_plugin.1*
391%doc %{_mandir}/man1/mysql_secure_installation.1*
392%doc %{_mandir}/man1/mysql_setpermission.1*
393%doc %{_mandir}/man1/mysql_upgrade.1*
394%doc %{_mandir}/man1/mysqlhotcopy.1*
395%doc %{_mandir}/man1/mysql.server.1*
396%doc %{_mandir}/man1/mysqltest.1*
397%doc %{_mandir}/man1/mysql_tzinfo_to_sql.1*
398%doc %{_mandir}/man1/mysql_zap.1*
399%doc %{_mandir}/man1/mysqlbug.1*
400%doc %{_mandir}/man1/perror.1*
401%doc %{_mandir}/man1/replace.1*
402%doc %{_mandir}/man1/resolve_stack_dump.1*
403%doc %{_mandir}/man1/resolveip.1*
404%{_bindir}/aria_*
405%{_bindir}/innochecksum
406%{_bindir}/my_print_defaults
407%{_bindir}/myisam_ftdump
408%{_bindir}/myisamchk
409%{_bindir}/myisamlog
410%{_bindir}/myisampack
411%{_bindir}/mysql_convert_table_format
412%{_bindir}/mysql_fix_extensions
413%{_bindir}/mysql_install_db
414%{_bindir}/mysql_plugin
415%{_bindir}/mysql_secure_installation
416%{_bindir}/mysql_setpermission
417%{_bindir}/mysql_tzinfo_to_sql
418%{_bindir}/mysql_upgrade
419%{_bindir}/mysql_zap
420%{_bindir}/mysqlbug
421%{_bindir}/mysqld_multi
422%{_bindir}/mysqld_safe
423%{_bindir}/mysqldumpslow
424%{_bindir}/mysqlhotcopy
425%{_bindir}/mysqltest
426%{_bindir}/perror
427%{_bindir}/replace
428%{_bindir}/resolve_stack_dump
429%{_bindir}/resolveip
430#%{_bindir}/tokuftdump
431%{_sbindir}/mysqld
432%exclude %{_libdir}/mysql/plugin/ha_mroonga.so
433%exclude %{_datadir}/mysql/mroonga
434%{_libdir}/mysql
435%config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
436#%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
437%config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
438%{_sysconfdir}/init.d/mysql
439%{_datadir}/mysql
440%attr(755, mysql, mysql) %dir %{mysqldatadir}
441
442%files mroonga
443%defattr(-, root, root)
444%{_libdir}/mysql/plugin/ha_mroonga.so
445%{_datadir}/mysql/mroonga
446
447%files client
448%defattr(-, root, root)
449%config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
450%{_bindir}/msql2mysql
451%{_bindir}/mysql
452%{_bindir}/mysql_find_rows
453%{_bindir}/mysql_waitpid
454%{_bindir}/mysqlaccess
455%{_bindir}/mysqladmin
456%{_bindir}/mysqlbinlog
457%{_bindir}/mysqlcheck
458%{_bindir}/mysqldump
459%{_bindir}/mysqlimport
460%{_bindir}/mysqlshow
461%{_bindir}/mysqlslap
462%{_bindir}/mytop
463
464%doc %{_mandir}/man1/msql2mysql.1*
465%doc %{_mandir}/man1/mysql.1*
466%doc %{_mandir}/man1/mysql_find_rows.1*
467%doc %{_mandir}/man1/mysql_waitpid.1*
468%doc %{_mandir}/man1/mysqlaccess.1*
469%doc %{_mandir}/man1/mysqladmin.1*
470%doc %{_mandir}/man1/mysqlbinlog.1*
471%doc %{_mandir}/man1/mysqlcheck.1*
472%doc %{_mandir}/man1/mysqldump.1*
473%doc %{_mandir}/man1/mysqlimport.1*
474%doc %{_mandir}/man1/mysqlshow.1*
475%doc %{_mandir}/man1/mysqlslap.1*
476
477%files devel -f optional-files-devel
478%defattr(-, root, root)
479%doc %{_mandir}/man1/mysql_config.1*
480%{_bindir}/mysql_config
481%{_includedir}/mysql
482%{_datadir}/aclocal/mysql.m4
483%{_libdir}/*.so
484%{_sysconfdir}/rpm/*
485%{_bindir}/mysql_embedded
486
487%files static
488%defattr(-,root,root)
489%{_libdir}/lib*.a
490
491%if %{with source}
492%files source
493%defattr(-, root, root)
494%{_datadir}/mariadb-source
495%endif
496
497%files test
498%defattr(-, root, root)
499%attr(-, root, root) %{_datadir}/mysql-test
500%{_bindir}/mysql_client_test
501%{_bindir}/mysql_client_test_embedded
502%{_bindir}/mysqltest_embedded
503%doc %{_mandir}/man1/mysql_client_test.1*
504%doc %{_mandir}/man1/mysql-stress-test.pl.1*
505%doc %{_mandir}/man1/mysql-test-run.pl.1*
506%doc %{_mandir}/man1/mysql_client_test_embedded.1*
507%doc %{_mandir}/man1/mysqltest_embedded.1*
508
509%files embedded
510%defattr(-,root,root)
511%{_libdir}/libmysqld.so.*
512
513
514%changelog
515* Mon Aug 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-1
516- new upstream release.
517- added patch1000 to update Mroonga from 5.02 to 5.05.
518
519* Tue Jun 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-2
520- fixed dependencies.
521
522* Fri Jun 19 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-1
523- new upstream release.
524
525* Sun May 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.19-1
526- new upstream release.
527
528* Fri May  8 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.18-1
529- new upstream release.
530
531* Tue Mar  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.17-1
532- new upstream release.
533
534* Wed Jan 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.16-1
535- new upstream release.
536
537* Wed Nov 26 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.15-1
538- new upstream release.
539- enabled bundled Mroonga.
540
541* Mon Sep 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.14-1
542- new upstream release.
543
544* Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
545- new upstream release.
546
547* Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
548- fixed Conflicts: and Obsoletes:.
549
550* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
551- new upstream release.
552
553* Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
554- new upstream release.
555
556* Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
557- new upstream release.
558
559* Sat Dec 07 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-2
560- removed duplicated files.
561
562* Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
563- switched to MariaDB.
564
565* Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
566- new upstream release.
567
568* Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
569- new upstream release.
570
571* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
572- new upstream release.
573- added a sub-package 'MySQL-source".
574- added some macros for rpm.
575
576* Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
577- new upstream release.
578
579* Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
580- new upstream release.
581
582* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
583- new upstream release.
584- added "Vendor:" and "Distribution:" tag.
585
586* Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
587- new upstream release.
588- removed NDB cluster support.
589
590* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
591- Added "BR: zlib-devel" to MySQL-devel.
592
593* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
594- Added "BR: openssl-devel" to MySQL-devel.
595
596* Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
597- new upstream release.
598
599* Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
600- new upstream release.
601- updated jp-patch.
602- added ssl support.
603
604* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
605- new upstream release.
606- replaced '%%__find_requires' to '%%__perl_requires'.
607- updated jp-patch.
608
609* Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
610- added mysql-5.1.44-lib64.patch (on x86_64)
611- added -fPIC (on x86_64)
612
613* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
614- made embedded package again
615
616* Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
617- new upstream release.
618- updated jp-patch.
619
620* Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
621- VineSeed: rebuilt with new toolchain.
622
623* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
624- new upstream release.
625  - fixed CVE-2009-4484.
626
627* Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
628- new upstream release.
629
630* Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
631- added net-tools to 'Requires'.
632- added groff to 'BuildRequires'.
633- renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
634
635* Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
636- new upstream release.
637
638* Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
639- new upstream release.
640
641* Sun Jul  5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
642- new upstream release.
643- dropped %%Patch100 (fixed in upstream).
644
645* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
646- new upstream release.
647- add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
648
649* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
650- new upstream release.
651- rename 'MySQL-bench' to 'MySQL-test'.
652- update Patch0.
653- change default charset to 'utf8'.
654
655* Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
656- new upstream release.
657- update Patch0.
658- add "--with-client-charset=ujis".
659- sync %%files to official RPM.
660- remove MySQL-Max.
661
662* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
663- for VineSeed
664
665* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
666- move shared library from /usr/lib/ to /usr/lib/mysql/
667- add /etc/ld.so.conf.d/*.conf
668- fix broken libmysqlcient*.la files (or should we remove them permanently?)
669
670* Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
671- rebuild <BTS:VineLinux:534>
672
673* Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
674- added -fPIC
675
676* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
677- fixed dependency. <BTS:338>
678
679* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
680- add %%Patch1. <BTS:320>
681
682* Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
683- new upstream release.
684
685* Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
686- new upstream release.
687
688* Sat Jun  3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
689- new upstream release.
690
691* Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
692- release++.
693
694* Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
695- new upstream release.
696- for VineSeed.
697
698* Wed Feb  8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
699- new upstream release.
700- replace Patch0 for MySQL-4.1.16.
701
702* Thu Oct  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
703- new upstream release.
704- add Patch0.
705
706* Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
707- new upstream version
708        -- mysql-4.0.25
709
710* Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
711- new upstream version
712        -- mysql-4.0.23
713
714* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
715- new upstream version
716        -- mysql-4.0.22
717 
718* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
719- new upstream version
720        -- mysql-4.0.21
721 
722* Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
723- new upstream version
724        -- mysql-4.0.20
725 
726* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
727- modify CFLAGS, CXXFLAGS and configure options for alpha
728
729* Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
730- Upgraded to MySQL-4
731- added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
732- merged to MySQL Official packages
733        -- renamed package "MySQL" to "MySQL-server"
734        -- when using gcc, _always_ use CXX=gcc
735        -- replaced Copyright with License field (Copyright is obsolete)
736        -- added myisam_ftdump to the Server package
737        -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
738        -- fixed file permissions (BUG 1672)
739        -- removed dependency on MySQL-client from the MySQL-devel subpackage
740        -- as it is not really required. (BUG 1610)
741        -- Fixed BUG 1162 (removed macro names from the changelog)
742        -- Really fixed BUG 998 (disable the checking for installed but
743        --  unpackaged files)
744        -- Fixed BUG 959 (libmysqld not being compiled properly)
745        -- Fixed BUG 998 (RPM build errors): added missing files to the
746        -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
747        -- mysql_fix_privilege_tables.1), removed "-n" from install section.
748        -- removed the GIF Icon (file was not included in the sources anyway)
749        -- removed unused variable shared_lib_version
750        -- do not run automake before building the standard binary
751        --  (should not be necessary)
752        -- add server suffix '-standard' to standard binary (to be in line
753        -- with the binary tarball distributions)
754        -- allow overriding CC and CXX (required when building
755        -- with other compilers)
756
757* Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
758- added BuildRequires:  automake16
759                                                                               
760* Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
761- add '-fPIC -DPIC' to CFLAGS on alpha
762- little fix of spec file
763                                                                               
764* Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
765- enable MySQL-shared subpackage for alpha
766- delete 'BuildPrereq: kernel24-headers' for alpha
767- fix shared %files (exclude sparc)
768                                                                               
769* Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
770- new upstream version
771                                                                               
772* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
773- fixed devel %files (dropped *.la files)
774                                                                               
775* Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
776- new upstream version
777- fixed document permission
778                                                                               
779* Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
780- new upstream version
781                                                                               
782* Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
783- dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
784        -- don't work
785                                                                               
786* Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
787- new upstream version
788- diseble-assembler in configure on sparc,sparc64,alpha
789                                                                               
790* Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
791- new upstream version
792- moved some man files to main package
793- added enable-local-infile in configure
794- changed --with-extra-charsets=all in configure
795                                                                               
796* Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
797- fixed changelog
798                                                                               
799* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
800- updated to mysql-3.23.51
801                                                                               
802* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
803- rebuild on zlib-1.1.4(security fix.)
804                                                                               
805* Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
806- updated to mysql-2.23.49
807                                                                               
808* Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
809- add 'BuildPrereq: kernel24-headers' on alpha
810- remove shared library and max on alpha
811                                                                               
812* Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
813- updated to mysql-3.23.48
814                                                                               
815* Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
816- updated to mysql-3.23.47
817                                                                               
818* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
819- updated to mysql-3.23.46
820                                                                               
821* Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
822- updated to mysql-3.23.45
823                                                                               
824* Mon Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
825- updated to mysql-3.23.44
826                                                                               
827* Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
828- updated to mysql-3.23.43
829- removed shared library and max on sparc
830                                                                               
831* Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
832- updated to mysql-3.23.42
833- changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
834                                                                               
835* Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
836- updated to mysql-3.23.41
837                                                                               
838* Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
839- updated to mysql-3.23.40
840                                                                               
841* Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
842- updated to mysql-3.23.39
843
844* Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
845- added configure --with-charset=ujis
846                                                                               
847* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
848- used some rpmmacro
849                                                                               
850* Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
851- updated to MySQL-3.23.38
852                                                                               
853* Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
854- removed Bench pakages
855                                                                               
856* Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
857- removed pt_BR locale
858- build on Vine Linux
859- partially used rpmmacros
860- added %clean tag
861                                                                               
862* Fri Aug 18 2000 Tim Smith <tim@mysql.com>
863- Added separate libmysql_r directory; now both a threaded
864  and non-threaded library is shipped.
865                                                                               
866* Tue Sep 28 1999 David Axmark <davida@mysql.com>
867- Added the support-files/my-example.cnf to the docs directory.
868- Removed devel dependency on base since it is about client
869  development.
870                                                                               
871* Wed Sep 8 1999 David Axmark <davida@mysql.com>
872- Cleaned up some for 3.23.
873                                                                               
874* Thu Jul 1 1999 David Axmark <davida@mysql.com>
875- Added support for shared libraries in a separate sub
876  package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
877- The --enable-assembler switch is now automatically disables on
878  platforms there assembler code is unavailable. This should allow
879  building this RPM on non i386 systems.
880                                                                               
881* Mon Feb 22 1999 David Axmark <david@detron.se>
882- Removed unportable cc switches from the spec file. The defaults can
883  now be overridden with environment variables. This feature is used
884  to compile the official RPM with optimal (but compiler version
885  specific) switches.
886- Removed the repetitive description parts for the sub rpms. Maybe add
887  again if RPM gets a multiline macro capability.
888- Added support for a pt_BR translation. Translation contributed by
889  Jorge Godoy <jorge@bestway.com.br>.
890                                                                               
891* Wed Nov 4 1998 David Axmark <david@detron.se>
892- A lot of changes in all the rpm and install scripts. This may even
893  be a working RPM :-)
894                                                                               
895* Sun Aug 16 1998 David Axmark <david@detron.se>
896- A developers changelog for MySQL is available in the source RPM. And
897  there is a history of major user visible changed in the Reference
898  Manual.  Only RPM specific changes will be documented here.
899
Note: See TracBrowser for help on using the repository browser.