source: projects/specs/trunk/m/mariadb/mariadb-vl.spec @ 10645

Revision 10645, 34.7 KB checked in by tomop, 8 years ago (diff)

mariadb-10.1.16-1

Line 
1%bcond_with source
2
3%define mysqld_user             mysql
4%define mysqld_group            mysql
5%define mysqldatadir /var/lib/mysql
6
7# Working around perl dependency problem
8%global __perl_requires %{SOURCE998}
9%global __perllib_requires %{SOURCE998}
10
11%define _unpackaged_files_terminate_build 1
12
13%define mariadb_base_version    10.0
14%define mariadb_version         10.1.16
15%define mroonga_version         6.06
16%define client_version          18
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager:       tomop
21
22Name: mariadb
23Summary:        MariaDB: a very fast and robust SQL database server
24Version:        %{mariadb_version}
25Release:        1%{_dist_release}
26
27Group:          Applications/Databases
28License:        GPL2
29URL:            http://www.mariadb.org/
30
31Source:         mariadb-%{version}.tar.gz
32# Don't depend on lib::mtr*
33Source998:      perl-requires.sh
34Source1000:     macros.mariadb.in
35
36# mroonga 5.04 -> 6.02
37#patch1000: mariadb-%{mariadb_version}-mroonga-master.patch
38patch1000: mariadb-%{mariadb_version}-mroonga-v%{mroonga_version}.patch
39
40#
41#Patch2000:     mysql-srv_buf_size.patch
42
43BuildRoot:              %{_tmppath}/%{name}-%{version}-root
44BuildRequires:  bison, cmake, gcc-c++, groff
45BuildRequires:  libaio-devel, libboost-devel, libevent-devel, libxml2-devel
46BuildRequires:  ncurses-devel, perl, openssl-devel, readline-devel
47BuildRequires:  jemalloc-devel
48BuildRequires:  unixODBC-devel
49BuildRequires:  zlib-devel
50BuildRequires:  mecab-devel
51Requires:               fileutils sh-utils
52Provides:               msqlormysql MySQL mysql
53Obsoletes:              mysql MySQL5
54
55# From the manual
56%description
57MariaDB: a very fast and robust SQL database server
58
59It is GPL v2 licensed, which means you can use the it free of charge under the
60conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
61
62MariaDB documentation can be found at http://kb.askmonty.org/
63MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
64
65
66%package server
67Version:        %{mariadb_version}
68Release:        %{release}
69Summary:        MariaDB: a very fast and robust SQL database server
70Group:          Applications/Databases
71Requires:       fileutils sh-utils net-tools mariadb-common
72Requires(post): mariadb-common
73Provides:       mysql-server mysql MySQL MySQL-server mariadbserver-%{mariadb_base_version}
74Obsoletes:      MySQL mysql mysql-server
75Obsoletes:      MySQL-server < 5.6.0
76
77%description server
78MariaDB: a very fast and robust SQL database server
79
80It is GPL v2 licensed, which means you can use the it free of charge under the
81conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
82
83MariaDB documentation can be found at http://kb.askmonty.org/
84MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
85
86%package mroonga
87##Version: %{mroonga_version}
88Version:        %{mariadb_version}
89Summary:        A fast fulltext searchable storage engine for MariaDB.
90Group:          Applications/Databases
91Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
92Requires:       mariadb-server = %{mariadb_version}-%{release}
93Obsoletes:      MySQL-mroonga < 4.02
94Obsoletes:      mariadb-mroonga < 4.07
95Obsoletes:      mariadb-mroonga-doc < 4.07
96
97%description mroonga
98Mroonga is a fast fulltext searchable storage plugin for MariaDB.
99It is based on groonga that is a fast fulltext search engine and
100column store. Groonga is good at real-time update.
101
102%package connect
103Version:        %{mariadb_version}
104Summary:        CONNECT storage engine for MariaDB.
105Group:          Applications/Databases
106Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
107Requires:       mariadb-server = %{mariadb_version}-%{release}
108
109%description connect
110The CONNECT storage engine enables MariaDB to access external
111local or remote data (MED). This is done by defining tables
112based on different data types, in particular files in various
113formats, data extracted from other DBMS or products (such as Excel)
114via ODBC, or data retrieved from the environment (for example
115DIR, WMI, and MAC tables).
116
117This storage engine supports table partitioning, MariaDB virtual
118columns and also permits defining special columns such as ROWID,
119FILEID, and SERVID.
120
121%ifarch x86_64
122%package tokudb
123Version:        %{mariadb_version}
124Summary:        TokuDB storage engine for MariaDB.
125Group:          Applications/Databases
126Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
127Requires:       mariadb-server = %{mariadb_version}-%{release}
128
129%description tokudb
130The TokuDB storage engine is for use in high-performance and
131write-intensive environments, offering increased compression and
132better performance.
133
134%endif
135
136%package client
137Version:        %{mariadb_version}
138Summary: MariaDB - Client
139Group: Applications/Databases
140Obsoletes: mysql-client MySQL-client < 5.6.0
141Provides: mysql-client MySQL-client  mariadbclient-%{mariadb_base_version}
142
143%description client
144This package contains the standard MariaDB clients and administration tools.
145
146
147%package devel
148Version:        %{mariadb_version}
149Summary: MariaDB - Development libraries and headers
150Group: Development/Libraries
151Requires: %{name}-static, openssl-devel, zlib-devel
152Conflicts: MySQL-devel < 5.6.0
153Conflicts: libmysqlclient-devel
154
155%description devel
156This package contains the development libraries and headers to develop
157MariaDB server components (e.g. plugins or embedded applications).
158
159
160%package static
161Version:        %{mariadb_version}
162Summary: MariaDB - static libraries
163Group: Development/Libraries
164Requires: %{name}-devel
165
166%description static
167This package provides static libraries of MariaDB.
168
169%if %{with source}
170%package source
171Version:        %{mariadb_version}
172Summary: MariaDB - Source
173Group: Development/Libraries
174Requires: mariadb-devel = %{version}-%{release}
175Obsoletes: MySQL-source < 5.6.0
176AutoReqProv: no
177
178%description source
179This package contains the sources files of MariaDB.
180
181%endif
182
183%package test
184Version:        %{mariadb_version}
185Requires: %{name}-client = %{version}-%{release} perl-DBI perl
186Summary: MariaDB - Test suite
187Group: Applications/Databases
188Obsoletes: mysql-bench MySQL5-bench MySQL-bench MySQL-test < 5.6.0
189Provides: perl(mtr_misc.pl)
190
191%description test
192This package contains the MariaDB regression test suite.
193
194
195%package embedded
196Version:        %{mariadb_version}
197Summary: MariaDB as an embeddable library
198Group: System Environment/Libraries
199Obsoletes: mysql-embedded MySQL-embedded
200Provides: mysql-embedded MySQL-embedded
201
202%description embedded
203This package contains a version of the MariaDB server that can be embedded
204into a client application instead of running as a separate process.
205
206
207%prep
208%setup -q
209%patch1000 -p1 -b .mroonga
210#%patch2000 -p1 -b .srv_buf_size
211
212%build
213
214# Be strict about variables, bail at earliest opportunity, etc.
215set -eu
216
217# Optional package files
218touch optional-files-devel
219
220export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
221export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
222
223# Build full release
224mkdir release
225(
226  cd release
227  cmake ../ \
228      -DINSTALL_LAYOUT=RPM \
229      -DBUILD_CONFIG=mysql_release \
230      -DCMAKE_BUILD_TYPE=Release \
231      -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
232      -DCOMPILATION_COMMENT="Vine Linux MariaDB RPM" \
233      -DWITH_PIC="ON" \
234      -DWITH_EMBEDDED_SERVER="ON" \
235      -DWITH_ZLIB="system" \
236      -DWITH_LOCALES="yes" \
237      -DWITH_UNIT_TESTS="no" \
238      -DWITH_SEQUENCE_STORAGE_ENGINE="ON" \
239      -DWITH_XTRADB_STORAGE_ENGINE="ON" \
240      -DWITH_JEMALLOC="yes" \
241      -DGRN_WITH_MECAB="yes" \
242      -DGRN_WITH_ONIGMO="no"
243
244#      -DWITHOUT_TOKUDB="yes"
245#      -DWITH_PCRE="system"
246
247  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
248  make %{?_smp_mflags} VERBOSE=1
249)
250
251
252%install
253rm -rf %{buildroot}
254
255install -d %{buildroot}%{mysqldatadir}/mysql
256install -d %{buildroot}%{_infodir}
257
258# Install all binaries
259(
260  cd release
261  make DESTDIR=%{buildroot} install
262)
263
264install -m 0644  Docs/mysql.info %{buildroot}%{_infodir}
265rm -rf ./doc
266mv -f %{buildroot}%{_docdir} ./
267
268mv -f %{buildroot}%{_datadir}/groonga ./
269mv -f %{buildroot}%{_datadir}/groonga-normalizer-mysql ./
270
271%if %{with source}
272mkdir -p %{buildroot}%{_datadir}/%{name}-source
273pushd %{buildroot}%{_datadir}/%{name}-source
274tar zxf %{SOURCE0}
275find %{buildroot}%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
276popd
277%endif
278
279install -d %{buildroot}%{_sysconfdir}/rpm
280sed -e 's/@BASEVERSION@/%{mariadb_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > %{buildroot}%{_sysconfdir}/rpm/macros.mariadb
281
282rm -f %{buildroot}%{_mandir}/man1/mysql_fix_privilege_tables.1*
283rm -f %{buildroot}%{_mandir}/man8/mysqlmanager.8*
284rm -f %{buildroot}%{_sysconfdir}/my.cnf
285rm -f %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
286rm -f %{buildroot}%{_libdir}/libmysqlclient*.so*
287rm -f %{buildroot}%{_libdir}/mysql/plugin/daemon_example.ini
288
289# force linking statically.
290perl -pi -e 's,-lmysqlclient_r,%{_libdir}/libmysqlclient_r.a,' %{buildroot}%{_bindir}/mysql_config
291perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_bindir}/mysql_config
292
293perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_datadir}/pkgconfig/mariadb.pc
294
295##############################################################################
296
297%pre server
298# Create a MySQL user and group. Do not report any problems if it already
299# exists.
300datadir=/var/lib/mysql
301
302groupadd -r mysql 2> /dev/null || true
303useradd -M -r -d $datadir -s /bin/bash -c "MySQL server" -g mysql mysql 2> /dev/null || true
304# The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
305usermod -g mysql mysql 2> /dev/null || true
306
307%post server
308
309# Make MySQL start/shutdown automatically when the machine does it.
310if [ $1 = 1 ] ; then
311  if [ -x /sbin/chkconfig ] ; then
312          /sbin/chkconfig --add mysql
313  fi
314
315  basedir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--basedir=//p'|tail -1`
316  if [ -z "$basedir" ] ; then
317    basedir=/usr
318  fi
319
320  datadir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
321  if [ -z "$datadir" ] ; then
322    datadir=/var/lib/mysql
323  else
324    # datadir may be relative to a basedir!
325    if ! expr $datadir : / > /dev/null; then
326      datadir=$basedir/$datadir
327    fi
328  fi
329
330  tmpdir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
331  if [ -z "$datadir" ] ; then
332    datadir=/var/lib/mysql
333  else
334    # datadir may be relative to a basedir!
335    if ! expr $datadir : / > /dev/null; then
336      datadir=$basedir/$datadir
337    fi
338  fi
339
340  # Change permissions so that the user that will run the MySQL daemon
341  # owns all database files.
342  chown -R mysql:mysql $datadir
343
344  if [ ! -e $datadir/mysql ]; then
345    # Create data directory
346    mkdir -p $datadir/{mysql,test}
347    chown -R mysql:mysql $datadir
348
349    # Initiate databases
350    /usr/bin/mysql_install_db --rpm --user=mysql
351  fi
352
353  # Change permissions again to fix any new files.
354  chown -R mysql:mysql $datadir
355
356  # Fix permissions for the permission database so that only the user
357  # can read them.
358  chmod -R og-rw $datadir/mysql
359fi
360
361%preun server
362if [ $1 = 0 ] ; then
363        # Stop MySQL before uninstalling it
364        if [ -x /etc/init.d/mysql ] ; then
365                /etc/init.d/mysql stop > /dev/null
366        fi
367        # Don't start it automatically anymore
368        if [ -x /sbin/chkconfig ] ; then
369                /sbin/chkconfig --del mysql
370        fi
371fi
372
373%postun server
374if [ $1 -ge 1 ]; then
375  if [ -x /etc/init.d/mysql ] ; then
376    # only restart the server if it was alredy running
377    /etc/init.d/mysql status > /dev/null 2>&1 && \
378    /etc/init.d/mysql restart
379  fi
380fi
381
382%pre mroonga
383if [ $1 -gt 1 ]; then
384/usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql || cat <<EOF
385An error occured when to unregister plugin.
386Please run a command below:
387
388  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql
389
390EOF
391
392fi
393
394%post mroonga
395if [ $1 -eq 1 ] ; then
396        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
397An error occured when to register plugin.
398Please run a command below:
399
400  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
401
402EOF
403fi
404
405%postun mroonga
406if [ $1 -gt 0 ] ; then
407        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
408An error occured when to register plugin.
409Please run a command below:
410
411  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
412
413EOF
414fi
415
416# Clean up the BuildRoot
417%clean
418[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
419
420%files server
421%defattr(-,root,root)
422%{!?_licensedir:%global license %%doc}
423%license COPYING* EXCEPTIONS-CLIENT
424
425%doc CREDITS README doc/*
426%doc release/support-files/my-*.cnf
427%doc %{_infodir}/mysql.info*
428
429%doc %{_mandir}/man1/aria_*.1*
430%doc %{_mandir}/man1/innochecksum.1*
431%doc %{_mandir}/man1/my_print_defaults.1*
432%doc %{_mandir}/man1/myisam_ftdump.1*
433%doc %{_mandir}/man1/myisamchk.1*
434%doc %{_mandir}/man1/myisamlog.1*
435%doc %{_mandir}/man1/myisampack.1*
436%doc %{_mandir}/man1/mysql_convert_table_format.1*
437%doc %{_mandir}/man1/mysql_fix_extensions.1*
438%doc %{_mandir}/man8/mysqld.8*
439%doc %{_mandir}/man1/mysqld_multi.1*
440%doc %{_mandir}/man1/mysqld_safe.1*
441%doc %{_mandir}/man1/mysqldumpslow.1*
442%doc %{_mandir}/man1/mysql_install_db.1*
443%doc %{_mandir}/man1/mysql_plugin.1*
444%doc %{_mandir}/man1/mysql_secure_installation.1*
445%doc %{_mandir}/man1/mysql_setpermission.1*
446%doc %{_mandir}/man1/mysql_upgrade.1*
447%doc %{_mandir}/man1/mysqlhotcopy.1*
448%doc %{_mandir}/man1/mysql.server.1*
449%doc %{_mandir}/man1/mysqltest.1*
450%doc %{_mandir}/man1/mysql_tzinfo_to_sql.1*
451%doc %{_mandir}/man1/mysql_zap.1*
452%doc %{_mandir}/man1/mysqlbug.1*
453%doc %{_mandir}/man1/perror.1*
454%doc %{_mandir}/man1/replace.1*
455%doc %{_mandir}/man1/resolve_stack_dump.1*
456%doc %{_mandir}/man1/resolveip.1*
457%{_bindir}/aria_*
458%{_bindir}/innochecksum
459%{_bindir}/my_print_defaults
460%{_bindir}/myisam_ftdump
461%{_bindir}/myisamchk
462%{_bindir}/myisamlog
463%{_bindir}/myisampack
464%{_bindir}/mysql_convert_table_format
465%{_bindir}/mysql_fix_extensions
466%{_bindir}/mysql_install_db
467%{_bindir}/mysql_plugin
468%{_bindir}/mysql_secure_installation
469%{_bindir}/mysql_setpermission
470%{_bindir}/mysql_tzinfo_to_sql
471%{_bindir}/mysql_upgrade
472%{_bindir}/mysql_zap
473%{_bindir}/mysqlbug
474%{_bindir}/mysqld_multi
475%{_bindir}/mysqld_safe
476%{_bindir}/mysqldumpslow
477%{_bindir}/mysqlhotcopy
478%{_bindir}/mysqltest
479%{_bindir}/perror
480%{_bindir}/replace
481%{_bindir}/resolve_stack_dump
482%{_bindir}/resolveip
483%{_bindir}/wsrep*
484%{_sbindir}/mysqld
485%{_sbindir}/rcmysql
486%exclude %{_libdir}/mysql/plugin/ha_connect.so
487%exclude %{_libdir}/mysql/plugin/ha_mroonga.so
488%ifarch x86_64
489%exclude %{_libdir}/mysql/plugin/ha_tokudb.so
490%endif
491%exclude %{_datadir}/mysql/mroonga
492%{_libdir}/mysql
493%config(noreplace) %{_sysconfdir}/my.cnf.d/enable_encryption.preset
494%config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
495%ifarch x86_64
496%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
497%endif
498%config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
499%{_sysconfdir}/init.d/mysql
500%{_datadir}/mysql
501%attr(755, mysql, mysql) %dir %{mysqldatadir}
502
503%files mroonga
504%defattr(-, root, root)
505%{!?_licensedir:%global license %%doc}
506%license groonga groonga-normalizer-mysql
507%{_libdir}/mysql/plugin/ha_mroonga.so
508%{_datadir}/mysql/mroonga
509
510%files connect
511%defattr(-, root, root)
512%{_libdir}/mysql/plugin/ha_connect.so
513
514%ifarch x86_64
515%files tokudb
516%defattr(-, root, root)
517%{_libdir}/mysql/plugin/ha_tokudb.so
518%{_bindir}/tokuft*
519%endif
520
521%files client
522%defattr(-, root, root)
523%{!?_licensedir:%global license %%doc}
524%license COPYING* EXCEPTIONS-CLIENT
525
526%config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
527%{_bindir}/msql2mysql
528%{_bindir}/mysql
529%{_bindir}/mysql_find_rows
530%{_bindir}/mysql_waitpid
531%{_bindir}/mysqlaccess
532%{_bindir}/mysqladmin
533%{_bindir}/mysqlbinlog
534%{_bindir}/mysqlcheck
535%{_bindir}/mysqldump
536%{_bindir}/mysqlimport
537%{_bindir}/mysqlshow
538%{_bindir}/mysqlslap
539%{_bindir}/mytop
540
541%doc %{_mandir}/man1/msql2mysql.1*
542%doc %{_mandir}/man1/mysql.1*
543%doc %{_mandir}/man1/mysql_find_rows.1*
544%doc %{_mandir}/man1/mysql_waitpid.1*
545%doc %{_mandir}/man1/mysqlaccess.1*
546%doc %{_mandir}/man1/mysqladmin.1*
547%doc %{_mandir}/man1/mysqlbinlog.1*
548%doc %{_mandir}/man1/mysqlcheck.1*
549%doc %{_mandir}/man1/mysqldump.1*
550%doc %{_mandir}/man1/mysqlimport.1*
551%doc %{_mandir}/man1/mysqlshow.1*
552%doc %{_mandir}/man1/mysqlslap.1*
553
554%files devel -f optional-files-devel
555%defattr(-, root, root)
556%doc %{_mandir}/man1/mysql_config.1*
557%{_bindir}/mysql_config
558%{_includedir}/mysql
559%{_datadir}/aclocal/mysql.m4
560%{_datadir}/pkgconfig/mariadb.pc
561%{_libdir}/*.so
562%{_sysconfdir}/rpm/*
563%{_bindir}/mysql_embedded
564
565%files static
566%defattr(-,root,root)
567%{_libdir}/lib*.a
568
569%if %{with source}
570%files source
571%defattr(-, root, root)
572%{_datadir}/mariadb-source
573%endif
574
575%files test
576%defattr(-, root, root)
577%attr(-, root, root) %{_datadir}/mysql-test
578%{_bindir}/mysql_client_test
579%{_bindir}/mysql_client_test_embedded
580%{_bindir}/mysqltest_embedded
581%doc %{_mandir}/man1/mysql_client_test.1*
582%doc %{_mandir}/man1/mysql-stress-test.pl.1*
583%doc %{_mandir}/man1/mysql-test-run.pl.1*
584%doc %{_mandir}/man1/mysql_client_test_embedded.1*
585%doc %{_mandir}/man1/mysqltest_embedded.1*
586
587%files embedded
588%defattr(-,root,root)
589%{_libdir}/libmysqld.so.*
590
591
592%changelog
593* Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.16-1
594- new upstream release.
595- replaced patch1000 to update Mroonga to v6.06.
596
597* Wed May 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.14-1
598- new upstream release.
599- replaced patch1000 to update Mroonga to v6.02.
600
601* Fri Apr  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.13-1
602- new upstream release.
603- replaced patch1000 to update Mroonga to v6.01.
604
605* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.12-1
606- new upstream release.
607- replaced patch1000 to update Mroonga to git HEAD.
608
609* Sat Jan 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.11-1
610- new upstream release.
611- replaced patch1000 to update Mroonga to v5.12.
612
613* Fri Jan  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.10-1
614- new upstream release.
615- replaced patch1000 to update Mroonga to v5.11.
616- moved CONNECT and TokuDB storage engines to subpackages.
617
618* Sun Nov 29 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-4
619- replaced patch1000 to update Mroonga to git HEAD.
620
621* Sat Nov 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-3
622- replaced patch1000 to update Mroonga to git HEAD.
623
624* Thu Nov 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-2
625- replaced patch1000 to update Mroonga to git HEAD.
626
627* Tue Nov 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-1
628- new upstream release.
629- replaced patch1000 to update Mroonga to git HEAD.
630
631* Fri Oct 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-3
632- added BR:jemalloc-devel.
633
634* Thu Oct 29 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-2
635- replaced patch1000 to update Mroonga to 5.09.
636
637* Wed Oct 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-1
638- new upstream release.
639- replaced patch1000 for MariaDB 10.1.8.
640
641* Fri Oct  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-3
642- replaced patch1000 to update Mroonga to 5.08.
643
644* Mon Aug 31 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-2
645- replaced patch1000 to update Mroonga to 5.06.
646
647* Mon Aug 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-1
648- new upstream release.
649- added patch1000 to update Mroonga from 5.02 to 5.05.
650
651* Tue Jun 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-2
652- fixed dependencies.
653
654* Fri Jun 19 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-1
655- new upstream release.
656
657* Sun May 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.19-1
658- new upstream release.
659
660* Fri May  8 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.18-1
661- new upstream release.
662
663* Tue Mar  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.17-1
664- new upstream release.
665
666* Wed Jan 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.16-1
667- new upstream release.
668
669* Wed Nov 26 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.15-1
670- new upstream release.
671- enabled bundled Mroonga.
672
673* Mon Sep 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.14-1
674- new upstream release.
675
676* Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
677- new upstream release.
678
679* Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
680- fixed Conflicts: and Obsoletes:.
681
682* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
683- new upstream release.
684
685* Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
686- new upstream release.
687
688* Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
689- new upstream release.
690
691* Sat Dec 07 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-2
692- removed duplicated files.
693
694* Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
695- switched to MariaDB.
696
697* Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
698- new upstream release.
699
700* Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
701- new upstream release.
702
703* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
704- new upstream release.
705- added a sub-package 'MySQL-source".
706- added some macros for rpm.
707
708* Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
709- new upstream release.
710
711* Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
712- new upstream release.
713
714* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
715- new upstream release.
716- added "Vendor:" and "Distribution:" tag.
717
718* Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
719- new upstream release.
720- removed NDB cluster support.
721
722* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
723- Added "BR: zlib-devel" to MySQL-devel.
724
725* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
726- Added "BR: openssl-devel" to MySQL-devel.
727
728* Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
729- new upstream release.
730
731* Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
732- new upstream release.
733- updated jp-patch.
734- added ssl support.
735
736* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
737- new upstream release.
738- replaced '%%__find_requires' to '%%__perl_requires'.
739- updated jp-patch.
740
741* Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
742- added mysql-5.1.44-lib64.patch (on x86_64)
743- added -fPIC (on x86_64)
744
745* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
746- made embedded package again
747
748* Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
749- new upstream release.
750- updated jp-patch.
751
752* Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
753- VineSeed: rebuilt with new toolchain.
754
755* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
756- new upstream release.
757  - fixed CVE-2009-4484.
758
759* Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
760- new upstream release.
761
762* Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
763- added net-tools to 'Requires'.
764- added groff to 'BuildRequires'.
765- renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
766
767* Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
768- new upstream release.
769
770* Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
771- new upstream release.
772
773* Sun Jul  5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
774- new upstream release.
775- dropped %%Patch100 (fixed in upstream).
776
777* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
778- new upstream release.
779- add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
780
781* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
782- new upstream release.
783- rename 'MySQL-bench' to 'MySQL-test'.
784- update Patch0.
785- change default charset to 'utf8'.
786
787* Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
788- new upstream release.
789- update Patch0.
790- add "--with-client-charset=ujis".
791- sync %%files to official RPM.
792- remove MySQL-Max.
793
794* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
795- for VineSeed
796
797* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
798- move shared library from /usr/lib/ to /usr/lib/mysql/
799- add /etc/ld.so.conf.d/*.conf
800- fix broken libmysqlcient*.la files (or should we remove them permanently?)
801
802* Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
803- rebuild <BTS:VineLinux:534>
804
805* Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
806- added -fPIC
807
808* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
809- fixed dependency. <BTS:338>
810
811* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
812- add %%Patch1. <BTS:320>
813
814* Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
815- new upstream release.
816
817* Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
818- new upstream release.
819
820* Sat Jun  3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
821- new upstream release.
822
823* Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
824- release++.
825
826* Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
827- new upstream release.
828- for VineSeed.
829
830* Wed Feb  8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
831- new upstream release.
832- replace Patch0 for MySQL-4.1.16.
833
834* Thu Oct  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
835- new upstream release.
836- add Patch0.
837
838* Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
839- new upstream version
840        -- mysql-4.0.25
841
842* Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
843- new upstream version
844        -- mysql-4.0.23
845
846* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
847- new upstream version
848        -- mysql-4.0.22
849 
850* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
851- new upstream version
852        -- mysql-4.0.21
853 
854* Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
855- new upstream version
856        -- mysql-4.0.20
857 
858* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
859- modify CFLAGS, CXXFLAGS and configure options for alpha
860
861* Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
862- Upgraded to MySQL-4
863- added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
864- merged to MySQL Official packages
865        -- renamed package "MySQL" to "MySQL-server"
866        -- when using gcc, _always_ use CXX=gcc
867        -- replaced Copyright with License field (Copyright is obsolete)
868        -- added myisam_ftdump to the Server package
869        -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
870        -- fixed file permissions (BUG 1672)
871        -- removed dependency on MySQL-client from the MySQL-devel subpackage
872        -- as it is not really required. (BUG 1610)
873        -- Fixed BUG 1162 (removed macro names from the changelog)
874        -- Really fixed BUG 998 (disable the checking for installed but
875        --  unpackaged files)
876        -- Fixed BUG 959 (libmysqld not being compiled properly)
877        -- Fixed BUG 998 (RPM build errors): added missing files to the
878        -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
879        -- mysql_fix_privilege_tables.1), removed "-n" from install section.
880        -- removed the GIF Icon (file was not included in the sources anyway)
881        -- removed unused variable shared_lib_version
882        -- do not run automake before building the standard binary
883        --  (should not be necessary)
884        -- add server suffix '-standard' to standard binary (to be in line
885        -- with the binary tarball distributions)
886        -- allow overriding CC and CXX (required when building
887        -- with other compilers)
888
889* Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
890- added BuildRequires:  automake16
891                                                                               
892* Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
893- add '-fPIC -DPIC' to CFLAGS on alpha
894- little fix of spec file
895                                                                               
896* Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
897- enable MySQL-shared subpackage for alpha
898- delete 'BuildPrereq: kernel24-headers' for alpha
899- fix shared %files (exclude sparc)
900                                                                               
901* Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
902- new upstream version
903                                                                               
904* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
905- fixed devel %files (dropped *.la files)
906                                                                               
907* Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
908- new upstream version
909- fixed document permission
910                                                                               
911* Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
912- new upstream version
913                                                                               
914* Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
915- dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
916        -- don't work
917                                                                               
918* Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
919- new upstream version
920- diseble-assembler in configure on sparc,sparc64,alpha
921                                                                               
922* Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
923- new upstream version
924- moved some man files to main package
925- added enable-local-infile in configure
926- changed --with-extra-charsets=all in configure
927                                                                               
928* Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
929- fixed changelog
930                                                                               
931* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
932- updated to mysql-3.23.51
933                                                                               
934* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
935- rebuild on zlib-1.1.4(security fix.)
936                                                                               
937* Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
938- updated to mysql-2.23.49
939                                                                               
940* Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
941- add 'BuildPrereq: kernel24-headers' on alpha
942- remove shared library and max on alpha
943                                                                               
944* Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
945- updated to mysql-3.23.48
946                                                                               
947* Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
948- updated to mysql-3.23.47
949                                                                               
950* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
951- updated to mysql-3.23.46
952                                                                               
953* Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
954- updated to mysql-3.23.45
955                                                                               
956* Mon Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
957- updated to mysql-3.23.44
958                                                                               
959* Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
960- updated to mysql-3.23.43
961- removed shared library and max on sparc
962                                                                               
963* Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
964- updated to mysql-3.23.42
965- changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
966                                                                               
967* Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
968- updated to mysql-3.23.41
969                                                                               
970* Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
971- updated to mysql-3.23.40
972                                                                               
973* Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
974- updated to mysql-3.23.39
975
976* Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
977- added configure --with-charset=ujis
978                                                                               
979* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
980- used some rpmmacro
981                                                                               
982* Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
983- updated to MySQL-3.23.38
984                                                                               
985* Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
986- removed Bench pakages
987                                                                               
988* Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
989- removed pt_BR locale
990- build on Vine Linux
991- partially used rpmmacros
992- added %clean tag
993                                                                               
994* Fri Aug 18 2000 Tim Smith <tim@mysql.com>
995- Added separate libmysql_r directory; now both a threaded
996  and non-threaded library is shipped.
997                                                                               
998* Tue Sep 28 1999 David Axmark <davida@mysql.com>
999- Added the support-files/my-example.cnf to the docs directory.
1000- Removed devel dependency on base since it is about client
1001  development.
1002                                                                               
1003* Wed Sep 8 1999 David Axmark <davida@mysql.com>
1004- Cleaned up some for 3.23.
1005                                                                               
1006* Thu Jul 1 1999 David Axmark <davida@mysql.com>
1007- Added support for shared libraries in a separate sub
1008  package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
1009- The --enable-assembler switch is now automatically disables on
1010  platforms there assembler code is unavailable. This should allow
1011  building this RPM on non i386 systems.
1012                                                                               
1013* Mon Feb 22 1999 David Axmark <david@detron.se>
1014- Removed unportable cc switches from the spec file. The defaults can
1015  now be overridden with environment variables. This feature is used
1016  to compile the official RPM with optimal (but compiler version
1017  specific) switches.
1018- Removed the repetitive description parts for the sub rpms. Maybe add
1019  again if RPM gets a multiline macro capability.
1020- Added support for a pt_BR translation. Translation contributed by
1021  Jorge Godoy <jorge@bestway.com.br>.
1022                                                                               
1023* Wed Nov 4 1998 David Axmark <david@detron.se>
1024- A lot of changes in all the rpm and install scripts. This may even
1025  be a working RPM :-)
1026                                                                               
1027* Sun Aug 16 1998 David Axmark <david@detron.se>
1028- A developers changelog for MySQL is available in the source RPM. And
1029  there is a history of major user visible changed in the Reference
1030  Manual.  Only RPM specific changes will be documented here.
1031
Note: See TracBrowser for help on using the repository browser.