source: projects/specs/trunk/m/mariadb/mariadb-vl.spec @ 10116

Revision 10116, 34.1 KB checked in by tomop, 8 years ago (diff)

mariadb-10.1.13-1

Line 
1%bcond_with source
2
3%define mysqld_user             mysql
4%define mysqld_group            mysql
5%define mysqldatadir /var/lib/mysql
6
7# Working around perl dependency problem
8%global __perl_requires %{SOURCE998}
9%global __perllib_requires %{SOURCE998}
10
11%define _unpackaged_files_terminate_build 1
12
13%define mariadb_base_version    10.0
14%define mariadb_version         10.1.13
15%define mroonga_version         6.01
16%define client_version          18
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager:       tomop
21
22Name: mariadb
23Summary:        MariaDB: a very fast and robust SQL database server
24Version:        %{mariadb_version}
25Release:        1%{_dist_release}
26
27Group:          Applications/Databases
28License:        GPL2
29URL:            http://www.mariadb.org/
30
31Source:         mariadb-%{version}.tar.gz
32# Don't depend on lib::mtr*
33Source998:      perl-requires.sh
34Source1000:     macros.mariadb.in
35
36# mroonga 5.04 -> 6.01
37#patch1000: mariadb-%{mariadb_version}-mroonga-master.patch
38patch1000: mariadb-%{mariadb_version}-mroonga-v%{mroonga_version}.patch
39
40#
41#Patch2000:     mysql-srv_buf_size.patch
42
43BuildRoot:              %{_tmppath}/%{name}-%{version}-root
44BuildRequires:  bison, cmake, gcc-c++, groff
45BuildRequires:  libaio-devel, libboost-devel, libevent-devel, libxml2-devel
46BuildRequires:  ncurses-devel, perl, openssl-devel, readline-devel
47BuildRequires:  jemalloc-devel
48BuildRequires:  unixODBC-devel
49BuildRequires:  zlib-devel
50BuildRequires:  mecab-devel
51Requires:               fileutils sh-utils
52Provides:               msqlormysql MySQL mysql
53Obsoletes:              mysql MySQL5
54
55# From the manual
56%description
57MariaDB: a very fast and robust SQL database server
58
59It is GPL v2 licensed, which means you can use the it free of charge under the
60conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
61
62MariaDB documentation can be found at http://kb.askmonty.org/
63MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
64
65
66%package server
67Version:        %{mariadb_version}
68Release:        %{release}
69Summary:        MariaDB: a very fast and robust SQL database server
70Group:          Applications/Databases
71Requires:       fileutils sh-utils net-tools mariadb-common
72Requires(post): mariadb-common
73Provides:       mysql-server mysql MySQL MySQL-server mariadbserver-%{mariadb_base_version}
74Obsoletes:      MySQL mysql mysql-server
75Obsoletes:      MySQL-server < 5.6.0
76
77%description server
78MariaDB: a very fast and robust SQL database server
79
80It is GPL v2 licensed, which means you can use the it free of charge under the
81conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
82
83MariaDB documentation can be found at http://kb.askmonty.org/
84MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
85
86%package mroonga
87##Version: %{mroonga_version}
88Version:        %{mariadb_version}
89Summary:        A fast fulltext searchable storage engine for MariaDB.
90Group:          Applications/Databases
91Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
92Requires:       mariadb-server = %{mariadb_version}-%{release}
93Obsoletes:      MySQL-mroonga < 4.02
94Obsoletes:      mariadb-mroonga < 4.07
95Obsoletes:      mariadb-mroonga-doc < 4.07
96
97%description mroonga
98Mroonga is a fast fulltext searchable storage plugin for MariaDB.
99It is based on groonga that is a fast fulltext search engine and
100column store. Groonga is good at real-time update.
101
102%package connect
103Version:        %{mariadb_version}
104Summary:        CONNECT storage engine for MariaDB.
105Group:          Applications/Databases
106Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
107Requires:       mariadb-server = %{mariadb_version}-%{release}
108
109%description connect
110The CONNECT storage engine enables MariaDB to access external
111local or remote data (MED). This is done by defining tables
112based on different data types, in particular files in various
113formats, data extracted from other DBMS or products (such as Excel)
114via ODBC, or data retrieved from the environment (for example
115DIR, WMI, and MAC tables).
116
117This storage engine supports table partitioning, MariaDB virtual
118columns and also permits defining special columns such as ROWID,
119FILEID, and SERVID.
120
121%ifarch x86_64
122%package tokudb
123Version:        %{mariadb_version}
124Summary:        TokuDB storage engine for MariaDB.
125Group:          Applications/Databases
126Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
127Requires:       mariadb-server = %{mariadb_version}-%{release}
128
129%description tokudb
130The TokuDB storage engine is for use in high-performance and
131write-intensive environments, offering increased compression and
132better performance.
133
134%endif
135
136%package client
137Version:        %{mariadb_version}
138Summary: MariaDB - Client
139Group: Applications/Databases
140Obsoletes: mysql-client MySQL-client < 5.6.0
141Provides: mysql-client MySQL-client  mariadbclient-%{mariadb_base_version}
142
143%description client
144This package contains the standard MariaDB clients and administration tools.
145
146
147%package devel
148Version:        %{mariadb_version}
149Summary: MariaDB - Development libraries and headers
150Group: Development/Libraries
151Requires: %{name}-static, openssl-devel, zlib-devel
152Conflicts: MySQL-devel < 5.6.0
153Conflicts: libmysqlclient-devel
154
155%description devel
156This package contains the development libraries and headers to develop
157MariaDB server components (e.g. plugins or embedded applications).
158
159
160%package static
161Version:        %{mariadb_version}
162Summary: MariaDB - static libraries
163Group: Development/Libraries
164Requires: %{name}-devel
165
166%description static
167This package provides static libraries of MariaDB.
168
169%if %{with source}
170%package source
171Version:        %{mariadb_version}
172Summary: MariaDB - Source
173Group: Development/Libraries
174Requires: mariadb-devel = %{version}-%{release}
175Obsoletes: MySQL-source < 5.6.0
176AutoReqProv: no
177
178%description source
179This package contains the sources files of MariaDB.
180
181%endif
182
183%package test
184Version:        %{mariadb_version}
185Requires: %{name}-client = %{version}-%{release} perl-DBI perl
186Summary: MariaDB - Test suite
187Group: Applications/Databases
188Obsoletes: mysql-bench MySQL5-bench MySQL-bench MySQL-test < 5.6.0
189Provides: perl(mtr_misc.pl)
190
191%description test
192This package contains the MariaDB regression test suite.
193
194
195%package embedded
196Version:        %{mariadb_version}
197Summary: MariaDB as an embeddable library
198Group: System Environment/Libraries
199Obsoletes: mysql-embedded MySQL-embedded
200Provides: mysql-embedded MySQL-embedded
201
202%description embedded
203This package contains a version of the MariaDB server that can be embedded
204into a client application instead of running as a separate process.
205
206
207%prep
208%setup -q
209%patch1000 -p1 -b .mroonga
210#%patch2000 -p1 -b .srv_buf_size
211
212%build
213
214# Be strict about variables, bail at earliest opportunity, etc.
215set -eu
216
217# Optional package files
218touch optional-files-devel
219
220export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
221export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
222
223# Build full release
224mkdir release
225(
226  cd release
227  cmake ../ \
228      -DINSTALL_LAYOUT=RPM \
229      -DBUILD_CONFIG=mysql_release \
230      -DCMAKE_BUILD_TYPE=Release \
231      -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
232      -DCOMPILATION_COMMENT="Vine Linux MariaDB RPM" \
233      -DWITH_PIC="ON" \
234      -DWITH_EMBEDDED_SERVER="ON" \
235      -DWITH_ZLIB="system" \
236      -DWITH_LOCALES="yes" \
237      -DWITH_UNIT_TESTS="no" \
238      -DWITH_SEQUENCE_STORAGE_ENGINE="ON" \
239      -DWITH_XTRADB_STORAGE_ENGINE="ON" \
240      -DWITH_JEMALLOC="yes" \
241      -DGRN_WITH_MECAB="yes" \
242      -DGRN_WITH_ONIGMO="no"
243
244#      -DWITHOUT_TOKUDB="yes"
245#      -DWITH_PCRE="system"
246
247  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
248  make %{?_smp_mflags} VERBOSE=1
249)
250
251
252%install
253rm -rf %{buildroot}
254
255install -d %{buildroot}%{mysqldatadir}/mysql
256install -d %{buildroot}%{_infodir}
257
258# Install all binaries
259(
260  cd release
261  make DESTDIR=%{buildroot} install
262)
263
264install -m 0644  Docs/mysql.info %{buildroot}%{_infodir}
265rm -rf ./doc
266mv -f %{buildroot}%{_docdir} ./
267
268mv -f %{buildroot}%{_datadir}/groonga ./
269
270%if %{with source}
271mkdir -p %{buildroot}%{_datadir}/%{name}-source
272pushd %{buildroot}%{_datadir}/%{name}-source
273tar zxf %{SOURCE0}
274find %{buildroot}%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
275popd
276%endif
277
278install -d %{buildroot}%{_sysconfdir}/rpm
279sed -e 's/@BASEVERSION@/%{mariadb_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > %{buildroot}%{_sysconfdir}/rpm/macros.mariadb
280
281rm -f %{buildroot}%{_mandir}/man1/mysql_fix_privilege_tables.1*
282rm -f %{buildroot}%{_mandir}/man8/mysqlmanager.8*
283rm -f %{buildroot}%{_sysconfdir}/my.cnf
284rm -f %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
285rm -f %{buildroot}%{_libdir}/libmysqlclient*.so*
286rm -f %{buildroot}%{_libdir}/mysql/plugin/daemon_example.ini
287
288# force linking statically.
289perl -pi -e 's,-lmysqlclient_r,%{_libdir}/libmysqlclient_r.a,' %{buildroot}%{_bindir}/mysql_config
290perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_bindir}/mysql_config
291
292perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_datadir}/pkgconfig/mariadb.pc
293
294##############################################################################
295
296%pre server
297# Create a MySQL user and group. Do not report any problems if it already
298# exists.
299datadir=/var/lib/mysql
300
301groupadd -r mysql 2> /dev/null || true
302useradd -M -r -d $datadir -s /bin/bash -c "MySQL server" -g mysql mysql 2> /dev/null || true
303# The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
304usermod -g mysql mysql 2> /dev/null || true
305
306%post server
307
308# Make MySQL start/shutdown automatically when the machine does it.
309if [ $1 = 1 ] ; then
310  if [ -x /sbin/chkconfig ] ; then
311          /sbin/chkconfig --add mysql
312  fi
313
314  basedir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--basedir=//p'|tail -1`
315  if [ -z "$basedir" ] ; then
316    basedir=/usr
317  fi
318
319  datadir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
320  if [ -z "$datadir" ] ; then
321    datadir=/var/lib/mysql
322  else
323    # datadir may be relative to a basedir!
324    if ! expr $datadir : / > /dev/null; then
325      datadir=$basedir/$datadir
326    fi
327  fi
328
329  tmpdir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
330  if [ -z "$datadir" ] ; then
331    datadir=/var/lib/mysql
332  else
333    # datadir may be relative to a basedir!
334    if ! expr $datadir : / > /dev/null; then
335      datadir=$basedir/$datadir
336    fi
337  fi
338
339  # Change permissions so that the user that will run the MySQL daemon
340  # owns all database files.
341  chown -R mysql:mysql $datadir
342
343  if [ ! -e $datadir/mysql ]; then
344    # Create data directory
345    mkdir -p $datadir/{mysql,test}
346    chown -R mysql:mysql $datadir
347
348    # Initiate databases
349    /usr/bin/mysql_install_db --rpm --user=mysql
350  fi
351
352  # Change permissions again to fix any new files.
353  chown -R mysql:mysql $datadir
354
355  # Fix permissions for the permission database so that only the user
356  # can read them.
357  chmod -R og-rw $datadir/mysql
358fi
359
360%preun server
361if [ $1 = 0 ] ; then
362        # Stop MySQL before uninstalling it
363        if [ -x /etc/init.d/mysql ] ; then
364                /etc/init.d/mysql stop > /dev/null
365        fi
366        # Don't start it automatically anymore
367        if [ -x /sbin/chkconfig ] ; then
368                /sbin/chkconfig --del mysql
369        fi
370fi
371
372%postun server
373if [ $1 -ge 1 ]; then
374  if [ -x /etc/init.d/mysql ] ; then
375    # only restart the server if it was alredy running
376    /etc/init.d/mysql status > /dev/null 2>&1 && \
377    /etc/init.d/mysql restart
378  fi
379fi
380
381%pre mroonga
382if [ $1 -gt 1 ]; then
383/usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql || cat <<EOF
384An error occured when to unregister plugin.
385Please run a command below:
386
387  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql
388
389EOF
390
391fi
392
393%post mroonga
394if [ $1 -eq 1 ] ; then
395        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
396An error occured when to register plugin.
397Please run a command below:
398
399  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
400
401EOF
402fi
403
404%postun mroonga
405if [ $1 -gt 0 ] ; then
406        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
407An error occured when to register plugin.
408Please run a command below:
409
410  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
411
412EOF
413fi
414
415# Clean up the BuildRoot
416%clean
417[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
418
419%files server
420%defattr(-,root,root)
421
422%doc doc/*
423%doc release/support-files/my-*.cnf
424%doc %{_infodir}/mysql.info*
425
426%doc %{_mandir}/man1/aria_*.1*
427%doc %{_mandir}/man1/innochecksum.1*
428%doc %{_mandir}/man1/my_print_defaults.1*
429%doc %{_mandir}/man1/myisam_ftdump.1*
430%doc %{_mandir}/man1/myisamchk.1*
431%doc %{_mandir}/man1/myisamlog.1*
432%doc %{_mandir}/man1/myisampack.1*
433%doc %{_mandir}/man1/mysql_convert_table_format.1*
434%doc %{_mandir}/man1/mysql_fix_extensions.1*
435%doc %{_mandir}/man8/mysqld.8*
436%doc %{_mandir}/man1/mysqld_multi.1*
437%doc %{_mandir}/man1/mysqld_safe.1*
438%doc %{_mandir}/man1/mysqldumpslow.1*
439%doc %{_mandir}/man1/mysql_install_db.1*
440%doc %{_mandir}/man1/mysql_plugin.1*
441%doc %{_mandir}/man1/mysql_secure_installation.1*
442%doc %{_mandir}/man1/mysql_setpermission.1*
443%doc %{_mandir}/man1/mysql_upgrade.1*
444%doc %{_mandir}/man1/mysqlhotcopy.1*
445%doc %{_mandir}/man1/mysql.server.1*
446%doc %{_mandir}/man1/mysqltest.1*
447%doc %{_mandir}/man1/mysql_tzinfo_to_sql.1*
448%doc %{_mandir}/man1/mysql_zap.1*
449%doc %{_mandir}/man1/mysqlbug.1*
450%doc %{_mandir}/man1/perror.1*
451%doc %{_mandir}/man1/replace.1*
452%doc %{_mandir}/man1/resolve_stack_dump.1*
453%doc %{_mandir}/man1/resolveip.1*
454%{_bindir}/aria_*
455%{_bindir}/innochecksum
456%{_bindir}/my_print_defaults
457%{_bindir}/myisam_ftdump
458%{_bindir}/myisamchk
459%{_bindir}/myisamlog
460%{_bindir}/myisampack
461%{_bindir}/mysql_convert_table_format
462%{_bindir}/mysql_fix_extensions
463%{_bindir}/mysql_install_db
464%{_bindir}/mysql_plugin
465%{_bindir}/mysql_secure_installation
466%{_bindir}/mysql_setpermission
467%{_bindir}/mysql_tzinfo_to_sql
468%{_bindir}/mysql_upgrade
469%{_bindir}/mysql_zap
470%{_bindir}/mysqlbug
471%{_bindir}/mysqld_multi
472%{_bindir}/mysqld_safe
473%{_bindir}/mysqldumpslow
474%{_bindir}/mysqlhotcopy
475%{_bindir}/mysqltest
476%{_bindir}/perror
477%{_bindir}/replace
478%{_bindir}/resolve_stack_dump
479%{_bindir}/resolveip
480%{_bindir}/wsrep*
481%{_sbindir}/mysqld
482%{_sbindir}/rcmysql
483%exclude %{_libdir}/mysql/plugin/ha_connect.so
484%exclude %{_libdir}/mysql/plugin/ha_mroonga.so
485%ifarch x86_64
486%exclude %{_libdir}/mysql/plugin/ha_tokudb.so
487%endif
488%exclude %{_datadir}/mysql/mroonga
489%{_libdir}/mysql
490%config(noreplace) %{_sysconfdir}/my.cnf.d/enable_encryption.preset
491%config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
492%ifarch x86_64
493%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
494%endif
495%config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
496%{_sysconfdir}/init.d/mysql
497%{_datadir}/mysql
498%attr(755, mysql, mysql) %dir %{mysqldatadir}
499
500%files mroonga
501%defattr(-, root, root)
502%doc groonga
503%{_libdir}/mysql/plugin/ha_mroonga.so
504%{_datadir}/mysql/mroonga
505
506%files connect
507%defattr(-, root, root)
508%{_libdir}/mysql/plugin/ha_connect.so
509
510%ifarch x86_64
511%files tokudb
512%defattr(-, root, root)
513%{_libdir}/mysql/plugin/ha_tokudb.so
514%{_bindir}/tokuft*
515%endif
516
517%files client
518%defattr(-, root, root)
519%config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
520%{_bindir}/msql2mysql
521%{_bindir}/mysql
522%{_bindir}/mysql_find_rows
523%{_bindir}/mysql_waitpid
524%{_bindir}/mysqlaccess
525%{_bindir}/mysqladmin
526%{_bindir}/mysqlbinlog
527%{_bindir}/mysqlcheck
528%{_bindir}/mysqldump
529%{_bindir}/mysqlimport
530%{_bindir}/mysqlshow
531%{_bindir}/mysqlslap
532%{_bindir}/mytop
533
534%doc %{_mandir}/man1/msql2mysql.1*
535%doc %{_mandir}/man1/mysql.1*
536%doc %{_mandir}/man1/mysql_find_rows.1*
537%doc %{_mandir}/man1/mysql_waitpid.1*
538%doc %{_mandir}/man1/mysqlaccess.1*
539%doc %{_mandir}/man1/mysqladmin.1*
540%doc %{_mandir}/man1/mysqlbinlog.1*
541%doc %{_mandir}/man1/mysqlcheck.1*
542%doc %{_mandir}/man1/mysqldump.1*
543%doc %{_mandir}/man1/mysqlimport.1*
544%doc %{_mandir}/man1/mysqlshow.1*
545%doc %{_mandir}/man1/mysqlslap.1*
546
547%files devel -f optional-files-devel
548%defattr(-, root, root)
549%doc %{_mandir}/man1/mysql_config.1*
550%{_bindir}/mysql_config
551%{_includedir}/mysql
552%{_datadir}/aclocal/mysql.m4
553%{_datadir}/pkgconfig/mariadb.pc
554%{_libdir}/*.so
555%{_sysconfdir}/rpm/*
556%{_bindir}/mysql_embedded
557
558%files static
559%defattr(-,root,root)
560%{_libdir}/lib*.a
561
562%if %{with source}
563%files source
564%defattr(-, root, root)
565%{_datadir}/mariadb-source
566%endif
567
568%files test
569%defattr(-, root, root)
570%attr(-, root, root) %{_datadir}/mysql-test
571%{_bindir}/mysql_client_test
572%{_bindir}/mysql_client_test_embedded
573%{_bindir}/mysqltest_embedded
574%doc %{_mandir}/man1/mysql_client_test.1*
575%doc %{_mandir}/man1/mysql-stress-test.pl.1*
576%doc %{_mandir}/man1/mysql-test-run.pl.1*
577%doc %{_mandir}/man1/mysql_client_test_embedded.1*
578%doc %{_mandir}/man1/mysqltest_embedded.1*
579
580%files embedded
581%defattr(-,root,root)
582%{_libdir}/libmysqld.so.*
583
584
585%changelog
586* Fri Apr  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.13-1
587- new upstream release.
588- replaced patch1000 to update Mroonga to v6.01.
589
590* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.12-1
591- new upstream release.
592- replaced patch1000 to update Mroonga to git HEAD.
593
594* Sat Jan 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.11-1
595- new upstream release.
596- replaced patch1000 to update Mroonga to v5.12.
597
598* Fri Jan  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.10-1
599- new upstream release.
600- replaced patch1000 to update Mroonga to v5.11.
601- moved CONNECT and TokuDB storage engines to subpackages.
602
603* Sun Nov 29 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-4
604- replaced patch1000 to update Mroonga to git HEAD.
605
606* Sat Nov 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-3
607- replaced patch1000 to update Mroonga to git HEAD.
608
609* Thu Nov 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-2
610- replaced patch1000 to update Mroonga to git HEAD.
611
612* Tue Nov 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-1
613- new upstream release.
614- replaced patch1000 to update Mroonga to git HEAD.
615
616* Fri Oct 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-3
617- added BR:jemalloc-devel.
618
619* Thu Oct 29 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-2
620- replaced patch1000 to update Mroonga to 5.09.
621
622* Wed Oct 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-1
623- new upstream release.
624- replaced patch1000 for MariaDB 10.1.8.
625
626* Fri Oct  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-3
627- replaced patch1000 to update Mroonga to 5.08.
628
629* Mon Aug 31 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-2
630- replaced patch1000 to update Mroonga to 5.06.
631
632* Mon Aug 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-1
633- new upstream release.
634- added patch1000 to update Mroonga from 5.02 to 5.05.
635
636* Tue Jun 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-2
637- fixed dependencies.
638
639* Fri Jun 19 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-1
640- new upstream release.
641
642* Sun May 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.19-1
643- new upstream release.
644
645* Fri May  8 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.18-1
646- new upstream release.
647
648* Tue Mar  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.17-1
649- new upstream release.
650
651* Wed Jan 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.16-1
652- new upstream release.
653
654* Wed Nov 26 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.15-1
655- new upstream release.
656- enabled bundled Mroonga.
657
658* Mon Sep 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.14-1
659- new upstream release.
660
661* Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
662- new upstream release.
663
664* Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
665- fixed Conflicts: and Obsoletes:.
666
667* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
668- new upstream release.
669
670* Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
671- new upstream release.
672
673* Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
674- new upstream release.
675
676* Sat Dec 07 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-2
677- removed duplicated files.
678
679* Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
680- switched to MariaDB.
681
682* Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
683- new upstream release.
684
685* Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
686- new upstream release.
687
688* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
689- new upstream release.
690- added a sub-package 'MySQL-source".
691- added some macros for rpm.
692
693* Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
694- new upstream release.
695
696* Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
697- new upstream release.
698
699* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
700- new upstream release.
701- added "Vendor:" and "Distribution:" tag.
702
703* Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
704- new upstream release.
705- removed NDB cluster support.
706
707* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
708- Added "BR: zlib-devel" to MySQL-devel.
709
710* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
711- Added "BR: openssl-devel" to MySQL-devel.
712
713* Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
714- new upstream release.
715
716* Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
717- new upstream release.
718- updated jp-patch.
719- added ssl support.
720
721* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
722- new upstream release.
723- replaced '%%__find_requires' to '%%__perl_requires'.
724- updated jp-patch.
725
726* Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
727- added mysql-5.1.44-lib64.patch (on x86_64)
728- added -fPIC (on x86_64)
729
730* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
731- made embedded package again
732
733* Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
734- new upstream release.
735- updated jp-patch.
736
737* Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
738- VineSeed: rebuilt with new toolchain.
739
740* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
741- new upstream release.
742  - fixed CVE-2009-4484.
743
744* Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
745- new upstream release.
746
747* Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
748- added net-tools to 'Requires'.
749- added groff to 'BuildRequires'.
750- renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
751
752* Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
753- new upstream release.
754
755* Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
756- new upstream release.
757
758* Sun Jul  5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
759- new upstream release.
760- dropped %%Patch100 (fixed in upstream).
761
762* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
763- new upstream release.
764- add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
765
766* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
767- new upstream release.
768- rename 'MySQL-bench' to 'MySQL-test'.
769- update Patch0.
770- change default charset to 'utf8'.
771
772* Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
773- new upstream release.
774- update Patch0.
775- add "--with-client-charset=ujis".
776- sync %%files to official RPM.
777- remove MySQL-Max.
778
779* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
780- for VineSeed
781
782* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
783- move shared library from /usr/lib/ to /usr/lib/mysql/
784- add /etc/ld.so.conf.d/*.conf
785- fix broken libmysqlcient*.la files (or should we remove them permanently?)
786
787* Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
788- rebuild <BTS:VineLinux:534>
789
790* Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
791- added -fPIC
792
793* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
794- fixed dependency. <BTS:338>
795
796* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
797- add %%Patch1. <BTS:320>
798
799* Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
800- new upstream release.
801
802* Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
803- new upstream release.
804
805* Sat Jun  3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
806- new upstream release.
807
808* Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
809- release++.
810
811* Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
812- new upstream release.
813- for VineSeed.
814
815* Wed Feb  8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
816- new upstream release.
817- replace Patch0 for MySQL-4.1.16.
818
819* Thu Oct  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
820- new upstream release.
821- add Patch0.
822
823* Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
824- new upstream version
825        -- mysql-4.0.25
826
827* Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
828- new upstream version
829        -- mysql-4.0.23
830
831* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
832- new upstream version
833        -- mysql-4.0.22
834 
835* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
836- new upstream version
837        -- mysql-4.0.21
838 
839* Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
840- new upstream version
841        -- mysql-4.0.20
842 
843* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
844- modify CFLAGS, CXXFLAGS and configure options for alpha
845
846* Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
847- Upgraded to MySQL-4
848- added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
849- merged to MySQL Official packages
850        -- renamed package "MySQL" to "MySQL-server"
851        -- when using gcc, _always_ use CXX=gcc
852        -- replaced Copyright with License field (Copyright is obsolete)
853        -- added myisam_ftdump to the Server package
854        -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
855        -- fixed file permissions (BUG 1672)
856        -- removed dependency on MySQL-client from the MySQL-devel subpackage
857        -- as it is not really required. (BUG 1610)
858        -- Fixed BUG 1162 (removed macro names from the changelog)
859        -- Really fixed BUG 998 (disable the checking for installed but
860        --  unpackaged files)
861        -- Fixed BUG 959 (libmysqld not being compiled properly)
862        -- Fixed BUG 998 (RPM build errors): added missing files to the
863        -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
864        -- mysql_fix_privilege_tables.1), removed "-n" from install section.
865        -- removed the GIF Icon (file was not included in the sources anyway)
866        -- removed unused variable shared_lib_version
867        -- do not run automake before building the standard binary
868        --  (should not be necessary)
869        -- add server suffix '-standard' to standard binary (to be in line
870        -- with the binary tarball distributions)
871        -- allow overriding CC and CXX (required when building
872        -- with other compilers)
873
874* Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
875- added BuildRequires:  automake16
876                                                                               
877* Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
878- add '-fPIC -DPIC' to CFLAGS on alpha
879- little fix of spec file
880                                                                               
881* Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
882- enable MySQL-shared subpackage for alpha
883- delete 'BuildPrereq: kernel24-headers' for alpha
884- fix shared %files (exclude sparc)
885                                                                               
886* Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
887- new upstream version
888                                                                               
889* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
890- fixed devel %files (dropped *.la files)
891                                                                               
892* Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
893- new upstream version
894- fixed document permission
895                                                                               
896* Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
897- new upstream version
898                                                                               
899* Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
900- dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
901        -- don't work
902                                                                               
903* Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
904- new upstream version
905- diseble-assembler in configure on sparc,sparc64,alpha
906                                                                               
907* Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
908- new upstream version
909- moved some man files to main package
910- added enable-local-infile in configure
911- changed --with-extra-charsets=all in configure
912                                                                               
913* Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
914- fixed changelog
915                                                                               
916* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
917- updated to mysql-3.23.51
918                                                                               
919* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
920- rebuild on zlib-1.1.4(security fix.)
921                                                                               
922* Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
923- updated to mysql-2.23.49
924                                                                               
925* Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
926- add 'BuildPrereq: kernel24-headers' on alpha
927- remove shared library and max on alpha
928                                                                               
929* Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
930- updated to mysql-3.23.48
931                                                                               
932* Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
933- updated to mysql-3.23.47
934                                                                               
935* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
936- updated to mysql-3.23.46
937                                                                               
938* Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
939- updated to mysql-3.23.45
940                                                                               
941* Mon Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
942- updated to mysql-3.23.44
943                                                                               
944* Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
945- updated to mysql-3.23.43
946- removed shared library and max on sparc
947                                                                               
948* Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
949- updated to mysql-3.23.42
950- changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
951                                                                               
952* Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
953- updated to mysql-3.23.41
954                                                                               
955* Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
956- updated to mysql-3.23.40
957                                                                               
958* Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
959- updated to mysql-3.23.39
960
961* Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
962- added configure --with-charset=ujis
963                                                                               
964* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
965- used some rpmmacro
966                                                                               
967* Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
968- updated to MySQL-3.23.38
969                                                                               
970* Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
971- removed Bench pakages
972                                                                               
973* Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
974- removed pt_BR locale
975- build on Vine Linux
976- partially used rpmmacros
977- added %clean tag
978                                                                               
979* Fri Aug 18 2000 Tim Smith <tim@mysql.com>
980- Added separate libmysql_r directory; now both a threaded
981  and non-threaded library is shipped.
982                                                                               
983* Tue Sep 28 1999 David Axmark <davida@mysql.com>
984- Added the support-files/my-example.cnf to the docs directory.
985- Removed devel dependency on base since it is about client
986  development.
987                                                                               
988* Wed Sep 8 1999 David Axmark <davida@mysql.com>
989- Cleaned up some for 3.23.
990                                                                               
991* Thu Jul 1 1999 David Axmark <davida@mysql.com>
992- Added support for shared libraries in a separate sub
993  package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
994- The --enable-assembler switch is now automatically disables on
995  platforms there assembler code is unavailable. This should allow
996  building this RPM on non i386 systems.
997                                                                               
998* Mon Feb 22 1999 David Axmark <david@detron.se>
999- Removed unportable cc switches from the spec file. The defaults can
1000  now be overridden with environment variables. This feature is used
1001  to compile the official RPM with optimal (but compiler version
1002  specific) switches.
1003- Removed the repetitive description parts for the sub rpms. Maybe add
1004  again if RPM gets a multiline macro capability.
1005- Added support for a pt_BR translation. Translation contributed by
1006  Jorge Godoy <jorge@bestway.com.br>.
1007                                                                               
1008* Wed Nov 4 1998 David Axmark <david@detron.se>
1009- A lot of changes in all the rpm and install scripts. This may even
1010  be a working RPM :-)
1011                                                                               
1012* Sun Aug 16 1998 David Axmark <david@detron.se>
1013- A developers changelog for MySQL is available in the source RPM. And
1014  there is a history of major user visible changed in the Reference
1015  Manual.  Only RPM specific changes will be documented here.
1016
Note: See TracBrowser for help on using the repository browser.