source: projects/specs/trunk/m/mariadb/mariadb-vl.spec @ 10010

Revision 10010, 33.8 KB checked in by tomop, 8 years ago (diff)

mariadb-10.1.11-1

Line 
1%bcond_with source
2
3%define mysqld_user             mysql
4%define mysqld_group            mysql
5%define mysqldatadir /var/lib/mysql
6
7# Working around perl dependency problem
8%global __perl_requires %{SOURCE998}
9%global __perllib_requires %{SOURCE998}
10
11%define _unpackaged_files_terminate_build 1
12
13%define mariadb_base_version    10.0
14%define mariadb_version         10.1.11
15%define mroonga_version         5.12
16%define client_version          18
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager:       tomop
21
22Name: mariadb
23Summary:        MariaDB: a very fast and robust SQL database server
24Version:        %{mariadb_version}
25Release:        1%{_dist_release}
26
27Group:          Applications/Databases
28License:        GPL2
29URL:            http://www.mariadb.org/
30
31Source:         mariadb-%{version}.tar.gz
32# Don't depend on lib::mtr*
33Source998:      perl-requires.sh
34Source1000:     macros.mariadb.in
35
36# mroonga 5.04 -> 5.12
37patch1000: mariadb-%{mariadb_version}-mroonga-v%{mroonga_version}.patch
38
39#
40#Patch2000:     mysql-srv_buf_size.patch
41
42BuildRoot:              %{_tmppath}/%{name}-%{version}-root
43BuildRequires:  bison, cmake, gcc-c++, groff
44BuildRequires:  libaio-devel, libboost-devel, libevent-devel, libxml2-devel
45BuildRequires:  ncurses-devel, perl, openssl-devel, readline-devel
46BuildRequires:  jemalloc-devel
47BuildRequires:  unixODBC-devel
48BuildRequires:  zlib-devel
49BuildRequires:  mecab-devel
50Requires:               fileutils sh-utils
51Provides:               msqlormysql MySQL mysql
52Obsoletes:              mysql MySQL5
53
54# From the manual
55%description
56MariaDB: a very fast and robust SQL database server
57
58It is GPL v2 licensed, which means you can use the it free of charge under the
59conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
60
61MariaDB documentation can be found at http://kb.askmonty.org/
62MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
63
64
65%package server
66Version:        %{mariadb_version}
67Release:        %{release}
68Summary:        MariaDB: a very fast and robust SQL database server
69Group:          Applications/Databases
70Requires:       fileutils sh-utils net-tools mariadb-common
71Requires(post): mariadb-common
72Provides:       mysql-server mysql MySQL MySQL-server mariadbserver-%{mariadb_base_version}
73Obsoletes:      MySQL mysql mysql-server
74Obsoletes:      MySQL-server < 5.6.0
75
76%description server
77MariaDB: a very fast and robust SQL database server
78
79It is GPL v2 licensed, which means you can use the it free of charge under the
80conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
81
82MariaDB documentation can be found at http://kb.askmonty.org/
83MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
84
85%package mroonga
86##Version: %{mroonga_version}
87Version:        %{mariadb_version}
88Summary:        A fast fulltext searchable storage engine for MariaDB.
89Group:          Applications/Databases
90Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
91Requires:       mariadb-server = %{mariadb_version}-%{release}
92Obsoletes:      MySQL-mroonga < 4.02
93Obsoletes:      mariadb-mroonga < 4.07
94Obsoletes:      mariadb-mroonga-doc < 4.07
95
96%description mroonga
97Mroonga is a fast fulltext searchable storage plugin for MariaDB.
98It is based on groonga that is a fast fulltext search engine and
99column store. Groonga is good at real-time update.
100
101%package connect
102Version:        %{mariadb_version}
103Summary:        CONNECT storage engine for MariaDB.
104Group:          Applications/Databases
105Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
106Requires:       mariadb-server = %{mariadb_version}-%{release}
107
108%description connect
109The CONNECT storage engine enables MariaDB to access external
110local or remote data (MED). This is done by defining tables
111based on different data types, in particular files in various
112formats, data extracted from other DBMS or products (such as Excel)
113via ODBC, or data retrieved from the environment (for example
114DIR, WMI, and MAC tables).
115
116This storage engine supports table partitioning, MariaDB virtual
117columns and also permits defining special columns such as ROWID,
118FILEID, and SERVID.
119
120%ifarch x86_64
121%package tokudb
122Version:        %{mariadb_version}
123Summary:        TokuDB storage engine for MariaDB.
124Group:          Applications/Databases
125Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
126Requires:       mariadb-server = %{mariadb_version}-%{release}
127
128%description tokudb
129The TokuDB storage engine is for use in high-performance and
130write-intensive environments, offering increased compression and
131better performance.
132
133%endif
134
135%package client
136Version:        %{mariadb_version}
137Summary: MariaDB - Client
138Group: Applications/Databases
139Obsoletes: mysql-client MySQL-client < 5.6.0
140Provides: mysql-client MySQL-client  mariadbclient-%{mariadb_base_version}
141
142%description client
143This package contains the standard MariaDB clients and administration tools.
144
145
146%package devel
147Version:        %{mariadb_version}
148Summary: MariaDB - Development libraries and headers
149Group: Development/Libraries
150Requires: %{name}-static, openssl-devel, zlib-devel
151Conflicts: MySQL-devel < 5.6.0
152Conflicts: libmysqlclient-devel
153
154%description devel
155This package contains the development libraries and headers to develop
156MariaDB server components (e.g. plugins or embedded applications).
157
158
159%package static
160Version:        %{mariadb_version}
161Summary: MariaDB - static libraries
162Group: Development/Libraries
163Requires: %{name}-devel
164
165%description static
166This package provides static libraries of MariaDB.
167
168%if %{with source}
169%package source
170Version:        %{mariadb_version}
171Summary: MariaDB - Source
172Group: Development/Libraries
173Requires: mariadb-devel = %{version}-%{release}
174Obsoletes: MySQL-source < 5.6.0
175AutoReqProv: no
176
177%description source
178This package contains the sources files of MariaDB.
179
180%endif
181
182%package test
183Version:        %{mariadb_version}
184Requires: %{name}-client = %{version}-%{release} perl-DBI perl
185Summary: MariaDB - Test suite
186Group: Applications/Databases
187Obsoletes: mysql-bench MySQL5-bench MySQL-bench MySQL-test < 5.6.0
188Provides: perl(mtr_misc.pl)
189
190%description test
191This package contains the MariaDB regression test suite.
192
193
194%package embedded
195Version:        %{mariadb_version}
196Summary: MariaDB as an embeddable library
197Group: System Environment/Libraries
198Obsoletes: mysql-embedded MySQL-embedded
199Provides: mysql-embedded MySQL-embedded
200
201%description embedded
202This package contains a version of the MariaDB server that can be embedded
203into a client application instead of running as a separate process.
204
205
206%prep
207%setup -q
208%patch1000 -p1 -b .mroonga
209#%patch2000 -p1 -b .srv_buf_size
210
211%build
212
213# Be strict about variables, bail at earliest opportunity, etc.
214set -eu
215
216# Optional package files
217touch optional-files-devel
218
219export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
220export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
221
222# Build full release
223mkdir release
224(
225  cd release
226  cmake ../ \
227      -DINSTALL_LAYOUT=RPM \
228      -DBUILD_CONFIG=mysql_release \
229      -DCMAKE_BUILD_TYPE=Release \
230      -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
231      -DCOMPILATION_COMMENT="Vine Linux MariaDB RPM" \
232      -DWITH_PIC="ON" \
233      -DWITH_EMBEDDED_SERVER="ON" \
234      -DWITH_ZLIB="system" \
235      -DWITH_LOCALES="yes" \
236      -DWITH_UNIT_TESTS="no" \
237      -DWITH_SEQUENCE_STORAGE_ENGINE="ON" \
238      -DWITH_XTRADB_STORAGE_ENGINE="ON" \
239      -DWITH_JEMALLOC="yes" \
240      -DGRN_WITH_MECAB="yes" \
241      -DGRN_WITH_ONIGMO="no"
242
243#      -DWITHOUT_TOKUDB="yes"
244#      -DWITH_PCRE="system"
245
246  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
247  make %{?_smp_mflags} VERBOSE=1
248)
249
250
251%install
252rm -rf %{buildroot}
253
254install -d %{buildroot}%{mysqldatadir}/mysql
255install -d %{buildroot}%{_infodir}
256
257# Install all binaries
258(
259  cd release
260  make DESTDIR=%{buildroot} install
261)
262
263install -m 0644  Docs/mysql.info %{buildroot}%{_infodir}
264rm -rf ./doc
265mv -f %{buildroot}%{_docdir} ./
266
267mv -f %{buildroot}%{_datadir}/groonga ./
268
269%if %{with source}
270mkdir -p %{buildroot}%{_datadir}/%{name}-source
271pushd %{buildroot}%{_datadir}/%{name}-source
272tar zxf %{SOURCE0}
273find %{buildroot}%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
274popd
275%endif
276
277install -d %{buildroot}%{_sysconfdir}/rpm
278sed -e 's/@BASEVERSION@/%{mariadb_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > %{buildroot}%{_sysconfdir}/rpm/macros.mariadb
279
280rm -f %{buildroot}%{_mandir}/man1/mysql_fix_privilege_tables.1*
281rm -f %{buildroot}%{_mandir}/man8/mysqlmanager.8*
282rm -f %{buildroot}%{_sysconfdir}/my.cnf
283rm -f %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
284rm -f %{buildroot}%{_libdir}/libmysqlclient*.so*
285rm -f %{buildroot}%{_libdir}/mysql/plugin/daemon_example.ini
286
287# force linking statically.
288perl -pi -e 's,-lmysqlclient_r,%{_libdir}/libmysqlclient_r.a,' %{buildroot}%{_bindir}/mysql_config
289perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_bindir}/mysql_config
290
291perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_datadir}/pkgconfig/mariadb.pc
292
293mv -f %{buildroot}%{_bindir}/maria_add_gis_sp.sql %{buildroot}%{_datadir}/mysql
294
295##############################################################################
296
297%pre server
298# Create a MySQL user and group. Do not report any problems if it already
299# exists.
300datadir=/var/lib/mysql
301
302groupadd -r mysql 2> /dev/null || true
303useradd -M -r -d $datadir -s /bin/bash -c "MySQL server" -g mysql mysql 2> /dev/null || true
304# The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
305usermod -g mysql mysql 2> /dev/null || true
306
307%post server
308
309# Make MySQL start/shutdown automatically when the machine does it.
310if [ $1 = 1 ] ; then
311  if [ -x /sbin/chkconfig ] ; then
312          /sbin/chkconfig --add mysql
313  fi
314
315  basedir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--basedir=//p'|tail -1`
316  if [ -z "$basedir" ] ; then
317    basedir=/usr
318  fi
319
320  datadir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
321  if [ -z "$datadir" ] ; then
322    datadir=/var/lib/mysql
323  else
324    # datadir may be relative to a basedir!
325    if ! expr $datadir : / > /dev/null; then
326      datadir=$basedir/$datadir
327    fi
328  fi
329
330  tmpdir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
331  if [ -z "$datadir" ] ; then
332    datadir=/var/lib/mysql
333  else
334    # datadir may be relative to a basedir!
335    if ! expr $datadir : / > /dev/null; then
336      datadir=$basedir/$datadir
337    fi
338  fi
339
340  # Change permissions so that the user that will run the MySQL daemon
341  # owns all database files.
342  chown -R mysql:mysql $datadir
343
344  if [ ! -e $datadir/mysql ]; then
345    # Create data directory
346    mkdir -p $datadir/{mysql,test}
347    chown -R mysql:mysql $datadir
348
349    # Initiate databases
350    /usr/bin/mysql_install_db --rpm --user=mysql
351  fi
352
353  # Change permissions again to fix any new files.
354  chown -R mysql:mysql $datadir
355
356  # Fix permissions for the permission database so that only the user
357  # can read them.
358  chmod -R og-rw $datadir/mysql
359fi
360
361%preun server
362if [ $1 = 0 ] ; then
363        # Stop MySQL before uninstalling it
364        if [ -x /etc/init.d/mysql ] ; then
365                /etc/init.d/mysql stop > /dev/null
366        fi
367        # Don't start it automatically anymore
368        if [ -x /sbin/chkconfig ] ; then
369                /sbin/chkconfig --del mysql
370        fi
371fi
372
373%postun server
374if [ $1 -ge 1 ]; then
375  if [ -x /etc/init.d/mysql ] ; then
376    # only restart the server if it was alredy running
377    /etc/init.d/mysql status > /dev/null 2>&1 && \
378    /etc/init.d/mysql restart
379  fi
380fi
381
382%pre mroonga
383if [ $1 -gt 1 ]; then
384/usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql || cat <<EOF
385An error occured when to unregister plugin.
386Please run a command below:
387
388  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql
389
390EOF
391
392fi
393
394%post mroonga
395if [ $1 -eq 1 ] ; then
396        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
397An error occured when to register plugin.
398Please run a command below:
399
400  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
401
402EOF
403fi
404
405%postun mroonga
406if [ $1 -gt 0 ] ; then
407        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
408An error occured when to register plugin.
409Please run a command below:
410
411  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
412
413EOF
414fi
415
416# Clean up the BuildRoot
417%clean
418[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
419
420%files server
421%defattr(-,root,root)
422
423%doc doc/*
424%doc release/support-files/my-*.cnf
425%doc %{_infodir}/mysql.info*
426
427%doc %{_mandir}/man1/aria_*.1*
428%doc %{_mandir}/man1/innochecksum.1*
429%doc %{_mandir}/man1/my_print_defaults.1*
430%doc %{_mandir}/man1/myisam_ftdump.1*
431%doc %{_mandir}/man1/myisamchk.1*
432%doc %{_mandir}/man1/myisamlog.1*
433%doc %{_mandir}/man1/myisampack.1*
434%doc %{_mandir}/man1/mysql_convert_table_format.1*
435%doc %{_mandir}/man1/mysql_fix_extensions.1*
436%doc %{_mandir}/man8/mysqld.8*
437%doc %{_mandir}/man1/mysqld_multi.1*
438%doc %{_mandir}/man1/mysqld_safe.1*
439%doc %{_mandir}/man1/mysqldumpslow.1*
440%doc %{_mandir}/man1/mysql_install_db.1*
441%doc %{_mandir}/man1/mysql_plugin.1*
442%doc %{_mandir}/man1/mysql_secure_installation.1*
443%doc %{_mandir}/man1/mysql_setpermission.1*
444%doc %{_mandir}/man1/mysql_upgrade.1*
445%doc %{_mandir}/man1/mysqlhotcopy.1*
446%doc %{_mandir}/man1/mysql.server.1*
447%doc %{_mandir}/man1/mysqltest.1*
448%doc %{_mandir}/man1/mysql_tzinfo_to_sql.1*
449%doc %{_mandir}/man1/mysql_zap.1*
450%doc %{_mandir}/man1/mysqlbug.1*
451%doc %{_mandir}/man1/perror.1*
452%doc %{_mandir}/man1/replace.1*
453%doc %{_mandir}/man1/resolve_stack_dump.1*
454%doc %{_mandir}/man1/resolveip.1*
455%{_bindir}/aria_*
456%{_bindir}/innochecksum
457%{_bindir}/my_print_defaults
458%{_bindir}/myisam_ftdump
459%{_bindir}/myisamchk
460%{_bindir}/myisamlog
461%{_bindir}/myisampack
462%{_bindir}/mysql_convert_table_format
463%{_bindir}/mysql_fix_extensions
464%{_bindir}/mysql_install_db
465%{_bindir}/mysql_plugin
466%{_bindir}/mysql_secure_installation
467%{_bindir}/mysql_setpermission
468%{_bindir}/mysql_tzinfo_to_sql
469%{_bindir}/mysql_upgrade
470%{_bindir}/mysql_zap
471%{_bindir}/mysqlbug
472%{_bindir}/mysqld_multi
473%{_bindir}/mysqld_safe
474%{_bindir}/mysqldumpslow
475%{_bindir}/mysqlhotcopy
476%{_bindir}/mysqltest
477%{_bindir}/perror
478%{_bindir}/replace
479%{_bindir}/resolve_stack_dump
480%{_bindir}/resolveip
481%{_bindir}/wsrep*
482%{_sbindir}/mysqld
483%{_sbindir}/rcmysql
484%exclude %{_libdir}/mysql/plugin/ha_connect.so
485%exclude %{_libdir}/mysql/plugin/ha_mroonga.so
486%ifarch x86_64
487%exclude %{_libdir}/mysql/plugin/ha_tokudb.so
488%endif
489%exclude %{_datadir}/mysql/mroonga
490%{_libdir}/mysql
491%config(noreplace) %{_sysconfdir}/my.cnf.d/enable_encryption.preset
492%config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
493%ifarch x86_64
494%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
495%endif
496%config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
497%{_sysconfdir}/init.d/mysql
498%{_datadir}/mysql
499%attr(755, mysql, mysql) %dir %{mysqldatadir}
500
501%files mroonga
502%defattr(-, root, root)
503%doc groonga
504%{_libdir}/mysql/plugin/ha_mroonga.so
505%{_datadir}/mysql/mroonga
506
507%files connect
508%defattr(-, root, root)
509%{_libdir}/mysql/plugin/ha_connect.so
510
511%ifarch x86_64
512%files tokudb
513%defattr(-, root, root)
514%{_libdir}/mysql/plugin/ha_tokudb.so
515%{_bindir}/tokuft*
516%endif
517
518%files client
519%defattr(-, root, root)
520%config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
521%{_bindir}/msql2mysql
522%{_bindir}/mysql
523%{_bindir}/mysql_find_rows
524%{_bindir}/mysql_waitpid
525%{_bindir}/mysqlaccess
526%{_bindir}/mysqladmin
527%{_bindir}/mysqlbinlog
528%{_bindir}/mysqlcheck
529%{_bindir}/mysqldump
530%{_bindir}/mysqlimport
531%{_bindir}/mysqlshow
532%{_bindir}/mysqlslap
533%{_bindir}/mytop
534
535%doc %{_mandir}/man1/msql2mysql.1*
536%doc %{_mandir}/man1/mysql.1*
537%doc %{_mandir}/man1/mysql_find_rows.1*
538%doc %{_mandir}/man1/mysql_waitpid.1*
539%doc %{_mandir}/man1/mysqlaccess.1*
540%doc %{_mandir}/man1/mysqladmin.1*
541%doc %{_mandir}/man1/mysqlbinlog.1*
542%doc %{_mandir}/man1/mysqlcheck.1*
543%doc %{_mandir}/man1/mysqldump.1*
544%doc %{_mandir}/man1/mysqlimport.1*
545%doc %{_mandir}/man1/mysqlshow.1*
546%doc %{_mandir}/man1/mysqlslap.1*
547
548%files devel -f optional-files-devel
549%defattr(-, root, root)
550%doc %{_mandir}/man1/mysql_config.1*
551%{_bindir}/mysql_config
552%{_includedir}/mysql
553%{_datadir}/aclocal/mysql.m4
554%{_datadir}/pkgconfig/mariadb.pc
555%{_libdir}/*.so
556%{_sysconfdir}/rpm/*
557%{_bindir}/mysql_embedded
558
559%files static
560%defattr(-,root,root)
561%{_libdir}/lib*.a
562
563%if %{with source}
564%files source
565%defattr(-, root, root)
566%{_datadir}/mariadb-source
567%endif
568
569%files test
570%defattr(-, root, root)
571%attr(-, root, root) %{_datadir}/mysql-test
572%{_bindir}/mysql_client_test
573%{_bindir}/mysql_client_test_embedded
574%{_bindir}/mysqltest_embedded
575%doc %{_mandir}/man1/mysql_client_test.1*
576%doc %{_mandir}/man1/mysql-stress-test.pl.1*
577%doc %{_mandir}/man1/mysql-test-run.pl.1*
578%doc %{_mandir}/man1/mysql_client_test_embedded.1*
579%doc %{_mandir}/man1/mysqltest_embedded.1*
580
581%files embedded
582%defattr(-,root,root)
583%{_libdir}/libmysqld.so.*
584
585
586%changelog
587* Sat Jan 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.11-1
588- new upstream release.
589- replaced patch1000 to update Mroonga to v5.12.
590
591* Fri Jan  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.10-1
592- new upstream release.
593- replaced patch1000 to update Mroonga to v5.11.
594- moved CONNECT and TokuDB storage engines to subpackages.
595
596* Sun Nov 29 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-4
597- replaced patch1000 to update Mroonga to git HEAD.
598
599* Sat Nov 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-3
600- replaced patch1000 to update Mroonga to git HEAD.
601
602* Thu Nov 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-2
603- replaced patch1000 to update Mroonga to git HEAD.
604
605* Tue Nov 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-1
606- new upstream release.
607- replaced patch1000 to update Mroonga to git HEAD.
608
609* Fri Oct 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-3
610- added BR:jemalloc-devel.
611
612* Thu Oct 29 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-2
613- replaced patch1000 to update Mroonga to 5.09.
614
615* Wed Oct 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-1
616- new upstream release.
617- replaced patch1000 for MariaDB 10.1.8.
618
619* Fri Oct  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-3
620- replaced patch1000 to update Mroonga to 5.08.
621
622* Mon Aug 31 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-2
623- replaced patch1000 to update Mroonga to 5.06.
624
625* Mon Aug 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-1
626- new upstream release.
627- added patch1000 to update Mroonga from 5.02 to 5.05.
628
629* Tue Jun 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-2
630- fixed dependencies.
631
632* Fri Jun 19 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-1
633- new upstream release.
634
635* Sun May 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.19-1
636- new upstream release.
637
638* Fri May  8 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.18-1
639- new upstream release.
640
641* Tue Mar  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.17-1
642- new upstream release.
643
644* Wed Jan 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.16-1
645- new upstream release.
646
647* Wed Nov 26 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.15-1
648- new upstream release.
649- enabled bundled Mroonga.
650
651* Mon Sep 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.14-1
652- new upstream release.
653
654* Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
655- new upstream release.
656
657* Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
658- fixed Conflicts: and Obsoletes:.
659
660* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
661- new upstream release.
662
663* Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
664- new upstream release.
665
666* Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
667- new upstream release.
668
669* Sat Dec 07 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-2
670- removed duplicated files.
671
672* Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
673- switched to MariaDB.
674
675* Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
676- new upstream release.
677
678* Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
679- new upstream release.
680
681* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
682- new upstream release.
683- added a sub-package 'MySQL-source".
684- added some macros for rpm.
685
686* Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
687- new upstream release.
688
689* Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
690- new upstream release.
691
692* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
693- new upstream release.
694- added "Vendor:" and "Distribution:" tag.
695
696* Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
697- new upstream release.
698- removed NDB cluster support.
699
700* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
701- Added "BR: zlib-devel" to MySQL-devel.
702
703* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
704- Added "BR: openssl-devel" to MySQL-devel.
705
706* Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
707- new upstream release.
708
709* Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
710- new upstream release.
711- updated jp-patch.
712- added ssl support.
713
714* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
715- new upstream release.
716- replaced '%%__find_requires' to '%%__perl_requires'.
717- updated jp-patch.
718
719* Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
720- added mysql-5.1.44-lib64.patch (on x86_64)
721- added -fPIC (on x86_64)
722
723* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
724- made embedded package again
725
726* Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
727- new upstream release.
728- updated jp-patch.
729
730* Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
731- VineSeed: rebuilt with new toolchain.
732
733* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
734- new upstream release.
735  - fixed CVE-2009-4484.
736
737* Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
738- new upstream release.
739
740* Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
741- added net-tools to 'Requires'.
742- added groff to 'BuildRequires'.
743- renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
744
745* Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
746- new upstream release.
747
748* Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
749- new upstream release.
750
751* Sun Jul  5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
752- new upstream release.
753- dropped %%Patch100 (fixed in upstream).
754
755* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
756- new upstream release.
757- add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
758
759* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
760- new upstream release.
761- rename 'MySQL-bench' to 'MySQL-test'.
762- update Patch0.
763- change default charset to 'utf8'.
764
765* Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
766- new upstream release.
767- update Patch0.
768- add "--with-client-charset=ujis".
769- sync %%files to official RPM.
770- remove MySQL-Max.
771
772* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
773- for VineSeed
774
775* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
776- move shared library from /usr/lib/ to /usr/lib/mysql/
777- add /etc/ld.so.conf.d/*.conf
778- fix broken libmysqlcient*.la files (or should we remove them permanently?)
779
780* Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
781- rebuild <BTS:VineLinux:534>
782
783* Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
784- added -fPIC
785
786* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
787- fixed dependency. <BTS:338>
788
789* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
790- add %%Patch1. <BTS:320>
791
792* Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
793- new upstream release.
794
795* Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
796- new upstream release.
797
798* Sat Jun  3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
799- new upstream release.
800
801* Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
802- release++.
803
804* Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
805- new upstream release.
806- for VineSeed.
807
808* Wed Feb  8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
809- new upstream release.
810- replace Patch0 for MySQL-4.1.16.
811
812* Thu Oct  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
813- new upstream release.
814- add Patch0.
815
816* Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
817- new upstream version
818        -- mysql-4.0.25
819
820* Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
821- new upstream version
822        -- mysql-4.0.23
823
824* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
825- new upstream version
826        -- mysql-4.0.22
827 
828* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
829- new upstream version
830        -- mysql-4.0.21
831 
832* Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
833- new upstream version
834        -- mysql-4.0.20
835 
836* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
837- modify CFLAGS, CXXFLAGS and configure options for alpha
838
839* Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
840- Upgraded to MySQL-4
841- added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
842- merged to MySQL Official packages
843        -- renamed package "MySQL" to "MySQL-server"
844        -- when using gcc, _always_ use CXX=gcc
845        -- replaced Copyright with License field (Copyright is obsolete)
846        -- added myisam_ftdump to the Server package
847        -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
848        -- fixed file permissions (BUG 1672)
849        -- removed dependency on MySQL-client from the MySQL-devel subpackage
850        -- as it is not really required. (BUG 1610)
851        -- Fixed BUG 1162 (removed macro names from the changelog)
852        -- Really fixed BUG 998 (disable the checking for installed but
853        --  unpackaged files)
854        -- Fixed BUG 959 (libmysqld not being compiled properly)
855        -- Fixed BUG 998 (RPM build errors): added missing files to the
856        -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
857        -- mysql_fix_privilege_tables.1), removed "-n" from install section.
858        -- removed the GIF Icon (file was not included in the sources anyway)
859        -- removed unused variable shared_lib_version
860        -- do not run automake before building the standard binary
861        --  (should not be necessary)
862        -- add server suffix '-standard' to standard binary (to be in line
863        -- with the binary tarball distributions)
864        -- allow overriding CC and CXX (required when building
865        -- with other compilers)
866
867* Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
868- added BuildRequires:  automake16
869                                                                               
870* Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
871- add '-fPIC -DPIC' to CFLAGS on alpha
872- little fix of spec file
873                                                                               
874* Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
875- enable MySQL-shared subpackage for alpha
876- delete 'BuildPrereq: kernel24-headers' for alpha
877- fix shared %files (exclude sparc)
878                                                                               
879* Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
880- new upstream version
881                                                                               
882* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
883- fixed devel %files (dropped *.la files)
884                                                                               
885* Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
886- new upstream version
887- fixed document permission
888                                                                               
889* Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
890- new upstream version
891                                                                               
892* Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
893- dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
894        -- don't work
895                                                                               
896* Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
897- new upstream version
898- diseble-assembler in configure on sparc,sparc64,alpha
899                                                                               
900* Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
901- new upstream version
902- moved some man files to main package
903- added enable-local-infile in configure
904- changed --with-extra-charsets=all in configure
905                                                                               
906* Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
907- fixed changelog
908                                                                               
909* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
910- updated to mysql-3.23.51
911                                                                               
912* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
913- rebuild on zlib-1.1.4(security fix.)
914                                                                               
915* Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
916- updated to mysql-2.23.49
917                                                                               
918* Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
919- add 'BuildPrereq: kernel24-headers' on alpha
920- remove shared library and max on alpha
921                                                                               
922* Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
923- updated to mysql-3.23.48
924                                                                               
925* Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
926- updated to mysql-3.23.47
927                                                                               
928* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
929- updated to mysql-3.23.46
930                                                                               
931* Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
932- updated to mysql-3.23.45
933                                                                               
934* Mon Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
935- updated to mysql-3.23.44
936                                                                               
937* Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
938- updated to mysql-3.23.43
939- removed shared library and max on sparc
940                                                                               
941* Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
942- updated to mysql-3.23.42
943- changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
944                                                                               
945* Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
946- updated to mysql-3.23.41
947                                                                               
948* Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
949- updated to mysql-3.23.40
950                                                                               
951* Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
952- updated to mysql-3.23.39
953
954* Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
955- added configure --with-charset=ujis
956                                                                               
957* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
958- used some rpmmacro
959                                                                               
960* Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
961- updated to MySQL-3.23.38
962                                                                               
963* Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
964- removed Bench pakages
965                                                                               
966* Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
967- removed pt_BR locale
968- build on Vine Linux
969- partially used rpmmacros
970- added %clean tag
971                                                                               
972* Fri Aug 18 2000 Tim Smith <tim@mysql.com>
973- Added separate libmysql_r directory; now both a threaded
974  and non-threaded library is shipped.
975                                                                               
976* Tue Sep 28 1999 David Axmark <davida@mysql.com>
977- Added the support-files/my-example.cnf to the docs directory.
978- Removed devel dependency on base since it is about client
979  development.
980                                                                               
981* Wed Sep 8 1999 David Axmark <davida@mysql.com>
982- Cleaned up some for 3.23.
983                                                                               
984* Thu Jul 1 1999 David Axmark <davida@mysql.com>
985- Added support for shared libraries in a separate sub
986  package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
987- The --enable-assembler switch is now automatically disables on
988  platforms there assembler code is unavailable. This should allow
989  building this RPM on non i386 systems.
990                                                                               
991* Mon Feb 22 1999 David Axmark <david@detron.se>
992- Removed unportable cc switches from the spec file. The defaults can
993  now be overridden with environment variables. This feature is used
994  to compile the official RPM with optimal (but compiler version
995  specific) switches.
996- Removed the repetitive description parts for the sub rpms. Maybe add
997  again if RPM gets a multiline macro capability.
998- Added support for a pt_BR translation. Translation contributed by
999  Jorge Godoy <jorge@bestway.com.br>.
1000                                                                               
1001* Wed Nov 4 1998 David Axmark <david@detron.se>
1002- A lot of changes in all the rpm and install scripts. This may even
1003  be a working RPM :-)
1004                                                                               
1005* Sun Aug 16 1998 David Axmark <david@detron.se>
1006- A developers changelog for MySQL is available in the source RPM. And
1007  there is a history of major user visible changed in the Reference
1008  Manual.  Only RPM specific changes will be documented here.
1009
Note: See TracBrowser for help on using the repository browser.