source: projects/specs/trunk/m/mariadb/mariadb-vl.spec @ 10088

Revision 10088, 34.0 KB checked in by tomop, 8 years ago (diff)

mariadb-10.1.12-1

Line 
1%bcond_with source
2
3%define mysqld_user             mysql
4%define mysqld_group            mysql
5%define mysqldatadir /var/lib/mysql
6
7# Working around perl dependency problem
8%global __perl_requires %{SOURCE998}
9%global __perllib_requires %{SOURCE998}
10
11%define _unpackaged_files_terminate_build 1
12
13%define mariadb_base_version    10.0
14%define mariadb_version         10.1.12
15%define mroonga_version         6.00
16%define client_version          18
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager:       tomop
21
22Name: mariadb
23Summary:        MariaDB: a very fast and robust SQL database server
24Version:        %{mariadb_version}
25Release:        1%{_dist_release}
26
27Group:          Applications/Databases
28License:        GPL2
29URL:            http://www.mariadb.org/
30
31Source:         mariadb-%{version}.tar.gz
32# Don't depend on lib::mtr*
33Source998:      perl-requires.sh
34Source1000:     macros.mariadb.in
35
36# mroonga 5.04 -> HEAD
37patch1000: mariadb-%{mariadb_version}-mroonga-master.patch
38#patch1000: mariadb-%{mariadb_version}-mroonga-v%{mroonga_version}.patch
39
40#
41#Patch2000:     mysql-srv_buf_size.patch
42
43BuildRoot:              %{_tmppath}/%{name}-%{version}-root
44BuildRequires:  bison, cmake, gcc-c++, groff
45BuildRequires:  libaio-devel, libboost-devel, libevent-devel, libxml2-devel
46BuildRequires:  ncurses-devel, perl, openssl-devel, readline-devel
47BuildRequires:  jemalloc-devel
48BuildRequires:  unixODBC-devel
49BuildRequires:  zlib-devel
50BuildRequires:  mecab-devel
51Requires:               fileutils sh-utils
52Provides:               msqlormysql MySQL mysql
53Obsoletes:              mysql MySQL5
54
55# From the manual
56%description
57MariaDB: a very fast and robust SQL database server
58
59It is GPL v2 licensed, which means you can use the it free of charge under the
60conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
61
62MariaDB documentation can be found at http://kb.askmonty.org/
63MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
64
65
66%package server
67Version:        %{mariadb_version}
68Release:        %{release}
69Summary:        MariaDB: a very fast and robust SQL database server
70Group:          Applications/Databases
71Requires:       fileutils sh-utils net-tools mariadb-common
72Requires(post): mariadb-common
73Provides:       mysql-server mysql MySQL MySQL-server mariadbserver-%{mariadb_base_version}
74Obsoletes:      MySQL mysql mysql-server
75Obsoletes:      MySQL-server < 5.6.0
76
77%description server
78MariaDB: a very fast and robust SQL database server
79
80It is GPL v2 licensed, which means you can use the it free of charge under the
81conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
82
83MariaDB documentation can be found at http://kb.askmonty.org/
84MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
85
86%package mroonga
87##Version: %{mroonga_version}
88Version:        %{mariadb_version}
89Summary:        A fast fulltext searchable storage engine for MariaDB.
90Group:          Applications/Databases
91Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
92Requires:       mariadb-server = %{mariadb_version}-%{release}
93Obsoletes:      MySQL-mroonga < 4.02
94Obsoletes:      mariadb-mroonga < 4.07
95Obsoletes:      mariadb-mroonga-doc < 4.07
96
97%description mroonga
98Mroonga is a fast fulltext searchable storage plugin for MariaDB.
99It is based on groonga that is a fast fulltext search engine and
100column store. Groonga is good at real-time update.
101
102%package connect
103Version:        %{mariadb_version}
104Summary:        CONNECT storage engine for MariaDB.
105Group:          Applications/Databases
106Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
107Requires:       mariadb-server = %{mariadb_version}-%{release}
108
109%description connect
110The CONNECT storage engine enables MariaDB to access external
111local or remote data (MED). This is done by defining tables
112based on different data types, in particular files in various
113formats, data extracted from other DBMS or products (such as Excel)
114via ODBC, or data retrieved from the environment (for example
115DIR, WMI, and MAC tables).
116
117This storage engine supports table partitioning, MariaDB virtual
118columns and also permits defining special columns such as ROWID,
119FILEID, and SERVID.
120
121%ifarch x86_64
122%package tokudb
123Version:        %{mariadb_version}
124Summary:        TokuDB storage engine for MariaDB.
125Group:          Applications/Databases
126Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
127Requires:       mariadb-server = %{mariadb_version}-%{release}
128
129%description tokudb
130The TokuDB storage engine is for use in high-performance and
131write-intensive environments, offering increased compression and
132better performance.
133
134%endif
135
136%package client
137Version:        %{mariadb_version}
138Summary: MariaDB - Client
139Group: Applications/Databases
140Obsoletes: mysql-client MySQL-client < 5.6.0
141Provides: mysql-client MySQL-client  mariadbclient-%{mariadb_base_version}
142
143%description client
144This package contains the standard MariaDB clients and administration tools.
145
146
147%package devel
148Version:        %{mariadb_version}
149Summary: MariaDB - Development libraries and headers
150Group: Development/Libraries
151Requires: %{name}-static, openssl-devel, zlib-devel
152Conflicts: MySQL-devel < 5.6.0
153Conflicts: libmysqlclient-devel
154
155%description devel
156This package contains the development libraries and headers to develop
157MariaDB server components (e.g. plugins or embedded applications).
158
159
160%package static
161Version:        %{mariadb_version}
162Summary: MariaDB - static libraries
163Group: Development/Libraries
164Requires: %{name}-devel
165
166%description static
167This package provides static libraries of MariaDB.
168
169%if %{with source}
170%package source
171Version:        %{mariadb_version}
172Summary: MariaDB - Source
173Group: Development/Libraries
174Requires: mariadb-devel = %{version}-%{release}
175Obsoletes: MySQL-source < 5.6.0
176AutoReqProv: no
177
178%description source
179This package contains the sources files of MariaDB.
180
181%endif
182
183%package test
184Version:        %{mariadb_version}
185Requires: %{name}-client = %{version}-%{release} perl-DBI perl
186Summary: MariaDB - Test suite
187Group: Applications/Databases
188Obsoletes: mysql-bench MySQL5-bench MySQL-bench MySQL-test < 5.6.0
189Provides: perl(mtr_misc.pl)
190
191%description test
192This package contains the MariaDB regression test suite.
193
194
195%package embedded
196Version:        %{mariadb_version}
197Summary: MariaDB as an embeddable library
198Group: System Environment/Libraries
199Obsoletes: mysql-embedded MySQL-embedded
200Provides: mysql-embedded MySQL-embedded
201
202%description embedded
203This package contains a version of the MariaDB server that can be embedded
204into a client application instead of running as a separate process.
205
206
207%prep
208%setup -q
209%patch1000 -p1 -b .mroonga
210#%patch2000 -p1 -b .srv_buf_size
211
212%build
213
214# Be strict about variables, bail at earliest opportunity, etc.
215set -eu
216
217# Optional package files
218touch optional-files-devel
219
220export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
221export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
222
223# Build full release
224mkdir release
225(
226  cd release
227  cmake ../ \
228      -DINSTALL_LAYOUT=RPM \
229      -DBUILD_CONFIG=mysql_release \
230      -DCMAKE_BUILD_TYPE=Release \
231      -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
232      -DCOMPILATION_COMMENT="Vine Linux MariaDB RPM" \
233      -DWITH_PIC="ON" \
234      -DWITH_EMBEDDED_SERVER="ON" \
235      -DWITH_ZLIB="system" \
236      -DWITH_LOCALES="yes" \
237      -DWITH_UNIT_TESTS="no" \
238      -DWITH_SEQUENCE_STORAGE_ENGINE="ON" \
239      -DWITH_XTRADB_STORAGE_ENGINE="ON" \
240      -DWITH_JEMALLOC="yes" \
241      -DGRN_WITH_MECAB="yes" \
242      -DGRN_WITH_ONIGMO="no"
243
244#      -DWITHOUT_TOKUDB="yes"
245#      -DWITH_PCRE="system"
246
247  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
248  make %{?_smp_mflags} VERBOSE=1
249)
250
251
252%install
253rm -rf %{buildroot}
254
255install -d %{buildroot}%{mysqldatadir}/mysql
256install -d %{buildroot}%{_infodir}
257
258# Install all binaries
259(
260  cd release
261  make DESTDIR=%{buildroot} install
262)
263
264install -m 0644  Docs/mysql.info %{buildroot}%{_infodir}
265rm -rf ./doc
266mv -f %{buildroot}%{_docdir} ./
267
268mv -f %{buildroot}%{_datadir}/groonga ./
269
270%if %{with source}
271mkdir -p %{buildroot}%{_datadir}/%{name}-source
272pushd %{buildroot}%{_datadir}/%{name}-source
273tar zxf %{SOURCE0}
274find %{buildroot}%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
275popd
276%endif
277
278install -d %{buildroot}%{_sysconfdir}/rpm
279sed -e 's/@BASEVERSION@/%{mariadb_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > %{buildroot}%{_sysconfdir}/rpm/macros.mariadb
280
281rm -f %{buildroot}%{_mandir}/man1/mysql_fix_privilege_tables.1*
282rm -f %{buildroot}%{_mandir}/man8/mysqlmanager.8*
283rm -f %{buildroot}%{_sysconfdir}/my.cnf
284rm -f %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
285rm -f %{buildroot}%{_libdir}/libmysqlclient*.so*
286rm -f %{buildroot}%{_libdir}/mysql/plugin/daemon_example.ini
287
288# force linking statically.
289perl -pi -e 's,-lmysqlclient_r,%{_libdir}/libmysqlclient_r.a,' %{buildroot}%{_bindir}/mysql_config
290perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_bindir}/mysql_config
291
292perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_datadir}/pkgconfig/mariadb.pc
293
294##############################################################################
295
296%pre server
297# Create a MySQL user and group. Do not report any problems if it already
298# exists.
299datadir=/var/lib/mysql
300
301groupadd -r mysql 2> /dev/null || true
302useradd -M -r -d $datadir -s /bin/bash -c "MySQL server" -g mysql mysql 2> /dev/null || true
303# The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
304usermod -g mysql mysql 2> /dev/null || true
305
306%post server
307
308# Make MySQL start/shutdown automatically when the machine does it.
309if [ $1 = 1 ] ; then
310  if [ -x /sbin/chkconfig ] ; then
311          /sbin/chkconfig --add mysql
312  fi
313
314  basedir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--basedir=//p'|tail -1`
315  if [ -z "$basedir" ] ; then
316    basedir=/usr
317  fi
318
319  datadir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
320  if [ -z "$datadir" ] ; then
321    datadir=/var/lib/mysql
322  else
323    # datadir may be relative to a basedir!
324    if ! expr $datadir : / > /dev/null; then
325      datadir=$basedir/$datadir
326    fi
327  fi
328
329  tmpdir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
330  if [ -z "$datadir" ] ; then
331    datadir=/var/lib/mysql
332  else
333    # datadir may be relative to a basedir!
334    if ! expr $datadir : / > /dev/null; then
335      datadir=$basedir/$datadir
336    fi
337  fi
338
339  # Change permissions so that the user that will run the MySQL daemon
340  # owns all database files.
341  chown -R mysql:mysql $datadir
342
343  if [ ! -e $datadir/mysql ]; then
344    # Create data directory
345    mkdir -p $datadir/{mysql,test}
346    chown -R mysql:mysql $datadir
347
348    # Initiate databases
349    /usr/bin/mysql_install_db --rpm --user=mysql
350  fi
351
352  # Change permissions again to fix any new files.
353  chown -R mysql:mysql $datadir
354
355  # Fix permissions for the permission database so that only the user
356  # can read them.
357  chmod -R og-rw $datadir/mysql
358fi
359
360%preun server
361if [ $1 = 0 ] ; then
362        # Stop MySQL before uninstalling it
363        if [ -x /etc/init.d/mysql ] ; then
364                /etc/init.d/mysql stop > /dev/null
365        fi
366        # Don't start it automatically anymore
367        if [ -x /sbin/chkconfig ] ; then
368                /sbin/chkconfig --del mysql
369        fi
370fi
371
372%postun server
373if [ $1 -ge 1 ]; then
374  if [ -x /etc/init.d/mysql ] ; then
375    # only restart the server if it was alredy running
376    /etc/init.d/mysql status > /dev/null 2>&1 && \
377    /etc/init.d/mysql restart
378  fi
379fi
380
381%pre mroonga
382if [ $1 -gt 1 ]; then
383/usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql || cat <<EOF
384An error occured when to unregister plugin.
385Please run a command below:
386
387  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql
388
389EOF
390
391fi
392
393%post mroonga
394if [ $1 -eq 1 ] ; then
395        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
396An error occured when to register plugin.
397Please run a command below:
398
399  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
400
401EOF
402fi
403
404%postun mroonga
405if [ $1 -gt 0 ] ; then
406        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
407An error occured when to register plugin.
408Please run a command below:
409
410  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
411
412EOF
413fi
414
415# Clean up the BuildRoot
416%clean
417[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
418
419%files server
420%defattr(-,root,root)
421
422%doc doc/*
423%doc release/support-files/my-*.cnf
424%doc %{_infodir}/mysql.info*
425
426%doc %{_mandir}/man1/aria_*.1*
427%doc %{_mandir}/man1/innochecksum.1*
428%doc %{_mandir}/man1/my_print_defaults.1*
429%doc %{_mandir}/man1/myisam_ftdump.1*
430%doc %{_mandir}/man1/myisamchk.1*
431%doc %{_mandir}/man1/myisamlog.1*
432%doc %{_mandir}/man1/myisampack.1*
433%doc %{_mandir}/man1/mysql_convert_table_format.1*
434%doc %{_mandir}/man1/mysql_fix_extensions.1*
435%doc %{_mandir}/man8/mysqld.8*
436%doc %{_mandir}/man1/mysqld_multi.1*
437%doc %{_mandir}/man1/mysqld_safe.1*
438%doc %{_mandir}/man1/mysqldumpslow.1*
439%doc %{_mandir}/man1/mysql_install_db.1*
440%doc %{_mandir}/man1/mysql_plugin.1*
441%doc %{_mandir}/man1/mysql_secure_installation.1*
442%doc %{_mandir}/man1/mysql_setpermission.1*
443%doc %{_mandir}/man1/mysql_upgrade.1*
444%doc %{_mandir}/man1/mysqlhotcopy.1*
445%doc %{_mandir}/man1/mysql.server.1*
446%doc %{_mandir}/man1/mysqltest.1*
447%doc %{_mandir}/man1/mysql_tzinfo_to_sql.1*
448%doc %{_mandir}/man1/mysql_zap.1*
449%doc %{_mandir}/man1/mysqlbug.1*
450%doc %{_mandir}/man1/perror.1*
451%doc %{_mandir}/man1/replace.1*
452%doc %{_mandir}/man1/resolve_stack_dump.1*
453%doc %{_mandir}/man1/resolveip.1*
454%{_bindir}/aria_*
455%{_bindir}/innochecksum
456%{_bindir}/my_print_defaults
457%{_bindir}/myisam_ftdump
458%{_bindir}/myisamchk
459%{_bindir}/myisamlog
460%{_bindir}/myisampack
461%{_bindir}/mysql_convert_table_format
462%{_bindir}/mysql_fix_extensions
463%{_bindir}/mysql_install_db
464%{_bindir}/mysql_plugin
465%{_bindir}/mysql_secure_installation
466%{_bindir}/mysql_setpermission
467%{_bindir}/mysql_tzinfo_to_sql
468%{_bindir}/mysql_upgrade
469%{_bindir}/mysql_zap
470%{_bindir}/mysqlbug
471%{_bindir}/mysqld_multi
472%{_bindir}/mysqld_safe
473%{_bindir}/mysqldumpslow
474%{_bindir}/mysqlhotcopy
475%{_bindir}/mysqltest
476%{_bindir}/perror
477%{_bindir}/replace
478%{_bindir}/resolve_stack_dump
479%{_bindir}/resolveip
480%{_bindir}/wsrep*
481%{_sbindir}/mysqld
482%{_sbindir}/rcmysql
483%exclude %{_libdir}/mysql/plugin/ha_connect.so
484%exclude %{_libdir}/mysql/plugin/ha_mroonga.so
485%ifarch x86_64
486%exclude %{_libdir}/mysql/plugin/ha_tokudb.so
487%endif
488%exclude %{_datadir}/mysql/mroonga
489%{_libdir}/mysql
490%config(noreplace) %{_sysconfdir}/my.cnf.d/enable_encryption.preset
491%config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
492%ifarch x86_64
493%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
494%endif
495%config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
496%{_sysconfdir}/init.d/mysql
497%{_datadir}/mysql
498%attr(755, mysql, mysql) %dir %{mysqldatadir}
499
500%files mroonga
501%defattr(-, root, root)
502%doc groonga
503%{_libdir}/mysql/plugin/ha_mroonga.so
504%{_datadir}/mysql/mroonga
505
506%files connect
507%defattr(-, root, root)
508%{_libdir}/mysql/plugin/ha_connect.so
509
510%ifarch x86_64
511%files tokudb
512%defattr(-, root, root)
513%{_libdir}/mysql/plugin/ha_tokudb.so
514%{_bindir}/tokuft*
515%endif
516
517%files client
518%defattr(-, root, root)
519%config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
520%{_bindir}/msql2mysql
521%{_bindir}/mysql
522%{_bindir}/mysql_find_rows
523%{_bindir}/mysql_waitpid
524%{_bindir}/mysqlaccess
525%{_bindir}/mysqladmin
526%{_bindir}/mysqlbinlog
527%{_bindir}/mysqlcheck
528%{_bindir}/mysqldump
529%{_bindir}/mysqlimport
530%{_bindir}/mysqlshow
531%{_bindir}/mysqlslap
532%{_bindir}/mytop
533
534%doc %{_mandir}/man1/msql2mysql.1*
535%doc %{_mandir}/man1/mysql.1*
536%doc %{_mandir}/man1/mysql_find_rows.1*
537%doc %{_mandir}/man1/mysql_waitpid.1*
538%doc %{_mandir}/man1/mysqlaccess.1*
539%doc %{_mandir}/man1/mysqladmin.1*
540%doc %{_mandir}/man1/mysqlbinlog.1*
541%doc %{_mandir}/man1/mysqlcheck.1*
542%doc %{_mandir}/man1/mysqldump.1*
543%doc %{_mandir}/man1/mysqlimport.1*
544%doc %{_mandir}/man1/mysqlshow.1*
545%doc %{_mandir}/man1/mysqlslap.1*
546
547%files devel -f optional-files-devel
548%defattr(-, root, root)
549%doc %{_mandir}/man1/mysql_config.1*
550%{_bindir}/mysql_config
551%{_includedir}/mysql
552%{_datadir}/aclocal/mysql.m4
553%{_datadir}/pkgconfig/mariadb.pc
554%{_libdir}/*.so
555%{_sysconfdir}/rpm/*
556%{_bindir}/mysql_embedded
557
558%files static
559%defattr(-,root,root)
560%{_libdir}/lib*.a
561
562%if %{with source}
563%files source
564%defattr(-, root, root)
565%{_datadir}/mariadb-source
566%endif
567
568%files test
569%defattr(-, root, root)
570%attr(-, root, root) %{_datadir}/mysql-test
571%{_bindir}/mysql_client_test
572%{_bindir}/mysql_client_test_embedded
573%{_bindir}/mysqltest_embedded
574%doc %{_mandir}/man1/mysql_client_test.1*
575%doc %{_mandir}/man1/mysql-stress-test.pl.1*
576%doc %{_mandir}/man1/mysql-test-run.pl.1*
577%doc %{_mandir}/man1/mysql_client_test_embedded.1*
578%doc %{_mandir}/man1/mysqltest_embedded.1*
579
580%files embedded
581%defattr(-,root,root)
582%{_libdir}/libmysqld.so.*
583
584
585%changelog
586* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.12-1
587- new upstream release.
588- replaced patch1000 to update Mroonga to git HEAD.
589
590* Sat Jan 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.11-1
591- new upstream release.
592- replaced patch1000 to update Mroonga to v5.12.
593
594* Fri Jan  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.10-1
595- new upstream release.
596- replaced patch1000 to update Mroonga to v5.11.
597- moved CONNECT and TokuDB storage engines to subpackages.
598
599* Sun Nov 29 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-4
600- replaced patch1000 to update Mroonga to git HEAD.
601
602* Sat Nov 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-3
603- replaced patch1000 to update Mroonga to git HEAD.
604
605* Thu Nov 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-2
606- replaced patch1000 to update Mroonga to git HEAD.
607
608* Tue Nov 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-1
609- new upstream release.
610- replaced patch1000 to update Mroonga to git HEAD.
611
612* Fri Oct 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-3
613- added BR:jemalloc-devel.
614
615* Thu Oct 29 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-2
616- replaced patch1000 to update Mroonga to 5.09.
617
618* Wed Oct 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.8-1
619- new upstream release.
620- replaced patch1000 for MariaDB 10.1.8.
621
622* Fri Oct  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-3
623- replaced patch1000 to update Mroonga to 5.08.
624
625* Mon Aug 31 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-2
626- replaced patch1000 to update Mroonga to 5.06.
627
628* Mon Aug 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-1
629- new upstream release.
630- added patch1000 to update Mroonga from 5.02 to 5.05.
631
632* Tue Jun 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-2
633- fixed dependencies.
634
635* Fri Jun 19 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-1
636- new upstream release.
637
638* Sun May 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.19-1
639- new upstream release.
640
641* Fri May  8 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.18-1
642- new upstream release.
643
644* Tue Mar  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.17-1
645- new upstream release.
646
647* Wed Jan 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.16-1
648- new upstream release.
649
650* Wed Nov 26 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.15-1
651- new upstream release.
652- enabled bundled Mroonga.
653
654* Mon Sep 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.14-1
655- new upstream release.
656
657* Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
658- new upstream release.
659
660* Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
661- fixed Conflicts: and Obsoletes:.
662
663* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
664- new upstream release.
665
666* Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
667- new upstream release.
668
669* Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
670- new upstream release.
671
672* Sat Dec 07 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-2
673- removed duplicated files.
674
675* Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
676- switched to MariaDB.
677
678* Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
679- new upstream release.
680
681* Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
682- new upstream release.
683
684* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
685- new upstream release.
686- added a sub-package 'MySQL-source".
687- added some macros for rpm.
688
689* Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
690- new upstream release.
691
692* Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
693- new upstream release.
694
695* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
696- new upstream release.
697- added "Vendor:" and "Distribution:" tag.
698
699* Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
700- new upstream release.
701- removed NDB cluster support.
702
703* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
704- Added "BR: zlib-devel" to MySQL-devel.
705
706* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
707- Added "BR: openssl-devel" to MySQL-devel.
708
709* Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
710- new upstream release.
711
712* Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
713- new upstream release.
714- updated jp-patch.
715- added ssl support.
716
717* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
718- new upstream release.
719- replaced '%%__find_requires' to '%%__perl_requires'.
720- updated jp-patch.
721
722* Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
723- added mysql-5.1.44-lib64.patch (on x86_64)
724- added -fPIC (on x86_64)
725
726* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
727- made embedded package again
728
729* Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
730- new upstream release.
731- updated jp-patch.
732
733* Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
734- VineSeed: rebuilt with new toolchain.
735
736* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
737- new upstream release.
738  - fixed CVE-2009-4484.
739
740* Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
741- new upstream release.
742
743* Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
744- added net-tools to 'Requires'.
745- added groff to 'BuildRequires'.
746- renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
747
748* Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
749- new upstream release.
750
751* Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
752- new upstream release.
753
754* Sun Jul  5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
755- new upstream release.
756- dropped %%Patch100 (fixed in upstream).
757
758* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
759- new upstream release.
760- add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
761
762* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
763- new upstream release.
764- rename 'MySQL-bench' to 'MySQL-test'.
765- update Patch0.
766- change default charset to 'utf8'.
767
768* Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
769- new upstream release.
770- update Patch0.
771- add "--with-client-charset=ujis".
772- sync %%files to official RPM.
773- remove MySQL-Max.
774
775* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
776- for VineSeed
777
778* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
779- move shared library from /usr/lib/ to /usr/lib/mysql/
780- add /etc/ld.so.conf.d/*.conf
781- fix broken libmysqlcient*.la files (or should we remove them permanently?)
782
783* Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
784- rebuild <BTS:VineLinux:534>
785
786* Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
787- added -fPIC
788
789* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
790- fixed dependency. <BTS:338>
791
792* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
793- add %%Patch1. <BTS:320>
794
795* Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
796- new upstream release.
797
798* Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
799- new upstream release.
800
801* Sat Jun  3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
802- new upstream release.
803
804* Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
805- release++.
806
807* Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
808- new upstream release.
809- for VineSeed.
810
811* Wed Feb  8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
812- new upstream release.
813- replace Patch0 for MySQL-4.1.16.
814
815* Thu Oct  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
816- new upstream release.
817- add Patch0.
818
819* Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
820- new upstream version
821        -- mysql-4.0.25
822
823* Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
824- new upstream version
825        -- mysql-4.0.23
826
827* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
828- new upstream version
829        -- mysql-4.0.22
830 
831* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
832- new upstream version
833        -- mysql-4.0.21
834 
835* Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
836- new upstream version
837        -- mysql-4.0.20
838 
839* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
840- modify CFLAGS, CXXFLAGS and configure options for alpha
841
842* Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
843- Upgraded to MySQL-4
844- added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
845- merged to MySQL Official packages
846        -- renamed package "MySQL" to "MySQL-server"
847        -- when using gcc, _always_ use CXX=gcc
848        -- replaced Copyright with License field (Copyright is obsolete)
849        -- added myisam_ftdump to the Server package
850        -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
851        -- fixed file permissions (BUG 1672)
852        -- removed dependency on MySQL-client from the MySQL-devel subpackage
853        -- as it is not really required. (BUG 1610)
854        -- Fixed BUG 1162 (removed macro names from the changelog)
855        -- Really fixed BUG 998 (disable the checking for installed but
856        --  unpackaged files)
857        -- Fixed BUG 959 (libmysqld not being compiled properly)
858        -- Fixed BUG 998 (RPM build errors): added missing files to the
859        -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
860        -- mysql_fix_privilege_tables.1), removed "-n" from install section.
861        -- removed the GIF Icon (file was not included in the sources anyway)
862        -- removed unused variable shared_lib_version
863        -- do not run automake before building the standard binary
864        --  (should not be necessary)
865        -- add server suffix '-standard' to standard binary (to be in line
866        -- with the binary tarball distributions)
867        -- allow overriding CC and CXX (required when building
868        -- with other compilers)
869
870* Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
871- added BuildRequires:  automake16
872                                                                               
873* Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
874- add '-fPIC -DPIC' to CFLAGS on alpha
875- little fix of spec file
876                                                                               
877* Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
878- enable MySQL-shared subpackage for alpha
879- delete 'BuildPrereq: kernel24-headers' for alpha
880- fix shared %files (exclude sparc)
881                                                                               
882* Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
883- new upstream version
884                                                                               
885* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
886- fixed devel %files (dropped *.la files)
887                                                                               
888* Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
889- new upstream version
890- fixed document permission
891                                                                               
892* Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
893- new upstream version
894                                                                               
895* Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
896- dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
897        -- don't work
898                                                                               
899* Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
900- new upstream version
901- diseble-assembler in configure on sparc,sparc64,alpha
902                                                                               
903* Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
904- new upstream version
905- moved some man files to main package
906- added enable-local-infile in configure
907- changed --with-extra-charsets=all in configure
908                                                                               
909* Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
910- fixed changelog
911                                                                               
912* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
913- updated to mysql-3.23.51
914                                                                               
915* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
916- rebuild on zlib-1.1.4(security fix.)
917                                                                               
918* Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
919- updated to mysql-2.23.49
920                                                                               
921* Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
922- add 'BuildPrereq: kernel24-headers' on alpha
923- remove shared library and max on alpha
924                                                                               
925* Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
926- updated to mysql-3.23.48
927                                                                               
928* Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
929- updated to mysql-3.23.47
930                                                                               
931* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
932- updated to mysql-3.23.46
933                                                                               
934* Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
935- updated to mysql-3.23.45
936                                                                               
937* Mon Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
938- updated to mysql-3.23.44
939                                                                               
940* Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
941- updated to mysql-3.23.43
942- removed shared library and max on sparc
943                                                                               
944* Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
945- updated to mysql-3.23.42
946- changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
947                                                                               
948* Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
949- updated to mysql-3.23.41
950                                                                               
951* Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
952- updated to mysql-3.23.40
953                                                                               
954* Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
955- updated to mysql-3.23.39
956
957* Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
958- added configure --with-charset=ujis
959                                                                               
960* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
961- used some rpmmacro
962                                                                               
963* Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
964- updated to MySQL-3.23.38
965                                                                               
966* Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
967- removed Bench pakages
968                                                                               
969* Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
970- removed pt_BR locale
971- build on Vine Linux
972- partially used rpmmacros
973- added %clean tag
974                                                                               
975* Fri Aug 18 2000 Tim Smith <tim@mysql.com>
976- Added separate libmysql_r directory; now both a threaded
977  and non-threaded library is shipped.
978                                                                               
979* Tue Sep 28 1999 David Axmark <davida@mysql.com>
980- Added the support-files/my-example.cnf to the docs directory.
981- Removed devel dependency on base since it is about client
982  development.
983                                                                               
984* Wed Sep 8 1999 David Axmark <davida@mysql.com>
985- Cleaned up some for 3.23.
986                                                                               
987* Thu Jul 1 1999 David Axmark <davida@mysql.com>
988- Added support for shared libraries in a separate sub
989  package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
990- The --enable-assembler switch is now automatically disables on
991  platforms there assembler code is unavailable. This should allow
992  building this RPM on non i386 systems.
993                                                                               
994* Mon Feb 22 1999 David Axmark <david@detron.se>
995- Removed unportable cc switches from the spec file. The defaults can
996  now be overridden with environment variables. This feature is used
997  to compile the official RPM with optimal (but compiler version
998  specific) switches.
999- Removed the repetitive description parts for the sub rpms. Maybe add
1000  again if RPM gets a multiline macro capability.
1001- Added support for a pt_BR translation. Translation contributed by
1002  Jorge Godoy <jorge@bestway.com.br>.
1003                                                                               
1004* Wed Nov 4 1998 David Axmark <david@detron.se>
1005- A lot of changes in all the rpm and install scripts. This may even
1006  be a working RPM :-)
1007                                                                               
1008* Sun Aug 16 1998 David Axmark <david@detron.se>
1009- A developers changelog for MySQL is available in the source RPM. And
1010  there is a history of major user visible changed in the Reference
1011  Manual.  Only RPM specific changes will be documented here.
1012
Note: See TracBrowser for help on using the repository browser.