source: projects/specs/trunk/m/man/man-vl.spec @ 2401

Revision 2401, 15.5 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild vine5.2 packages

Line 
1%define  _mandir                %{_datadir}/man
2
3Summary:      A set of documentation tools:  man, apropos and whatis.
4Summary(ja):  ドキュメンテーション・ツール: man, apropos, whatis
5
6Name:         man
7Version:      1.5o
8Release:      6%{?_dist_release}
9
10Group:        System Environment/Base
11License:      GPLv2
12
13Source0:      http://www.kernel.org/pub/linux/utils/man/man-%{version}.tar.bz2
14Source1:      makewhatis.cronweekly
15Source2:      makewhatis.crondaily
16Patch1:       man-1.5m2-confpath.patch
17Patch5:       man-1.5i-nonascii.patch
18Patch6:       man-1.5m2-security.patch
19Patch7:       man-1.5m2-mandirs.patch
20Patch8:       man-1.5h1-bug11621.patch
21Patch9:       man-1.5m2-sofix.patch
22Patch10:      man-1.5m2-buildroot.patch
23Patch12:      man-1.5m2-ro-usr.patch
24Patch15:      man-1.5h1-lookon.patch
25Patch17:      man-1.5m2-utf8.patch
26
27# Vine Source(s)/Patch(es)
28Patch101:     man-1.5h1-gencat.patch
29Patch106:     man-man2html_aux_path.patch
30Patch107:     man-1.5m2-hman-use-w3m.patch
31Patch108:     man-1.5m2-no-mansearch.patch
32Patch110:     man-1.5o-tmpcache.patch
33Patch120:     man-1.5o-convert-manpage-to-utf8.patch
34Patch130:     man-1.5o-utf8-msgs.patch
35Patch140:     man-1.5o-utf8-makewhatis.patch
36
37Buildroot:    %{_tmppath}/%{name}-%{version}-root
38BuildRequires: bzip2
39BuildRequires: gzip
40Requires:      bzip2
41Requires:      coreutils
42Requires:      findutils
43Requires:      gawk
44Requires:      grep
45Requires:      groff
46Requires:      gzip
47Requires:      nkf
48# pager
49%if %{?_dist_release} == "vl5"
50Requires:      lv
51%else
52Requires:      less
53%endif
54Requires(post): coreutils
55
56Vendor:       Project Vine
57Distribution: Vine Linux
58Packager:     shaolin, daisuke
59
60
61%description
62The man package includes three tools for finding information and/or
63documentation about your Linux system: man, apropos and whatis.  The
64man system formats and displays on-line manual pages about commands or
65functions on your system.  Apropos searches the whatis database
66(containing short descriptions of system commands) for a string.
67Whatis searches its own database for a complete word.
68
69The man package should be installed on your system because it is the
70primary way to find documentation on a Linux system.
71
72%description -l ja
73マニュアルページを表示するためのプログラム man の日本語対応版です.
74日本語対応の groff パッケージが必要です.特定のキーワードに関連する文書
75を探すための whatis や apropos も含んでいます.
76環境変数 LANG=ja_JP.* の時には、
77
78    1.JMANプロジェクトまたはオリジナルソースに付随する日本語マニュアル
79    2.オリジナル・ソースに付随する英語マニュアル
80
81という順でマニュアルの検索がなされます.英語マニュアルを見る場合は、
82LANG=C man などとして利用してください.
83
84%package -n man2html
85Summary:        manroff to HTML converter
86Summary(ja):    manroff から HTML への変換器
87Group:          Applications/System
88Requires:       %{name} = %{version}-%{release}
89
90%description -n man2html
91This package contains manroff to HTML converter.
92
93%description -n man2html -l ja
94このパッケージには、manroff から HTML へのコンバータが含まれています.
95
96%prep
97%setup -q
98%patch1 -p1 -b .confpath
99%patch6 -p1 -b .security
100%patch7 -p1 -b .mandirs
101%patch9 -p1 -b .sofix
102%patch10 -p1 -b .less
103%patch12 -p1 -b .usr
104
105%patch101 -p1
106
107%patch17 -p1 -b .utf8
108
109%patch106 -p1 -b .aux
110%patch107 -p1 -b .w3m
111%if ! 0%{?mansearch}
112%patch108 -p1 -b .search
113%endif
114%patch110 -p1 -b .tmpcache
115%patch120 -p1 -b .convert-man-to-utf8
116%patch130 -p1 -b .utf8-msgs
117%patch140 -p1 -b .utf8-makewhatis
118
119pushd msgs
120%__mv mess.ja mess.ja_JP.eucJP
121%__mv mess.ja.codeset mess.ja_JP.eucJP.codeset
122iconv -f euc-jp -t utf-8 mess.ja_JP.eucJP > mess.ja
123echo "$ codeset=utf-8" > mess.ja.codeset
124popd
125
126%build
127./configure -default +fhs +lang en,ja,ja_JP.eucJP -confdir %{_sysconfdir}
128make CC="gcc $RPM_OPT_FLAGS -D_GNU_SOURCE"
129
130pushd src
131mv man.conf man.conf.orig
132%if %{?_dist_release} == "vl5"
133sed -e 's/less -is/lv -c/g' man.conf.orig > man.conf
134%else
135sed -e 's/less -is/less -isMr/g' man.conf.orig > man.conf
136%endif
137popd
138
139%install
140rm -rf $RPM_BUILD_ROOT
141mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/cron.{daily,weekly}
142make install PREFIX=$RPM_BUILD_ROOT
143%__mv $RPM_BUILD_ROOT%{_mandir}/man5/man.conf.5 $RPM_BUILD_ROOT%{_mandir}/man5/man.config.5
144%__mv $RPM_BUILD_ROOT%{_mandir}/ja/man5/man.conf.5 $RPM_BUILD_ROOT%{_mandir}/ja/man5/man.config.5
145
146install -m755 %{_sourcedir}/makewhatis.cronweekly $RPM_BUILD_ROOT%{_sysconfdir}/cron.weekly/makewhatis.cron
147install -m755 %{_sourcedir}/makewhatis.crondaily $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/makewhatis.cron
148
149mkdir -p $RPM_BUILD_ROOT/var/cache
150mkdir -p $RPM_BUILD_ROOT/var/cache/man/local
151mkdir -p $RPM_BUILD_ROOT/var/cache/man/X11R6
152
153mkdir -p $RPM_BUILD_ROOT/var/cache/ja
154mkdir -p $RPM_BUILD_ROOT/var/cache/man/local/ja
155mkdir -p $RPM_BUILD_ROOT/var/cache/man/X11R6/ja
156for i in 1 2 3 4 5 6 7 8 9 n; do
157        mkdir -p $RPM_BUILD_ROOT/var/cache/man/cat$i
158        mkdir -p $RPM_BUILD_ROOT/var/cache/man/local/cat$i
159        mkdir -p $RPM_BUILD_ROOT/var/cache/man/X11R6/cat$i
160
161        mkdir -p $RPM_BUILD_ROOT/var/cache/man/ja/cat$i
162        mkdir -p $RPM_BUILD_ROOT/var/cache/man/local/ja/cat$i
163        mkdir -p $RPM_BUILD_ROOT/var/cache/man/X11R6/ja/cat$i
164done
165
166# added man2html stuff
167cd man2html
168make install PREFIX=$RPM_BUILD_ROOT
169
170# symlinks for manpath
171( cd $RPM_BUILD_ROOT
172  ln -s man ./usr/bin/manpath
173  ln -s man.1.gz .%{_mandir}/man1/manpath.1.gz
174  ln -s man.1.gz .%{_mandir}/ja/man1/manpath.1.gz
175)
176
177# symlinks for compatibility
178ln -s man $RPM_BUILD_ROOT/usr/bin/jman
179
180%preun
181# Clean up accumulated cat litter.
182rm -f /var/cache/man/cat[123456789n]/*
183rm -f /var/cache/man/local/cat[123456789n]/*
184rm -f /var/cache/man/X11R6/cat[123456789n]/*
185
186rm -f /var/cache/man/ja/cat[123456789n]/*
187rm -f /var/cache/man/local/ja/cat[123456789n]/*
188rm -f /var/cache/man/X11R6/ja/cat[123456789n]/*
189
190
191%post
192rm -f /var/cache/man/cat[123456789n]/*
193rm -f /var/cache/man/local/cat[123456789n]/*
194rm -f /var/cache/man/X11R6/cat[123456789n]/*
195
196rm -f /var/cache/man/ja/cat[123456789n]/*
197rm -f /var/cache/man/local/ja/cat[123456789n]/*
198rm -f /var/cache/man/X11R6/ja/cat[123456789n]/*
199
200
201%clean
202rm -rf $RPM_BUILD_ROOT
203
204
205%files
206%defattr(-,root,root)
207%doc README* COPYING HISTORY INSTALL LSM TODO
208%config(noreplace) %{_sysconfdir}/cron.weekly/makewhatis.cron
209%config(noreplace) %{_sysconfdir}/cron.daily/makewhatis.cron
210%attr(2755,root,man)    /usr/bin/man
211/usr/bin/jman
212/usr/bin/manpath
213/usr/bin/apropos
214/usr/bin/whatis
215/usr/sbin/makewhatis
216%config(noreplace) %{_sysconfdir}/man.config
217#%config(noreplace) %{_sysconfdir}/man-j.config
218%{_mandir}/man1/man.1*
219%{_mandir}/man1/manpath.1*
220%{_mandir}/man1/apropos.1*
221%{_mandir}/man1/whatis.1*
222%{_mandir}/man5/man.config.5*
223%{_mandir}/man8/makewhatis.8*
224%{_mandir}/ja/man1/man.1*
225%{_mandir}/ja/man1/manpath.1*
226%{_mandir}/ja/man1/apropos.1*
227%{_mandir}/ja/man1/whatis.1*
228%{_mandir}/ja/man5/man.config.5*
229
230/usr/share/locale/*/man
231
232%attr(0775,root,man)    %dir /var/cache/man
233%attr(0775,root,man)    %dir /var/cache/man/cat[123456789n]
234%attr(0775,root,man)    %dir /var/cache/man/local
235%attr(0775,root,man)    %dir /var/cache/man/local/cat[123456789n]
236%attr(0775,root,man)    %dir /var/cache/man/X11R6
237%attr(0775,root,man)    %dir /var/cache/man/X11R6/cat[123456789n]
238
239%attr(0775,root,man)    %dir /var/cache/man/ja
240%attr(0775,root,man)    %dir /var/cache/man/ja/cat[123456789n]
241%attr(0775,root,man)    %dir /var/cache/man/local/ja
242%attr(0775,root,man)    %dir /var/cache/man/local/ja/cat[123456789n]
243%attr(0775,root,man)    %dir /var/cache/man/X11R6/ja
244%attr(0775,root,man)    %dir /var/cache/man/X11R6/ja/cat[123456789n]
245
246%files -n man2html
247%defattr(-,root,root)
248%doc man2html/README man2html/TODO
249/usr/bin/man2html
250%{_mandir}/man1/man2html.1*
251
252%if 0%{?mansearch}
253/home/httpd/cgi-bin/man/mansearch
254/home/httpd/cgi-bin/man/mansearchhelp
255%{_datadir}/man2html/mansearch.aux
256%{_datadir}/man2html/mansearchhelp.aux
257/var/man2html/.glimpse_filters
258%endif
259
260%changelog
261* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5o-6
262- added Patch140 to convert /var/cache/man/whatis encodings to UTF-8 <BTS:846>
263- added Requires: gawk, grep (used at apropos, makewhatis)
264
265* Fri Sep 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5o-5
266- used less as pager again
267- fixed SOURCE1, 2 <BTS:846>
268
269* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5o-4
270- remove Patch120(run-groff-in-eucjp)
271- add new Patch120 to convert manpage to utf8 before formatting.
272- add Requires: nkf
273
274* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5o-3
275- remove jman and man-j.config
276
277* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5o-2
278- spec in utf-8
279- drop man2html cgi script
280
281* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5o-1
282- add Patch120 to run groff in eucJP locale if current locale
283  is eucJP or not.
284- add Patch130 to add utf8 messages
285- use lv as pager
286- add lv to Requires, remove less.
287
288* Sun Dec  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5o-0vl5
289- update man[-j].config (using -r option instead of -R on less)
290
291* Sun Sep 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5o-0vl4
292- update man[-j].config (less option @ PAGER)
293
294* Wed Dec 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.5o-0vl3
295- update makewhatis.cronweekly: always use -w option. <BTS:VineLinux:336>
296
297* Sat Dec 16 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.5o-0vl2
298- update Source1 & 2: set LANG variable for makewhatis. <BTS:VineLinux:336>
299- add patch110 to make makewhatis -u works correctly. <BTS:VineLinux:336>
300
301* Mon Aug 30 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.5o-0vl1
302- update to 1.5o
303- remove patches reflected in base: 105(mansec-loop), 109(man-ja-typo).
304- remove patch104(msgs): resolved by adding codeset to gencat.
305
306* Fri Jun 18 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.5m2-0vl2
307- separate man2html package for man2html and CGI scripts,
308  and make it depends on apache.
309- change owner of /var/man2html from nobody to apache
310- Patch107: hman use w3m by default
311- Patch108: remove mansearch CGI because it does not work without glimpse
312- Patch106: move cgi-aux directory to %{_datadir}/man2html (from PLD Linux)
313- Patch105: fix a fatal bug in mansec CGI
314- Patch109: fix typo in Japanese man.1 man page
315- re-enable Patch17(utf) not to output latin-1 to euc-jp terminal
316- add Japanese manpath.1 man page
317- add docs
318- add dependencies to bzip2 and gzip
319
320* Wed May 26 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.5m2-0vl1
321- update to 1.5m2
322- remove patches reflected in base:
323  2(i18n) 14(newline) 18(root) 19(overflow)
324  20(quote) 21(fixcache) 22(nocache) 100(ja)
325- default config change to create cache
326- makewhatis now does not read Japanese man pages by default
327- noreplace config files
328- drop Patch5(nonascii): grep -a is not needed for most non-ASCII text
329- drop Patch8(bug11621): less -r is not needed and rather dangerous
330- drop Patch15(lookon): incorporated but disabled because of its disadvantage
331- drop Patch17(utf8) and Patch103(configure.nroff): they canceled each other
332- modify patches (1,6,7,9,10,12) to apply to 1.5m2
333- rename man page of man.config by mv, not patch(3,4)
334- give owner/group of buildroot/var/man2html as parameters instead of patch102
335- gencat now requires LC_CTYPE is set properly
336- add Patch104(msgs): only make catalogs of specified languages
337
338* Mon Dec 31 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5i-0vl5
339- Oh my /usr/share/locale/{en,ja}/man were missing. Fixed.
340
341* Thu Oct 18 2001 Jun Nishii <jun@vinelinux.org> 1.5i-0vl4
342- added PATH in makewhatis.cron*
343
344* Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
345- 1.5i-0vl3: fix grammatical error in makewhatis
346
347* Sat Sep  1 2001 Jun Nishii <jun@vinelinux.org>
348- build for VineSeed
349
350* Sat Sep  1 2001 Jun Nishii <jun@vinelinux.org> 1.5i-0vl1
351- follow up with rawhide for security fix
352
353* Thu Jul 19 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
354- added makewhatis (8) man.
355- modified security patch for cache path.
356
357* Wed Jul 13 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
358- renew SPEC from rawhide.
359- removed /home/httpd/cgi-{bin|aux}/man* from %files that does not exist.
360- modified ja patch to recognize "/jman/" dir as Japanese manual.
361- remove unnecessary SGID from jman command.
362
363* Mon Jun 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
364- gzip the man pages manually - since file doesn't recognize them as
365  man pages, the build root policy doesn't do it (Bug #12015)
366
367* Tue May 16 2000 Preston Brown <pbrown@redhat.com>
368- default man path is now /usr/share/man.  /usr/man maintained for compat.
369- remove +sgid option to allow builds as a normal user.  SPEC file maintains
370  proper permissions.
371
372* Tue May  9 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
373- modified man-ja patch to fix my stupid mistake of makewhatis.sh.
374
375* Tue Apr 18 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
376- modified jman-vine.sh to set ja_JP.eucJP locale.
377
378* Tue Apr 18 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
379- updated to 1.5h1
380- modified man-j.config to sync with man-1.5h1 default.
381- renew SPEC from RH6.2
382
383* Wed Mar  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
384- Add kerberos man paths to man.config (Bug #11168 + extra fixes)
385
386* Tue Feb 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
387- 1.5h1 - this has a better fix for the security problems.
388- remove manpath patch (now in base)
389- remove loop patch (now in base)
390
391* Mon Feb 28 2000 Bernhard Rosenkraenzer <bero@redhat.com>
392- Fix security problems related to buffer overruns caused by oversized
393  enviroment variables
394
395* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
396- deal with rpm gziping man pages
397- fix file locking (Bug #8947)
398
399* Thu Dec 23 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
400- replace jman script to keep orignal man binary.
401- renew man-ja patch
402
403* Fri Nov 12 1999 Jun Nishii <jun@flatout.org>
404- ported for Vine Linux
405
406* Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
407- strip man2html
408
409* Fri Sep 10 1999 Cristian Gafton <gafton@redhat.com>
410- revert to latin1 instead of ascii
411
412* Wed Jun 16 1999 Cristian Gafton <gafton@redhat.com>
413- fixed man2html loop on terminfo.5 (patrch from the author; #3316)
414
415* Mon May 10 1999 Michael K. Johnson <johnsonm@redhat.com>
416- fixed #2532 by adding /usr/local/sbin as a MANPATH_MAP
417
418* Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
419- cron.weekly rebuilds, cron.daily updates in minimal time
420
421* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
422- man 1.5g bugfix release
423
424* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
425- auto rebuild in the new build environment (release 5)
426
427* Thu Feb 18 1999 Jeff Johnson <jbj@redhat.com>
428- add manpath symlinks (#1138).
429
430* Fri Feb 12 1999 Michael Maher <mike@redhat.com>
431- fixed bug #792
432- added man2html files
433
434* Tue Dec 29 1998 Cristian Gafton <gafton@redhat.com>
435- build for 6.0
436- upgraded to 1.5e
437- properly buildrooted
438
439* Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
440- enable fsstnd organization
441- change /var/catman/X11 to X11R6
442- %post/%preun to clean up cat litter
443
444* Tue Jun 02 1998 Prospector System <bugs@redhat.com>
445- translations modified for de
446
447* Tue Jun 02 1998 Erik Troan <ewt@redhat.com>
448- you can't do free(malloc(10) + 4) <sigh>
449
450* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
451- upgraded to 1.5d
452
453* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
454- translations modified for de, fr, tr
455
456* Fri Apr 10 1998 Cristian Gafton <gafton@redhat.com>
457- updated to 1.5a
458
459* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
460- uses a build root
461
462* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
463- updated to man-1.4j, which fixes some security problems; release 1 is
464  for RH 4.2, release 2 is for glibc
465 
466* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
467- built against glibc
468
469* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
470- Added /usr/lib/perl5/man to default manpath
Note: See TracBrowser for help on using the repository browser.