source: projects/specs/trunk/m/man/man-vl.spec @ 521

Revision 521, 14.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define  _mandir                %{_datadir}/man
2
3Summary:      A set of documentation tools:  man, apropos and whatis.
4Summary(ja):  ドキュメンテーション・ツール: man, apropos, whatis
5
6Name:         man
7Version:      1.5o
8Release:      4%{?_dist_release}
9License:      GPL
10Group:        System Environment/Base
11Source0:      http://www.kernel.org/pub/linux/utils/man/man-%{version}.tar.bz2
12Source1:      makewhatis.cronweekly
13Source2:      makewhatis.crondaily
14Patch1:       man-1.5m2-confpath.patch
15Patch5:       man-1.5i-nonascii.patch
16Patch6:       man-1.5m2-security.patch
17Patch7:       man-1.5m2-mandirs.patch
18Patch8:       man-1.5h1-bug11621.patch
19Patch9:       man-1.5m2-sofix.patch
20Patch10:      man-1.5m2-buildroot.patch
21Patch12:      man-1.5m2-ro-usr.patch
22Patch15:      man-1.5h1-lookon.patch
23Patch17:      man-1.5m2-utf8.patch
24
25# Vine Source(s)/Patch(es)
26Patch101:     man-1.5h1-gencat.patch
27Patch106:     man-man2html_aux_path.patch
28Patch107:     man-1.5m2-hman-use-w3m.patch
29Patch108:     man-1.5m2-no-mansearch.patch
30Patch110:     man-1.5o-tmpcache.patch
31Patch120:     man-1.5o-convert-manpage-to-utf8.patch
32Patch130:     man-1.5o-utf8-msgs.patch
33
34Buildroot:    %{_tmppath}/%{name}-%{version}-root
35Requires(post): coreutils
36Requires:     groff, lv, findutils, coreutils
37Requires:     nkf
38Requires:     bzip2, gzip
39BuildPreReq:  bzip2, gzip
40
41Vendor:       Project Vine
42Distribution: Vine Linux
43Packager:     shaolin, daisuke
44
45
46%description
47The man package includes three tools for finding information and/or
48documentation about your Linux system: man, apropos and whatis.  The
49man system formats and displays on-line manual pages about commands or
50functions on your system.  Apropos searches the whatis database
51(containing short descriptions of system commands) for a string.
52Whatis searches its own database for a complete word.
53
54The man package should be installed on your system because it is the
55primary way to find documentation on a Linux system.
56
57%description -l ja
58マニュアルページを表示するためのプログラムmanの日本語対応版です.
59日本語対応のgroffパッケージが必要です. 特定のキーワードに関連する文書
60を探すための whatis や apropos も含んでいます.
61環境変数 LANG=ja_JP.* の時には、
62
63    1.JMANプロジェクトまたはオリジナルソースに付随する日本語マニュアル
64    2.オリジナル・ソースに付随する英語マニュアル
65
66という順でマニュアルの検索がなされます。英語マニュアルを見る場合は、
67LANG=C man などとして利用してください。
68
69%package -n man2html
70Summary:        manroff to HTML converter
71Summary(ja):    manroff から HTML への変換器
72Group:          Applications/System
73Requires:       %{name} = %{version}-%{release}
74
75%description -n man2html
76This package contains manroff to HTML converter.
77
78%description -n man2html -l ja
79このパッケージには、manroff から HTMLへのコンバータが含まれています。
80
81%prep
82%setup -q
83%patch1 -p1 -b .confpath
84%patch6 -p1 -b .security
85%patch7 -p1 -b .mandirs
86%patch9 -p1 -b .sofix
87%patch10 -p1 -b .less
88%patch12 -p1 -b .usr
89
90%patch101 -p1
91
92%patch17 -p1 -b .utf8
93
94%patch106 -p1 -b .aux
95%patch107 -p1 -b .w3m
96%if ! 0%{?mansearch}
97%patch108 -p1 -b .search
98%endif
99%patch110 -p1 -b .tmpcache
100%patch120 -p1 -b .convert-man-to-utf8
101%patch130 -p1 -b .utf8-msgs
102
103pushd msgs
104%__mv mess.ja mess.ja_JP.eucJP
105%__mv mess.ja.codeset mess.ja_JP.eucJP.codeset
106iconv -f euc-jp -t utf-8 mess.ja_JP.eucJP > mess.ja
107echo "$ codeset=utf-8" > mess.ja.codeset
108popd
109
110%build
111./configure -default +fhs +lang en,ja,ja_JP.eucJP -confdir %{_sysconfdir}
112make CC="gcc $RPM_OPT_FLAGS -D_GNU_SOURCE"
113
114# use lv as PAGER instead of less
115pushd src
116mv man.conf man.conf.orig
117#sed -e 's/less -is/less -isMr/g' man.conf.orig > man.conf
118sed -e 's/less -is/lv -c/g' man.conf.orig > man.conf
119popd
120
121%install
122rm -rf $RPM_BUILD_ROOT
123mkdir -p %{buildroot}%{_sysconfdir}/cron.{daily,weekly}
124make install PREFIX=$RPM_BUILD_ROOT
125%__mv %{buildroot}%{_mandir}/man5/man.conf.5 %{buildroot}%{_mandir}/man5/man.config.5
126%__mv %{buildroot}%{_mandir}/ja/man5/man.conf.5 %{buildroot}%{_mandir}/ja/man5/man.config.5
127
128install -m755 %{_sourcedir}/makewhatis.cronweekly %{buildroot}%{_sysconfdir}/cron.weekly/makewhatis.cron
129        install -m755 %{_sourcedir}/makewhatis.crondaily %{buildroot}%{_sysconfdir}/cron.daily/makewhatis.cron
130
131mkdir -p $RPM_BUILD_ROOT/var/cache
132mkdir -p $RPM_BUILD_ROOT/var/cache/man/local
133mkdir -p $RPM_BUILD_ROOT/var/cache/man/X11R6
134
135mkdir -p $RPM_BUILD_ROOT/var/cache/ja
136mkdir -p $RPM_BUILD_ROOT/var/cache/man/local/ja
137mkdir -p $RPM_BUILD_ROOT/var/cache/man/X11R6/ja
138for i in 1 2 3 4 5 6 7 8 9 n; do
139        mkdir -p $RPM_BUILD_ROOT/var/cache/man/cat$i
140        mkdir -p $RPM_BUILD_ROOT/var/cache/man/local/cat$i
141        mkdir -p $RPM_BUILD_ROOT/var/cache/man/X11R6/cat$i
142
143        mkdir -p $RPM_BUILD_ROOT/var/cache/man/ja/cat$i
144        mkdir -p $RPM_BUILD_ROOT/var/cache/man/local/ja/cat$i
145        mkdir -p $RPM_BUILD_ROOT/var/cache/man/X11R6/ja/cat$i
146done
147
148# added man2html stuff
149cd man2html
150make install PREFIX=$RPM_BUILD_ROOT
151
152# symlinks for manpath
153( cd $RPM_BUILD_ROOT
154  ln -s man ./usr/bin/manpath
155  ln -s man.1.gz .%{_mandir}/man1/manpath.1.gz
156  ln -s man.1.gz .%{_mandir}/ja/man1/manpath.1.gz
157)
158
159# symlinks for compatibility
160ln -s man $RPM_BUILD_ROOT/usr/bin/jman
161
162%preun
163# Clean up accumulated cat litter.
164rm -f /var/cache/man/cat[123456789n]/*
165rm -f /var/cache/man/local/cat[123456789n]/*
166rm -f /var/cache/man/X11R6/cat[123456789n]/*
167
168rm -f /var/cache/man/ja/cat[123456789n]/*
169rm -f /var/cache/man/local/ja/cat[123456789n]/*
170rm -f /var/cache/man/X11R6/ja/cat[123456789n]/*
171
172
173%post
174rm -f /var/cache/man/cat[123456789n]/*
175rm -f /var/cache/man/local/cat[123456789n]/*
176rm -f /var/cache/man/X11R6/cat[123456789n]/*
177
178rm -f /var/cache/man/ja/cat[123456789n]/*
179rm -f /var/cache/man/local/ja/cat[123456789n]/*
180rm -f /var/cache/man/X11R6/ja/cat[123456789n]/*
181
182
183%clean
184rm -rf $RPM_BUILD_ROOT
185
186
187%files
188%defattr(-,root,root)
189%doc README* COPYING HISTORY INSTALL LSM TODO
190%config(noreplace) %{_sysconfdir}/cron.weekly/makewhatis.cron
191%config(noreplace) %{_sysconfdir}/cron.daily/makewhatis.cron
192%attr(2755,root,man)    /usr/bin/man
193/usr/bin/jman
194/usr/bin/manpath
195/usr/bin/apropos
196/usr/bin/whatis
197/usr/sbin/makewhatis
198%config(noreplace) %{_sysconfdir}/man.config
199#%config(noreplace) %{_sysconfdir}/man-j.config
200%{_mandir}/man1/man.1*
201%{_mandir}/man1/manpath.1*
202%{_mandir}/man1/apropos.1*
203%{_mandir}/man1/whatis.1*
204%{_mandir}/man5/man.config.5*
205%{_mandir}/man8/makewhatis.8*
206%{_mandir}/ja/man1/man.1*
207%{_mandir}/ja/man1/manpath.1*
208%{_mandir}/ja/man1/apropos.1*
209%{_mandir}/ja/man1/whatis.1*
210%{_mandir}/ja/man5/man.config.5*
211
212/usr/share/locale/*/man
213
214%attr(0775,root,man)    %dir /var/cache/man
215%attr(0775,root,man)    %dir /var/cache/man/cat[123456789n]
216%attr(0775,root,man)    %dir /var/cache/man/local
217%attr(0775,root,man)    %dir /var/cache/man/local/cat[123456789n]
218%attr(0775,root,man)    %dir /var/cache/man/X11R6
219%attr(0775,root,man)    %dir /var/cache/man/X11R6/cat[123456789n]
220
221%attr(0775,root,man)    %dir /var/cache/man/ja
222%attr(0775,root,man)    %dir /var/cache/man/ja/cat[123456789n]
223%attr(0775,root,man)    %dir /var/cache/man/local/ja
224%attr(0775,root,man)    %dir /var/cache/man/local/ja/cat[123456789n]
225%attr(0775,root,man)    %dir /var/cache/man/X11R6/ja
226%attr(0775,root,man)    %dir /var/cache/man/X11R6/ja/cat[123456789n]
227
228%files -n man2html
229%defattr(-,root,root)
230%doc man2html/README man2html/TODO
231/usr/bin/man2html
232%{_mandir}/man1/man2html.1*
233
234%if 0%{?mansearch}
235/home/httpd/cgi-bin/man/mansearch
236/home/httpd/cgi-bin/man/mansearchhelp
237%{_datadir}/man2html/mansearch.aux
238%{_datadir}/man2html/mansearchhelp.aux
239/var/man2html/.glimpse_filters
240%endif
241
242%changelog
243* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5o-4
244- remove Patch120(run-groff-in-eucjp)
245- add new Patch120 to convert manpage to utf8 before formatting.
246- add Requires: nkf
247
248* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5o-3
249- remove jman and man-j.config
250
251* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5o-2
252- spec in utf-8
253- drop man2html cgi script
254
255* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5o-1
256- add Patch120 to run groff in eucJP locale if current locale
257  is eucJP or not.
258- add Patch130 to add utf8 messages
259- use lv as pager
260- add lv to Requires, remove less.
261
262* Sun Dec  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5o-0vl5
263- update man[-j].config (using -r option instead of -R on less)
264
265* Sun Sep 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5o-0vl4
266- update man[-j].config (less option @ PAGER)
267
268* Wed Dec 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.5o-0vl3
269- update makewhatis.cronweekly: always use -w option. <BTS:VineLinux:336>
270
271* Sat Dec 16 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.5o-0vl2
272- update Source1 & 2: set LANG variable for makewhatis. <BTS:VineLinux:336>
273- add patch110 to make makewhatis -u works correctly. <BTS:VineLinux:336>
274
275* Mon Aug 30 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.5o-0vl1
276- update to 1.5o
277- remove patches reflected in base: 105(mansec-loop), 109(man-ja-typo).
278- remove patch104(msgs): resolved by adding codeset to gencat.
279
280* Fri Jun 18 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.5m2-0vl2
281- separate man2html package for man2html and CGI scripts,
282  and make it depends on apache.
283- change owner of /var/man2html from nobody to apache
284- Patch107: hman use w3m by default
285- Patch108: remove mansearch CGI because it does not work without glimpse
286- Patch106: move cgi-aux directory to %{_datadir}/man2html (from PLD Linux)
287- Patch105: fix a fatal bug in mansec CGI
288- Patch109: fix typo in Japanese man.1 man page
289- re-enable Patch17(utf) not to output latin-1 to euc-jp terminal
290- add Japanese manpath.1 man page
291- add docs
292- add dependencies to bzip2 and gzip
293
294* Wed May 26 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.5m2-0vl1
295- update to 1.5m2
296- remove patches reflected in base:
297  2(i18n) 14(newline) 18(root) 19(overflow)
298  20(quote) 21(fixcache) 22(nocache) 100(ja)
299- default config change to create cache
300- makewhatis now does not read Japanese man pages by default
301- noreplace config files
302- drop Patch5(nonascii): grep -a is not needed for most non-ASCII text
303- drop Patch8(bug11621): less -r is not needed and rather dangerous
304- drop Patch15(lookon): incorporated but disabled because of its disadvantage
305- drop Patch17(utf8) and Patch103(configure.nroff): they canceled each other
306- modify patches (1,6,7,9,10,12) to apply to 1.5m2
307- rename man page of man.config by mv, not patch(3,4)
308- give owner/group of buildroot/var/man2html as parameters instead of patch102
309- gencat now requires LC_CTYPE is set properly
310- add Patch104(msgs): only make catalogs of specified languages
311
312* Mon Dec 31 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5i-0vl5
313- Oh my /usr/share/locale/{en,ja}/man were missing. Fixed.
314
315* Thu Oct 18 2001 Jun Nishii <jun@vinelinux.org> 1.5i-0vl4
316- added PATH in makewhatis.cron*
317
318* Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
319- 1.5i-0vl3: fix grammatical error in makewhatis
320
321* Sat Sep  1 2001 Jun Nishii <jun@vinelinux.org>
322- build for VineSeed
323
324* Sat Sep  1 2001 Jun Nishii <jun@vinelinux.org> 1.5i-0vl1
325- follow up with rawhide for security fix
326
327* Thu Jul 19 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
328- added makewhatis (8) man.
329- modified security patch for cache path.
330
331* Wed Jul 13 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
332- renew SPEC from rawhide.
333- removed /home/httpd/cgi-{bin|aux}/man* from %files that does not exist.
334- modified ja patch to recognize "/jman/" dir as Japanese manual.
335- remove unnecessary SGID from jman command.
336
337* Mon Jun 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
338- gzip the man pages manually - since file doesn't recognize them as
339  man pages, the build root policy doesn't do it (Bug #12015)
340
341* Tue May 16 2000 Preston Brown <pbrown@redhat.com>
342- default man path is now /usr/share/man.  /usr/man maintained for compat.
343- remove +sgid option to allow builds as a normal user.  SPEC file maintains
344  proper permissions.
345
346* Tue May  9 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
347- modified man-ja patch to fix my stupid mistake of makewhatis.sh.
348
349* Tue Apr 18 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
350- modified jman-vine.sh to set ja_JP.eucJP locale.
351
352* Tue Apr 18 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
353- updated to 1.5h1
354- modified man-j.config to sync with man-1.5h1 default.
355- renew SPEC from RH6.2
356
357* Wed Mar  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
358- Add kerberos man paths to man.config (Bug #11168 + extra fixes)
359
360* Tue Feb 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
361- 1.5h1 - this has a better fix for the security problems.
362- remove manpath patch (now in base)
363- remove loop patch (now in base)
364
365* Mon Feb 28 2000 Bernhard Rosenkraenzer <bero@redhat.com>
366- Fix security problems related to buffer overruns caused by oversized
367  enviroment variables
368
369* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
370- deal with rpm gziping man pages
371- fix file locking (Bug #8947)
372
373* Thu Dec 23 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
374- replace jman script to keep orignal man binary.
375- renew man-ja patch
376
377* Fri Nov 12 1999 Jun Nishii <jun@flatout.org>
378- ported for Vine Linux
379
380* Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
381- strip man2html
382
383* Fri Sep 10 1999 Cristian Gafton <gafton@redhat.com>
384- revert to latin1 instead of ascii
385
386* Wed Jun 16 1999 Cristian Gafton <gafton@redhat.com>
387- fixed man2html loop on terminfo.5 (patrch from the author; #3316)
388
389* Mon May 10 1999 Michael K. Johnson <johnsonm@redhat.com>
390- fixed #2532 by adding /usr/local/sbin as a MANPATH_MAP
391
392* Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
393- cron.weekly rebuilds, cron.daily updates in minimal time
394
395* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
396- man 1.5g bugfix release
397
398* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
399- auto rebuild in the new build environment (release 5)
400
401* Thu Feb 18 1999 Jeff Johnson <jbj@redhat.com>
402- add manpath symlinks (#1138).
403
404* Fri Feb 12 1999 Michael Maher <mike@redhat.com>
405- fixed bug #792
406- added man2html files
407
408* Tue Dec 29 1998 Cristian Gafton <gafton@redhat.com>
409- build for 6.0
410- upgraded to 1.5e
411- properly buildrooted
412
413* Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
414- enable fsstnd organization
415- change /var/catman/X11 to X11R6
416- %post/%preun to clean up cat litter
417
418* Tue Jun 02 1998 Prospector System <bugs@redhat.com>
419- translations modified for de
420
421* Tue Jun 02 1998 Erik Troan <ewt@redhat.com>
422- you can't do free(malloc(10) + 4) <sigh>
423
424* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
425- upgraded to 1.5d
426
427* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
428- translations modified for de, fr, tr
429
430* Fri Apr 10 1998 Cristian Gafton <gafton@redhat.com>
431- updated to 1.5a
432
433* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
434- uses a build root
435
436* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
437- updated to man-1.4j, which fixes some security problems; release 1 is
438  for RH 4.2, release 2 is for glibc
439 
440* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
441- built against glibc
442
443* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
444- Added /usr/lib/perl5/man to default manpath
Note: See TracBrowser for help on using the repository browser.