source: projects/specs/trunk/m/man-db/man-db-vl.spec @ 12105

Revision 12105, 5.4 KB checked in by tomop, 5 years ago (diff)

man-db-2.8.5-2

Line 
1%bcond_with check
2
3%global cache /var/cache/man
4
5# Basic Information
6Name:           man-db
7Version:        2.8.5
8Release:        2%{?_dist_release}
9License:        GPL
10Group:          System Environment/Base
11Source0:        http://download.savannah.gnu.org/releases/%{name}/%{name}-%{version}.tar.xz
12Source1:        man-db.crondaily
13Source2:        man-db.sysconfig
14Patch0: man-db-2.8.3-change-owner-of-man-cache.patch
15# http://lists.nongnu.org/archive/html/man-db-devel/2017-01/msg00013.html
16Patch1: man-db-2.7.6.1-fix-override-dir-handling.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22Packager:       yasumichi
23
24Summary:        the man-db manual pager suite
25Summary(ja):    man-dbマニュアルページャスイート
26
27# Dependency
28Requires:       groff >= 1.20.1
29BuildRequires:  groff >= 1.20.1
30Requires:       gdbm
31BuildRequires:  gdbm-devel
32BuildRequires:  libpipeline-devel >= 1.1.0
33BuildRequires:  zlib-devel
34BuildRequires:  po4a
35
36Obsoletes:      man
37Provides:       man
38
39%description
40This package provides the man command. This utility is the primary way of
41examining the on-line help files (manual pages). Other utilities provided
42include the whatis and apropos commands for searching the manual page
43database, the manpath utility for determining the manual page search path,
44and the maintenance utilities mandb, catman, and zsoelim. This package uses
45the groff suite of programs to format and display the manual pages.
46
47%description -l ja
48このパッケージは、man コマンドを提供します。このユーティリティの主な用途は
49ヘルプファイル(マニュアルページ)を調べることです。他のユーティリティとして
50マニュアルページデータベースを検索するための whatis と apropos コマンド、
51マニュアルページの検索パスを決定する manpath ユーティリティ、および
52メンテナンスユーティリティである mandb、catman および zsoelim を提供します。
53このパッケージは、マニュアルページを整形および表示するために groff プログラム
54スイートを利用しています。
55
56%prep
57%autosetup -p1
58
59%build
60%configure \
61        --disable-setuid --disable-cache-owner \
62        --with-browser=elinks --with-lzip=lzip \
63        --with-override-dir=overrides
64
65%{__make} %{?_smp_mflags}
66
67%install
68%{__rm} -rf ${RPM_BUILD_ROOT}
69make install DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} INSTALL='install -p'
70
71# move the documentation to the relevant place
72mv $RPM_BUILD_ROOT%{_datadir}/doc/man-db/* ./
73
74# remove zsoelim man page - part of groff package
75rm $RPM_BUILD_ROOT%{_datadir}/man/man1/zsoelim.1
76
77# remove libtool archives
78rm $RPM_BUILD_ROOT%{_libdir}/man-db/*.la
79
80# install cron script for man-db creation/update
81mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
82install -D -p -m 0755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/man-db.cron
83
84# config for cron script
85mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
86install -D -p -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/man-db
87
88# install cache directory
89install -d -m 0755  $RPM_BUILD_ROOT%{cache}
90
91%find_lang %{name}
92%find_lang %{name}-gnulib
93
94# drop files for systemd
95rm -rf %{buildroot}/lib/systemd
96rm -rf %{buildroot}%{_prefix}/lib/tmpfiles.d
97
98%if %{with check}
99%check
100make check
101%endif
102
103%clean
104%{__rm} -rf ${RPM_BUILD_ROOT}
105
106# clear the old cache
107%post
108%{__rm} -rf %{cache}/*
109
110%files -f %{name}.lang -f %{name}-gnulib.lang
111%defattr(-,root,root)
112%doc ChangeLog NEWS README
113%config(noreplace) %{_sysconfdir}/man_db.conf
114%config(noreplace) %{_sysconfdir}/sysconfig/man-db
115%{_sysconfdir}/cron.daily/man-db.cron
116%{_bindir}/apropos
117%{_bindir}/catman
118%{_bindir}/lexgrog
119%{_bindir}/man
120%{_bindir}/mandb
121%{_bindir}/manpath
122%{_bindir}/whatis
123%{_libdir}/man-db
124%{_libexecdir}/man-db
125%{_sbindir}/accessdb
126%{_defaultdocdir}/man-db
127%attr(0755,root,root)   %dir %{cache}
128%lang(da) %{_mandir}/da/man*/*
129%lang(de) %{_mandir}/de/man*/*
130%lang(es) %{_mandir}/es/man*/*
131%lang(fr) %{_mandir}/fr/man*/*
132%lang(id) %{_mandir}/id/man*/*
133%lang(it) %{_mandir}/it/man*/*
134%lang(ja) %{_mandir}/ja/man*/*
135%lang(nl) %{_mandir}/nl/man*/*
136%lang(pl) %{_mandir}/pl/man*/*
137%lang(pt) %{_mandir}/pt/man*/*
138%lang(pt_BR) %{_mandir}/pt_BR/man*/*
139%lang(ru) %{_mandir}/ru/man*/*
140%lang(sr) %{_mandir}/sr/man*/*
141%lang(sv) %{_mandir}/sv/man*/*
142%lang(tr) %{_mandir}/tr/man*/*
143%lang(zh_CN) %{_mandir}/zh_CN/man*/*
144%{_mandir}/man1/apropos.1.*
145%{_mandir}/man1/lexgrog.1.*
146%{_mandir}/man1/man.1.*
147%{_mandir}/man1/manconv.1.*
148%{_mandir}/man1/manpath.1.*
149%{_mandir}/man1/whatis.1.*
150%{_mandir}/man5/manpath.5.*
151%{_mandir}/man8/accessdb.8.*
152%{_mandir}/man8/catman.8.*
153%{_mandir}/man8/mandb.8.*
154
155
156%changelog
157* Wed May 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.5-2
158- fixed options for configure.
159- imported Patch1 and 1 from rawhide.
160
161* Mon May 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.5-1
162- new upstream release.
163- added BR:zlib-devel.
164
165* Sat Jan 25 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.6.6-1
166- new upstream release
167
168* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-1
169- new upstream release
170- add BR: libpipeline-devel instead of libpipeline
171- add BR: po4a
172
173* Fri Sep 23 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.6.0.2-1
174- new upstream release.
175- remove Patch0.
176
177* Wed Mar 30 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.5.9-1
178- new upstream release.
179- add Source1,Source2 and Patch0 from fedora.
180
181* Tue Nov 16 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.5.8-1
182- initial build for Vine Linux
183
Note: See TracBrowser for help on using the repository browser.