source: projects/specs/trunk/m/mailx/mailx-vl.spec @ 521

Revision 521, 6.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:     The /bin/mail program, which is used to send mail via shell scripts.
2Summary(ja): シェルスクリプトからメールを送る /bin/mail プログラム
3Name:        mailx
4Version:     8.1.1
5Release:     35%{?_dist_release}
6License:     BSD
7Group:       Applications/Internet
8Source:      ftp://ftp.debian.org/pub/debian/hamm/source/mail/mailx-8.1.1.tar.gz
9Source1:     flock.c
10Patch0:      mailx-8.1.1.debian.patch
11Patch1:      mailx-8.1.1.security.patch
12Patch2:      mailx-8.1.1.nolock.patch
13Patch3:      mailx-8.1.1.debian2.patch
14Patch4:      mailx-noroot.patch
15Patch5:      mailx-nopanic.patch
16Patch6:      mailx-nullchar.patch
17Patch7:      mailx-8.1.1-fhs.patch
18Patch8:      mailx-8.1.1-environ.patch
19Patch9:      mailx-8.1.1-siglj.patch
20Patch10:     mailx-8.1.1-bug15728.patch
21Patch11:     mailx-8.1.1-bug10074.patch
22Patch12:     mailx-8.1.1-uidcheck.patch
23Patch13:     mailx-8.1.1-flock.patch
24Patch14:     mailx-8.1.1-nostrip.patch
25Patch15:     mailx-8.1.1-ctime.patch
26# bug fix for environ patch for Vine Linux
27#Patch9:    mailx-fio.patch
28
29BuildRoot:   %{_tmppath}/%{name}-%{version}-root
30
31
32%description
33The mailx package installs the /bin/mail program, which is used to
34send quick email messages (i.e., without opening up a full-featured
35mail user agent). Mail is often used in shell scripts.
36
37You should install mailx because of its quick email sending ability,
38which is especially useful if you're planning on writing any shell
39scripts.
40
41%description -l ja
42mailx パッケージは /bin/mail プログラムをインストールします.
43/bin/mail は,多機能のメールクライアントを起動すること無く迅速に
44メールを送信するのに使われます./bin/mail はシェルスクリプトから
45よく使われています.
46
47メール送信が関係するシェルスクリプト作成を検討しているのならば,
48迅速なメール送信機能を備えた mailx パッケージを是非インストールして下さい.
49
50
51%prep
52%setup -q
53cp %{SOURCE1} .
54%patch0 -p1 -b .debian
55%patch1 -p1 -b .security
56%patch2 -p1 -b .nolock
57%patch3 -p1 -b .debian2
58%patch4 -p1 -b .noroot
59%patch5 -p1 -b .nopanic
60%patch6 -p1 -b .nullchar
61%patch7 -p1 -b .fhs
62%patch8 -p1 -b .environ
63%patch9 -p1 -b .siglj
64%patch10 -p1 -b .bug15728
65%patch11 -p1 -b .bug10074
66%patch12 -p1 -b .uidcheck
67%patch13 -p1 -b .flock
68%patch14 -p1
69%patch15 -p1
70
71#%patch9 -p0 -b .fio
72
73
74%build
75make CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
76
77
78%install
79rm -rf ${RPM_BUILD_ROOT}
80mkdir -p ${RPM_BUILD_ROOT}/{bin,etc}
81mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
82mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib
83mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
84
85make DESTDIR=${RPM_BUILD_ROOT} bindir=%{_bindir} mandir=%{_mandir} install
86
87( cd ${RPM_BUILD_ROOT}
88  mv .%{_bindir}/mail ./bin/mail
89  chmod g-s ./bin/mail
90  ln -sf ../../bin/mail .%{_bindir}/Mail
91  ln -sf mail.1 .%{_mandir}/man1/Mail.1
92)
93
94
95%clean
96rm -rf ${RPM_BUILD_ROOT}
97
98
99%files
100%defattr(-,root,root)
101%attr(755,root,mail)    /bin/mail
102%{_bindir}/Mail
103%{_prefix}/lib/mail.help
104%{_prefix}/lib/mail.tildehelp
105%config(noreplace) /etc/mail.rc
106%{_mandir}/man1/mail.1*
107%{_mandir}/man1/Mail.1*
108
109
110%changelog
111* Sun Oct 18 2009 Shu KONNO <owa@bg.wakwak.com> 8.1.1-35
112- applied vine5 updates
113        * Wed Sep 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.1.1-35
114        - use %%{_prefix}/lib to build on x86_64
115
116* Tue Sep  8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.1.1-34
117- man files in the wrong location - fixed.
118
119* Tue Aug  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.1-33
120- applied new versioning policy
121- spec in UTF-8
122
123* Sat Sep 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 8.1.1-32vl2
124- rebuild to add gpg sign
125
126* Fri Mar 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 8.1.1-32vl1
127- rebuilt with new toolchains
128- s/Copyright/License/
129- added Patch9--Patch15 from Fedora 8.1.1-32
130  * Fri Aug 01 2003 Florian La Roche <Florian.LaRoche@redhat.de>
131  - fix include file order #101251
132  * Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
133  - clean up flock() usage -- LOCK_EX shouldn't work on read-only descriptors
134  * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
135  - patch to use fcntl() for locking instead of flock() (#15779)
136  - patch to ignore ~/.mailrc if it's owned by anyone other than the owner of
137    this process
138  - clean up flock() emulation semantics
139  * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
140  - summaries from specspo.
141  * Fri Aug 11 2000 Jeff Johnson <jbj@redhat.com>
142  - time to use sigsetjmp/siglongjmp (#14010).
143  - avoid indexing on NOSTR valued pointer (#15728).
144  - ignore MAIL enviromment variable when invoked with -u (#10074).
145- mailx-fio.patch dropped because it was merged Patch8
146
147* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
148- 8.1.1-16vl2
149- rebuilt for VineSeed, as well as adding Japanese summary/description
150- define %%{_mandir} on the top of this spec file :-P
151
152* Mon Sep 18 2000 Jun Nishii <jun@vinelinux.org>
153- added fio-patch to fix bug for `mail -f`
154
155* Mon Aug  7 2000 Nalin Dahyabhai <nalin@redhat.com>
156- disable security-prone variables-inherited-from-environment behavior
157- inherit only SHELL, DEAD, PAGER, LISTER, EDITOR, VISUAL, MBOX from environment
158- document the environment variables that are used
159
160* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
161- automatic rebuild
162
163* Wed Jun 21 2000 Preston Brown <pbrown@redhat.com>
164- noreplace mail.rc
165
166* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
167- FHS packaging.
168
169* Sun May  7 2000 Bill Nottingham <notting@redhat.com>
170- fix explosions on ia64
171
172* Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
173- Fix bug #8451
174- Fix bug #8100
175
176* Tue Aug 31 1999 Bill Nottingham <notting@redhat.com>
177- fix pathnames
178- take out makefile install crud
179
180* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
181- auto rebuild in the new build environment (release 8)
182
183* Thu Aug 27 1998 Alan Cox <alan@redhat.com>
184- Synchronized with the Debian people (more small edge case cures)
185
186* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
187- build root
188
189* Wed Jun 24 1998 Alan Cox <alan@redhat.com>
190- Switched dotlocking off. This fits the Red Hat model of not having setgid
191  mail agents and fixes the "lock" problem reported.
192
193* Mon Jun 22 1998 Alan Cox <alan@redhat.com>
194- Buffer overrun patches. These dont bite us when we don't run mailx setgid
195  but do want to be in as mailx needs to be setgid
196
197* Fri Jun 12 1998 Alan Cox <alan@redhat.com>
198- Moved from 5.5 to the OpenBSD 8.1 release plus Debian patches
199
200* Tue May 05 1998 Prospector System <bugs@redhat.com>
201- translations modified for de, fr, tr
202
203* Tue Oct 21 1997 Donnie Barnes <djb@redhat.com>
204- spec file cleanups
205
206* Thu Jun 12 1997 Erik Troan <ewt@redhat.com>
207- built against glibc
Note: See TracBrowser for help on using the repository browser.