source: projects/specs/trunk/m/m4/m4-vl.spec @ 521

Revision 521, 5.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The GNU macro processor.
2Summary(ja): GNU マクロプロセッサ
3Name: m4
4Version: 1.4.14
5Release: 1%{?_dist_release}
6License: GPLv3+
7Group: Development/Tools
8Source: ftp://ftp.gnu.org/gnu/m4/m4-%{version}.tar.bz2
9URL: http://www.gnu.org/software/m4/
10
11Buildroot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: libsigsegv-devel
13Requires(post): /sbin/install-info
14Requires(preun): /sbin/install-info
15
16
17%description
18A GNU implementation of the traditional UNIX macro processor.  M4 is
19useful for writing text files which can be logically parsed, and is used
20by many programs as part of their build process.  M4 has built-in
21functions for including files, running shell commands, doing arithmetic,
22etc.  The autoconf program needs m4 for generating configure scripts, but
23not for running configure scripts.
24
25Install m4 if you need a macro processor.
26
27%description -l ja
28m4 は UNIX で使われるマクロプロセッサの GNU 版です.
29m4 を使うと,論理的に解析可能なテキストファイルを書く際に便利ですし,
30また多くのプログラムのビルド過程で m4 が使われています.
31m4 にはファイルのインクルード,シェルコマンドの実行,計算等の
32組み込み関数が備わっています.autoconf は configure スクリプトの
33生成に m4 を必要とします (が configure スクリプト実行には必要
34ありません).
35
36マクロプロセッサが必要なら m4 をインストールして下さい.
37
38%prep
39%setup -q
40
41%build
42%configure
43make CFLAGS="$RPM_OPT_FLAGS" %{?_smp_mflags}
44
45%install
46rm -rf $RPM_BUILD_ROOT
47%makeinstall INSTALL_DATA="install -c -m644"
48
49# ensure /usr/share/info.dir is not included into the package
50rm -fv %{buildroot}%{_infodir}/dir
51
52
53%post
54/sbin/install-info %{_infodir}/m4.info.gz %{_infodir}/dir
55
56%preun
57if [ "$1" = 0 ]; then
58    /sbin/install-info --delete %{_infodir}/m4.info.gz %{_infodir}/dir
59fi
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64
65%files
66%defattr(-,root,root)
67%doc AUTHORS COPYING ChangeLog NEWS THANKS README
68%{_bindir}/m4
69%{_infodir}/*
70%{_mandir}/man1/*
71
72%changelog
73* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.14-1
74- new upstream release
75- built with new toolchain, libsigsegv-2.8
76
77* Sun Apr  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.13-2
78- ensure /usr/share/info/dir is not included in the package
79
80* Sun Apr  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.13-1
81- new upstream release
82
83* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-1
84- new upstream release
85- added BuildRequires: libsigsegv-devel
86
87* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.11-2vl5
88- spec in utf-8
89
90* Thu Apr  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.11-1vl5
91- new upstream release
92
93* Tue Mar 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.9-0vl1
94- new upstream
95
96* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.8-0vl1
97- new upstream
98- changed URL
99
100* Sat Nov 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.4-0vl1
101- new upstream
102- s/Copyright/License/
103- added some documents
104
105* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-1vl1
106- updated to 1.4.3 based on Fedora development
107
108* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.4.1-12vl2
109- rebuild
110
111* Thu Dec 05 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.1-12vl1
112- based on 1.4.1-12 from Rawhide and built for Vine Linux
113- added Japanese summary and description
114
115* Mon Nov 11 2002 Florian La Roche <Florian.LaRoche@redhat.de>
116- add french translation file
117
118* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
119- automated rebuild
120
121* Wed Jun 19 2002 Florian La Roche <Florian.LaRoche@redhat.de>
122- do not strip apps
123
124* Fri Jun 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
125- rebuild
126
127* Thu May 23 2002 Tim Powers <timp@redhat.com>
128- automated rebuild
129
130* Thu Mar 07 2002 Florian La Roche <Florian.LaRoche@redhat.de>
131- use _infodir on popular request #47465
132
133* Sat Jan 05 2002 Florian La Roche <Florian.LaRoche@redhat.de>
134- add URL tag
135- improved spec file
136- add hack to update config.guess config.sub
137- fix to build with newer autoconf versions
138
139* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
140- Bump release + rebuild.
141
142* Tue Feb 13 2001 Florian La Roche <Florian.LaRoche@redhat.de>
143- signal patch is not necessary anymore
144- fix printf buffer overflow problem
145
146* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
147- automatic rebuild
148
149* Sat Jun 17 2000 Matt Wilson <msw@redhat.com>
150- added defattr
151
152* Mon Jun  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
153- FHS compliance
154- 1.4.1
155- some fixes to spec file
156
157* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
158- auto rebuild in the new build environment (release 12)
159
160* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
161- build against glibc 2.1
162
163* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
164- translations modified for de, fr, tr
165
166* Fri Apr 10 1998 Cristian Gafton <gafton@redhat.com>
167- Manhattan build
168
169* Wed Oct 21 1997 Cristian Gafton <gafton@redhat.com>
170- added info file handling and BuildRoot
171
172* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
173- built against glibc
174
Note: See TracBrowser for help on using the repository browser.