source: projects/specs/trunk/lib/libz/libzen/libzen-vl.spec @ 4836

Revision 4836, 4.1 KB checked in by kudoh, 13 years ago (diff)

# Copyright (c) 2008 oc2pus
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Please submit bugfixes or comments to toni@…
#
# * This spec is modified for Vine Linux *

# norootforbuild

%define _prefix /usr
# %define _SO_nr 0

Name: libzen
Version: 0.4.22
Release: 1%{?_dist_release}
Summary: Shared library for libmediainfo and medianfo-*
Summary(ja): libmediainfo 及び mediainfo-* 用の共有ライブラリ
Group: System Environment/Libraries?
License: BSD
URL:  http://zenlib.sourceforge.net/
Source: libzen_%{version}.tar.bz2
BuildRoot?: %{_tmppath}/%{name}-%{version}-root
# BuildRequires?: dos2unix
BuildRequires?: nkf
BuildRequires?: doxygen
## Need GCC3
BuildRequires?: gcc-c++

Packager: babasaki

%description
Shared library for libmediainfo and medianfo-*.

%description -l ja
libmediainfo 及び mediainfo-* 用の共有ライブラリです。

%package -n libzen-devel
Summary: Include files and mandatory libraries for development
Summary(ja): libzen の開発用のヘッダとライブラリファイル
Group: Development/Libraries?
Requires: %{name} = %{version}-%{release}

%description -n libzen-devel
Include files and mandatory libraries for development.

%description -n libzen-devel -l ja
libzen の開発用のヘッダとライブラリファイルです。

%prep
%setup -q -n ZenLib?
## dos2unix *.txt Source/Doc/?*.html
nkf --unix --overwrite *.txt Source/Doc/?*.html

%chmod 644 *.txt Source/Doc/?*.html

%build
export CFLAGS="$RPM_OPT_FLAGS"
export CPPFLAGS="$RPM_OPT_FLAGS"
export CXXFLAGS="$RPM_OPT_FLAGS"

pushd Source/Doc/?

doxygen Doxyfile

popd
cp Source/Doc/?*.html ./

pushd Project/GNU/Library

%chmod +x autogen
./autogen
%configure --enable-shared --disable-static

%make clean
%
make %{?jobs:-j%{jobs}}

popd

%install
pushd Project/GNU/Library

%make install-strip DESTDIR=%{buildroot}

popd

# Zenlib headers and ZenLib?-config
%install -dm 755 %{buildroot}%{_includedir}/ZenLib?
%
install -m 644 Source/ZenLib/?*.h \

%{buildroot}%{_includedir}/ZenLib?

for i in Base64 HTTP_Client Format/Html? Format/Http? TinyXml?; do

%install -dm 755 %{buildroot}%{_includedir}/ZenLib/?$i
%
install -m 644 Source/ZenLib/?$i/*.h \

%{buildroot}%{_includedir}/ZenLib/?$i

done

%sed -i -e 's|Version: |Version: %{version}|g' \

Project/GNU/Library/libzen.pc

%install -dm 755 %{buildroot}%{_libdir}/pkgconfig
%install -m 644 Project/GNU/Library/libzen.pc \

%{buildroot}%{_libdir}/pkgconfig

# remove unpackaged files
rm -f ${RPM_BUILD_ROOT}/%{_libdir}/*.la

%clean
[ -d "%{buildroot}" -a "%{buildroot}" != "" ] && %rm -rf "%{buildroot}"

%post -n libzen -p /sbin/ldconfig

%postun -n libzen -p /sbin/ldconfig

%files
%defattr(-,root,root,-)
%doc History.txt License.txt ReadMe?.txt
%{_libdir}/libzen.so.*

%files -n libzen-devel
%defattr(-,root,root,-)
%doc Documentation.html
%doc Doc/*
%dir %{_includedir}/ZenLib?
%{_includedir}/ZenLib/?*
%{_libdir}/libzen.so
%{_libdir}/pkgconfig/*.pc

%changelog

  • Tue Sep 27 2011 Toshiharu Kudoh <toshi.kd2@…> 0.4.22-1
  • new upstream release
  • Fri Jul 15 2011 Toshiharu Kudoh <toshi.kd2@…> 0.4.20-1
  • new upstream release
  • Sat Dec 25 2010 Toshiharu Kudoh <toshi.kd2@…> 0.4.17-1
  • new upstream release
  • Mon Sep 27 2010 Shu KONNO <owa@…> 0.4.15-4
  • rebuilt with rpm-4.8.1 for pkg-config
  • Sat Jul 24 2010 Yoji TOYODA <bsyamato@…> 0.4.15-2
  • fix %install (add install directory)
  • Tue Jun 15 2010 Toshiharu Kudoh <toshi.kd2@…> 0.4.15-1
  • new upstream release
  • Tue Jul 28 2009 Kazutaka HARADA <kazutaka@…> 0.4.3-1
  • new upstream release
  • change spec file name to libzen-vl.spec
  • add japanese summary and description
  • change group for -devel sub package to Development/Libraries?
  • add configure option --disable-static
  • remove unpackaged file (.la)
  • add Packager tag
  • Tue Jan 01 2009 Jerome Martinez <zen@…> - 0.3.6-0
  • See History.txt for more info and real dates
  • Previous packages made by Toni Graffy <toni@…>
Line 
1# Copyright (c) 2008 oc2pus
2# This file and all modifications and additions to the pristine
3# package are under the same license as the package itself.
4#
5# Please submit bugfixes or comments to toni@links2linux.de
6#
7# *** This spec is modified for Vine Linux ***
8
9# norootforbuild
10
11%define _prefix /usr
12# %define _SO_nr        0
13
14Name:                   libzen
15Version:                0.4.22
16Release:                1%{?_dist_release}
17Summary:                Shared library for libmediainfo and medianfo-*
18Summary(ja):            libmediainfo 及び mediainfo-* 用の共有ライブラリ
19Group:                  System Environment/Libraries
20License:                BSD
21URL:                    http://zenlib.sourceforge.net/
22Source:                 libzen_%{version}.tar.bz2
23BuildRoot:              %{_tmppath}/%{name}-%{version}-root
24# BuildRequires:                dos2unix
25BuildRequires:          nkf
26BuildRequires:          doxygen
27## Need GCC3
28BuildRequires:          gcc-c++
29
30Packager:               babasaki
31
32%description
33Shared library for libmediainfo and medianfo-*.
34
35%description -l ja
36libmediainfo 及び mediainfo-* 用の共有ライブラリです。
37
38%package -n libzen-devel
39Summary:        Include files and mandatory libraries for development
40Summary(ja):    libzen の開発用のヘッダとライブラリファイル
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43
44%description -n libzen-devel
45Include files and mandatory libraries for development.
46
47%description -n libzen-devel -l ja
48libzen の開発用のヘッダとライブラリファイルです。
49
50%prep
51%setup -q -n ZenLib
52## dos2unix     *.txt Source/Doc/*.html
53nkf --unix --overwrite *.txt Source/Doc/*.html
54
55%__chmod 644 *.txt Source/Doc/*.html
56
57%build
58export CFLAGS="$RPM_OPT_FLAGS"
59export CPPFLAGS="$RPM_OPT_FLAGS"
60export CXXFLAGS="$RPM_OPT_FLAGS"
61
62pushd Source/Doc/
63        doxygen Doxyfile
64popd
65cp Source/Doc/*.html ./
66
67pushd Project/GNU/Library
68        %__chmod +x autogen
69        ./autogen
70        %configure --enable-shared --disable-static
71
72        %__make clean
73        %__make %{?jobs:-j%{jobs}}
74popd
75
76%install
77pushd Project/GNU/Library
78        %__make install-strip DESTDIR=%{buildroot}
79popd
80
81# Zenlib headers and ZenLib-config
82%__install -dm 755 %{buildroot}%{_includedir}/ZenLib
83%__install -m 644 Source/ZenLib/*.h \
84        %{buildroot}%{_includedir}/ZenLib
85for i in Base64 HTTP_Client Format/Html Format/Http TinyXml; do
86        %__install -dm 755 %{buildroot}%{_includedir}/ZenLib/$i
87        %__install -m 644 Source/ZenLib/$i/*.h \
88                %{buildroot}%{_includedir}/ZenLib/$i
89done
90
91%__sed -i -e 's|Version: |Version: %{version}|g' \
92        Project/GNU/Library/libzen.pc
93%__install -dm 755 %{buildroot}%{_libdir}/pkgconfig
94%__install -m 644 Project/GNU/Library/libzen.pc \
95        %{buildroot}%{_libdir}/pkgconfig
96
97# remove unpackaged files
98rm -f ${RPM_BUILD_ROOT}/%{_libdir}/*.la
99
100
101%clean
102[ -d "%{buildroot}" -a "%{buildroot}" != "" ] && %__rm -rf "%{buildroot}"
103
104%post -n libzen -p /sbin/ldconfig
105
106%postun -n libzen -p /sbin/ldconfig
107
108%files
109%defattr(-,root,root,-)
110%doc History.txt License.txt ReadMe.txt
111%{_libdir}/libzen.so.*
112
113%files -n libzen-devel
114%defattr(-,root,root,-)
115%doc Documentation.html
116%doc Doc/*
117%dir %{_includedir}/ZenLib
118%{_includedir}/ZenLib/*
119%{_libdir}/libzen.so
120%{_libdir}/pkgconfig/*.pc
121
122%changelog
123* Tue Sep 27 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.22-1
124- new upstream release
125
126* Fri Jul 15 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.20-1
127- new upstream release
128
129* Sat Dec 25 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.17-1
130- new upstream release
131
132* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.15-4
133- rebuilt with rpm-4.8.1 for pkg-config
134
135* Sat Aug 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.15-3
136- fixed Group to System Environment/Libraries
137
138* Sat Jul 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.15-2
139- fix %install (add install directory)
140
141* Tue Jun 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15-1
142- new upstream release
143
144* Tue Jul 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.3-1
145- new upstream release
146- change spec file name to libzen-vl.spec
147- add japanese summary and description
148- change group for -devel sub package to Development/Libraries
149- add configure option --disable-static
150- remove unpackaged file (.la)
151- add Packager tag
152
153* Tue Jan 01 2009 Jerome Martinez <zen@mediaarea.net> - 0.3.6-0
154- See History.txt for more info and real dates
155- Previous packages made by Toni Graffy <toni@links2linux.de>
Note: See TracBrowser for help on using the repository browser.