source: projects/specs/trunk/lib/liby/libyaml/libyaml-vl.spec @ 12532

Revision 12532, 2.5 KB checked in by tomop, 3 years ago (diff)

updated 3 packages

libnetfilter_queue-1.0.5-1

libyaml-0.2.5-1

suricata-6.0.1-1

Line 
1Summary:        YAML 1.1 parser and emitter written in C
2Name:           libyaml
3Version:        0.2.5
4Release:        1%{?_dist_release}
5Group:          system
6Vendor:         Project Vine
7Distribution:   Vine Linux
8
9License:        MIT
10URL:            https://pyyaml.org/
11Source0:        http://pyyaml.org/download/libyaml/yaml-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13
14%description
15YAML is a data serialization format designed for human readability and
16interaction with scripting languages.  LibYAML is a YAML parser and
17emitter written in C.
18
19
20%package devel
21Summary:        Development libraries and headers for developing LibYAML applications
22Group:          programming
23Requires:       libyaml = %{version}-%{release}
24
25%description devel
26Development libraries and headers for developing LibYAML applications.
27
28
29%debug_package
30
31
32%prep
33%setup -q -n yaml-%{version}
34
35
36%build
37#./bootstrap
38%configure
39make %{?_smp_mflags}
40
41
42%install
43rm -rf %{buildroot}
44make DESTDIR=%{buildroot} INSTALL="install -p" install
45rm -f %{buildroot}%{_libdir}/*.{la,a}
46
47soname=$(readelf -d %{buildroot}%{_libdir}/libyaml.so | awk '$2 == "(SONAME)" {print $NF}' | tr -d '[]')
48rm -f %{buildroot}%{_libdir}/libyaml.so
49echo "INPUT($soname)" > %{buildroot}%{_libdir}/libyaml.so
50
51
52%check
53make check
54
55
56%clean
57rm -rf %{buildroot}
58
59
60%post -p /sbin/ldconfig
61%postun -p /sbin/ldconfig
62
63
64%files
65%defattr(-,root,root,-)
66%license LICENSE
67%doc README
68%{_libdir}/%{name}*.so.*
69
70%files devel
71%defattr(-,root,root,-)
72%doc doc/html
73%{_libdir}/%{name}*.so
74%{_libdir}/pkgconfig/yaml-0.1.pc
75%{_includedir}/yaml.h
76
77
78%changelog
79* Wed Feb 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.2.5-1
80- new upstream release.
81
82* Wed Oct 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.2.2-1
83- new upstream release.
84
85* Sun Oct 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.1.6-2
86- moved libyaml to System Environment/Libraries Group
87
88* Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.6-1
89- update to 0.1.6
90
91* Mon Mar 12 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.1.4-1
92- new upstream release
93
94* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.2-1
95- initial build for Vine Linux
96
97* Tue Mar 3 2009 John Eckersberg <jeckersb@redhat.com> - 0.1.2-3
98- Remove static libraries
99
100* Thu Feb 26 2009 John Eckersberg <jeckersb@redhat.com> - 0.1.2-2
101- Remove README and LICENSE from docs on -devel package
102- Remove -static package and merge contents into the -devel package
103
104* Wed Feb 25 2009 John Eckersberg <jeckersb@redhat.com> - 0.1.2-1
105- Initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.