source: projects/specs/trunk/lib/libx/libxslt/libxslt-vl.spec @ 5701

Revision 5701, 10.7 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Library providing the Gnome XSLT engine
4Summary(ja): XSLT エンジンライブラリ
5Name: libxslt
6Version: 1.1.26
7Release: 7%{_dist_release}
8License: MIT
9Group: System Environment/Libraries
10URL: http://xmlsoft.org/XSLT/
11Source0: ftp://xmlsoft.org/XSLT/%{name}-%{version}.tar.gz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: libxml2-devel >= 2.6.27
15BuildRequires: zlib-devel >= 1.1.4
16BuildRequires: python python-devel perl libxml2-python
17Requires: libxml2 >= 2.6.27
18
19%description
20This C library allows to transform XML files into other XML files
21(or HTML, text, ...) using the standard XSLT stylesheet transformation
22mechanism. To use it you need to have a version of libxml2 >= 2.6.15
23installed. The xsltproc command is a command line interface to the XSLT engine
24
25%description -l ja
26XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
27
28%package devel
29Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
30Summary(ja): XSLT 開発用ファイル
31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
33Requires: libxml2-devel >= 2.6.27
34
35%description devel
36This C library allows to transform XML files into other XML files
37(or HTML, text, ...) using the standard XSLT stylesheet transformation
38mechanism. To use it you need to have a version of libxml2 >= 2.6.15
39installed.
40
41%description devel -l ja
42XSLTのための開発用ファイルです。
43
44%package static
45Summary: Static library for %{name}
46Summary(ja): %{name} のスタティックライブラリ
47Group: Development/Libraries
48Requires: libxslt-devel = %{version}-%{release}
49
50%description static
51The libxslt-static package contains the static library for libxslt.
52
53%package python
54Summary: Python bindings for the libxslt library
55Group: Development/Libraries
56Requires: libxslt = %{version}-%{release}
57Requires: libxml2 >= 2.6.27
58Requires: python
59
60%description python
61The libxslt-python package contains a module that permits applications
62written in the Python programming language to use the interface
63supplied by the libxslt library to apply XSLT transformations.
64
65This library allows to parse sytlesheets, uses the libxml2-python
66to load and save XML and HTML files. Direct access to XPath and
67the XSLT transformation context are possible to extend the XSLT language
68with XPath functions written in Python.
69
70# compat32
71%package -n compat32-%{name}
72Summary: Library providing the Gnome XSLT engine
73Summary(ja): XSLT エンジンライブラリ
74Group: System Environment/Libraries
75Requires: %{name} = %{version}-%{release}
76Requires: compat32-libxml2 >= 2.6.27
77
78%description -n compat32-%{name}
79This C library allows to transform XML files into other XML files
80(or HTML, text, ...) using the standard XSLT stylesheet transformation
81mechanism. To use it you need to have a version of libxml2 >= 2.6.15
82installed. The xsltproc command is a command line interface to the XSLT engine
83
84%description -n compat32-%{name} -l ja
85XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
86
87%package -n compat32-%{name}-devel
88Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
89Summary(ja): XSLT 開発用ファイル
90Group: Development/Libraries
91Requires: %{name}-devel = %{version}-%{release}
92Requires: compat32-%{name} = %{version}-%{release}
93Requires: compat32-libxml2-devel >= 2.6.27
94
95%description -n compat32-%{name}-devel
96This C library allows to transform XML files into other XML files
97(or HTML, text, ...) using the standard XSLT stylesheet transformation
98mechanism. To use it you need to have a version of libxml2 >= 2.6.15
99installed.
100
101%description -n compat32-%{name}-devel -l ja
102XSLTのための開発用ファイルです。
103
104%prep
105%setup -q
106
107%build
108%configure --without-crypto
109make %{?_smp_mflags}
110
111%install
112[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
113
114make DESTDIR=$RPM_BUILD_ROOT install
115
116rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
117rm -f $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/*.{a,la}
118
119#
120# this is a bit ugly but tries to generate the bindings for all versions
121# of python installed
122#for i in %{prefix}/include/python*
123#do
124#    py_version=`echo $i | sed "s+%{prefix}/include/python++"`
125#    if test -x %{prefix}/bin/python$py_version
126#    then
127#        echo generating bindings for Python $py_version
128#        (cd python ; make clean ; \
129#         make PYTHON="%{prefix}/bin/python$py_version" \
130#              PYTHON_VERSION="$py_version"; \
131#         make PYTHON="%{prefix}/bin/python$py_version" \
132#              PYTHON_VERSION="$py_version" \
133#              prefix=$RPM_BUILD_ROOT%{prefix} \
134#              mandir=$RPM_BUILD_ROOT%{_mandir} install)
135#    fi
136#done
137
138%clean
139[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
140
141%post -p /sbin/ldconfig
142
143%postun -p /sbin/ldconfig
144
145%post -n compat32-%{name} -p /sbin/ldconfig
146
147%postun -n compat32-%{name} -p /sbin/ldconfig
148
149%files
150%defattr(-, root, root)
151%doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
152%doc doc/*.html doc/html doc/tutorial doc/EXSLT
153%{_bindir}/xsltproc
154%{_libdir}/lib*.so.*
155%{_mandir}/man1/xsltproc.1*
156
157%files devel
158%defattr(-, root, root)
159%doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
160%{_includedir}/*
161%{_libdir}/lib*.so
162%{_libdir}/*.sh
163%{_libdir}/pkgconfig/*.pc
164%{_bindir}/xslt-config
165%{_datadir}/aclocal/*.m4
166%{_mandir}/man3/*
167
168%files static
169%defattr(-, root, root)
170%{_libdir}/lib*.a
171
172%files python
173%defattr(-, root, root)
174%doc AUTHORS ChangeLog NEWS README Copyright FEATURES
175%doc python/TODO
176%doc python/libxsltclass.txt
177%doc python/tests/*.py
178%doc python/tests/*.xml
179%doc python/tests/*.xsl
180%{_libdir}/python*/site-packages/libxslt.py
181%{_libdir}/python*/site-packages/libxsltmod*
182
183# compat32
184%if %{build_compat32}
185%files -n compat32-%{name}
186%defattr(-, root, root)
187%{_libdir}/lib*.so.*
188
189%files -n compat32-%{name}-devel
190%defattr(-, root, root)
191%{_libdir}/lib*.so
192%{_libdir}/lib*.a
193%{_libdir}/*.sh
194%{_libdir}/pkgconfig/*.pc
195%endif
196
197%changelog
198* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.26-7
199- rebuild with python-2.7.2
200
201* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.1.26-6
202- build with rpm-4.8.1-1 for pkg-config file
203
204* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-5
205- rebuilt with gcc-4.4.3-3 on ppc
206
207* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-4
208- removed %%{_libdir}/python*/site-packages/*.{a,la}
209
210* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.26-3
211- rebuild with python-2.6
212
213* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-2
214- rebuilt with new toolchain
215
216* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-1
217- new upstream release
218- split static libraries to subpackage
219
220* Mon Jul 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.23-3
221- added compat32 package for x86_64 arch support
222
223* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.23-2
224- rebuilt with python-2.5.2
225
226* Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.23-1
227- new upstream release
228- remove *.la file from devel package
229
230* Wed Oct  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.22-0vl1
231- new upstream release
232
233* Sun Feb  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-0vl1
234- new upstream release
235- updated BuildRequires: libxml2-devel >= 2.6.27
236- updated Requires: libxml2 >= 2.6.27
237
238* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.17-0vl1
239- added --libdir=%%{_libdir} to ./configure option
240
241* Fri Jul 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.17-0vl1
242- new upstream release
243- updated libxml2 dependancy
244
245* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.15-0vl1
246- new upstream release
247
248* Tue Apr 12 2005 Satoshi MACHINO <machino@vinelinux.org> 1.1.14-0vl1
249- new upstream release
250
251* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 1.1.12-0vl3
252- rebuild with python-2.4.1-0vl1
253
254* Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl2
255- build without libgcrypt (add --without-crypto to configure option)
256- remove lines about snapshot release
257- use %%makeinstall
258- add %%{_libdir}/python*/site-packages/libxsltmod* to python package
259
260* Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl1
261- source upgrade (security fix)
262- BuildPrereq: libxml2-devel >= 2.6.15
263- Requires: libxml2 >= 2.6.15
264- add doc/EXSLT to %%doc
265
266* Tue Sep 07 2004 Satoshi MACHINO <machino@vinelinux.org> 1.1.9-0vl1
267- new upstream version
268
269* Tue Apr 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.6-0vl1
270- source upgrade
271- BuildPrereq: libxml2-devel >= 2.6.8
272- Requires: libxml2 >= 2.6.8
273
274* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl2
275- rebuild with python-2.3.3-0vl1
276
277* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl1.1
278- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
279
280* Thu Mar 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.4-0vl1
281- new upstream release
282
283* Thu Jan 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.2-0vl1
284- new upstream release
285- BuildPrereq: libxml2-devel >= 2.6.3
286- Requires: libxml2 >= 2.6.3
287
288* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.32-0vl1
289- new upstream release
290
291* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.31-0vl1
292- source upgrade
293
294* Sat May 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.30-0vl1
295- source upgrade
296
297* Tue Feb 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.26-0vl1
298- source upgrade
299- BuildPrereq: libxml2-devel >= 2.5.2
300- Requires: libxml2 >= 2.5.2
301
302* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.23-0vl1
303- source upgrade
304- build with new toolchains
305
306* Tue Oct 29 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-0vl1
307- source update to 1.0.22
308- BuildPrereq: libxml2-devel >= 2.4.23
309- Requires: libxml2 >= 2.4.23
310
311* Sun May 26 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.17-1vl1
312- merged with 1.0.17-1
313 -- Fri Feb  8 2002 Daniel.Veillard <veillard@redhat.com>
314  - added the python module
315- clean up spec
316- BuildPrereq: libxml2-devel >= 2.4.17
317- Requires: libxml2 >= 2.4.17
318
319* Mon Mar 18 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl2
320- changed License to MIT (not LGPL)
321- add BuildPrereq: zlib-devel >= 1.1.4 perl
322
323* Sun Feb 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl1
324- source update
325- BuildPrereq: libxml2-devel >= 2.4.13
326
327* Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.9-0vl1
328- add gtk-doc to BuildPrereq
329
330* Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com>
331- 1.0.1-1vl2
332- Build for VineSeed
333
334* Fri Aug 24 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
335- 1.0.1-1vl1
336- cleaning
337
338* Fri Jul 27 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
339- 1.0.1-1vl0
340- modify for Vine Linux 2.1x
341
342* Mon Jan 22 2001 Daniel.Veillard <daniel@veillard.com>
343- created based on libxml2 spec file
Note: See TracBrowser for help on using the repository browser.