source: projects/specs/trunk/lib/libx/libxslt/libxslt-vl.spec @ 9791

Revision 9791, 11.2 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Library providing the Gnome XSLT engine
4Summary(ja): XSLT エンジンライブラリ
5Name: libxslt
6Version: 1.1.28
7Release: 2%{_dist_release}
8License: MIT
9Group: System Environment/Libraries
10URL: http://xmlsoft.org/XSLT/
11Source0: ftp://xmlsoft.org/XSLT/%{name}-%{version}.tar.gz
12
13# from upstream
14Patch0: libxslt-1.1.28-CVE-2015-7995.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: libxml2-devel >= 2.6.27
18BuildRequires: zlib-devel >= 1.1.4
19BuildRequires: python python-devel perl libxml2-python
20Requires: libxml2 >= 2.6.27
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26This C library allows to transform XML files into other XML files
27(or HTML, text, ...) using the standard XSLT stylesheet transformation
28mechanism. To use it you need to have a version of libxml2 >= 2.6.15
29installed. The xsltproc command is a command line interface to the XSLT engine
30
31%description -l ja
32XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
33
34%package devel
35Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
36Summary(ja): XSLT 開発用ファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: libxml2-devel >= 2.6.27
40
41%description devel
42This C library allows to transform XML files into other XML files
43(or HTML, text, ...) using the standard XSLT stylesheet transformation
44mechanism. To use it you need to have a version of libxml2 >= 2.6.15
45installed.
46
47%description devel -l ja
48XSLTのための開発用ファイルです。
49
50%package static
51Summary: Static library for %{name}
52Summary(ja): %{name} のスタティックライブラリ
53Group: Development/Libraries
54Requires: libxslt-devel = %{version}-%{release}
55
56%description static
57The libxslt-static package contains the static library for libxslt.
58
59%package python
60Summary: Python bindings for the libxslt library
61Group: Development/Libraries
62Requires: libxslt = %{version}-%{release}
63Requires: libxml2 >= 2.6.27
64Requires: python
65
66%description python
67The libxslt-python package contains a module that permits applications
68written in the Python programming language to use the interface
69supplied by the libxslt library to apply XSLT transformations.
70
71This library allows to parse sytlesheets, uses the libxml2-python
72to load and save XML and HTML files. Direct access to XPath and
73the XSLT transformation context are possible to extend the XSLT language
74with XPath functions written in Python.
75
76# compat32
77%package -n compat32-%{name}
78Summary: Library providing the Gnome XSLT engine
79Summary(ja): XSLT エンジンライブラリ
80Group: System Environment/Libraries
81Requires: %{name} = %{version}-%{release}
82Requires: compat32-libxml2 >= 2.6.27
83
84%description -n compat32-%{name}
85This C library allows to transform XML files into other XML files
86(or HTML, text, ...) using the standard XSLT stylesheet transformation
87mechanism. To use it you need to have a version of libxml2 >= 2.6.15
88installed. The xsltproc command is a command line interface to the XSLT engine
89
90%description -n compat32-%{name} -l ja
91XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
92
93%package -n compat32-%{name}-devel
94Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
95Summary(ja): XSLT 開発用ファイル
96Group: Development/Libraries
97Requires: %{name}-devel = %{version}-%{release}
98Requires: compat32-%{name} = %{version}-%{release}
99Requires: compat32-libxml2-devel >= 2.6.27
100
101%description -n compat32-%{name}-devel
102This C library allows to transform XML files into other XML files
103(or HTML, text, ...) using the standard XSLT stylesheet transformation
104mechanism. To use it you need to have a version of libxml2 >= 2.6.15
105installed.
106
107%description -n compat32-%{name}-devel -l ja
108XSLTのための開発用ファイルです。
109
110%prep
111%setup -q
112%patch0 -p1 -b .CVE-2015-7995
113
114%build
115%configure --without-crypto
116make %{?_smp_mflags}
117
118%install
119[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
120
121make DESTDIR=$RPM_BUILD_ROOT install
122
123rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
124rm -f $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/*.{a,la}
125
126#
127# this is a bit ugly but tries to generate the bindings for all versions
128# of python installed
129#for i in %{prefix}/include/python*
130#do
131#    py_version=`echo $i | sed "s+%{prefix}/include/python++"`
132#    if test -x %{prefix}/bin/python$py_version
133#    then
134#        echo generating bindings for Python $py_version
135#        (cd python ; make clean ; \
136#         make PYTHON="%{prefix}/bin/python$py_version" \
137#              PYTHON_VERSION="$py_version"; \
138#         make PYTHON="%{prefix}/bin/python$py_version" \
139#              PYTHON_VERSION="$py_version" \
140#              prefix=$RPM_BUILD_ROOT%{prefix} \
141#              mandir=$RPM_BUILD_ROOT%{_mandir} install)
142#    fi
143#done
144
145%clean
146[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
147
148%post -p /sbin/ldconfig
149
150%postun -p /sbin/ldconfig
151
152%post -n compat32-%{name} -p /sbin/ldconfig
153
154%postun -n compat32-%{name} -p /sbin/ldconfig
155
156%files
157%defattr(-, root, root)
158%doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
159%doc doc/*.html doc/html doc/tutorial doc/EXSLT
160%{_bindir}/xsltproc
161%{_libdir}/lib*.so.*
162%{_mandir}/man1/xsltproc.1*
163
164%files devel
165%defattr(-, root, root)
166%doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
167%{_includedir}/*
168%{_libdir}/lib*.so
169%{_libdir}/*.sh
170%{_libdir}/pkgconfig/*.pc
171%{_bindir}/xslt-config
172%{_datadir}/aclocal/*.m4
173%{_mandir}/man3/*
174
175%files static
176%defattr(-, root, root)
177%{_libdir}/lib*.a
178
179%files python
180%defattr(-, root, root)
181%doc AUTHORS ChangeLog NEWS README Copyright FEATURES
182%doc python/TODO
183%doc python/libxsltclass.txt
184%doc python/tests/*.py
185%doc python/tests/*.xml
186%doc python/tests/*.xsl
187%{_libdir}/python*/site-packages/libxslt.py
188%{_libdir}/python*/site-packages/libxsltmod*
189
190# compat32
191%if %{build_compat32}
192%files -n compat32-%{name}
193%defattr(-, root, root)
194%{_libdir}/lib*.so.*
195
196%files -n compat32-%{name}-devel
197%defattr(-, root, root)
198%{_libdir}/lib*.so
199%{_libdir}/lib*.a
200%{_libdir}/*.sh
201%endif
202
203%changelog
204* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.28-2
205- add Patch0 (libxslt-1.1.28-CVE-2015-7995.patch)
206
207* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.28-1
208- update to 1.1.28
209
210* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.27-2
211- rebuild with VineSeed environment
212
213* Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.27-1
214- new upstream release
215
216* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.26-7
217- rebuild with python-2.7.2
218
219* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.1.26-6
220- build with rpm-4.8.1-1 for pkg-config file
221
222* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-5
223- rebuilt with gcc-4.4.3-3 on ppc
224
225* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-4
226- removed %%{_libdir}/python*/site-packages/*.{a,la}
227
228* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.26-3
229- rebuild with python-2.6
230
231* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-2
232- rebuilt with new toolchain
233
234* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-1
235- new upstream release
236- split static libraries to subpackage
237
238* Mon Jul 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.23-3
239- added compat32 package for x86_64 arch support
240
241* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.23-2
242- rebuilt with python-2.5.2
243
244* Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.23-1
245- new upstream release
246- remove *.la file from devel package
247
248* Wed Oct  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.22-0vl1
249- new upstream release
250
251* Sun Feb  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-0vl1
252- new upstream release
253- updated BuildRequires: libxml2-devel >= 2.6.27
254- updated Requires: libxml2 >= 2.6.27
255
256* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.17-0vl1
257- added --libdir=%%{_libdir} to ./configure option
258
259* Fri Jul 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.17-0vl1
260- new upstream release
261- updated libxml2 dependancy
262
263* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.15-0vl1
264- new upstream release
265
266* Tue Apr 12 2005 Satoshi MACHINO <machino@vinelinux.org> 1.1.14-0vl1
267- new upstream release
268
269* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 1.1.12-0vl3
270- rebuild with python-2.4.1-0vl1
271
272* Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl2
273- build without libgcrypt (add --without-crypto to configure option)
274- remove lines about snapshot release
275- use %%makeinstall
276- add %%{_libdir}/python*/site-packages/libxsltmod* to python package
277
278* Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl1
279- source upgrade (security fix)
280- BuildPrereq: libxml2-devel >= 2.6.15
281- Requires: libxml2 >= 2.6.15
282- add doc/EXSLT to %%doc
283
284* Tue Sep 07 2004 Satoshi MACHINO <machino@vinelinux.org> 1.1.9-0vl1
285- new upstream version
286
287* Tue Apr 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.6-0vl1
288- source upgrade
289- BuildPrereq: libxml2-devel >= 2.6.8
290- Requires: libxml2 >= 2.6.8
291
292* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl2
293- rebuild with python-2.3.3-0vl1
294
295* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl1.1
296- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
297
298* Thu Mar 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.4-0vl1
299- new upstream release
300
301* Thu Jan 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.2-0vl1
302- new upstream release
303- BuildPrereq: libxml2-devel >= 2.6.3
304- Requires: libxml2 >= 2.6.3
305
306* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.32-0vl1
307- new upstream release
308
309* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.31-0vl1
310- source upgrade
311
312* Sat May 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.30-0vl1
313- source upgrade
314
315* Mon Feb 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.26-0vl1
316- source upgrade
317- BuildPrereq: libxml2-devel >= 2.5.2
318- Requires: libxml2 >= 2.5.2
319
320* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.23-0vl1
321- source upgrade
322- build with new toolchains
323
324* Tue Oct 29 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-0vl1
325- source update to 1.0.22
326- BuildPrereq: libxml2-devel >= 2.4.23
327- Requires: libxml2 >= 2.4.23
328
329* Sun May 26 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.17-1vl1
330- merged with 1.0.17-1
331 -- Fri Feb  8 2002 Daniel.Veillard <veillard@redhat.com>
332  - added the python module
333- clean up spec
334- BuildPrereq: libxml2-devel >= 2.4.17
335- Requires: libxml2 >= 2.4.17
336
337* Mon Mar 18 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl2
338- changed License to MIT (not LGPL)
339- add BuildPrereq: zlib-devel >= 1.1.4 perl
340
341* Sun Feb 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl1
342- source update
343- BuildPrereq: libxml2-devel >= 2.4.13
344
345* Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.9-0vl1
346- add gtk-doc to BuildPrereq
347
348* Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com>
349- 1.0.1-1vl2
350- Build for VineSeed
351
352* Fri Aug 24 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
353- 1.0.1-1vl1
354- cleaning
355
356* Fri Jul 27 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
357- 1.0.1-1vl0
358- modify for Vine Linux 2.1x
359
360* Mon Jan 22 2001 Daniel.Veillard <daniel@veillard.com>
361- created based on libxml2 spec file
Note: See TracBrowser for help on using the repository browser.