source: projects/specs/trunk/lib/libx/libxml/libxml-vl.spec @ 521

Revision 521, 4.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Note that this is NOT a relocatable package
2%define ver     1.8.17
3%define rel     2%{?_dist_release}
4%define name    libxml
5
6Summary:        An XML library
7Summary(ja):    XMLライブラリ
8Name:           %name
9Version:        %ver
10Release:        %rel
11License:        LGPL
12Group:          System Environment/Libraries
13Source:         ftp://ftp.gnome.org/pub/GNOME/sources/libxml/1.8/%{name}-%{ver}.tar.bz2
14Patch0:         libxml-1.8.6-zlib_fixed.patch
15Patch100:       CAN-2004-0110.patch
16Patch110:       libxml-1.8.17_CVE-2009-2414-2416.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  zlib-devel
20URL:            http://www.gnome.org
21
22%description
23The libxml package contains an XML library, which allows you to
24manipulate XML files. XML (eXtensible Markup Language) is a data
25format for structured document interchange via the Web.
26
27%description -l ja
28libxmlパッケージは XMLファイルを操作するためのXMLライブラリを備
29えています. XML (eXtensible Markup Language)は、
30ウェブ経由でデータを交換するための構造化された形式です。
31
32
33%package devel
34Summary:        Libraries, includes and other files to develop libxml applications.
35Group:          Development/Libraries
36Requires:       %{name} = %{version}-%{release}
37Requires:       zlib-devel
38
39%description devel
40The libxml-devel package contains the libraries, include and other
41files you can use to develop libxml applications.
42
43%description devel -l ja
44libxml-develパッケージはlibxmlアプリケーションを開発するのに利用する
45ライブラリやヘッダファイルを含んでいます。
46
47
48%prep
49%setup -q
50%patch0 -p1
51
52%patch100 -p1 -b .CAN-2004-0110
53%patch110 -p0 -b .CVE-2009-2414-2416
54
55%build
56%configure
57make
58
59%install
60[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
61
62%makeinstall
63
64
65%clean
66[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
67
68
69%post -p /sbin/ldconfig
70
71%postun -p /sbin/ldconfig
72
73
74%files
75%defattr(-, root, root)
76
77%doc AUTHORS ChangeLog NEWS README COPYING COPYING.LIB TODO
78%doc doc/html
79%{_libdir}/*.so.*
80
81
82%files devel
83%defattr(-, root, root)
84%docdir %{_datadir}/gnome-xml/html
85%{_datadir}/gnome-xml
86
87%defattr(-, root, root)
88%{_bindir}/xml-config
89
90%{_libdir}/*.so
91%{_libdir}/*.a
92%{_libdir}/*.la
93%{_libdir}/*.sh
94%{_libdir}/pkgconfig
95%{_includedir}/*
96
97
98%changelog
99* Wed Aug 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.8.17-2vl5
100- add patch100 for fix CAN-2004-0110 (from RHEL3)
101- add patch110 for fix CVE-2009-2414-2416 (from RHEL3)
102
103* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.8.17-1vl5
104- applied new versioning policy, spec in utf-8
105
106* Sun Jun 03 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.17-0vl6
107- rebuilt with new toolchain
108- remove PreReq: install-info
109
110* Sun Feb 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.8.17-0vl5
111- rebuild
112- add PreReq: install-info instead of /sbin/install-info
113- contain %%{_libdir}/pkgconfig/*.pc instead of %%{_libdir}/pkgconfig
114
115* Wed Jul 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.8.17-0vl4
116- rebuild
117
118* Sun Apr 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.17-0vl3
119- fix %doc (removed Docdir: /usr/doc)
120
121* Fri Apr 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.17-0vl2
122- fix to contain %{_libdir}/pkgconfig
123
124* Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.17-0vl1
125- rebuild with new toolchains
126- updated to 1.8.17
127
128* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.16-0vl1
129- updated in sync with the new upstream 1.8.16 release
130
131* Sun Jul 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
132- 1.8.14-0vl1
133- updated in sync with the new upstream 1.8.14 release
134
135* Wed Mar  7 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.8.11-0vl1
136- New upstream release.
137
138* Thu Dec 28 2000 Akira TAGOH <tagoh@gnome.gr.jp>
139- 1.8.10-0vl1
140- updated to 1.8.10
141
142* Mon Aug 14 2000 Yoshihiro Kajiki <kajiki@ylug.org>
143- updated to 1.8.9
144
145* Tue May 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
146- updated to 1.8.7
147
148* Wed Feb  9 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
149- updated to 1.8.6
150
151* Mon Jan 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
152- updated to 1.8.4
153
154* Mon Jan 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
155- added zlib_fixed patch for small bug in macro.
156
157* Sun Jan 9 2000 Kazuhito Nishi <nishi@imasy.or.jp>
158- version 1.8.3
159
160* Sat Oct 16 1999 Kazuhito Nishi <nishi@imasy.or.jp>
161- modified spec file, %description, %files
162
163* Sat Sep 18 1999 Kazuhito Nishi <nishi@imasy.or.jp>
164- First try at a spec file for Vine
Note: See TracBrowser for help on using the repository browser.