source: projects/specs/trunk/lib/libx/libxml++/libxml++-vl.spec @ 1901

Revision 1901, 5.8 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%global         apiver 2.6
2Name:           libxml++
3Version:        2.30.0
4Release:        3%{?_dist_release}
5Summary:        C++ wrapper for the libxml2 XML parser library
6
7Group:          System Environment/Libraries
8License:        LGPLv2+
9URL:            http://libxmlplusplus.sourceforge.net/
10
11Source:         http://ftp.gnome.org/pub/GNOME/sources/libxml++/2.26/libxml++-%{version}.tar.bz2
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14BuildRequires:  libxml2-devel >= 2.6.1
15BuildRequires:  glibmm-devel >= 2.4.0
16BuildRequires:  doxygen, graphviz
17
18%description
19libxml++ is a C++ wrapper for the libxml2 XML parser library. It's original
20author is Ari Johnson and it is currently maintained by Christophe de Vienne
21and Murray Cumming.
22
23
24%package devel
25Summary:        Development files for %{name}
26Group:          Development/Libraries
27Requires:       %{name} = %{version}-%{release}
28Requires:       pkgconfig, libxml2-devel, glibmm-devel
29
30%description devel
31This package contains the headers and libraries for libxml++ development.
32
33
34%prep
35%setup -q
36# fix wrong end of line
37sed -i s'#\r##' examples/dom_parser/example_with_namespace.xml
38
39%build
40%configure --disable-static
41make %{?_smp_mflags}
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46%makeinstall
47find $RPM_BUILD_ROOT -name "*.la" -o -name '*.a' | xargs rm -f
48# Modify temporary working directories for files section.
49rm -rf _reference _examples _manual
50mkdir -m 755 _reference _examples _manual
51cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{apiver}/reference/html _reference/reference
52#cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{apiver}/manual _manual/manual
53mv docs/manual/html _manual/manual
54rm -rf $RPM_BUILD_ROOT%{_docdir}
55cp -a examples _examples/examples
56
57# Delete non-working makefiles, object files, prebuilt binaries and
58# empty files.
59find _examples -type f -a \( -name Makefile\* -o -name \*.o \
60    -o \( -name example -a -perm +0111 \) -o -empty \) | xargs rm -f
61find _examples -type d -name '*.libs' -o -name '.deps' | xargs rm -rf
62# fix devhelp index file
63sed -i "s#"$RPM_BUILD_ROOT"##g" \
64        $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-%{apiver}/%{name}-%{apiver}.devhelp2
65sed -i "s#"/%{name}-%{apiver}/reference/html"#"/%{name}-devel-%{version}/reference"#" \
66        $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-%{apiver}/%{name}-%{apiver}.devhelp2
67
68
69%post -p /sbin/ldconfig
70
71
72%postun -p /sbin/ldconfig
73
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78
79%files
80%defattr (-,root,root,-)
81%doc AUTHORS COPYING NEWS README ChangeLog
82%{_libdir}/*.so.*
83
84
85%files devel
86%defattr (-,root,root,-)
87%doc _examples/examples _reference/reference _manual/manual
88%{_includedir}/*
89%{_libdir}/*.so
90%{_libdir}/pkgconfig/*
91%dir %{_libdir}/%{name}-%{apiver}
92%dir %{_libdir}/%{name}-%{apiver}/include
93%{_libdir}/%{name}-%{apiver}/include/*.h
94%{_datadir}/devhelp/books/%{name}-%{apiver}/%{name}-%{apiver}.devhelp2
95
96%changelog
97* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-3
98- rebuild with rpm-4.8.1 for pkg-config file
99
100* Thu Sep  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.30.0-2
101- Initial build for VineLinux
102
103* Fri Apr 09 2010 Haïkel Guémar <hguemar@gmail.com> - 2.30.0-1
104- Update to upstream 2.30.0
105
106* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.26.0-2
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
108
109* Sun Apr 12 2009 Denis Leroy <denis@poolshark.org> - 2.26.0-1
110- Update to upstream 2.26.0 (to match Gnome release)
111
112* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.24.2-2
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
114
115* Thu Jan 15 2009 Denis Leroy <denis@poolshark.org> - 2.24.2-1
116- Update to 2.24.2 (memleak fixes)
117- Fixed Gnome FTP URL
118
119* Fri Aug 29 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 2.23.2-2
120- Include unowned directories
121
122* Tue Aug  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.23.2-1
123- update to 2.23.2
124
125* Tue May 13 2008 Denis Leroy <denis@poolshark.org>
126- Removed unneeded example binaries from devel package
127
128* Thu Mar 13 2008 Denis Leroy <denis@poolshark.org> - 2.22.0-1
129- Update to upstream 2.22.0
130- GCC 4.3 patch upstreamed
131
132* Sun Feb 17 2008 Denis Leroy <denis@poolshark.org> - 2.20.0-2
133- Added patch for gcc 4.3 rebuild
134
135* Thu Sep 20 2007 Denis Leroy <denis@poolshark.org> - 2.20.0-1
136- Update to new 2.20 stable branch
137
138* Thu Aug 16 2007 Denis Leroy <denis@poolshark.org> - 2.18.2-2
139- Update to upstream 2.18.2 (mem leak fix)
140- Fixed License tag
141
142* Wed Jul 25 2007 Jesse Keating <jkeating@redhat.com> - 2.18.1-2
143- Rebuild for RH #249435
144
145* Tue Jul 24 2007 Denis Leroy <denis@poolshark.org> - 2.18.1-1
146- Update to version 2.18.1
147
148* Sun Sep 03 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 2.14.0-1.1
149- FC6 rebuild
150
151* Tue May 02 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 2.14.0-1
152- Version 2.14.0
153
154* Mon Feb 13 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 2.12.0-2.1
155- FC5 Rebuild
156
157* Thu Jan 26 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 2.12.0-2
158- Rebuilt to address RH #178592
159
160* Thu Sep 08 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 2.12.0-1
161- Version 2.12.0
162- Use --disable-static for configure.
163
164* Thu Jul 21 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 2.10.0-1
165- Version 2.10.0
166- Rearrange and conform to new FE standards
167- Buildrequire glibmm24-devel
168- Add devel requires to -devel
169
170* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 0.26.0-5
171- rebuild on all arches
172
173* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
174- rebuilt
175
176* Tue Nov 04 2003 Panu Matilainen <pmatilai@welho.com> - 0:0:26.0-0.fdr.3
177- remove empty .libs directories
178
179* Mon Nov  3 2003 Michael Schwendt <mschwendt[AT]users.sf.net> - 0:0.26.0-0.fdr.2
180- buildrequires graphviz
181- devel package requires main package and pkgconfig
182- own %%_includedir/libxml++-1.0
183- clean up examples tree
184
185* Tue Oct 21 2003 Panu Matilainen <pmatilai@welho.com>
186- Initial Fedora packaging
187
Note: See TracBrowser for help on using the repository browser.