source: projects/specs/trunk/lib/libx/libxcb/libxcb-vl.spec @ 8064

Revision 8064, 6.1 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define xpyb_version 1.2
4
5Summary:        A C binding to the X11 protocol
6Summary(ja):    X11 プロトコルの C による実装
7Name:           libxcb
8Version:        1.10
9Release:        1%{?_dist_release}
10
11Group:          System Environment/Libraries
12License:        MIT
13URL:            http://xcb.freedesktop.org/
14Source0:        http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.bz2
15# This is stolen straight from the pthread-stubs source:
16# http://cgit.freedesktop.org/xcb/pthread-stubs/blob/?id=6900598192bacf5fd9a34619b11328f746a5956d
17# we don't need the library because glibc has working pthreads, but we need
18# the pkgconfig file so libs that link against libxcb know this...
19Source1:        pthread-stubs.pc.in
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires:  autoconf automake libtool pkgconfig
23#BuildRequires:  doxygen
24#BuildRequires:  graphviz
25BuildRequires:  libXau-devel
26BuildRequires:  libxslt
27BuildRequires:  xcb-proto >= 1.6
28BuildRequires:  xorg-x11-proto-devel
29BuildRequires:  xorg-x11-util-macros
30BuildRequires:  python-devel
31
32Obsoletes:      %{name}-python < 1.8
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: Takemikaduchi
37
38%description
39The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
40small footprint, latency hiding, direct access to the protocol, improved
41threading support, and extensibility.
42
43%package        devel
44Summary:        Development files for %{name}
45Group:          Development/Libraries
46Requires:       %{name} = %{version}-%{release}
47Requires:       pkgconfig
48
49%description    devel
50The %{name}-devel package contains libraries and header files for
51developing applications that use %{name}.
52
53%package        doc
54Summary:        Documentation for %{name}
55Group:          Documentation
56
57%description    doc
58The %{name}-doc package contains documentation for the %{name} library.
59
60%package        -n compat32-%{name}
61Summary:        A C binding to the X11 protocol
62Summary(ja):    X11 プロトコルの C による実装
63Group:          System Environment/Libraries
64
65%description    -n compat32-%{name}
66The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
67small footprint, latency hiding, direct access to the protocol, improved
68threading support, and extensibility.
69
70%package        -n compat32-%{name}-devel
71Summary:        Development files for %{name}
72Group:          Development/Libraries
73Requires:       compat32-%{name} = %{version}-%{release}
74Requires:       %{name}-devel = %{version}-%{release}
75
76%description    -n compat32-%{name}-devel
77The %{name}-devel package contains libraries and header files for
78developing applications that use %{name}.
79
80%prep
81%setup -q
82
83%build
84sed -i 's/pthread-stubs //' configure.ac
85autoreconf -v --install
86%configure --disable-static \
87           --docdir=%{_datadir}/doc/%{name}-%{version} \
88           --disable-selinux \
89           --enable-xkb \
90           --disable-xprint
91make %{?_smp_mflags}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95make install DESTDIR=$RPM_BUILD_ROOT
96find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f
97install -m 644 COPYING NEWS README $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
98
99sed 's,@libdir@,%{_libdir},;s,@prefix@,%{_prefix},;s,@exec_prefix@,%{_exec_prefix},' %{SOURCE1} > $RPM_BUILD_ROOT%{_libdir}/pkgconfig/pthread-stubs.pc
100
101find $RPM_BUILD_ROOT -name '*.la' -delete
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -p /sbin/ldconfig
107%postun -p /sbin/ldconfig
108
109%post -n compat32-%{name} -p /sbin/ldconfig
110%postun -n compat32-%{name} -p /sbin/ldconfig
111
112%files
113%defattr(-,root,root,-)
114%{_libdir}/*.so.*
115
116%files devel
117%defattr(-,root,root,-)
118%{_includedir}/xcb
119%{_libdir}/*.so
120%{_libdir}/pkgconfig/*.pc
121
122%files doc
123%defattr(-,root,root,-)
124%{_datadir}/doc/%{name}-%{version}
125%{_mandir}/man3/*
126
127%if %{build_compat32}
128%files -n compat32-%{name}
129%defattr(-,root,root,-)
130%{_libdir}/*.so.*
131
132%files  -n compat32-%{name}-devel
133%defattr(-,root,root,-)
134%{_libdir}/*.so
135%endif
136
137%changelog
138* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10-1
139- new upstream release
140
141* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.1-1
142- new upstream release
143  (including security fix for CVE-2013-2064)
144
145* Sat Nov 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-2
146- add Source1: pthread-stubs.pc, remove patch10
147
148* Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9-1
149- new upstream release
150
151* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
152- new upstream release
153- update Patch10 (libxcb-1.8.1-no-pthread-stubs.patch)
154
155* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8-1
156- new upstream release
157- remove Source2
158- remove python sub package
159
160* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7-1
161- new upstream release
162- update Patch10
163
164* Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-3
165- add BuildRequires: python-devel
166
167* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.5-2
168- build with rpm-4.8.1-1 for pkg-config file
169
170* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-1
171- new upstream release
172
173* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.4-2
174- rebuild with python-2.6
175
176* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-1
177- new upstream release
178- add libxcb python binding (xpyb)
179
180* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-2
181- added compat32 package for x86_64 arch support
182
183* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
184- new upstream release
185
186* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.1-2
187- spec in utf-8
188- added japanese summary
189
190* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
191- new versioning policy
192
193* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
194- initial build for Vine Linux
195
196* Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 1.1-1
197- libxcb 1.1
198
199* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> 1.0-3
200- libxcb-1.0-abstract-socket.patch: When connecting to the X server, prefer
201  abstract-namespace unix sockets to filesystem-bound sockets.
202
203* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0-2
204- Rebuild for PPC toolchain bug
205
206* Fri Jun 29 2007 Adam Jackson <ajax@redhat.com> 1.0-1
207- Initial revision.
Note: See TracBrowser for help on using the repository browser.