source: projects/specs/trunk/lib/libx/libxcb/libxcb-vl.spec @ 7123

Revision 7123, 5.8 KB checked in by daisuke, 12 years ago (diff)

libxcb: add pthread-stubs.pc

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define xpyb_version 1.2
4
5Summary:        A C binding to the X11 protocol
6Summary(ja):    X11 プロトコルの C による実装
7Name:           libxcb
8Version:        1.9
9Release:        2%{?_dist_release}
10
11Group:          System Environment/Libraries
12License:        MIT
13URL:            http://xcb.freedesktop.org/
14Source0:        http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.bz2
15# This is stolen straight from the pthread-stubs source:
16# http://cgit.freedesktop.org/xcb/pthread-stubs/blob/?id=6900598192bacf5fd9a34619b11328f746a5956d
17# we don't need the library because glibc has working pthreads, but we need
18# the pkgconfig file so libs that link against libxcb know this...
19Source1:        pthread-stubs.pc.in
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires:  autoconf automake libtool pkgconfig
23#BuildRequires:  doxygen
24#BuildRequires:  graphviz
25BuildRequires:  libXau-devel
26BuildRequires:  libxslt
27BuildRequires:  xcb-proto >= 1.6
28BuildRequires:  xorg-x11-proto-devel
29BuildRequires:  xorg-x11-util-macros
30BuildRequires:  python-devel
31
32Obsoletes:      %{name}-python < 1.8
33
34%description
35The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
36small footprint, latency hiding, direct access to the protocol, improved
37threading support, and extensibility.
38
39%package        devel
40Summary:        Development files for %{name}
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43Requires:       pkgconfig
44
45%description    devel
46The %{name}-devel package contains libraries and header files for
47developing applications that use %{name}.
48
49%package        doc
50Summary:        Documentation for %{name}
51Group:          Documentation
52
53%description    doc
54The %{name}-doc package contains documentation for the %{name} library.
55
56%package        -n compat32-%{name}
57Summary:        A C binding to the X11 protocol
58Summary(ja):    X11 プロトコルの C による実装
59Group:          System Environment/Libraries
60
61%description    -n compat32-%{name}
62The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
63small footprint, latency hiding, direct access to the protocol, improved
64threading support, and extensibility.
65
66%package        -n compat32-%{name}-devel
67Summary:        Development files for %{name}
68Group:          Development/Libraries
69Requires:       compat32-%{name} = %{version}-%{release}
70Requires:       %{name}-devel = %{version}-%{release}
71
72%description    -n compat32-%{name}-devel
73The %{name}-devel package contains libraries and header files for
74developing applications that use %{name}.
75
76%prep
77%setup -q
78
79%build
80sed -i 's/pthread-stubs //' configure.ac
81autoreconf -v --install
82%configure --disable-static \
83           --docdir=%{_datadir}/doc/%{name}-%{version} \
84           --disable-selinux \
85           --enable-xkb \
86           --disable-xprint
87make %{?_smp_mflags}
88
89%install
90rm -rf $RPM_BUILD_ROOT
91make install DESTDIR=$RPM_BUILD_ROOT
92find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f
93install -m 644 COPYING NEWS README $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
94
95sed 's,@libdir@,%{_libdir},;s,@prefix@,%{_prefix},;s,@exec_prefix@,%{_exec_prefix},' %{SOURCE1} > $RPM_BUILD_ROOT%{_libdir}/pkgconfig/pthread-stubs.pc
96
97find $RPM_BUILD_ROOT -name '*.la' -delete
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post -p /sbin/ldconfig
103%postun -p /sbin/ldconfig
104
105%post -n compat32-%{name} -p /sbin/ldconfig
106%postun -n compat32-%{name} -p /sbin/ldconfig
107
108%files
109%defattr(-,root,root,-)
110%{_libdir}/*.so.*
111
112%files devel
113%defattr(-,root,root,-)
114%{_includedir}/xcb
115%{_libdir}/*.so
116%{_libdir}/pkgconfig/*.pc
117
118%files doc
119%defattr(-,root,root,-)
120%{_datadir}/doc/%{name}-%{version}
121%{_mandir}/man3/*
122
123%if %{build_compat32}
124%files -n compat32-%{name}
125%defattr(-,root,root,-)
126%{_libdir}/*.so.*
127
128%files  -n compat32-%{name}-devel
129%defattr(-,root,root,-)
130%{_libdir}/*.so
131%endif
132
133%changelog
134* Sat Nov 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-2
135- add Source1: pthread-stubs.pc, remove patch10
136
137* Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9-1
138- new upstream release
139
140* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
141- new upstream release
142- update Patch10 (libxcb-1.8.1-no-pthread-stubs.patch)
143
144* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8-1
145- new upstream release
146- remove Source2
147- remove python sub package
148
149* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7-1
150- new upstream release
151- update Patch10
152
153* Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-3
154- add BuildRequires: python-devel
155
156* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.5-2
157- build with rpm-4.8.1-1 for pkg-config file
158
159* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-1
160- new upstream release
161
162* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.4-2
163- rebuild with python-2.6
164
165* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-1
166- new upstream release
167- add libxcb python binding (xpyb)
168
169* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-2
170- added compat32 package for x86_64 arch support
171
172* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
173- new upstream release
174
175* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.1-2
176- spec in utf-8
177- added japanese summary
178
179* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
180- new versioning policy
181
182* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
183- initial build for Vine Linux
184
185* Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 1.1-1
186- libxcb 1.1
187
188* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> 1.0-3
189- libxcb-1.0-abstract-socket.patch: When connecting to the X server, prefer
190  abstract-namespace unix sockets to filesystem-bound sockets.
191
192* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0-2
193- Rebuild for PPC toolchain bug
194
195* Fri Jun 29 2007 Adam Jackson <ajax@redhat.com> 1.0-1
196- Initial revision.
Note: See TracBrowser for help on using the repository browser.