source: projects/specs/trunk/lib/libx/libxcb/libxcb-vl.spec @ 5549

Revision 5549, 4.9 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define xpyb_version 1.2
4
5Summary:        A C binding to the X11 protocol
6Summary(ja):    X11 プロトコルの C による実装
7Name:           libxcb
8Version:        1.8
9Release:        1%{?_dist_release}
10
11Group:          System Environment/Libraries
12License:        MIT
13URL:            http://xcb.freedesktop.org/
14Source0:        http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.bz2
15
16Patch10:        libxcb-1.7-no-pthread-stubs.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires:  autoconf automake libtool pkgconfig
20#BuildRequires:  doxygen
21#BuildRequires:  graphviz
22BuildRequires:  libXau-devel
23BuildRequires:  libxslt
24BuildRequires:  xcb-proto >= 1.6
25BuildRequires:  xorg-x11-proto-devel
26BuildRequires:  xorg-x11-util-macros
27BuildRequires:  python-devel
28
29Obsoletes:      %{name}-python < 1.8
30
31%description
32The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
33small footprint, latency hiding, direct access to the protocol, improved
34threading support, and extensibility.
35
36%package        devel
37Summary:        Development files for %{name}
38Group:          Development/Libraries
39Requires:       %{name} = %{version}-%{release}
40Requires:       pkgconfig
41
42%description    devel
43The %{name}-devel package contains libraries and header files for
44developing applications that use %{name}.
45
46%package        doc
47Summary:        Documentation for %{name}
48Group:          Documentation
49
50%description    doc
51The %{name}-doc package contains documentation for the %{name} library.
52
53%package        -n compat32-%{name}
54Summary:        A C binding to the X11 protocol
55Summary(ja):    X11 プロトコルの C による実装
56Group:          System Environment/Libraries
57
58%description    -n compat32-%{name}
59The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
60small footprint, latency hiding, direct access to the protocol, improved
61threading support, and extensibility.
62
63%package        -n compat32-%{name}-devel
64Summary:        Development files for %{name}
65Group:          Development/Libraries
66Requires:       compat32-%{name} = %{version}-%{release}
67Requires:       %{name}-devel = %{version}-%{release}
68
69%description    -n compat32-%{name}-devel
70The %{name}-devel package contains libraries and header files for
71developing applications that use %{name}.
72
73%prep
74%setup -q
75%patch10 -p1
76
77%build
78autoreconf -v --install
79%configure --disable-static --docdir=%{_datadir}/doc/%{name}-%{version} --disable-selinux
80make %{?_smp_mflags}
81
82%install
83rm -rf $RPM_BUILD_ROOT
84make install DESTDIR=$RPM_BUILD_ROOT
85find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f
86install -m 644 COPYING NEWS README $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
87
88find $RPM_BUILD_ROOT -name '*.la' -delete
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post -p /sbin/ldconfig
94%postun -p /sbin/ldconfig
95
96%post -n compat32-%{name} -p /sbin/ldconfig
97%postun -n compat32-%{name} -p /sbin/ldconfig
98
99%files
100%defattr(-,root,root,-)
101%{_libdir}/*.so.*
102
103%files devel
104%defattr(-,root,root,-)
105%{_includedir}/xcb
106%{_libdir}/*.so
107%{_libdir}/pkgconfig/*.pc
108
109%files doc
110%defattr(-,root,root,-)
111%{_datadir}/doc/%{name}-%{version}
112
113%if %{build_compat32}
114%files -n compat32-%{name}
115%defattr(-,root,root,-)
116%{_libdir}/*.so.*
117
118%files  -n compat32-%{name}-devel
119%defattr(-,root,root,-)
120%{_libdir}/*.so
121%{_libdir}/pkgconfig/*.pc
122%endif
123
124%changelog
125* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8-1
126- new upstream release
127- remove Source2
128- remove python sub package
129
130* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7-1
131- new upstream release
132- update Patch10
133
134* Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-3
135- add BuildRequires: python-devel
136
137* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.5-2
138- build with rpm-4.8.1-1 for pkg-config file
139
140* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-1
141- new upstream release
142
143* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.4-2
144- rebuild with python-2.6
145
146* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-1
147- new upstream release
148- add libxcb python binding (xpyb)
149
150* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-2
151- added compat32 package for x86_64 arch support
152
153* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
154- new upstream release
155
156* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.1-2
157- spec in utf-8
158- added japanese summary
159
160* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
161- new versioning policy
162
163* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
164- initial build for Vine Linux
165
166* Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 1.1-1
167- libxcb 1.1
168
169* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> 1.0-3
170- libxcb-1.0-abstract-socket.patch: When connecting to the X server, prefer
171  abstract-namespace unix sockets to filesystem-bound sockets.
172
173* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0-2
174- Rebuild for PPC toolchain bug
175
176* Fri Jun 29 2007 Adam Jackson <ajax@redhat.com> 1.0-1
177- Initial revision.
Note: See TracBrowser for help on using the repository browser.