source: projects/specs/trunk/lib/libx/libxcb/libxcb-vl.spec @ 521

Revision 521, 5.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define xpyb_version 1.1
4
5Summary:        A C binding to the X11 protocol
6Summary(ja):    X11 プロトコルの C による実装
7Name:           libxcb
8Version:        1.4
9Release:        2%{?_dist_release}
10
11Group:          System Environment/Libraries
12License:        MIT
13URL:            http://xcb.freedesktop.org/
14Source0:        http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.bz2
15
16Source2:        http://xcb.freedesktop.org/dist/xpyb-%{xpyb_version}.tar.bz2
17
18Patch10:        libxcb-1.4-no-pthread-stubs.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
21BuildRequires:  autoconf automake libtool pkgconfig
22#BuildRequires:  doxygen
23#BuildRequires:  graphviz
24BuildRequires:  libXau-devel
25BuildRequires:  libxslt
26BuildRequires:  xcb-proto >= 1.5
27BuildRequires:  xorg-x11-proto-devel
28BuildRequires:  xorg-x11-util-macros
29
30%description
31The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
32small footprint, latency hiding, direct access to the protocol, improved
33threading support, and extensibility.
34
35%package        devel
36Summary:        Development files for %{name}
37Group:          Development/Libraries
38Requires:       %{name} = %{version}-%{release}
39Requires:       pkgconfig
40
41%description    devel
42The %{name}-devel package contains libraries and header files for
43developing applications that use %{name}.
44
45%package        doc
46Summary:        Documentation for %{name}
47Group:          Documentation
48
49%description    doc
50The %{name}-doc package contains documentation for the %{name} library.
51
52%package        python
53Summary:        Python bindings for %{name}
54Group:          Development/Libraries
55Provides:       xpyb
56
57%description    python
58Python bindings for %{name}.
59
60%package        -n compat32-%{name}
61Summary:        A C binding to the X11 protocol
62Summary(ja):    X11 プロトコルの C による実装
63Group:          System Environment/Libraries
64
65%description    -n compat32-%{name}
66The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
67small footprint, latency hiding, direct access to the protocol, improved
68threading support, and extensibility.
69
70%package        -n compat32-%{name}-devel
71Summary:        Development files for %{name}
72Group:          Development/Libraries
73Requires:       compat32-%{name} = %{version}-%{release}
74Requires:       %{name}-devel = %{version}-%{release}
75
76%description    -n compat32-%{name}-devel
77The %{name}-devel package contains libraries and header files for
78developing applications that use %{name}.
79
80%prep
81%setup -q -b2
82%patch10 -p1
83
84pushd ../xpyb-%{xpyb_version}
85# XXX fix me upstream please
86sed -i 's@$(pythondir)@$(pyexecdir)@' src/Makefile.am
87popd
88
89%build
90autoreconf -v --install
91%configure --disable-static --docdir=%{_datadir}/doc/%{name}-%{version} --disable-selinux
92make %{?_smp_mflags}
93
94pushd ../xpyb-%{xpyb_version}
95autoreconf -v --install
96%configure
97make %{?_smp_mflags}
98popd
99
100%install
101rm -rf $RPM_BUILD_ROOT
102make install DESTDIR=$RPM_BUILD_ROOT
103find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f
104install -m 644 COPYING NEWS README $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
105
106pushd ../xpyb-%{xpyb_version}
107make install DESTDIR=$RPM_BUILD_ROOT
108popd
109
110find $RPM_BUILD_ROOT -name '*.la' -delete
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post -p /sbin/ldconfig
116%postun -p /sbin/ldconfig
117
118%post -n compat32-%{name} -p /sbin/ldconfig
119%postun -n compat32-%{name} -p /sbin/ldconfig
120
121%files
122%defattr(-,root,root,-)
123%{_libdir}/*.so.*
124
125%files devel
126%defattr(-,root,root,-)
127%{_includedir}/xcb
128%{_libdir}/*.so
129%{_libdir}/pkgconfig/*.pc
130
131%files doc
132%defattr(-,root,root,-)
133%{_datadir}/doc/%{name}-%{version}
134
135%files python
136%defattr(-,root,root,-)
137%{python_sitearch}/xcb
138
139%if %{build_compat32}
140%files -n compat32-%{name}
141%defattr(-,root,root,-)
142%{_libdir}/*.so.*
143
144%files  -n compat32-%{name}-devel
145%defattr(-,root,root,-)
146%{_libdir}/*.so
147%{_libdir}/pkgconfig/*.pc
148%endif
149
150%changelog
151* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.4-2
152- rebuild with python-2.6
153
154* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-1
155- new upstream release
156- add libxcb python binding (xpyb)
157
158* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-2
159- added compat32 package for x86_64 arch support
160
161* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
162- new upstream release
163
164* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.1-2
165- spec in utf-8
166- added japanese summary
167
168* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
169- new versioning policy
170
171* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
172- initial build for Vine Linux
173
174* Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 1.1-1
175- libxcb 1.1
176
177* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> 1.0-3
178- libxcb-1.0-abstract-socket.patch: When connecting to the X server, prefer
179  abstract-namespace unix sockets to filesystem-bound sockets.
180
181* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0-2
182- Rebuild for PPC toolchain bug
183
184* Fri Jun 29 2007 Adam Jackson <ajax@redhat.com> 1.0-1
185- Initial revision.
Note: See TracBrowser for help on using the repository browser.