source: projects/specs/trunk/lib/libx/libxcb/libxcb-vl.spec @ 12185

Revision 12185, 6.4 KB checked in by tomop, 5 years ago (diff)

updated X11 libs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define xpyb_version 1.2
4
5Summary:        A C binding to the X11 protocol
6Summary(ja):    X11 プロトコルの C による実装
7Name:           libxcb
8Version:        1.13
9Release:        1%{?_dist_release}
10
11Group:          System Environment/Libraries
12License:        MIT
13URL:            http://xcb.freedesktop.org/
14Source0:        http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.bz2
15# This is stolen straight from the pthread-stubs source:
16# http://cgit.freedesktop.org/xcb/pthread-stubs/blob/?id=6900598192bacf5fd9a34619b11328f746a5956d
17# we don't need the library because glibc has working pthreads, but we need
18# the pkgconfig file so libs that link against libxcb know this...
19Source1:        pthread-stubs.pc.in
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires:  autoconf
23BuildRequires:  automake
24BuildRequires:  libtool
25BuildRequires:  pkgconfig
26#BuildRequires:  doxygen
27#BuildRequires:  graphviz
28BuildRequires:  libXau-devel
29BuildRequires:  libxslt
30BuildRequires:  xcb-proto >= 1.6
31BuildRequires:  xorg-x11-proto-devel
32BuildRequires:  xorg-x11-util-macros
33BuildRequires:  python-devel
34
35Obsoletes:      %{name}-python < 1.8
36
37Vendor: Project Vine
38Distribution: Vine Linux
39
40%description
41The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
42small footprint, latency hiding, direct access to the protocol, improved
43threading support, and extensibility.
44
45%package        devel
46Summary:        Development files for %{name}
47Summary(ja):    %{name} の開発用ファイル
48Group:          Development/Libraries
49Requires:       %{name} = %{version}-%{release}
50Requires:       pkgconfig
51
52%description    devel
53The %{name}-devel package contains libraries and header files for
54developing applications that use %{name}.
55
56%package        doc
57Summary:        Documentation for %{name}
58Group:          Documentation
59
60%description    doc
61The %{name}-doc package contains documentation for the %{name} library.
62
63%package        -n compat32-%{name}
64Summary:        A C binding to the X11 protocol
65Summary(ja):    X11 プロトコルの C による実装
66Group:          System Environment/Libraries
67
68%description    -n compat32-%{name}
69The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
70small footprint, latency hiding, direct access to the protocol, improved
71threading support, and extensibility.
72
73%package        -n compat32-%{name}-devel
74Summary:        Development files for %{name}
75Summary(ja):    %{name} の開発用ファイル
76Group:          Development/Libraries
77Requires:       compat32-%{name} = %{version}-%{release}
78Requires:       %{name}-devel = %{version}-%{release}
79
80%description    -n compat32-%{name}-devel
81The %{name}-devel package contains libraries and header files for
82developing applications that use %{name}.
83
84%prep
85%setup -q
86
87%build
88sed -i 's/pthread-stubs //' configure.ac
89autoreconf -v --install
90%configure --disable-static \
91           --docdir=%{_datadir}/doc/%{name}-%{version} \
92           --disable-selinux \
93           --enable-xkb \
94           --disable-xprint
95make %{?_smp_mflags}
96
97%install
98rm -rf $RPM_BUILD_ROOT
99make install DESTDIR=$RPM_BUILD_ROOT
100find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f
101install -m 644 COPYING NEWS README $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
102
103sed 's,@libdir@,%{_libdir},;s,@prefix@,%{_prefix},;s,@exec_prefix@,%{_exec_prefix},' %{SOURCE1} > $RPM_BUILD_ROOT%{_libdir}/pkgconfig/pthread-stubs.pc
104
105find $RPM_BUILD_ROOT -name '*.la' -delete
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%post -p /sbin/ldconfig
111%postun -p /sbin/ldconfig
112
113%post -n compat32-%{name} -p /sbin/ldconfig
114%postun -n compat32-%{name} -p /sbin/ldconfig
115
116%files
117%defattr(-,root,root,-)
118%{_libdir}/*.so.*
119
120%files devel
121%defattr(-,root,root,-)
122%{_includedir}/xcb
123%{_libdir}/*.so
124%{_libdir}/pkgconfig/*.pc
125
126%files doc
127%defattr(-,root,root,-)
128%{_datadir}/doc/%{name}-%{version}
129%{_mandir}/man3/*
130
131%if %{build_compat32}
132%files -n compat32-%{name}
133%defattr(-,root,root,-)
134%{_libdir}/*.so.*
135
136%files  -n compat32-%{name}-devel
137%defattr(-,root,root,-)
138%{_libdir}/*.so
139%endif
140
141%changelog
142* Thu Sep 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13-1
143- new upstream release.
144
145* Fri Oct 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.11-1
146- new upstream release
147
148* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10-1
149- new upstream release
150
151* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.1-1
152- new upstream release
153  (including security fix for CVE-2013-2064)
154
155* Sat Nov 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-2
156- add Source1: pthread-stubs.pc, remove patch10
157
158* Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9-1
159- new upstream release
160
161* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
162- new upstream release
163- update Patch10 (libxcb-1.8.1-no-pthread-stubs.patch)
164
165* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8-1
166- new upstream release
167- remove Source2
168- remove python sub package
169
170* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7-1
171- new upstream release
172- update Patch10
173
174* Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-3
175- add BuildRequires: python-devel
176
177* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.5-2
178- build with rpm-4.8.1-1 for pkg-config file
179
180* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-1
181- new upstream release
182
183* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.4-2
184- rebuild with python-2.6
185
186* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-1
187- new upstream release
188- add libxcb python binding (xpyb)
189
190* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-2
191- added compat32 package for x86_64 arch support
192
193* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
194- new upstream release
195
196* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.1-2
197- spec in utf-8
198- added japanese summary
199
200* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
201- new versioning policy
202
203* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
204- initial build for Vine Linux
205
206* Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 1.1-1
207- libxcb 1.1
208
209* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> 1.0-3
210- libxcb-1.0-abstract-socket.patch: When connecting to the X server, prefer
211  abstract-namespace unix sockets to filesystem-bound sockets.
212
213* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0-2
214- Rebuild for PPC toolchain bug
215
216* Fri Jun 29 2007 Adam Jackson <ajax@redhat.com> 1.0-1
217- Initial revision.
Note: See TracBrowser for help on using the repository browser.