source: projects/specs/trunk/lib/libx/libxcb/libxcb-vl.spec @ 9044

Revision 9044, 6.3 KB checked in by inagaki, 10 years ago (diff)

2014-11-01 Ryoichi INAGAKI <ryo1@…>

  • libxcb, xcb-proto, xcb-util, xcb-util-image, xcb-util-keysyms, xcb-util-renderutil: updated
  • xcb-util-cursor, xcb-util-wm: changed Group


Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define xpyb_version 1.2
4
5Summary:        A C binding to the X11 protocol
6Summary(ja):    X11 プロトコルの C による実装
7Name:           libxcb
8Version:        1.11
9Release:        1%{?_dist_release}
10
11Group:          System Environment/Libraries
12License:        MIT
13URL:            http://xcb.freedesktop.org/
14Source0:        http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.bz2
15# This is stolen straight from the pthread-stubs source:
16# http://cgit.freedesktop.org/xcb/pthread-stubs/blob/?id=6900598192bacf5fd9a34619b11328f746a5956d
17# we don't need the library because glibc has working pthreads, but we need
18# the pkgconfig file so libs that link against libxcb know this...
19Source1:        pthread-stubs.pc.in
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires:  autoconf
23BuildRequires:  automake
24BuildRequires:  libtool
25BuildRequires:  pkgconfig
26#BuildRequires:  doxygen
27#BuildRequires:  graphviz
28BuildRequires:  libXau-devel
29BuildRequires:  libxslt
30BuildRequires:  xcb-proto >= 1.6
31BuildRequires:  xorg-x11-proto-devel
32BuildRequires:  xorg-x11-util-macros
33BuildRequires:  python-devel
34
35Obsoletes:      %{name}-python < 1.8
36
37Vendor: Project Vine
38Distribution: Vine Linux
39Packager: Takemikaduchi
40
41%description
42The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
43small footprint, latency hiding, direct access to the protocol, improved
44threading support, and extensibility.
45
46%package        devel
47Summary:        Development files for %{name}
48Summary(ja):    %{name} の開発用ファイル
49Group:          Development/Libraries
50Requires:       %{name} = %{version}-%{release}
51Requires:       pkgconfig
52
53%description    devel
54The %{name}-devel package contains libraries and header files for
55developing applications that use %{name}.
56
57%package        doc
58Summary:        Documentation for %{name}
59Group:          Documentation
60
61%description    doc
62The %{name}-doc package contains documentation for the %{name} library.
63
64%package        -n compat32-%{name}
65Summary:        A C binding to the X11 protocol
66Summary(ja):    X11 プロトコルの C による実装
67Group:          System Environment/Libraries
68
69%description    -n compat32-%{name}
70The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
71small footprint, latency hiding, direct access to the protocol, improved
72threading support, and extensibility.
73
74%package        -n compat32-%{name}-devel
75Summary:        Development files for %{name}
76Summary(ja):    %{name} の開発用ファイル
77Group:          Development/Libraries
78Requires:       compat32-%{name} = %{version}-%{release}
79Requires:       %{name}-devel = %{version}-%{release}
80
81%description    -n compat32-%{name}-devel
82The %{name}-devel package contains libraries and header files for
83developing applications that use %{name}.
84
85%prep
86%setup -q
87
88%build
89sed -i 's/pthread-stubs //' configure.ac
90autoreconf -v --install
91%configure --disable-static \
92           --docdir=%{_datadir}/doc/%{name}-%{version} \
93           --disable-selinux \
94           --enable-xkb \
95           --disable-xprint
96make %{?_smp_mflags}
97
98%install
99rm -rf $RPM_BUILD_ROOT
100make install DESTDIR=$RPM_BUILD_ROOT
101find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f
102install -m 644 COPYING NEWS README $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
103
104sed 's,@libdir@,%{_libdir},;s,@prefix@,%{_prefix},;s,@exec_prefix@,%{_exec_prefix},' %{SOURCE1} > $RPM_BUILD_ROOT%{_libdir}/pkgconfig/pthread-stubs.pc
105
106find $RPM_BUILD_ROOT -name '*.la' -delete
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%post -p /sbin/ldconfig
112%postun -p /sbin/ldconfig
113
114%post -n compat32-%{name} -p /sbin/ldconfig
115%postun -n compat32-%{name} -p /sbin/ldconfig
116
117%files
118%defattr(-,root,root,-)
119%{_libdir}/*.so.*
120
121%files devel
122%defattr(-,root,root,-)
123%{_includedir}/xcb
124%{_libdir}/*.so
125%{_libdir}/pkgconfig/*.pc
126
127%files doc
128%defattr(-,root,root,-)
129%{_datadir}/doc/%{name}-%{version}
130%{_mandir}/man3/*
131
132%if %{build_compat32}
133%files -n compat32-%{name}
134%defattr(-,root,root,-)
135%{_libdir}/*.so.*
136
137%files  -n compat32-%{name}-devel
138%defattr(-,root,root,-)
139%{_libdir}/*.so
140%endif
141
142%changelog
143* Fri Oct 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.11-1
144- new upstream release
145
146* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10-1
147- new upstream release
148
149* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.1-1
150- new upstream release
151  (including security fix for CVE-2013-2064)
152
153* Sat Nov 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-2
154- add Source1: pthread-stubs.pc, remove patch10
155
156* Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9-1
157- new upstream release
158
159* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
160- new upstream release
161- update Patch10 (libxcb-1.8.1-no-pthread-stubs.patch)
162
163* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8-1
164- new upstream release
165- remove Source2
166- remove python sub package
167
168* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7-1
169- new upstream release
170- update Patch10
171
172* Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-3
173- add BuildRequires: python-devel
174
175* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.5-2
176- build with rpm-4.8.1-1 for pkg-config file
177
178* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-1
179- new upstream release
180
181* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.4-2
182- rebuild with python-2.6
183
184* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-1
185- new upstream release
186- add libxcb python binding (xpyb)
187
188* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-2
189- added compat32 package for x86_64 arch support
190
191* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
192- new upstream release
193
194* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.1-2
195- spec in utf-8
196- added japanese summary
197
198* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
199- new versioning policy
200
201* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
202- initial build for Vine Linux
203
204* Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 1.1-1
205- libxcb 1.1
206
207* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> 1.0-3
208- libxcb-1.0-abstract-socket.patch: When connecting to the X server, prefer
209  abstract-namespace unix sockets to filesystem-bound sockets.
210
211* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0-2
212- Rebuild for PPC toolchain bug
213
214* Fri Jun 29 2007 Adam Jackson <ajax@redhat.com> 1.0-1
215- Initial revision.
Note: See TracBrowser for help on using the repository browser.