source: projects/specs/trunk/lib/libx/libxcb/libxcb-vl.spec @ 12451

Revision 12451, 6.3 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

libX11-1.6.11-1

libepoxy-1.5.4-2

libxcb-1.14-1

pixman-0.40.0-1

xcb-proto-1.14-1

xorg-x11-server-1.20.8-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define xpyb_version 1.2
4
5Summary:        A C binding to the X11 protocol
6Summary(ja):    X11 プロトコルの C による実装
7Name:           libxcb
8Version:        1.14
9Release:        1%{?_dist_release}
10Group:          system
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14License:        MIT
15URL:            https://xcb.freedesktop.org/
16Source0:        https://xcb.freedesktop.org/dist/%{name}-%{version}.tar.xz
17# This is stolen straight from the pthread-stubs source:
18# http://cgit.freedesktop.org/xcb/pthread-stubs/blob/?id=6900598192bacf5fd9a34619b11328f746a5956d
19# we don't need the library because glibc has working pthreads, but we need
20# the pkgconfig file so libs that link against libxcb know this...
21Source1:        pthread-stubs.pc.in
22
23BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
24BuildRequires:  autoconf
25BuildRequires:  automake
26BuildRequires:  libtool
27BuildRequires:  pkgconfig
28#BuildRequires:  doxygen
29#BuildRequires:  graphviz
30BuildRequires:  libXau-devel
31BuildRequires:  libxslt
32BuildRequires:  xcb-proto >= 1.6
33BuildRequires:  xorg-x11-proto-devel
34BuildRequires:  xorg-x11-util-macros
35BuildRequires:  python-devel
36
37Obsoletes:      %{name}-python < 1.8
38
39%description
40The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
41small footprint, latency hiding, direct access to the protocol, improved
42threading support, and extensibility.
43
44%package        devel
45Summary:        Development files for %{name}
46Summary(ja):    %{name} の開発用ファイル
47Group:          programming
48Requires:       %{name} = %{version}-%{release}
49Requires:       pkgconfig
50
51%description    devel
52The %{name}-devel package contains libraries and header files for
53developing applications that use %{name}.
54
55%package        doc
56Summary:        Documentation for %{name}
57Group:          documentation
58
59%description    doc
60The %{name}-doc package contains documentation for the %{name} library.
61
62%package        -n compat32-%{name}
63Summary:        A C binding to the X11 protocol
64Summary(ja):    X11 プロトコルの C による実装
65Group:          programming
66
67%description    -n compat32-%{name}
68The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
69small footprint, latency hiding, direct access to the protocol, improved
70threading support, and extensibility.
71
72%package        -n compat32-%{name}-devel
73Summary:        Development files for %{name}
74Summary(ja):    %{name} の開発用ファイル
75Group:          programming
76Requires:       compat32-%{name} = %{version}-%{release}
77Requires:       %{name}-devel = %{version}-%{release}
78
79%description    -n compat32-%{name}-devel
80The %{name}-devel package contains libraries and header files for
81developing applications that use %{name}.
82
83%prep
84%setup -q
85
86%build
87sed -i 's/pthread-stubs //' configure.ac
88autoreconf -v --install
89%configure --disable-static \
90           --docdir=%{_datadir}/doc/%{name}-%{version} \
91           --disable-selinux \
92           --enable-xkb \
93           --disable-xprint
94make %{?_smp_mflags}
95
96%install
97rm -rf $RPM_BUILD_ROOT
98make install DESTDIR=$RPM_BUILD_ROOT
99find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f
100
101sed 's,@libdir@,%{_libdir},;s,@prefix@,%{_prefix},;s,@exec_prefix@,%{_exec_prefix},' %{SOURCE1} > $RPM_BUILD_ROOT%{_libdir}/pkgconfig/pthread-stubs.pc
102
103find $RPM_BUILD_ROOT -name '*.la' -delete
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post -p /sbin/ldconfig
109%postun -p /sbin/ldconfig
110
111%post -n compat32-%{name} -p /sbin/ldconfig
112%postun -n compat32-%{name} -p /sbin/ldconfig
113
114%files
115%defattr(-,root,root,-)
116%license COPYING
117%doc NEWS README.md
118%{_libdir}/*.so.*
119
120%files devel
121%defattr(-,root,root,-)
122%{_includedir}/xcb
123%{_libdir}/*.so
124%{_libdir}/pkgconfig/*.pc
125
126%files doc
127%defattr(-,root,root,-)
128%{_mandir}/man3/*
129
130%if %{build_compat32}
131%files -n compat32-%{name}
132%defattr(-,root,root,-)
133%{_libdir}/*.so.*
134
135%files  -n compat32-%{name}-devel
136%defattr(-,root,root,-)
137%{_libdir}/*.so
138%endif
139
140%changelog
141* Fri Aug 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14-1
142- new upstream release.
143
144* Thu Sep 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13-1
145- new upstream release.
146
147* Fri Oct 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.11-1
148- new upstream release
149
150* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10-1
151- new upstream release
152
153* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.1-1
154- new upstream release
155  (including security fix for CVE-2013-2064)
156
157* Sat Nov 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-2
158- add Source1: pthread-stubs.pc, remove patch10
159
160* Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9-1
161- new upstream release
162
163* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
164- new upstream release
165- update Patch10 (libxcb-1.8.1-no-pthread-stubs.patch)
166
167* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8-1
168- new upstream release
169- remove Source2
170- remove python sub package
171
172* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7-1
173- new upstream release
174- update Patch10
175
176* Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-3
177- add BuildRequires: python-devel
178
179* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.5-2
180- build with rpm-4.8.1-1 for pkg-config file
181
182* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-1
183- new upstream release
184
185* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.4-2
186- rebuild with python-2.6
187
188* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-1
189- new upstream release
190- add libxcb python binding (xpyb)
191
192* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-2
193- added compat32 package for x86_64 arch support
194
195* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
196- new upstream release
197
198* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.1-2
199- spec in utf-8
200- added japanese summary
201
202* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
203- new versioning policy
204
205* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
206- initial build for Vine Linux
207
208* Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 1.1-1
209- libxcb 1.1
210
211* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> 1.0-3
212- libxcb-1.0-abstract-socket.patch: When connecting to the X server, prefer
213  abstract-namespace unix sockets to filesystem-bound sockets.
214
215* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0-2
216- Rebuild for PPC toolchain bug
217
218* Fri Jun 29 2007 Adam Jackson <ajax@redhat.com> 1.0-1
219- Initial revision.
Note: See TracBrowser for help on using the repository browser.