source: projects/specs/trunk/lib/libx/libxcb/libxcb-vl.spec @ 1863

Revision 1863, 5.3 KB checked in by Takemikaduchi, 14 years ago (diff)

add BuildRequires?: python-devel

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define xpyb_version 1.1
4
5Summary:        A C binding to the X11 protocol
6Summary(ja):    X11 プロトコルの C による実装
7Name:           libxcb
8Version:        1.5
9Release:        3%{?_dist_release}
10
11Group:          System Environment/Libraries
12License:        MIT
13URL:            http://xcb.freedesktop.org/
14Source0:        http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.bz2
15
16Source2:        http://xcb.freedesktop.org/dist/xpyb-%{xpyb_version}.tar.bz2
17
18Patch10:        libxcb-1.4-no-pthread-stubs.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
21BuildRequires:  autoconf automake libtool pkgconfig
22#BuildRequires:  doxygen
23#BuildRequires:  graphviz
24BuildRequires:  libXau-devel
25BuildRequires:  libxslt
26BuildRequires:  xcb-proto >= 1.6
27BuildRequires:  xorg-x11-proto-devel
28BuildRequires:  xorg-x11-util-macros
29BuildRequires:  python-devel
30
31%description
32The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
33small footprint, latency hiding, direct access to the protocol, improved
34threading support, and extensibility.
35
36%package        devel
37Summary:        Development files for %{name}
38Group:          Development/Libraries
39Requires:       %{name} = %{version}-%{release}
40Requires:       pkgconfig
41
42%description    devel
43The %{name}-devel package contains libraries and header files for
44developing applications that use %{name}.
45
46%package        doc
47Summary:        Documentation for %{name}
48Group:          Documentation
49
50%description    doc
51The %{name}-doc package contains documentation for the %{name} library.
52
53%package        python
54Summary:        Python bindings for %{name}
55Group:          Development/Libraries
56Provides:       xpyb
57
58%description    python
59Python bindings for %{name}.
60
61%package        -n compat32-%{name}
62Summary:        A C binding to the X11 protocol
63Summary(ja):    X11 プロトコルの C による実装
64Group:          System Environment/Libraries
65
66%description    -n compat32-%{name}
67The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
68small footprint, latency hiding, direct access to the protocol, improved
69threading support, and extensibility.
70
71%package        -n compat32-%{name}-devel
72Summary:        Development files for %{name}
73Group:          Development/Libraries
74Requires:       compat32-%{name} = %{version}-%{release}
75Requires:       %{name}-devel = %{version}-%{release}
76
77%description    -n compat32-%{name}-devel
78The %{name}-devel package contains libraries and header files for
79developing applications that use %{name}.
80
81%prep
82%setup -q -b2
83%patch10 -p1
84
85pushd ../xpyb-%{xpyb_version}
86# XXX fix me upstream please
87sed -i 's@$(pythondir)@$(pyexecdir)@' src/Makefile.am
88popd
89
90%build
91autoreconf -v --install
92%configure --disable-static --docdir=%{_datadir}/doc/%{name}-%{version} --disable-selinux
93make %{?_smp_mflags}
94
95pushd ../xpyb-%{xpyb_version}
96autoreconf -v --install
97%configure
98make %{?_smp_mflags}
99popd
100
101%install
102rm -rf $RPM_BUILD_ROOT
103make install DESTDIR=$RPM_BUILD_ROOT
104find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f
105install -m 644 COPYING NEWS README $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
106
107pushd ../xpyb-%{xpyb_version}
108make install DESTDIR=$RPM_BUILD_ROOT
109popd
110
111find $RPM_BUILD_ROOT -name '*.la' -delete
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%post -p /sbin/ldconfig
117%postun -p /sbin/ldconfig
118
119%post -n compat32-%{name} -p /sbin/ldconfig
120%postun -n compat32-%{name} -p /sbin/ldconfig
121
122%files
123%defattr(-,root,root,-)
124%{_libdir}/*.so.*
125
126%files devel
127%defattr(-,root,root,-)
128%{_includedir}/xcb
129%{_libdir}/*.so
130%{_libdir}/pkgconfig/*.pc
131
132%files doc
133%defattr(-,root,root,-)
134%{_datadir}/doc/%{name}-%{version}
135
136%files python
137%defattr(-,root,root,-)
138%{python_sitearch}/xcb
139
140%if %{build_compat32}
141%files -n compat32-%{name}
142%defattr(-,root,root,-)
143%{_libdir}/*.so.*
144
145%files  -n compat32-%{name}-devel
146%defattr(-,root,root,-)
147%{_libdir}/*.so
148%{_libdir}/pkgconfig/*.pc
149%endif
150
151%changelog
152* Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-3
153- add BuildRequires: python-devel
154
155* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.5-2
156- build with rpm-4.8.1-1 for pkg-config file
157
158* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-1
159- new upstream release
160
161* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.4-2
162- rebuild with python-2.6
163
164* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-1
165- new upstream release
166- add libxcb python binding (xpyb)
167
168* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-2
169- added compat32 package for x86_64 arch support
170
171* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
172- new upstream release
173
174* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.1-2
175- spec in utf-8
176- added japanese summary
177
178* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
179- new versioning policy
180
181* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
182- initial build for Vine Linux
183
184* Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 1.1-1
185- libxcb 1.1
186
187* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> 1.0-3
188- libxcb-1.0-abstract-socket.patch: When connecting to the X server, prefer
189  abstract-namespace unix sockets to filesystem-bound sockets.
190
191* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0-2
192- Rebuild for PPC toolchain bug
193
194* Fri Jun 29 2007 Adam Jackson <ajax@redhat.com> 1.0-1
195- Initial revision.
Note: See TracBrowser for help on using the repository browser.