source: projects/specs/trunk/lib/libw/libwnck/libwnck-vl.spec @ 521

Revision 521, 7.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1## don't replace ltmain.sh
2%define __libtoolize :
3
4%define glib2_version 2.20.0
5%define gtk2_version 2.16.0
6%define startup_notification_version 0.8
7
8Summary: Window Navigator Construction Kit
9Name: libwnck
10Version: 2.28.0
11Release: 2%{?_dist_release}
12URL: ftp://ftp.gnome.org
13Source0: %{name}-%{version}.tar.bz2
14License: LGPLv2+
15Group: System Environment/Libraries
16BuildRoot: %{_tmppath}/%{name}-root
17
18# follow 3lines was added 2.26.2-2
19Vendor:         Project Vine   
20Distribution:   Vine Linux
21Packager:       inagaki,yasumichi
22
23Requires: glib2 >= %{glib2_version}
24Requires: gtk2 >= %{gtk2_version}
25Requires: startup-notification >= %{startup_notification_version}
26Requires: libXres
27
28BuildRequires:  glib2-devel >= %{glib2_version}
29BuildRequires:  gtk2-devel >= %{gtk2_version}
30BuildRequires:  startup-notification-devel >= %{startup_notification_version}
31BuildRequires:  perl-XML-Parser gettext
32BuildRequires: libXres-devel
33
34Patch1: libwnck-2.18.0-above.patch
35# http://bugzilla.gnome.org/show_bug.cgi?id=459984
36Patch2: crash-on-shutdown.patch
37
38%description
39
40libwnck (pronounced "libwink") is used to implement pagers, tasklists,
41and other such things. It allows applications to monitor information
42about open windows, workspaces, their names/icons, and so forth.
43
44%package devel
45Summary: Libraries and headers for libwnck
46Group: Development/Libraries
47Requires: %{name} = %{version}
48
49Requires: glib2-devel >= %{glib2_version}
50Requires: gtk2-devel >= %{gtk2_version}
51Requires: pkgconfig
52# added 2.26.2-2
53Requires: startup-notification-devel >= %{startup_notification_version}
54Requires: libXres-devel
55
56%description devel
57
58libwnck (pronounced "libwink") is used to implement pagers, tasklists,
59and other such things. It allows applications to monitor information
60about open windows, workspaces, their names/icons, and so forth.
61
62You should install the libwnck-devel package if you would like to
63compile applications that use libwnck. You don't need libwnck-devel
64just to use precompiled applications.
65
66
67%prep
68%setup -q
69#patch0 -p1 -b .appearance
70%patch1 -p1 -b .above
71%patch2 -p1 -b .crash-on-shutdown
72
73%build
74%configure --disable-static
75make %{?_smp_mflags}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79%makeinstall
80
81rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
82
83%find_lang %{name}
84
85%post -p /sbin/ldconfig
86
87%postun -p /sbin/ldconfig
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%files -f %{name}.lang
93%defattr(-,root,root)
94%doc AUTHORS COPYING ChangeLog README
95%{_bindir}/*
96%{_libdir}/lib*.so.*
97
98%files devel
99%defattr(-,root,root)
100#{_libdir}/lib*.a
101%{_libdir}/lib*.so
102%{_libdir}/pkgconfig/*
103%{_includedir}/*
104%{_datadir}/gtk-doc
105
106%changelog
107* Fri Feb 26 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.0-2
108- rebuilt with new toolchain
109
110* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
111- new upstream release
112- added --disable-static to %%configure
113
114* Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.26.2-2
115- update requires and BR(add libXres*)
116
117* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
118- new upstream release
119
120* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
121- new upstream release
122
123* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
124- new upstream release
125
126* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
127- new upstream release
128
129* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
130- new upstream release
131
132* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
133- new upstream release
134
135* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
136- new upstream release
137
138* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
139- new upstream release
140
141* Mon Dec 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
142- new upstream release
143- added Patch0, 1 and 2 from Fedora
144  * Tue Jul 24 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.5-2
145  - Fix a crash on shutdown in the wnck-applet
146  * Wed Mar 28 2007 Kristian Høgsberg <krh@redhat.com> - 2.18.0-2
147  - Add compiz integration patches from GNOME #352383:
148     - libwnck-2.18.0-appearance.patch
149     - libwnck-2.18.0-viewport.patch
150     - libwnck-2.18.0-above.patch
151
152* Mon May 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
153- new upstream release
154
155* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
156- new upstream release
157
158* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
159- new upstream release
160
161* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
162- new upstream release
163
164* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
165- new upstream release
166
167* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
168- new upstream release
169
170* Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
171- new upstream release
172
173* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
174- new upstream release
175
176* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
177- new upstream release
178
179* Sat Aug 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
180- new upstream release
181
182* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.4-0vl1
183- new upstream release
184
185* Sun Jul 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
186- new upstream release
187
188* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
189- new upstream version
190
191* Mon Nov 08 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
192- new upstream release
193
194* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0.1-0vl1
195- new upstream release
196
197* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
198- new upstream release
199
200* Sat May 31 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
201- new upstream release
202
203* Fri Apr 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
204- new upstream release
205
206* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
207- new upstream release
208
209* Sat Jan 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90-0vl1
210- new upstream release
211
212* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
213- fixed BuildRequires/Requires.
214
215* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
216- build for Vine Linux
217- new upstream release from gnome-2.1.4
218
219* Fri Nov  8 2002 Havoc Pennington <hp@redhat.com>
220- 2.1.3
221
222* Thu Oct 31 2002 Havoc Pennington <hp@redhat.com>
223- 0.18 that displays standalone dialogs in task list
224
225* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
226- 0.17 allows clicking a task to minimize it, and DND over a task to
227  switch to it, adds translations, and fixes a couple crash things in
228  the accessibility stuff.
229
230* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
231- 0.16 with some tasklist fixes and
232  pager fixes
233
234* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
235- automated rebuild
236
237* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
238- remove empty NEWS
239
240* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
241- 0.14
242
243* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
244- rebuild in different environment
245
246* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
247- 0.13
248- add ldconfig to post/postun
249
250* Sun May 26 2002 Tim Powers <timp@redhat.com>
251- automated rebuild
252
253* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
254- rebuild in different environment
255
256* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
257- 0.12
258
259* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
260- 0.9
261
262* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
263- 0.8
264
265* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
266- 0.3
267
268* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
269- Rebuild with new glib and gtk+
270
271* Wed Jan 23 2002 Havoc Pennington <hp@redhat.com>
272- Initial build
273
Note: See TracBrowser for help on using the repository browser.