source: projects/specs/trunk/lib/libw/libwnck/libwnck-vl.spec @ 4704

Revision 4704, 8.6 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2 beta 1 (3.1.90)

Line 
1## don't replace ltmain.sh
2%define __libtoolize :
3
4%define glib2_version 2.26.1
5%define gtk2_version 2.22.1
6%define startup_notification_version 0.10
7
8Summary: Window Navigator Construction Kit
9Name: libwnck
10Version: 2.30.7
11Release: 1%{?_dist_release}
12URL: ftp://ftp.gnome.org
13Source0: http://ftp.gnome.org/pub/GNOME/sources/libwnck/2.30/%{name}-%{version}.tar.xz
14License: LGPLv2+
15Group: System Environment/Libraries
16BuildRoot: %{_tmppath}/%{name}-root
17
18# follow 3lines was added 2.26.2-2
19Vendor:         Project Vine   
20Distribution:   Vine Linux
21Packager:       inagaki,yasumichi
22
23Requires: glib2 >= %{glib2_version}
24Requires: gtk2 >= %{gtk2_version}
25Requires: startup-notification >= %{startup_notification_version}
26Requires: libXres
27
28BuildRequires:  glib2-devel >= %{glib2_version}
29BuildRequires:  gtk2-devel >= %{gtk2_version}
30BuildRequires:  startup-notification-devel >= %{startup_notification_version}
31BuildRequires:  perl-XML-Parser gettext
32BuildRequires:  libXres-devel
33BuildRequires:  gobject-introspection-devel
34
35Patch1: libwnck-2.18.0-above.patch
36# http://bugzilla.gnome.org/show_bug.cgi?id=459984
37Patch2: crash-on-shutdown.patch
38
39%description
40
41libwnck (pronounced "libwink") is used to implement pagers, tasklists,
42and other such things. It allows applications to monitor information
43about open windows, workspaces, their names/icons, and so forth.
44
45%package devel
46Summary: Libraries and headers for libwnck
47Group: Development/Libraries
48Requires: %{name} = %{version}
49
50Requires: glib2-devel >= %{glib2_version}
51Requires: gtk2-devel >= %{gtk2_version}
52Requires: pkgconfig
53# added 2.26.2-2
54Requires: startup-notification-devel >= %{startup_notification_version}
55Requires: libXres-devel
56
57%description devel
58
59libwnck (pronounced "libwink") is used to implement pagers, tasklists,
60and other such things. It allows applications to monitor information
61about open windows, workspaces, their names/icons, and so forth.
62
63You should install the libwnck-devel package if you would like to
64compile applications that use libwnck. You don't need libwnck-devel
65just to use precompiled applications.
66
67
68%prep
69%setup -q
70#patch0 -p1 -b .appearance
71%patch1 -p1 -b .above
72%patch2 -p1 -b .crash-on-shutdown
73
74%build
75%configure --disable-static --enable-introspection=yes
76make %{?_smp_mflags}
77
78%install
79rm -rf $RPM_BUILD_ROOT
80make install DESTDIR=$RPM_BUILD_ROOT
81
82rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
83
84mv -f $RPM_BUILD_ROOT%{_bindir}/wnckprop $RPM_BUILD_ROOT%{_bindir}/wnckprop2
85
86# This package is merely compat for gtk2 apps, now.
87# The binaries are shipped in libwnck3
88rm -rf $RPM_BUILD_ROOT%{_bindir}
89
90%find_lang %{name}
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%files -f %{name}.lang
100%defattr(-,root,root)
101%doc AUTHORS COPYING ChangeLog README
102#%{_bindir}/*
103%{_libdir}/lib*.so.*
104%{_libdir}/girepository-1.0
105
106%files devel
107%defattr(-,root,root)
108%{_libdir}/lib*.so
109%{_libdir}/pkgconfig/*
110%{_includedir}/*
111%{_datadir}/gtk-doc
112%{_datadir}/gir-1.0
113
114%changelog
115* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.7-1
116- new upstream release
117
118* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.6-3
119- remove /usr/bin
120
121* Sun Feb 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.6-2
122- rename wnckprop (wnckprop2)
123
124* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.6-1
125- new upstream release
126
127* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.5-1
128- new upstream release
129- add BuildRequires: gobject-introspection-devel
130- add configure option (--enable-introspection=yes)
131
132* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
133- rebuild with rpm-4.8.1 for pkg-config file
134
135* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.2-1
136- new upstream release
137
138* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.0-1
139- new upstream release
140
141* Fri Feb 26 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.0-2
142- rebuilt with new toolchain
143
144* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
145- new upstream release
146- added --disable-static to %%configure
147
148* Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.26.2-2
149- update requires and BR(add libXres*)
150
151* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
152- new upstream release
153
154* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
155- new upstream release
156
157* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
158- new upstream release
159
160* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
161- new upstream release
162
163* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
164- new upstream release
165
166* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
167- new upstream release
168
169* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
170- new upstream release
171
172* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
173- new upstream release
174
175* Mon Dec 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
176- new upstream release
177- added Patch0, 1 and 2 from Fedora
178  * Tue Jul 24 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.5-2
179  - Fix a crash on shutdown in the wnck-applet
180  * Wed Mar 28 2007 Kristian Høgsberg <krh@redhat.com> - 2.18.0-2
181  - Add compiz integration patches from GNOME #352383:
182     - libwnck-2.18.0-appearance.patch
183     - libwnck-2.18.0-viewport.patch
184     - libwnck-2.18.0-above.patch
185
186* Mon May 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
187- new upstream release
188
189* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
190- new upstream release
191
192* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
193- new upstream release
194
195* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
196- new upstream release
197
198* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
199- new upstream release
200
201* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
202- new upstream release
203
204* Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
205- new upstream release
206
207* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
208- new upstream release
209
210* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
211- new upstream release
212
213* Sat Aug 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
214- new upstream release
215
216* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.4-0vl1
217- new upstream release
218
219* Sun Jul 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
220- new upstream release
221
222* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
223- new upstream version
224
225* Mon Nov 08 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
226- new upstream release
227
228* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0.1-0vl1
229- new upstream release
230
231* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
232- new upstream release
233
234* Sat May 31 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
235- new upstream release
236
237* Fri Apr 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
238- new upstream release
239
240* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
241- new upstream release
242
243* Sat Jan 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90-0vl1
244- new upstream release
245
246* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
247- fixed BuildRequires/Requires.
248
249* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
250- build for Vine Linux
251- new upstream release from gnome-2.1.4
252
253* Fri Nov  8 2002 Havoc Pennington <hp@redhat.com>
254- 2.1.3
255
256* Thu Oct 31 2002 Havoc Pennington <hp@redhat.com>
257- 0.18 that displays standalone dialogs in task list
258
259* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
260- 0.17 allows clicking a task to minimize it, and DND over a task to
261  switch to it, adds translations, and fixes a couple crash things in
262  the accessibility stuff.
263
264* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
265- 0.16 with some tasklist fixes and
266  pager fixes
267
268* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
269- automated rebuild
270
271* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
272- remove empty NEWS
273
274* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
275- 0.14
276
277* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
278- rebuild in different environment
279
280* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
281- 0.13
282- add ldconfig to post/postun
283
284* Sun May 26 2002 Tim Powers <timp@redhat.com>
285- automated rebuild
286
287* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
288- rebuild in different environment
289
290* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
291- 0.12
292
293* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
294- 0.9
295
296* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
297- 0.8
298
299* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
300- 0.3
301
302* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
303- Rebuild with new glib and gtk+
304
305* Wed Jan 23 2002 Havoc Pennington <hp@redhat.com>
306- Initial build
307
Note: See TracBrowser for help on using the repository browser.