source: projects/specs/trunk/lib/libw/libwebp/libwebp-vl.spec @ 8835

Revision 8835, 4.3 KB checked in by Takemikaduchi, 10 years ago (diff)

rebuild or new upstream release

Line 
1%define ver 0.3.1
2%define rel 2
3
4Name:           libwebp
5Version:        %{ver}
6Release:        %{rel}%{?_dist_release}
7Group:          Development/Libraries
8URL:            http://webmproject.org/
9Summary:        Library and tools for the WebP graphics format
10Summary(ja):    WebP 画像フォーマットのためのライブラリとツール
11# Additional IPR is licensed as well. See PATENTS file for details
12License:        BSD
13Source0:        http://webp.googlecode.com/files/%{name}-%{version}.tar.gz
14Source1:        libwebp_jni_example.java       
15BuildRequires:  libjpeg-devel libpng-devel libtool swig
16BuildRequires:  java-devel
17BuildRequires:  jpackage-utils
18
19%description
20WebP is an image format that does lossy compression of digital
21photographic images. WebP consists of a codec based on VP8, and a
22container based on RIFF. Webmasters, web developers and browser
23developers can use WebP to compress, archive and distribute digital
24images more efficiently.
25
26%package tools
27Group:          Development/Tools
28Summary:        The WebP command line tools
29Summary(ja):    WebP コマンドラインツール
30
31%description tools
32WebP is an image format that does lossy compression of digital
33photographic images. WebP consists of a codec based on VP8, and a
34container based on RIFF. Webmasters, web developers and browser
35developers can use WebP to compress, archive and distribute digital
36images more efficiently.
37
38%package devel
39Group:          Development/Libraries
40Summary:        Development files for libwebp, a library for the WebP format
41Summary(ja):    WebP フォーマットのためのライブラリ libwebp の開発ファイル
42Requires:       %{name} = %{version}-%{release}
43
44%description devel
45WebP is an image format that does lossy compression of digital
46photographic images. WebP consists of a codec based on VP8, and a
47container based on RIFF. Webmasters, web developers and browser
48developers can use WebP to compress, archive and distribute digital
49images more efficiently.
50
51%package java
52Group:          Development/Libraries
53Summary:        Java bindings for libwebp, a library for the WebP format
54Summary(ja):    WebP フォーマットのためのライブラリ libwebp の Java バインディング
55Requires:       %{name} = %{version}-%{release}
56Requires:       java
57Requires:       jpackage-utils
58
59%description java
60Java bindings for libwebp.
61
62Vendor: Project Vine
63Distribution: Vine Linux
64Packager: iwaim
65
66%prep
67%setup -q
68
69%build
70mkdir -p m4
71./autogen.sh
72%configure --disable-static
73make %{?_smp_mflags}
74
75# swig generated Java bindings
76cp %{SOURCE1} .
77cd swig
78rm -rf libwebp.jar libwebp_java_wrap.c
79mkdir -p java/com/google/webp
80swig -ignoremissing -I../src -java \
81        -package com.google.webp  \
82        -outdir java/com/google/webp \
83        -o libwebp_java_wrap.c libwebp.i
84
85gcc %{optflags} -shared -fPIC -fno-strict-aliasing \
86        -I/usr/lib/jvm/java/include \
87        -I/usr/lib/jvm/java/include/linux \
88        -I../src \
89        -L../src/.libs -lwebp libwebp_java_wrap.c \
90        -o libwebp_jni.so
91
92cd java
93javac com/google/webp/libwebp.java
94jar cvf ../libwebp.jar com/google/webp/*.class
95
96%install
97make install DESTDIR=%{buildroot}
98find "%{buildroot}/%{_libdir}" -type f -name "*.la" -delete
99
100# swig generated Java bindings
101mkdir -p %{buildroot}/%{_libdir}/%{name}-java
102cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
103
104%post -n %{name} -p /sbin/ldconfig
105
106%postun -n %{name} -p /sbin/ldconfig
107
108%files tools
109%{_bindir}/*
110%{_mandir}/man*/*
111
112%files -n %{name}
113%doc README PATENTS COPYING NEWS AUTHORS
114%{_libdir}/%{name}*.so.*
115
116%files devel
117%{_libdir}/%{name}*.so
118%{_includedir}/*
119%{_libdir}/pkgconfig/*
120
121%files java
122%doc libwebp_jni_example.java
123%{_libdir}/%{name}-java/
124
125%changelog
126* Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.1-2
127- rebuild with libpng-1.6.12
128
129* Sat Oct 12 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.3.1-1
130- new upstream release
131
132* Sat Jan 12 2013 IWAI, Masaharu <iwai@alib.jp> 0.2.1-1
133- initial build for Vine Linux
134
135* Thu Dec 27 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.2.1-1
136- new upstream release 0.2.1
137
138* Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 0.1.3-3
139- rebuild against new libjpeg
140
141* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.3-2
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
143
144* Thu Feb 02 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.3-1
145- Several spec improvements by Scott Tsai <scottt.tw@gmail.com>
146
147* Wed May 25 2011 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.2-1
148- Initial spec. Based on openSUSE one
149
Note: See TracBrowser for help on using the repository browser.