source: projects/specs/trunk/lib/libw/libwebp/libwebp-vl.spec @ 9006

Revision 9006, 4.5 KB checked in by inagaki, 10 years ago (diff)

2014-10-12 Ryoichi INAGAKI <ryo1@…>

  • libcgroup, libwebp, libyaml: fixed Group
  • syslinux: updated


Line 
1%define ver 0.3.1
2%define rel 3
3
4Name:           libwebp
5Version:        %{ver}
6Release:        %{rel}%{?_dist_release}
7Group:          System Environment/Libraries
8URL:            http://webmproject.org/
9Summary:        Library and tools for the WebP graphics format
10Summary(ja):    WebP 画像フォーマットのためのライブラリとツール
11# Additional IPR is licensed as well. See PATENTS file for details
12License:        BSD
13Source0:        http://webp.googlecode.com/files/%{name}-%{version}.tar.gz
14Source1:        libwebp_jni_example.java       
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  libjpeg-devel
18BuildRequires:  libpng-devel
19BuildRequires:  libtool
20BuildRequires:  java-devel
21BuildRequires:  jpackage-utils
22BuildRequires:  swig
23
24%description
25WebP is an image format that does lossy compression of digital
26photographic images. WebP consists of a codec based on VP8, and a
27container based on RIFF. Webmasters, web developers and browser
28developers can use WebP to compress, archive and distribute digital
29images more efficiently.
30
31%package tools
32Summary:        The WebP command line tools
33Summary(ja):    WebP コマンドラインツール
34Group:          Development/Tools
35
36%description tools
37WebP is an image format that does lossy compression of digital
38photographic images. WebP consists of a codec based on VP8, and a
39container based on RIFF. Webmasters, web developers and browser
40developers can use WebP to compress, archive and distribute digital
41images more efficiently.
42
43%package devel
44Summary:        Development files for libwebp, a library for the WebP format
45Summary(ja):    WebP フォーマットのためのライブラリ libwebp の開発ファイル
46Group:          Development/Libraries
47Requires:       %{name} = %{version}-%{release}
48
49%description devel
50WebP is an image format that does lossy compression of digital
51photographic images. WebP consists of a codec based on VP8, and a
52container based on RIFF. Webmasters, web developers and browser
53developers can use WebP to compress, archive and distribute digital
54images more efficiently.
55
56%package java
57Summary:        Java bindings for libwebp, a library for the WebP format
58Summary(ja):    WebP フォーマットのためのライブラリ libwebp の Java バインディング
59Group:          Development/Libraries
60Requires:       %{name} = %{version}-%{release}
61Requires:       java
62Requires:       jpackage-utils
63
64%description java
65Java bindings for libwebp.
66
67Vendor: Project Vine
68Distribution: Vine Linux
69Packager: iwaim
70
71%prep
72%setup -q
73
74%build
75mkdir -p m4
76./autogen.sh
77%configure --disable-static
78make %{?_smp_mflags}
79
80# swig generated Java bindings
81cp %{SOURCE1} .
82cd swig
83rm -rf libwebp.jar libwebp_java_wrap.c
84mkdir -p java/com/google/webp
85swig -ignoremissing -I../src -java \
86        -package com.google.webp  \
87        -outdir java/com/google/webp \
88        -o libwebp_java_wrap.c libwebp.i
89
90gcc %{optflags} -shared -fPIC -fno-strict-aliasing \
91        -I/usr/lib/jvm/java/include \
92        -I/usr/lib/jvm/java/include/linux \
93        -I../src \
94        -L../src/.libs -lwebp libwebp_java_wrap.c \
95        -o libwebp_jni.so
96
97cd java
98javac com/google/webp/libwebp.java
99jar cvf ../libwebp.jar com/google/webp/*.class
100
101%install
102make install DESTDIR=%{buildroot}
103find "%{buildroot}/%{_libdir}" -type f -name "*.la" -delete
104
105# swig generated Java bindings
106mkdir -p %{buildroot}/%{_libdir}/%{name}-java
107cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
108
109%post -n %{name} -p /sbin/ldconfig
110
111%postun -n %{name} -p /sbin/ldconfig
112
113%files tools
114%{_bindir}/*
115%{_mandir}/man*/*
116
117%files -n %{name}
118%doc README PATENTS COPYING NEWS AUTHORS
119%{_libdir}/%{name}*.so.*
120
121%files devel
122%{_libdir}/%{name}*.so
123%{_includedir}/*
124%{_libdir}/pkgconfig/*
125
126%files java
127%doc libwebp_jni_example.java
128%{_libdir}/%{name}-java/
129
130%changelog
131* Sun Oct 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.3.1-3
132- moved libwebp to System Environment/Libraries Group
133
134* Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.1-2
135- rebuild with libpng-1.6.12
136
137* Sat Oct 12 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.3.1-1
138- new upstream release
139
140* Sat Jan 12 2013 IWAI, Masaharu <iwai@alib.jp> 0.2.1-1
141- initial build for Vine Linux
142
143* Thu Dec 27 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.2.1-1
144- new upstream release 0.2.1
145
146* Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 0.1.3-3
147- rebuild against new libjpeg
148
149* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.3-2
150- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
151
152* Thu Feb 02 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.3-1
153- Several spec improvements by Scott Tsai <scottt.tw@gmail.com>
154
155* Wed May 25 2011 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.2-1
156- Initial spec. Based on openSUSE one
157
Note: See TracBrowser for help on using the repository browser.