source: projects/specs/trunk/lib/libv/libvpx/libvpx-vl.spec @ 6901

Revision 6901, 4.8 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1Name:           libvpx
2Version:        1.1.0
3Release:        1%{?_dist_release}
4Summary:        The VP8 Codec SDK
5Summary(ja):    VP8 コーデックソフトウェア開発キット
6
7Group:          System Environment/Libraries
8License:        BSD
9URL:            http://www.webmproject.org/tools/vp8-sdk/
10Source0:        http://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
11Source2:        libvpx.ver
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14%ifarch %{ix86} x86_64
15BuildRequires:  yasm
16%endif
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: daisuke
21
22%description
23The WebM VP8 Codec SDK allows you to integrate your applications with
24the VP8 video codec, a high quality, royalty free, open source codec
25deployed on millions of computers and devices worldwide.
26
27%description -l ja
28WebM VP8 コーデック SDK は、VP8 ビデオコーデックをアプリケーションに
29統合するための開発きっとです。VP8ビデオコーデックは高品質でロイヤリティ
30フリーかつオープンソースのコーデックで、世界中の多くのコンピュータや
31デバイスで利用されています。
32
33%package devel
34Summary:        Development files for %{name}
35Summary(ja):    %{name} の開発ファイル
36Group:          Development/Libraries
37Requires:       %{name} = %{version}-%{release}
38
39%description devel
40The %{name}-devel package contains development files for
41%{name}.
42
43%description devel -l ja
44%{name}-devel パッケージは %{name} の開発用ファイルを含んでいます。
45
46%package utils
47Summary:        example programs for %{name}
48Summary(ja):    %{name} のサンプルプログラム
49Group:          Applications/Multimedia
50Requires:       %{name} = %{version}-%{release}
51
52%description utils
53The %{name}-utils package contains example programs that
54use %{name}.
55
56%description utils -l ja
57%{name}-utils パッケージは、%{name} を使用したサンプル
58アプリケーションを含んでいます。
59
60
61%prep
62%setup -q -n %{name}-v%{version}
63
64%build
65
66%ifarch %{ix86}
67%global vpxtarget x86-linux-gcc
68%else
69%ifarch x86_64
70%global vpxtarget x86_64-linux-gcc
71%else
72%global vpxtarget generic-gnu
73%endif
74%endif
75
76%if "%{vpxtarget}" == "generic-gnu"
77%global generic_target 1
78%else
79%global generic_target 0
80%endif
81
82./configure \
83 --target=%{vpxtarget} \
84 --enable-pic \
85%if ! %{generic_target}
86 --enable-shared \
87%endif
88 --prefix=%{_prefix} \
89 --libdir=%{_libdir} \
90 --disable-install-docs \
91 --disable-install-srcs
92
93# fix up optflags
94sed -i "s|-O3|%{optflags}|g" libs-%{vpxtarget}.mk
95sed -i "s|-O3|%{optflags}|g" examples-%{vpxtarget}.mk
96sed -i "s|-O3|%{optflags}|g" docs-%{vpxtarget}.mk
97
98%{__make} %{?_smp_mflags} verbose=true target=libs
99
100%if %{generic_target}
101mkdir -p tmp
102pushd tmp
103ar x ../libvpx_g.a
104popd
105gcc -shared -fPIC -pthread -lm \
106    -Wl,--no-undefined \
107    -Wl,-soname,libvpx.so.0 \
108    -Wl,--version-script,%{SOURCE2} \
109    -Wl,-z,noexecstack \
110    -o libvpx.so.%{version} tmp/*.o
111rm -rf tmp
112%endif
113
114ln -sf libvpx.so.%{version} libvpx.so
115
116mv libvpx.a libvpx.a.tmp
117mv libvpx_g.a libvpx_g.a.tmp
118
119make %{?_smp_mflags} verbose=true target=examples
120
121mv libvpx.a.tmp libvpx.a
122mv libvpx_g.a.tmp libvpx_g.a
123
124%install
125%{__rm} -rf $RPM_BUILD_ROOT
126%{__make} DIST_DIR=$RPM_BUILD_ROOT%{_prefix} dist
127
128%if %{generic_target}
129install -p libvpx.so.%{version} %{buildroot}%{_libdir}
130pushd %{buildroot}%{_libdir}
131ln -sf libvpx.so.%{version} libvpx.so
132ln -sf libvpx.so.%{version} libvpx.so.1
133ln -sf libvpx.so.%{version} libvpx.so.1.1
134popd
135%endif
136
137pushd %{buildroot}
138# Rename a few examples
139mv usr/bin/postproc usr/bin/vp8_postproc
140mv usr/bin/simple_decoder usr/bin/vp8_simple_decoder
141mv usr/bin/simple_encoder usr/bin/vp8_simple_encoder
142mv usr/bin/twopass_encoder usr/bin/vp8_twopass_encoder
143# Fix the binary permissions
144chmod 755 usr/bin/*
145popd
146
147rm -f $RPM_BUILD_ROOT%{_prefix}/md5sums.txt
148rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
149rm -f $RPM_BUILD_ROOT%{_prefix}/{CHANGELOG,README}
150rm -rf $RPM_BUILD_ROOT%{_prefix}/build
151
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156
157%post -p /sbin/ldconfig
158
159%postun -p /sbin/ldconfig
160
161
162%files
163%defattr(-,root,root,-)
164%doc AUTHORS LICENSE README CHANGELOG
165%{_libdir}/*.so.*
166
167%files devel
168%defattr(-,root,root,-)
169%{_libdir}/*.so
170%{_libdir}/pkgconfig/*.pc
171%{_includedir}/vpx/*.h
172
173%files utils
174%defattr(-,root,root,-)
175%{_bindir}/*
176
177
178%changelog
179* Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
180- new upstream release
181- remove Patch0 (libvpx-0.9.0-no-explicit-dep-on-static-lib.patch)
182- remove Source1 (libvpx.pc)
183
184* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.6-1
185- new upstream release
186
187* Mon Dec 27 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.5-1
188- new upstream release
189
190* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.1-2
191- rebuild with rpm-4.8.1 for pkg-config file
192
193* Sun Jul 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.1-1
194- new upstream release
195
196* Mon May 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.0-1
197- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.