source: projects/specs/trunk/lib/libv/libvpx/libvpx-vl.spec @ 12380

Revision 12380, 6.3 KB checked in by tomop, 4 years ago (diff)

updated 12 packages

alsa-firmware-1.2.1-1

alsa-lib-1.2.2-1

alsa-tools-1.2.2-1

alsa-utils-1.2.2-1

gstreamer1-1.16.2-1

linux-firmware-20200316-1

libsrtp-2.3.0-1

libvpx-1.8.2-1

libwebp-1.1.0-1

opus-1.3.1-1

pulseaudio-13.0-1

speex-1.2.0-2

Line 
1%global somajor 6
2%global sominor 0
3%global sotiny  0
4%global soversion %{somajor}.%{sominor}.%{sotiny}
5
6Name:           libvpx
7Version:        1.8.2
8Release:        1%{?_dist_release}
9Summary:        The VP8/VP9 Codec SDK
10Summary(ja):    VP8/VP9 コーデックソフトウェア開発キット
11Group:          System Environment/Libraries
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       daisuke
15
16License:        BSD
17URL:            https://www.webmproject.org/code/
18Source0:        https://github.com/webmproject/libvpx/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
19Source1:        vpx_config.h
20Source2:        libvpx.ver
21
22BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
23%ifarch %{ix86} x86_64
24BuildRequires:  yasm
25%endif
26
27%description
28The WebM VP8/VP9 Codec SDK allows you to integrate your applications with
29the VP8/VP9 video codec, a high quality, royalty free, open source codec
30deployed on millions of computers and devices worldwide.
31
32%description -l ja
33WebM VP8/VP9 コーデック SDK は、VP8/VP9 ビデオコーデックをアプリケーションに
34統合するための開発キットです。VP8/VP9ビデオコーデックは高品質でロイヤリティフリー
35かつオープンソースのコーデックで、世界中の多くのコンピュータやデバイスで利用されて
36います。
37
38%package devel
39Summary:        Development files for %{name}
40Summary(ja):    %{name} の開発ファイル
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43
44%description devel
45The %{name}-devel package contains development files for
46%{name}.
47
48%description devel -l ja
49%{name}-devel パッケージは %{name} の開発用ファイルを含んでいます。
50
51%package utils
52Summary:        example programs for %{name}
53Summary(ja):    %{name} のサンプルプログラム
54Group:          Applications/Multimedia
55Requires:       %{name} = %{version}-%{release}
56
57%description utils
58The %{name}-utils package contains example programs that
59use %{name}.
60
61%description utils -l ja
62%{name}-utils パッケージは、%{name} を使用したサンプル
63アプリケーションを含んでいます。
64
65
66%prep
67%setup -q
68
69%build
70
71%ifarch %{ix86}
72%global vpxtarget x86-linux-gcc
73%else
74%ifarch x86_64
75%global vpxtarget x86_64-linux-gcc
76%else
77%global vpxtarget generic-gnu
78%endif
79%endif
80
81%if "%{vpxtarget}" == "generic-gnu"
82%global generic_target 1
83%else
84%global generic_target 0
85%endif
86
87./configure \
88 --target=%{vpxtarget} \
89 --enable-pic \
90 --enable-vp9-decoder --enable-vp9-encoder \
91 --enable-experimental \
92 --enable-vp9-highbitdepth \
93 --enable-experimental \
94%if ! %{generic_target}
95 --enable-shared \
96%endif
97 --prefix=%{_prefix} \
98 --libdir=%{_libdir} \
99 --disable-install-docs \
100 --enable-install-srcs \
101 --size-limit=16384x16384
102
103%{__make} %{?_smp_mflags} verbose=true
104
105# Manual shared library creation
106# We should never need to do this anymore, and if we do, we need to fix the version-script.
107%if %{generic_target}
108mkdir tmp
109cd tmp
110ar x ../libvpx_g.a
111cd ..
112gcc -fPIC -shared -pthread -lm -Wl,--no-undefined -Wl,-soname,libvpx.so.%{somajor} -Wl,--version-script,%{SOURCE2} -Wl,-z,noexecstack -o libvpx.so.%{soversion}
113tmp/*.o
114rm -rf tmp
115%endif
116
117%install
118%{__rm} -rf $RPM_BUILD_ROOT
119%{__make} DIST_DIR=$RPM_BUILD_ROOT%{_prefix} dist
120
121# Simpler to label the dir as %%doc.
122if [ -d %{buildroot}/usr/docs ]; then
123   mv %{buildroot}/usr/docs doc/
124fi
125
126# Again, we should never need to do this anymore.
127%if %{generic_target}
128install -p libvpx.so.%{soversion} %{buildroot}%{_libdir}
129pushd %{buildroot}%{_libdir}
130ln -sf libvpx.so.%{soversion} libvpx.so
131ln -sf libvpx.so.%{soversion} libvpx.so.%{somajor}
132ln -sf libvpx.so.%{soversion} libvpx.so.%{somajor}.%{sominor}
133popd
134%endif
135
136pushd %{buildroot}
137# Stuff we don't need.
138rm -rf usr/build/ usr/md5sums.txt usr/lib*/*.a usr/CHANGELOG usr/README
139# No, bad google. No treat.
140mv usr/bin/examples/* usr/bin/
141rm -rf usr/bin/examples
142
143# Rename a few examples
144mv usr/bin/postproc usr/bin/vp8_postproc
145mv usr/bin/simple_decoder usr/bin/vp8_simple_decoder
146mv usr/bin/simple_encoder usr/bin/vp8_simple_encoder
147mv usr/bin/twopass_encoder usr/bin/vp8_twopass_encoder
148# Fix the binary permissions
149chmod 755 usr/bin/*
150popd
151
152# Get the vpx_config.h file
153%ifarch %{arm}
154cp -a vpx_config.h %{buildroot}%{_includedir}/vpx/vpx_config-arm.h
155%else
156# Does ppc64le need its own?
157%ifarch ppc64 ppc64le
158cp -a vpx_config.h %{buildroot}%{_includedir}/vpx/vpx_config-ppc64.h
159%else
160%ifarch s390 s390x
161cp -a vpx_config.h %{buildroot}%{_includedir}/vpx/vpx_config-s390.h
162%else
163%ifarch %{ix86}
164cp -a vpx_config.h %{buildroot}%{_includedir}/vpx/vpx_config-x86.h
165%else
166cp -a vpx_config.h %{buildroot}%{_includedir}/vpx/vpx_config-%{_arch}.h
167%endif
168%endif
169%endif
170%endif
171
172cp %{SOURCE1} %{buildroot}%{_includedir}/vpx/vpx_config.h
173# for timestamp sync
174touch -r AUTHORS %{buildroot}%{_includedir}/vpx/vpx_config.h
175
176mv %{buildroot}%{_prefix}/src/vpx_dsp %{buildroot}%{_includedir}/
177mv %{buildroot}%{_prefix}/src/vpx_mem %{buildroot}%{_includedir}/
178mv %{buildroot}%{_prefix}/src/vpx_ports %{buildroot}%{_includedir}/
179mv %{buildroot}%{_prefix}/src/vpx_scale %{buildroot}%{_includedir}/
180
181rm -rf %{buildroot}%{_prefix}/src
182
183%clean
184rm -rf $RPM_BUILD_ROOT
185
186
187%post -p /sbin/ldconfig
188
189%postun -p /sbin/ldconfig
190
191
192%files
193%defattr(-,root,root,-)
194%license LICENSE
195%doc AUTHORS README CHANGELOG
196%{_libdir}/*.so.*
197
198%files devel
199%defattr(-,root,root,-)
200%doc docs/html/
201%{_includedir}/vpx/
202%{_includedir}/vpx_dsp/
203%{_includedir}/vpx_mem/
204%{_includedir}/vpx_ports/
205%{_includedir}/vpx_scale/
206%{_libdir}/pkgconfig/vpx.pc
207%{_libdir}/libvpx.so
208
209%files utils
210%defattr(-,root,root,-)
211%{_bindir}/*
212
213
214%changelog
215* Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.2-1
216- new upstream release.
217
218* Thu Feb 22 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.0-1
219- new upstream release.
220- updated Source2.
221- added Source1.
222
223* Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
224- new upstream release
225- remove Patch0 (libvpx-0.9.0-no-explicit-dep-on-static-lib.patch)
226- remove Source1 (libvpx.pc)
227
228* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.6-1
229- new upstream release
230
231* Mon Dec 27 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.5-1
232- new upstream release
233
234* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.1-2
235- rebuild with rpm-4.8.1 for pkg-config file
236
237* Sun Jul 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.1-1
238- new upstream release
239
240* Mon May 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.0-1
241- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.