source: projects/specs/trunk/lib/libv/libvncserver/libvncserver-vl.spec @ 7728

Revision 7728, 4.3 KB checked in by Takemikaduchi, 11 years ago (diff)

KDE-4.10.5

Line 
1%define system_minilzo 1
2
3Summary: Library to make writing a vnc server easy
4Name:    libvncserver
5Version: 0.9.9
6Release: 1%{?_dist_release}
7# NOTE: --with-tightvnc-filetransfer => GPLv2
8License: GPLv2+
9Group:   System Environment/Libraries
10URL:     http://libvncserver.sourceforge.net/
11Source0: http://downloads.sf.net/libvncserver/LibVNCServer-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14# workaround there being no x11vnc/ dir in tarball
15Patch0: LibVNCServer-0.9.9-no_x11vnc.patch
16Patch1: LibVNCServer-0.9.9-system_minilzo.patch
17Patch2: libvncserver-0.9.1-multilib.patch
18# pkgconfig love (upstreamable)
19Patch3: LibVNCServer-0.9.9-pkgconfig.patch
20
21# upstream name
22Obsoletes: LibVNCServer < %{version}-%{release}
23Provides:  LibVNCServer = %{version}-%{release}
24
25BuildRequires: findutils
26BuildRequires: libjpeg-devel
27BuildRequires: zlib-devel
28BuildRequires: lzo-minilzo lzo-devel
29
30%description
31LibVNCServer makes writing a VNC server (or more correctly, a program
32exporting a framebuffer via the Remote Frame Buffer protocol) easy.
33
34It hides the programmer from the tedious task of managing clients and
35compression schemata.
36
37%package devel
38Summary: Development files for %{name}
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41# libvncserver-config deps
42Requires: coreutils
43# upstream name
44#Obsoletes: LibVNCServer-devel < %{version}-%{release}
45Provides:  LibVNCServer-devel = %{version}-%{release}
46
47%description devel
48%{summary}.
49
50
51%prep
52%setup -q -n LibVNCServer-%{version}
53
54%patch0 -p1 -b .no_x11vnc
55%if %{system_minilzo}
56%patch1 -p1 -b .system_minilzo
57#nuke bundled minilzo
58rm -f common/lzodefs.h common/lzoconf.h commmon/minilzo.h common/minilzo.c
59%endif
60%patch2 -p1 -b .multilib
61%patch3 -p1 -b .pkgconfig
62
63# fix encoding
64mv AUTHORS AUTHORS.OLD && \
65iconv -f ISO_8859-1 -t UTF8 AUTHORS.OLD > AUTHORS && \
66touch --reference AUTHORS.OLD AUTHORS
67
68# fix source perms
69find -name "*.c" -o -name "*.h" | xargs chmod 644
70
71
72%build
73autoreconf
74%configure \
75  --disable-static \
76  --without-tightvnc-filetransfer
77
78# hack to omit unused-direct-shlib-dependencies
79sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool
80
81make \
82%if %{system_minilzo}
83CFLAGS="$RPM_OPT_FLAGS -I %{_includedir}/lzo" LDFLAGS="$LDFLAGS -lminilzo" \
84%endif
85%{?_smp_mflags}
86
87%install
88rm -rf %{buildroot}
89
90make install DESTDIR=%{buildroot}
91
92# unpackaged files
93rm -f %{buildroot}%{_bindir}/LinuxVNC
94rm -f %{buildroot}%{_libdir}/lib*.a
95rm -f %{buildroot}%{_libdir}/lib*.la
96
97
98%clean
99rm -rf %{buildroot}
100
101
102%post -p /sbin/ldconfig
103
104%postun -p /sbin/ldconfig
105
106
107%files
108%defattr(-,root,root,-)
109%doc AUTHORS ChangeLog COPYING NEWS README TODO
110%{_bindir}/linuxvnc
111%{_libdir}/libvncclient.so.0*
112%{_libdir}/libvncserver.so.0*
113
114%files devel
115%defattr(-,root,root,-)
116%{_bindir}/*-config
117%{_includedir}/rfb/
118%{_libdir}/libvncclient.so
119%{_libdir}/libvncserver.so
120%{_libdir}/pkgconfig/libvncclient.pc
121%{_libdir}/pkgconfig/libvncserver.pc
122
123
124%changelog
125* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.9-1
126- update to 0.9.9
127- remove Patch50 (libvncserver-LINUX.patch)
128- remove Patch100 (libvncserver-0.9.1-close_server_socket.patch)
129- add patches from fedora
130  - Patch0 (LibVNCServer-0.9.9-no_x11vnc.patch)
131  - Patch3 (LibVNCServer-0.9.9-pkgconfig.patch)
132- update Patch1 (LibVNCServer-0.9.9-system_minilzo.patch) from fedora
133
134* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.7-4
135- Initial build for Vine Linux
136
137* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.7-3
138- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
139
140* Sat May 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.9.7-3
141- Socket is not closed when disconnecting from server (#501895)
142
143* Mon May 04 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.9.7-2
144- fix detection of LINUX platform/define
145
146* Mon May 04 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.9.7-1
147- LibVNCServer-0.9.7
148
149* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.1-4
150- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
151
152* Thu Apr 10 2008 Manuel Wolfshant <wolfy@fedoraproject.org> 0.9.1-3
153- do not use bundled copy of minilzo (#439979)
154
155* Sun Jan 27 2008 Rex Dieter <rdieter@fedoraproject.org> 0.9.1-2
156- hack libtool to omit unused shlib dependencies
157- fix AUTHORS encoding
158- fix src perms
159
160* Mon Jan 21 2008 Rex Dieter <rdieter@fedoraproject.org> 0.9.1-1
161- 0.9.1
Note: See TracBrowser for help on using the repository browser.